[ Contents] [ Prev] [ Next] [ Index] [ Report an Error]

Configuring Shared Interfaces on a PSD

To configure shared interfaces on a PSD:

  1. Configure the physical SONET interface using the so-fpc/pic/slot statement at the [edit interfaces] hierarchy level. Or, configure the physical Gigabit Ethernet interface using the ge-fpc/pic/slot statement at the [edit interfaces] hierarchy level.
  2. Configure Frame Relay encapsulation using the encapsulation frame-relay statement at the [edit interfaces so-fpc/pic/slot] hierarchy level. Or, configure VLAN tagging using the vlan-tagging statement at the [edit interfaces ge-fpc/pic/slot] hierarchy level.
  3. Identify the physical interface as a shared interface using the shared-interface statement at the [edit interfaces so-fpc/pic/slot] hierarchy level or at the [edit interfaces ge-fpc/pic/slot] hierarchy level.
  4. Configure logical interfaces under the physical interface using the unit logical-unit-number statement at the [edit interfaces so-fpc/pic/slot] or [edit interfaces ge-fpc/pic/slot] hierarchy levels. The values for logical-unit-number must match the values set in the RSD configuration.
  5. For each logical interface, include the following statements:
      • For SONET interfaces, include the dlci dlci-identifier statement at the [edit interfaces so-fpc/pic/slot unit logical-unit-number] hierarchy level to assign a data-link connection identifier (DLCI) for the point-to-point Frame Relay connection between the RSD and the PSD. The value for dlci-identifier must match the value set in the RSD configuration for the specified logical SONET interface.
      • For Gigabit Ethernet interfaces, include the vlan-id number statement at the [edit interfaces ge-fpc/pic/slot unit logical-unit-number] hierarchy level to bind an 802.1Q virtual LAN (VLAN) identifier tag to the logical interface. The value for number must match the value set in the RSD configuration for the specified logical Gigabit Ethernet interface.
    1. peer-interface interface-name—Configure the tunnel peer interface that is bound to the logical interface.

    2. family family—Configure the protocol family for the logical interface.
  6. Configure the IP address of the logical interface using the address address statement at the [edit interfaces so-fpc/pic/slot unit logical-unit-number family family] or [edit interfaces ge-fpc/pic/slot unit logical-unit-number family family] hierarchy level.
  7. Configure the physical tunnel interface using the ut-fpc/pic/slot statement at the [edit interfaces] hierarchy level.
  8. Configure the logical tunnel interfaces using the unit logical-unit-number statement at the [ut-fpc/pic/slot] hierarchy level.

    The logical unit number must match the value of the logical unit number for the physical shared interface. For example, if the shared interface logical unit is 1 (as part of so-0/0/0.1), configure ut-0/0/0.1 as the logical peer tunnel interface.

  9. For each logical tunnel interface, specify the logical peer interface on the SONET or Gigabit Ethernet PIC using the peer-interface statement at the [ut-fpc/pic/slot unit logical-unit-number] hierarchy level.

    As described in the previous step, the logical unit number for the shared interface and the uplink tunnel interface must match.

SONET (PSD1)

In the following example, the logical SONET interface so-0/0/0.0 is peered with the logical tunnel interface ut-1/0/0.0 and so-0/0/0.1 is peered with ut-1/0/0/.1.

interfaces {
so-0/0/0 {
encapsulation frame-relay;
shared-interface;
unit 0 {
dlci 100;
peer-interface ut-1/0/0.0;
family inet {
address 10.10.10.1/24;
}
}
unit 1 {
dlci 101;
peer-interface ut-1/0/0.1
family inet {
address 10.10.11.1/24;
}
}
}
ut-1/0/0 {
unit 0 {
peer-interface so-0/0/0.0;
}
unit 1 {
peer-interface so-0/0/0.1;
}
}
}

SONET (PSD2)

In the following example, the logical SONET interface so-0/0/0.2 is peered with the logical tunnel interface ut-2/0/0.2.

interfaces {
so-0/0/0 {
encapsulation frame-relay;
shared-interface;
unit 2 {
dlci 102;
peer-interface ut-2/0/0.2;
family inet {
address 10.10.12.1/24;
}
}
ut-2/0/0 {
unit 0 {
peer-interface so-0/0/0.2;
}
}
}

Ethernet (PSD1)

In the following example, the logical SONET interface ge-1/0/0.1 is peered with the logical tunnel interface ut-3/0/0.1 and ge-1/0/0.2 is peered with ut-4/0/0/.2.

interfaces {
ge-1/0/0 {
vlan-tagging;
shared-interface;
unit 1{
vlan-id 100;
peer-interface ut-3/0/0.1;
family inet {
address 10.10.13.1/24;
}
}
unit 2{
vlan-id 101;
peer-interface ut-4/0/0.2
family inet {
address 10.10.14.1/24;
}
}
}
ut-3/0/0 {
unit 1{
peer-interface ge-1/0/0.1;
}
unit 2{
peer-interface ge-1/0/0.2;
}
}
}

Ethernet (PSD2)

In the following example, the logical SONET interface ge-1/0/0.3 is peered with the logical tunnel interface ut-4/0/0.3.

interfaces {
ge-1/0/0 {
vlan-tagging;
shared-interface;
unit 3{
vlan-id 102;
peer-interface ut-4/0/0.3;
family inet {
address 10.10.15.1/24;
}
}
ut-4/0/0 {
unit 3{
peer-interface ge-1/0/0.3;
}
}
}

Related Topics


[ Contents] [ Prev] [ Next] [ Index] [ Report an Error]