This example shows how you can configure a subscriber interface using a static IP demultiplexing (demux) interface stacked on a two-link aggregated Ethernet logical interface. In this example, the underlying aggregated Ethernet logical interface is configured for one-to-one active/backup redundancy at the DPC level.
In this example, only one aggregated Ethernet logical interface is configured on the router:
- [edit]
- chassis {
-
- aggregated-devices {
-
- ethernet {
- device-count 1;
- }
- }
- }
In this example, the LAG bundle is configured for one-to-one active/backup link redundancy. To support link redundancy at the DPC level, the LAG bundle attaches ports from two different EQ DPCs.
- [edit]
- interfaces {
-
- ge-5/0/3 {
-
- gigether-options {
-
- 802.3ad {
- ae0;
- primary;
- }
- }
- }
-
- ge-5/1/2 {
-
- gigether-options {
-
- 802.3ad {
- ae0;
- backup;
- }
- }
- }
- }
- [edit]
- interfaces {
-
- ae0 {
-
- aggregated-ether-options {
- link-protection;
- minimum-links 1;
- link-speed 1g;
- }
-
- unit 0 {
- demux-source inet {
-
- family inet {
- address 20.1.1.0/24;
- }
- }
-
- unit 1 {
- demux-source inet {
-
- family inet {
- address 20.1.1.1/24;
- }
- }
- }
- }
- [edit]
- interfaces {
-
- demux0 {
-
- unit 101 {
-
- demux-options {
- underlying-interface ae0.0;
- }
-
- family inet {
- demux-source 10.1.0.0/16;
- address 1.1.1.0/24;
- }
- }
-
- unit 101 {
-
- demux-options {
- underlying-interface ae0.1;
- }
-
- family inet {
- demux-source 10.1.0.1/16;
- address 1.1.1.1/24;
- }
- }
- }
- }