Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Example: Configuring a Multihomed VPLS (FEC 128)

This example shows how to set up a multihomed VPLS network.

Requirements

The network topology discussed in this example uses the following devices:

  • EX Series Ethernet Switches that are running Junos OS Release 9.4 or later for customer edge devices
  • M Series Multiservice Edge Routers that are running Junos OS Release 9.3 or later for provider edge routers

Overview

You can configure multihoming for any routing instance of type VPLS. This example provides a sample topology of a multihomed VPLS, and explains how to set up a multihomed VPLS network. This example also shows how to verify a multihomed VPLS network configuration.

Sample Topology

In this example, the customer edge device, CE1, connects over interfaces ge-0/0/9 and ge-0/0/8 to interfaces ge-1/0/5 and ge-3/0/4 on provider edge routers PE1 and PE3, respectively, to create a multihomed VPLS with Device CE2 that is connected through provider edge router PE2.

Figure 1: Sample Topology of a Multihomed VPLS Site

Sample Topology of a Multihomed VPLS Site

Guidelines for Configuring a Multihomed VPLS Site

When setting up a multihomed VPLS configuration, you must:

  • Include the multihoming statement to enable multihoming for the site. In this example, multihoming is configured on Routers PE1 and PE3, the provider edge routers that connect to the customer edge device CE1.
  • Assign the same site ID on all PE routers that are connected to the same CE device. In this example, Routers PE1 and PE3, the provider edge routers that connect to Device CE1, have the same site name (site 1) and site ID (10).
  • Configure the same VLAN ID on all devices that are part of the multihomed VPLS network. In this example, VLAN ID is constant (600) across the customer edge devices, CE1 and CE2, and the provider edge routers, PE1, PE2, and PE3.
  • Assign distinct route distinguishers for multihomed PE routers. In this example, Routers PE1, PE2, and PE3 have unique route identifiers configured on them.
  • Configure the multihomed provider edge routers as primary and backup. In this example, Router PE1 is configured as the primary site, whereas Router PE3 is configured as the backup site.
  • Reference all interfaces assigned to the multihomed VPLS site on each PE router. Only one of these interfaces is used to send and receive traffic for this site at a time.
  • Either designate a primary interface or allow the router to select the interface to be used as the primary interface. If the router selects the interface, the interface used to connect the PE router to the site depends on the order in which interfaces are listed in the PE router’s configuration. The first operational interface in the set of configured interfaces is chosen to be the designated interface. If this interface fails, the next interface in the list is selected to send and receive traffic for the site.

To enable VPLS multihoming, you must include the following configuration statements in the provider edge router configuration:

[edit routing-instances routing-instance-name]instance-type vpls;interface interface-name;protocols {vpls {site site-name {active-interface {any;primary interface-name;}interface interface-name;multihoming;site-identifier number;}}route-distinguisher (as-number:id | ip-address:id);

Configuration

To configure a multihomed VPLS network, perform these tasks:

Configuring Customer Edge Device CE1

Step-by-Step Procedure

To configure Device CE1:

  1. Enable the interfaces on which you want to configure the VPLS routing instance.
    user@CE1# set interfaces ge-0/0/8 enableuser@CE1# set interfaces ge-0/0/9 enable
  2. Enable the interfaces to receive and forward frames with 802.1Q VLAN tags.
    user@CE1# set interfaces ge-0/0/8 vlan-tagginguser@CE1# set interfaces ge-0/0/9 vlan-tagging
  3. Configure the logical interfaces, VLAN identifier value for 802.1Q VLAN tags, and the address family.
    user@CE1# set interfaces ge-0/0/8 unit 600 vlan-id 600 family inet address 15.11.3.2/24user@CE1# set interfaces ge-0/0/9 unit 600 vlan-id 600 family inet address 15.11.3.1/24

Results

After you complete the steps in the preceding procedure, the relevant section of the configuration on Device CE1 reads as:

interfaces ge-0/0/8 {enable;vlan-tagging;unit 600 {vlan-id 600;family inet {address 15.11.3.2/24;}}}interfaces ge-0/0/9 {enable;vlan-tagging;unit 600 {vlan-id 600;family inet {address 15.11.3.1/24;}}}

Configuring Customer Edge Device CE2

Step-by-Step Procedure

To configure Device CE2:

  1. Enable the interface on which you want to configure the VPLS routing instance.
    user@CE1# set interfaces ge-0/0/2 enable
  2. Enable the interface to receive and forward frames with 802.1Q VLAN tags.
    user@CE1# set interfaces ge-0/0/2 vlan-tagging
  3. Configure the logical interface, VLAN identifier value for 802.1Q VLAN tags, and the address family.
    user@CE1# set interfaces ge-0/0/2 unit 600 vlan-id 600 family inet address 15.11.3.3/24

Results

After you complete the steps in the preceding procedure, the relevant section of configuration on Device CE2 reads as:

interfaces ge-0/0/2 {enable;vlan-tagging;unit 600 {vlan-id 600;family inet {address 15.11.3.3/24;}}}

Configuring Provider Edge Router PE1

Step-by-Step Procedure

To configure Router PE1 for multihoming:

  1. Configure the interface properties.
    [edit interfaces ge-1/0/5]user@PE1# set enableuser@PE1# set flexible-vlan-tagginguser@PE1# set encapsulation vlan-vplsuser@PE1# set unit 10
    [edit interfaces ge-1/0/5 unit 10] user@PE1# set encapsulation vlan-vplsuser@PE1# set vlan-id 600 user@PE1# set family vpls
  2. Create a routing instance of type VPLS, and configure the following parameters.
    [edit]user@PE1# set routing-instances vpls-multihoming instance-type vpls
    [edit routing-instances vpls-multihoming]user@PE1# set interface ge-1/0/5.10user@PE1# set route-distinguisher 65410:102 user@PE1# set vrf-target target:65410:0
    [edit routing-instances vpls-multihoming protocols vpls]user@PE1# set no-tunnel services
    [edit routing-instances vpls-multihoming protocols vpls site site1]user@PE1# set site identifier 10user@PE1# set multihominguser@PE1# set site-preference primaryuser@PE1# set interface ge-1/0/5.10user@PE1# set active-interface primary ge-1/0/5.10
  3. Configure the routing options.
    [edit routing-options]user@PE1# set static route 0.0.0.0/0 next-hop [116.197.178.110.93.54.254]user@PE1# set router-id 192.1.1.4user@PE1# set autonomous-system 69user@PE1# set forwarding-table export exp-to-fwd
  4. Configure BGP properties.
    [edit protocols bgp]user@PE1# set group vpls-pe type internal
    [edit protocols bgp group vpls-pe]user@PE1# set local- address 192.1.1.4 user@PE1# set family l2vpn signalinguser@PE1# set neighbor 192.1.1.5user@PE1# set neighbor 192.1.1.6user@PE1# set neighbor 192.1.1.3
  5. Configure RSVP properties.
    [edit]user@PE1# set protocols rsvp interface all aggregate
  6. Configure OSPF properties.
    [edit protocols ospf]user@PE1# set traceoptions file ospf world-readable flag erroruser@PE1# set overload timeout 600user@PE1# set traffic-engineeringuser@PE1# set lsa-refresh-interval 30
    [edit protocols ospf area 0.0.0.0]user@PE1# set interface lo.0.0 passiveuser@PE1# set interface ge-2/2/2.0 metric 11
  7. Configure policy options.
    [edit]user@PE1# set policy-options policy-statement exp-to-fwd
    [edit policy-options policy-statement exp-to-fwd]user@PE1# set term a
    [edit policy-options policy-statement exp-to-fwd term a]user@PE1# set from community testuser@PE1# set then install next-nexthop lsp [pe1-to-pe3 pe1-to-pe2]user@PE1# set then acceptuser@PE1# exituser@PE1# set policy-options policy-statement next-hop-self
    [edit policy-options policy-statement next-hop-self]user@PE1# set then next-hop-selfuser@PE1# set then next policyuser@PE1# exituser@PE1# set policy-options community test members target:65410:0

Results

After you complete this procedure, the configuration on Router PE1 reads:

routing-instances vpls-multihoming instance-type vpls {interface ge-1/0/5.10;route-distinguisher 65410:102; vrf-target target:65410:0;protocols {vpls {no-tunnel-services;site site1 {site-identifier 10; multihoming;site-preference primary;active-interface primary ge-1/0/5.10;interface ge-1/0/5.10;}}}}routing-options {static {route 0.0.0.0/0 next-hop [ 116.197.178.1 10.93.54.254 ];}router-id 192.1.1.4;autonomous-system 69;forwarding-table {export exp-to-fwd;}}interfaces ge-1/0/5 {enable;flexible-vlan-tagging;encapsulation vlan-vpls;unit 10 {encapsulation vlan-vpls;vlan-id 600;family vpls;}}protocols{bgp {group vpls-pe {type internal;local-address 192.1.1.4;family l2vpn {signaling;}neighbor 192.1.1.5;neighbor 192.1.1.6;neighbor 192.1.1.3;}}rsvp {interface all {aggregate;}}ospf {traceoptions {file ospf world-readable;flag error;}overload timeout 600;traffic-engineering;lsa-refresh-interval 30;area 0.0.0.0 {interface lo0.0 {passive;}interface ge-2/2/2.0 {metric 11;}}}}policy-options {policy-statement exp-to-fwd {term a {from community test;then {install-nexthop lsp [ pe1-to-pe3 pe1-to-pe2 ];accept;}}}policy-statement next-hop-self {then {next-hop self;next policy;}}community test members target:65410:0;}

Configuring Provider Edge Router PE2

Step-by-Step Procedure

To configure Router PE2 for multihoming:

  1. Configure the interface properties.
    [edit interfaces ge-1/0/2]user@PE2# set enableuser@PE2# set flexible-vlan-tagginguser@PE2# set encapsulation flexible-ethernet-servicesuser@PE2# set unit 10
    [edit interfaces ge-1/0/5 unit 10] user@PE2# set encapsulation vlan-vplsuser@PE2# set vlan-id 600user@PE2# set family vpls
  2. Create a routing instance of type VPLS, and configure the following parameters.
    [edit]user@PE2# set routing-instances vpls-multihoming instance-type vpls
    [edit routing-instances vpls-multihoming]user@PE2# set interface ge-1/0/1.10user@PE2# set interface ge-1/0/2.100user@PE2# set route-distinguisher 65410:103 user@PE2# set vrf-target target:65410:0
    [edit routing-instances vpls-multihoming protocols vpls]user@PE2# set no-tunnel services
    [edit routing-instances vpls-multihoming protocols vpls site site2]user@PE2# set site identifier 20
  3. Configure the routing options.
    [edit routing-options]user@PE2# set static route 0.0.0.0/0 next-hop [116.197.178.1 10.93.54.254]user@PE2# set static route 6.6.6.8/32 next-hop 116.197.179.15user@PE2# set static route 18.1.1.1/32 next-hop 116.197.179.15user@PE2# set router-id 192.1.1.3user@PE2# set autonomous-system 69user@PE2# set forwarding-table export exp-to-fwd
  4. Configure BGP properties.
    [edit protocols bgp]user@PE2# set group vpls-pe type internal
    [edit protocols bgp group vpls-pe]user@PE2# set local- address 192.1.1.3 user@PE2# set family l2vpn signalinguser@PE2# set neighbor 192.1.1.4user@PE2# set neighbor 192.1.1.5user@PE2# set neighbor 192.1.1.6
  5. Configure RSVP properties.
    [edit]user@PE2# set protocols rsvp interface all aggregate
  6. Configure OSPF properties.
    [edit protocols ospf]user@PE2# set traceoptions file ospf world-readable flag erroruser@PE2# set overload timeout 600user@PE2# set traffic-engineeringuser@PE2# set lsa-refresh-interval 30
    [edit protocols ospf area 0.0.0.0]user@PE2# set interface lo.0.0 passiveuser@PE2# set interface ge-2/2/1.0 metric 12
  7. Configure policy options.
    [edit]user@PE2# set policy-options policy-statement exp-to-fwd
    [edit policy-options policy-statement exp-to-fwd]user@PE2# set term a
    [edit policy-options policy-statement exp-to-fwd term a]user@PE2# set from community testuser@PE2# set then install next-nexthop lsp [pe2-to-PE1 pe2-to-pe3]user@PE2# set then acceptuser@PE2# exituser@PE2# set policy-options policy-statement next-hop-self
    [edit policy-options policy-statement next-hop-self]user@PE2# set then next-hop-selfuser@PE2# set then next policyuser@PE2# exituser@PE2# set policy-options community test members target:65410:0

Results

After you complete this procedure, the configuration on Router PE2 reads:

interfaces ge-1/0/2 {enable;flexible-vlan-tagging;encapsulation flexible-ethernet-services;unit 10 {encapsulation vlan-vpls;vlan-id 600;family vpls;}}routing-instances vpls-multihoming {instance-type vpls;interface ge-1/0/1.10;interface ge-1/0/2.100;route-distinguisher 65410:103;vrf-target target:65410:0;protocols {vpls {no-tunnel-services;site site2 {site-identifier 20;}}}}routing-options {static {route 0.0.0.0/0 next-hop [ 116.197.178.1 10.93.54.254 ];route 6.6.6.8/32 next-hop 116.197.179.15;route 18.1.1.1/32 next-hop 116.197.179.15;}router-id 192.1.1.3;autonomous-system 69;forwarding-table {export exp-to-fwd;}}protocols {bgp {group vpls-pe {type internal;local-address 192.1.1.3;family l2vpn {signaling;}neighbor 192.1.1.4;neighbor 192.1.1.5;neighbor 192.1.1.6;}}rsvp {interface all {aggregate;}}ospf {traceoptions {file ospf world-readable;flag error;}overload timeout 600;traffic-engineering;lsa-refresh-interval 30;area 0.0.0.0 {interface lo0.0 {passive;}interface ge-2/2/1.0 {metric 12;}}}}policy-options {policy-statement exp-to-fwd {term a {from community test;then {install-nexthop lsp [ pe2-to-pe1 pe2-to-pe3 ];accept;}}}policy-statement next-hop-self {then {next-hop self;next policy;}}community test members target:65410:0;}

Configuring Provider Edge Router PE3

Step-by-Step Procedure

To configure Router PE3 for multihoming:

  1. Configure the interface properties.
    [edit interfaces ge-3/0/4]user@PE3# set enableuser@PE3# set flexible-vlan-tagginguser@PE3# set encapsulation vlan-vplsuser@PE3# set unit 100
    [edit interfaces ge-3/0/4 unit 100] user@PE3# set encapsulation vlan-vplsuser@PE3# set vlan-id 600user@PE3# set family vpls
  2. Create a routing instance of type VPLS, and configure the following parameters.
    [edit]user@PE3# set routing-instances vpls-multihoming instance-type vpls
    [edit routing-instances vpls-multihoming]user@PE3# set interface ge-3/0/4.100user@PE3# set route-distinguisher 65410:100 user@PE3# set vrf-target target:65410:0
    [edit routing-instances vpls-multihoming protocols vpls]user@PE3# set no-tunnel services
    [edit routing-instances vpls-multihoming protocols vpls site site1]user@PE3# set site identifier 10user@PE3# set multihominguser@PE3# set site-preference backup
  3. Configure the routing options.
    [edit routing-options]user@PE3# set static route 0.0.0.0/0 next-hop 116.197.178.1user@PE3# set router-id 192.1.1.6user@PE3# set autonomous-system 69user@PE3# set forwarding-table export exp-to-fwd
  4. Configure BGP properties.
    [edit protocols bgp]user@PE3# set group vpls-pe type internal
    [edit protocols bgp group vpls-pe]user@PE3# set local- address 192.1.1.6 user@PE3# set family l2vpn signalinguser@PE3# set neighbor 192.1.1.4user@PE3# set neighbor 192.1.1.5user@PE3# set neighbor 192.1.1.3
  5. Configure RSVP properties.
    [edit]user@PE3# set protocols rsvp interface all aggregate
  6. Configure OSPF properties.
    [edit protocols ospf]user@PE3# set traceoptions file ospf world-readable flag erroruser@PE3# set overload timeout 600user@PE3# set traffic-engineeringuser@PE3# set lsa-refresh-interval 30
    [edit protocols ospf area 0.0.0.0]user@PE3# set interface lo.0.0 passiveuser@PE3# set interface ge-3/0/0.0 metric 15
  7. Configure policy options.
    [edit]user@PE3# set policy-options policy-statement exp-to-fwd
    [edit policy-options policy-statement exp-to-fwd]user@PE3# set term a
    [edit policy-options policy-statement exp-to-fwd term a]user@PE3# set from community testuser@PE3# set then install next-nexthop lsp [pe3-to-pe1 pe3-to-pe2]user@PE3# set then acceptuser@PE3# exituser@PE3# set policy-options policy-statement next-hop-self
    [edit policy-options policy-statement next-hop-self]user@PE3# set then next-hop-selfuser@PE3# set then next policyuser@PE3# exituser@PE3# set policy-options community test members target:65410:0

Results

After you complete this procedure, the configuration on Router PE3 reads:

interfaces ge-3/0/4 {enable;encapsulation vlan-vpls;flexible-vlan-tagging;unit 100 {encapsulation vlan-vpls;vlan-id 600;family vpls;}}routing-instances vpls-multihoming instance-type vpls {interface ge-3/0/4.100;route-distinguisher 65410:100vrf-target target:65410:0;protocols {vpls {no-tunnel-services;site site1 {site-identifier 10;multihoming;site-preference backup;}}}}routing-options {static {route 0.0.0.0/0 next-hop 116.197.178.1;}router-id 192.1.1.6;autonomous-system 69;forwarding-table {export exp-to-fwd;}}protocols {bgp {group vpls-pe {type internal;local-address 192.1.1.6;family l2vpn {signaling;}neighbor 192.1.1.4;neighbor 192.1.1.5;neighbor 192.1.1.3;}}ospf {traceoptions {file ospf world-readable;flag error;}overload timeout 600;traffic-engineering;lsa-refresh-interval 30;area 0.0.0.0 {interface ge-3/0/0.0 {metric 15;}interface lo0.0 {passive;}}}rsvp {interface all {aggregate;}}}policy-options {policy-statement exp-to-fwd {term a {from community test;then {install-nexthop lsp [ pe3-to-pe1 pe3-to-pe2 ];accept;}}}policy-statement next-hop-self {then {next-hop self;next policy;}}community test members target:65410:0;}

Verification

Confirm that the configuration is working properly.

Verifying a Multihomed VPLS Connection from the Junos OS CLI

Purpose

Validate the multihomed VPLS connection.

Action

Verify the multihomed VPLS connections on the provider edge routers.

  1. Enter the show vpls connections command on Router PE1.
    user@PE1> show vpls connections
    Layer-2 VPN connections:
    
    Legend for connection status (St)
    EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
    EM -- encapsulation mismatch     WE -- interface and instance encaps not same
    VC-Dn -- Virtual circuit down    NP -- interface hardware not present
    CM -- control-word mismatch      -> -- only outbound connection is up
    CN -- circuit not provisioned    <- -- only inbound connection is up
    OR -- out of range               Up -- operational
    OL -- no outgoing label          Dn -- down
    LD -- local site signaled down   CF -- call admission control failure
    RD -- remote site signaled down  SC -- local and remote site ID collision
    LN -- local site not designated  LM -- local site ID not minimum designated
    RN -- remote site not designated RM -- remote site ID not minimum designated
    XX -- unknown connection status  IL -- no incoming label
    MM -- MTU mismatch               MI -- Mesh-Group ID not availble
    BK -- Backup connection          ST -- Standby connection
    PF -- Profile parse failure      PB -- Profile busy
    
    Legend for interface status
    Up -- operational
    Dn -- down
    
    Instance: vpls-multihoming
      Local site: site1 (10)
        connection-site      Type   St     Time last up      # Up trans
        10                   rmt   RN
        20                   rmt   Up     May 14 07:54:42 2010    1
          Remote PE: 192.1.1.3, Negotiated control-word: No
          Incoming label: 262164, Outgoing label: 262154
          Local interface: lsi.1048834, Status: Up, Encapsulation: VPLS
            Description: Intf - vpls vpls-multihoming local site 10 remote site 20
    

    The output shows that Router PE1 is connected to two sites (ID: 10 and 20), where site 10 is a remote site that is not designated, and site 20 is the remote site that is connected to Router PE1.

  2. Enter the show vpls connections command on Router PE2.
    user@PE2> show vpls connections
    Layer-2 VPN connections:
    
    ~
    ~
    ~
    Instance: vpls-multihoming
      Local site: site2 (20)
      connection-site         Type  St     Time last up       # Up trans
      10                      rmt   Up     May 14 07:29:55 2010    1
          Remote PE: 192.1.1.4, Negotiated control-word: No
          Incoming label: 262154, Outgoing label: 262164
          Local interface: lsi.1048576, Status: Up, Encapsulation: VPLS
            Description: Intf - vpls vpls-multihoming local site 20 remote site 10
    

    The output shows that Router PE2, with site ID 20, is connected to the remote site (192.1.1.4) with site ID 10, that is, Router PE1.

  3. Enter the show vpls connections command on Router PE3.
    user@PE3> show vpls connections
    Layer-2 VPN connections:
    
    ~
    ~
    ~
    Instance: vpls-multihoming
      Local site: site1 (10)
        connection-site           Type  St     Time last up          # Up trans
        10                        rmt   LN
        20                        rmt   LN
    
    

    The output shows that Router PE3 is connected to two remote sites, site ID 10 and site ID 20.

Published: 2012-06-13

Supported Platforms

Published: 2012-06-13