The complete topology as shown in Figure 1 consists of:
The data center fabric:
Five EVPN LEAF PEs: LEAF-1, LEAF-2, LEAF-3, LEAF-4, and
LEAF-5
Two EVPN Border LEAF PEs: BL-1 and BL-2
Two Lean Spine devices: SPINE-1 and SPINE-2
External multicast world:
One PIM Gateway: PIM-GW
One PIM RP: PIM-RP
Three CE devices for multihoming some of the end Hosts:
CE-1, CE-2, and CE-3.
Eight router tester (RT) ports to simulate multicast traffic
source(s) and receivers.
We will configure these devices as required.
Base EVPN Configuration
Configuring the Underlay
LEAF-1
Configure the underlay interfaces:
set interfaces xe-0/0/0 description "TO SPINE-1"
set interfaces xe-0/0/0 unit 0 family inet address 8.8.8.2/24
set interfaces xe-0/0/1 description "TO SPINE-2"
set interfaces xe-0/0/1 unit 0 family inet address 13.13.13.2/24
set interfaces lo0 unit 0 family inet address 105.105.105.105/32
commit
Configure BGP for routing in the underlay:
set routing-options router-id 105.105.105.105
set routing-options autonomous-system 65005
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65005
set protocols bgp group UNDERLAY neighbor 8.8.8.1 description
SPINE-1
set protocols bgp group UNDERLAY neighbor 8.8.8.1 peer-as
65003
set protocols bgp group UNDERLAY neighbor 13.13.13.1 description
SPINE-2
set protocols bgp group UNDERLAY neighbor 13.13.13.1 peer-as
65004
commit
The underlay configuration on other LEAF PEs and border LEAF
PEs will be similar and is provided in the Appendix
SPINE-1
Configure the underlay interfaces:
set interfaces xe-0/0/0 description "TO BL-1"
set interfaces xe-0/0/0 unit 0 family inet address 5.5.5.2/24
set interfaces xe-0/0/1 description "TO BL-2"
set interfaces xe-0/0/1 unit 0 family inet address 7.7.7.2/24
set interfaces xe-0/0/2 description "TO LEAF-1"
set interfaces xe-0/0/2 unit 0 family inet address 13.13.13.1/24
set interfaces xe-0/0/3 description "TO LEAF-2"
set interfaces xe-0/0/3 unit 0 family inet address 14.14.14.1/24
set interfaces xe-0/0/4 description "TO LEAF-3"
set interfaces xe-0/0/4 unit 0 family inet address 15.15.15.1/24
set interfaces xe-0/0/5 description "TO LEAF-4"
set interfaces xe-0/0/5 unit 0 family inet address 16.16.16.1/24
set interfaces xe-0/0/6 description "TO LEAF-5"
set interfaces xe-0/0/6 unit 0 family inet address 17.17.17.1/24
set interfaces lo0 unit 0 family inet address 104.104.104.104/32
commit
Configure BGP for routing in the underlay:
set routing-options router-id 104.104.104.104
set routing-options autonomous-system 65004
set policy-options policy-statement EXPORT-LO term 1 from
protocol direct
set policy-options policy-statement EXPORT-LO term 1 then
accept
set protocols bgp group UNDERLAY family inet any
set protocols bgp group UNDERLAY export EXPORT-LO
set protocols bgp group UNDERLAY local-as 65004
set protocols bgp group UNDERLAY neighbor 5.5.5.1 description
BL-1
set protocols bgp group UNDERLAY neighbor 5.5.5.1 peer-as
65001
set protocols bgp group UNDERLAY neighbor 7.7.7.1 description
BL-2
set protocols bgp group UNDERLAY neighbor 7.7.7.1 peer-as
65002
set protocols bgp group UNDERLAY neighbor 13.13.13.2 description
LEAF-1
set protocols bgp group UNDERLAY neighbor 13.13.13.2 peer-as
65005
set protocols bgp group UNDERLAY neighbor 14.14.14.2 description
LEAF-2
set protocols bgp group UNDERLAY neighbor 14.14.14.2 peer-as
65006
set protocols bgp group UNDERLAY neighbor 15.15.15.2 description
LEAF-3
set protocols bgp group UNDERLAY neighbor 15.15.15.2 peer-as
65007
set protocols bgp group UNDERLAY neighbor 16.16.16.2 description
LEAF-4
set protocols bgp group UNDERLAY neighbor 16.16.16.2 peer-as
65008
set protocols bgp group UNDERLAY neighbor 17.17.17.2 description
LEAF-5
set protocols bgp group UNDERLAY neighbor 17.17.17.2 peer-as
65009
commit
We will go over the configuration for SPINE-1. The configuration
on SPINE-2 will be similar and is provided in the Appendix.
Configuring the Overlay
We will now configure the overlay on the EVPN PEs.
LEAF-1
Configure I-BGP for routing in the overlay:
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 105.105.105.105
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 102.102.102.102
description BL-2
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
commit
Configure the customer interfaces and VLANs:
set chassis aggregated-devices ethernet deviCE-3ount 2
set interfaces xe-0/0/2 gigether-options 802.3ad ae0
set interfaces xe-0/0/3 gigether-options 802.3ad ae1
set interfaces xe-0/0/4 description "TO Host-2"
set interfaces xe-0/0/4 unit 0 family ethernet-switching
interface-mode trunk
set interfaces xe-0/0/4 unit 0 family ethernet-switching
VLAN members VLAN-101
set interfaces ae0 description "TO CE-1"
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 aggregated-ether-options lacp system-id
00:11:11:11:11:11
set interfaces ae0 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae0 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae1 description "TO CE-2"
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic
fast
set interfaces ae1 aggregated-ether-options lacp system-id
00:22:22:22:22:22
set interfaces ae1 unit 0 family ethernet-switching interface-mode
trunk
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-101
set interfaces ae1 unit 0 family ethernet-switching VLAN
members VLAN-102
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
commit
Configure EVPN to extend the customer VLANs:
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 105.105.105.105:1
set switch-options vrf-target target:1:1
commit
Configure ESIs for multihomed interfaces:
set interfaces ae0 esi 00:11:11:11:11:11:11:11:11:11
set interfaces ae0 esi 00:11:11:11:11:11:11:11:11:11
set interfaces ae1 esi 00:22:22:22:22:22:22:22:22:22
set interfaces ae1 esi all-active
commit
The overlay configuration on other EVPN LEAF PEs will be similar
and is provided in the Appendix.
BL-1
Configure I-BGP for routing in the overlay:
set protocols bgp group OVERLAY type internal
set protocols bgp group OVERLAY local-address 102.102.102.102
set protocols bgp group OVERLAY family evpn signaling
set protocols bgp group OVERLAY local-as 65000
set protocols bgp group OVERLAY neighbor 101.101.101.101
description BL-1
set protocols bgp group OVERLAY neighbor 105.105.105.105
description LEAF-1
set protocols bgp group OVERLAY neighbor 106.106.106.106
description LEAF-2
set protocols bgp group OVERLAY neighbor 107.107.107.107
description LEAF-3
set protocols bgp group OVERLAY neighbor 108.108.108.108
description LEAF-4
set protocols bgp group OVERLAY neighbor 109.109.109.109
description LEAF-5
commit
Configure the customer VLANs:
set vlans VLAN-101 VLAN-id 101
set vlans VLAN-101 vxlan vni 101
set vlans VLAN-102 VLAN-id 102
set vlans VLAN-102 vxlan vni 102
commit
Configure EVPN to extend the customer VLANs:
set protocols evpn encapsulation vxlan
set protocols evpn extended-vni-list 101
set protocols evpn extended-vni-list 102
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 101.101.101.101:1
set switch-options vrf-target target:1:1
commit
Configure the L3 VRF and its interfaces:
set interfaces irb unit 101 virtual-gateway-accept-data
set interfaces irb unit 101 virtual-gateway-esi 00:66:66:66:66:66:66:66:66:66
set interfaces irb unit 101 virtual-gateway-esi all-active
set interfaces irb unit 101 family inet address 18.18.18.1/24
virtual-gateway-address 18.18.18.100
set interfaces irb unit 102 virtual-gateway-accept-data
set interfaces irb unit 102 virtual-gateway-esi 00:77:77:77:77:77:77:77:77:77
set interfaces irb unit 102 virtual-gateway-esi all-active
set interfaces irb unit 102 family inet address 19.19.19.1/24
virtual-gateway-address 19.19.19.100
set interfaces lo0 unit 1 family inet address 101.101.101.102/32
set routing-instances VRF-1 instance-type virtual-router
set routing-instances VRF-1 interface irb.101
set routing-instances VRF-1 interface irb.102
set routing-instances VRF-1 interface lo0.1
set vlans VLAN-101 l3-interface irb.101
set vlans VLAN-102 l3-interface irb.102
commit
Configure the L3 multicast protocols on the L3 VRF:
set routing-instances VRF-1 protocols pim interface lo0.1
mode sparse
set routing-instances VRF-1 protocols pim rp local address
101.101.101.102
set routing-instances VRF-1 protocols pim interface all
mode sparse
set routing-instances VRF-1 protocols pim interface irb.102
priority 2
commit
The overlay configuration on BL-2 will be similar and is provided
in the Appendix.
Configuring the CE devices
CE-1
Configure the interfaces and bridge-domains:
set chassis aggregated-devices ethernet deviCE-3ount 1
set interfaces ge-0/0/0 description "TO Host-1"
set interfaces ge-0/0/0 unit 0 family bridge interface-mode
trunk
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
101
set interfaces ge-0/0/0 unit 0 family bridge VLAN-id-list
102
set interfaces ge-0/0/1 gigether-options 802.3ad ae0
set interfaces ge-0/0/2 gigether-options 802.3ad ae0
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic
fast
set interfaces ae0 description "TO LEAF-1_LEAF-2"
set interfaces ae0 unit 0 family bridge interface-mode
trunk
set interfaces ae0 unit 0 family bridge VLAN-id-list 101
set interfaces ae0 unit 0 family bridge VLAN-id-list 102
set bridge-domains BD-101 domain-type bridge
set bridge-domains BD-101 VLAN-id 101
set bridge-domains BD-102 domain-type bridge
set bridge-domains BD-102 VLAN-id 102
commit
The overlay configuration on other CE devices will be similar
and is provided in the Appendix, and refer to the Appendix for complete
base configuration on all devices in the topology.