Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Example: ATM Pseudowire Base Configuration

Requirements

The following is a list of the hardware and software requirements for this configuration.

  • One ACX Series router
  • Junos OS Release 12.2 or later

Overview of an ATM Pseudowire With Cell Mode Base Configuration

The configuration shown here is the base configuration of an ATM pseudowire with ATM cell-relay encapsulation on an ACX Series router. This configuration is for one provider edge router. To complete the configuration of an ATM pseudowire, you need to repeat this configuration on an other provider edge router in the MPLS network.

Configuring an ATM Pseudowire

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level:

set interfaces at-0/0/0 atm-options vpi 0
set interfaces at-0/0/0 unit 0 encapsulation atm-ccc-cell-relay
set interfaces at-0/0/0 unit 0 vci 0.64
set interfaces ct1-0/0/0 no-partition interface-type at
set interfaces ge-0/2/0 unit 0 family inet address 20.1.1.2/24
set interfaces ge-0/2/0 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 70.1.1.1/32
set protocols rsvp interface ge-0/2/0.0
set protocols mpls no-cspf
set protocols mpls label-switched-path PE1-to-PE2 to 40.1.1.1
set protocols mpls interface ge-0/2/0.0
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface ge-0/2/0.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface ge-0/2/0.0
set protocols ldp interface lo0.0
set protocols l2circuit neighbor 40.1.1.1 interface at-0/0/0.0 virtual-circuit-id 1

Note: To configure an ATM pseudowire with ATM virtual circuit (VC) multiplex encapsulation on CCC circuits, include the atm-ccc-vc-mux statement at the [edit interfaces at-0/0/0 unit 0 encapsulation] hierarchy level instead of the atm-ccc-cell-relay statement shown in this example.

Step-by-Step Procedure

  1. Create an ATM interface on a channelized T1 interface (ct1) and enable full channelization with the no-partition statement. On the ATM interface, set the ATM virtual circuit identifier (VCI), the virtual path identifier (VPI), and set the encapsulation cell mode.

    [edit]user@host# edit interfaces[edit interfaces]user@host# set ct1-0/0/0 no-partition interface-type atuser@host# set at-0/0/0 unit 0 vci 0.64user@host# set at-0/0/0 atm-options vpi 0user@host# set at-0/0/0 unit 0 encapsulation atm-ccc-cell-relay
  2. Create a Gigabit Ethernet interface and enable MPLS on that interface. Create the loopback (lo0) interface:

    [edit interfaces]user@host# set ge-0/2/0 unit 0 family inet address 20.1.1.2/24user@host# set ge-0/2/0 unit 0 family mplsuser@host# set lo0 unit 0 family inet address 70.1.1.1/32
  3. Enable the MPLS and RSVP protocols on the MPLS interface—ge-0/2/0.0:

    [edit]user@host# edit protocols[edit protocols]user@host# set rsvp interface ge-0/2/0.0user@host# set mpls interface ge-0/2/0.0
  4. Configure LDP. If you configure RSVP for a pseudowire, you must also configure LDP:

    [edit protocols]user@host# set protocols ldp interface ge-0/2/0.0user@host# set protocols ldp interface lo0.0
  5. Configure a point-to-point label-switched path (LSP) and disable constrained-path LSP computation:

    [edit protocols]user@host# set mpls label-switched-path PE1-to-PE2 to 40.1.1.1user@host# set mpls no-cspf
  6. Configure OSPF and enable traffic engineering on the MPLS interface—ge-0/2/0.0, and on the loopback (lo0) interface:

    [edit protocols]user@host# set ospf traffic-engineeringuser@host# set ospf area 0.0.0.0 interface ge-0/2/0.0user@host# set ospf area 0.0.0.0 interface lo0.0 passive
  7. Uniquely identify a Layer 2 circuit for the ATM pseudowire:

    [edit protocols]user@host# set l2circuit neighbor 40.1.1.1 interface at-0/0/0.0 virtual-circuit-id 1

Results

[edit]
user@host# show
interfaces {
    at-0/0/0 {
        atm-options {
            vpi 0;
        }
        unit 0 {
            encapsulation atm-ccc-cell-relay;
            vci 0.64;
        }
    }
    ct1-0/0/0 {
        no-partition interface-type at;
    }
    ge-0/2/0 {
        unit 0 {
            family inet {
                address 20.1.1.2/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 70.1.1.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface ge-0/2/0.0;
    }
    mpls {
        no-cspf;
        label-switched-path PE1-to-PE2 {
            to 40.1.1.1;
        }
        interface ge-0/2/0.0;
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface ge-0/2/0.0;
            interface lo0.0 {
                passive;
            }
        }
    }
    ldp {
        interface ge-0/2/0.0;
        interface lo0.0;
    }
    l2circuit {
        neighbor 40.1.1.1 {
            interface at-0/0/0.0 {
                virtual-circuit-id 1;
            }
        }
    }
}

Published: 2013-01-11