Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Example: Ethernet Pseudowire Base Configuration

Requirements

The following is a list of the hardware and software requirements for this configuration.

  • One ACX Series router
  • Junos OS Release 12.2 or later

Overview of an Ethernet Pseudowire Base Configuration

The configuration shown here is the base configuration of an Ethernet pseudowire with Ethernet cross-connect for physical interface encapsulation on an ACX Series router. This configuration is for one provider edge router. To complete the configuration of an Ethernet pseudowire, you need to repeat this configuration on an other provider edge router in the Multiprotocol Label Switched (MPLS) network.

Configuring an Ethernet Pseudowire

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level:

set interfaces ge-0/1/1 encapsulation ethernet-ccc
set interfaces ge-0/1/1 unit 0
set interfaces ge-0/2/0 unit 0 family inet address 20.1.1.2/24
set interfaces ge-0/2/0 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 70.1.1.1/32
set protocols rsvp interface ge-0/2/0.0
set protocols mpls no-cspf
set protocols mpls label-switched-path PE1-to-PE2 to 40.1.1.1
set protocols mpls interface ge-0/2/0.0
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface ge-0/2/0.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface ge-0/2/0.0
set protocols ldp interface lo0.0
set protocols l2circuit neighbor 40.1.1.1 interface ge-0/1/1.0 virtual-circuit-id 1

Note: To configure an Ethernet pseudowire with 802.1Q tagging for cross-connect logical interface encapsulation, include the vlan-ccc statement at the [edit interfaces ge-0/1/1 unit 0 encapsulation] hierarchy level instead of the ethernet-ccc statement shown in this example.

Step-by-Step Procedure

  1. Create two Gigabit Ethernet interfaces, set the encapsulation mode on one interface and MPLS on the other interface. Create the loopback (lo0) interface:

    [edit]user@host# edit interfaces[edit interfaces]user@host# set ge-0/1/1 encapsulation ethernet-cccuser@host# set ge-0/1/1 unit 0user@host# set ge-0/2/0 unit 0 family inet address 20.1.1.2/24user@host# set ge-0/2/0 unit 0 family mplsuser@host# set lo0 unit 0 family inet address 70.1.1.1/32
  2. Enable the MPLS and RSVP protocols on the interface configured with MPLS—ge-0/2/0.0:

    [edit]user@host# edit protocols[edit protocols]user@host# set rsvp interface ge-0/2/0.0user@host# set mpls interface ge-0/2/0.0
  3. Configure LDP. If you configure RSVP for a pseudowire, you must also configure LDP:

    [edit protocols]user@host# set protocols ldp interface ge-0/2/0.0user@host# set protocols ldp interface lo0.0
  4. Configure a point-to-point label-switched path (LSP) and disable constrained-path LSP computation:

    [edit protocols]user@host# set mpls label-switched-path PE1-to-PE2 to 40.1.1.1user@host# set mpls no-cspf
  5. Configure OSPF and enable traffic engineering on the MPLS interface—ge-0/2/0.0, and on the loopback (lo0) interface:

    [edit protocols]user@host# set ospf traffic-engineeringuser@host# set ospf area 0.0.0.0 interface ge-0/2/0.0user@host# set ospf area 0.0.0.0 interface lo0.0 passive
  6. Uniquely identify a Layer 2 circuit for the Ethernet pseudowire:

    [edit protocols]user@host# set l2circuit neighbor 40.1.1.1 interface ge-0/1/1.0 virtual-circuit-id 1

Results

[edit]
user@host# show
interfaces {
    ge-0/1/1 {
        encapsulation ethernet-ccc;
        unit 0;
    }
    ge-0/2/0 {
        unit 0 {
            family inet {
                address 20.1.1.2/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 70.1.1.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface ge-0/2/0.0;
    }
    mpls {
        no-cspf;
        label-switched-path PE1-to-PE2 {
            to 40.1.1.1;
        }
        interface ge-0/2/0.0;
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface ge-0/2/0.0;
            interface lo0.0 {
                passive;
            }
        }
    }
    ldp {
        interface ge-0/2/0.0;
        interface lo0.0;
    }
    l2circuit {
        neighbor 40.1.1.1 {
            interface ge-0/1/1.0 {
                virtual-circuit-id 1;
            }
        }
    }
}

Published: 2013-01-11