Supported Platforms
Related Documentation
- ACX, EX, M, MX, SRX, T Series
- Example: Generating a Persistent Change
- ACX, EX, M, MX, PTX, SRX, T Series
- Generating a Persistent or Transient Change
- Removing a Persistent or Transient Change
- jcs:emit-change Template
- ACX, EX, J, M, MX, PTX, QFX, SRX, T Series
- Overview of Generating Persistent or Transient Configuration Changes
Example: Generating a Transient Change
This example uses a commit script to set PPP encapsulation on all SONET/SDH interfaces with the IPv4 protocol family enabled. The changes are added as transient changes.
Requirements
This example uses a device running Junos OS with one or more SONET/SDH interfaces.
Overview and Commit Script
The commit script in this example finds all SONET/SDH interfaces
with the IPv4 protocol family enabled in the configuration and adds
the encapsulation ppp statement to the interface configuration.
The transient change is generated by the jcs:emit-change template, which is a helper template contained in the junos.xsl
import file. The tag parameter of the jcs:emit-change template
has the value transient-change, which directs
the script to emit the change as a transient change rather than a persistent change.
The content parameter of the jcs:emit-change template includes the configuration
statements to be added as a transient change.
The script is shown in both XSLT and SLAX syntax.
XSLT Syntax
<?xml version="1.0" standalone="yes"?>
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:junos="http://xml.juniper.net/junos/*/junos"
xmlns:xnm="http://xml.juniper.net/xnm/1.1/xnm"
xmlns:jcs="http://xml.juniper.net/junos/commit-scripts/1.0">
<xsl:import href="../import/junos.xsl"/>
<xsl:template match="configuration">
<xsl:for-each select="interfaces/interface[starts-with(name, 'so-')
and unit/family/inet]">
<xsl:call-template name="jcs:emit-change">
<xsl:with-param name="tag" select="'transient-change'"/>
<xsl:with-param name="content">
<encapsulation>ppp</encapsulation>
</xsl:with-param>
</xsl:call-template>
</xsl:for-each>
</xsl:template>
</xsl:stylesheet>
SLAX Syntax
version 1.0;
ns junos = "http://xml.juniper.net/junos/*/junos";
ns xnm = "http://xml.juniper.net/xnm/1.1/xnm";
ns jcs = "http://xml.juniper.net/junos/commit-scripts/1.0";
import "../import/junos.xsl";
match configuration {
for-each (interfaces/interface[starts-with(name, 'so-') and unit/family/inet]) {
call jcs:emit-change($tag = 'transient-change') {
with $content = {
<encapsulation> "ppp";
}
}
}
}
Configuration
Step-by-Step Procedure
Download, enable, and test the script.
- Copy the XSLT or SLAX script into a text file, name the
file
encap-ppp.xsl
orencap-ppp.slax
as appropriate, and copy it to the/var/db/scripts/commit/
directory on the device. In configuration mode, include the file statement at the [edit system scripts commit] hierarchy level and
encap-ppp.xsl
orencap-ppp.slax
as appropriate.[edit]user@host# set system scripts commit file encap-ppp.xslInclude the allow-transients statement at the [edit system scripts commit] hierarchy level. This enables commit scripts to load transient changes into the checkout configuration.
[edit]user@host# set system scripts commit allow-transientsTo test that the commit script generates the transient change correctly, make sure that the configuration contains the condition that elicits the change. Ensure that the encapsulation ppp statement is not included at the [edit interfaces so-fpc/pic/port] hierarchy level for at least one SONET/SDH interface.
If the encapsulation ppp statement is included at the [edit interfaces so-fpc/pic/port] hierarchy level, issue the following configuration mode command to delete the statement:
[edit]user@host# delete interfaces so-fpc/pic/port encapsulation ppp- The commit check command verifies the syntax
of the configuration prior to a commit, but it does not commit the
changes. Issue the commit check command to preview a trace
of commit script processing to verify that the script will add the
transient change to the checkout configuration.
Issue the commit check | display detail command to display a detailed trace of commit script processing. In the sample output, there are two transient changes that are loaded into the checkout configuration.
[edit]
user@host# commit check | display detail
2011-06-15 12:07:30 PDT: reading commit script configuration
2011-06-15 12:07:30 PDT: testing commit script configuration
2011-06-15 12:07:30 PDT: opening commit script '/var/db/scripts/commit/encap-ppp.xsl'
2011-06-15 12:07:30 PDT: reading commit script 'encap-ppp.xsl'
2011-06-15 12:07:30 PDT: running commit script 'encap-ppp.xsl'
2011-06-15 12:07:30 PDT: processing commit script 'encap-ppp.xsl'
2011-06-15 12:07:30 PDT: no errors from encap-ppp.xsl
2011-06-15 12:07:30 PDT: saving commit script changes for script encap-ppp.xsl
2011-06-15 12:07:30 PDT: summary of script encap-ppp.xsl: changes 0, transients 2 (allowed), syslog 0
2011-06-15 12:07:30 PDT: start loading commit script changes
2011-06-15 12:07:30 PDT: no commit script changes
2011-06-15 12:07:30 PDT: updating transient changes into transient tree
2011-06-15 12:07:30 PDT: finished loading commit script changes
2011-06-15 12:07:30 PDT: copying juniper.db to juniper.data+
2011-06-15 12:07:30 PDT: finished copying juniper.db to juniper.data+
2011-06-15 12:07:30 PDT: exporting juniper.conf
2011-06-15 12:07:30 PDT: merging transient changes
... configuration check succeeds After verifying that the script produces the correct changes, issue the commit command to start the commit operation and execute the script.
user@host# commit
Verification
Verifying the Configuration
Purpose
Verify that the correct changes are integrated into the checkout configuration. If there are one or more SONET/SDH interfaces with the IPv4 protocol family enabled, you should see the encapsulation ppp statement added as a transient change to the interface hierarchy.
Action
To view the configuration with transient changes, issue the show interfaces | display commit-scripts configuration mode command. The show interfaces | display commit-scripts command displays all the statements that are in the configuration, including statements that are generated by transient changes. If there are one or more SONET/SDH interfaces with the IPv4 protocol family enabled, the output is similar to the following:
[edit]
user@host# show interfaces | display commit-scripts
... other configured interface types ...
so-1/2/3 {
mtu 576;
encapsulation ppp; /* Added by transient change. */
unit 0 {
family inet {
address 10.0.0.3/32;
}
}
}
so-1/2/4 {
encapsulation ppp; /* Added by transient change. */
unit 0 {
family inet {
address 10.0.0.4/32;
}
}
}
so-2/3/4 {
encapsulation cisco-hdlc; # Not affected by this script, because IPv4 protocol
# family is not configured on this interface.
unit 0 {
family mpls;
}
}
... other configured interface types ...
Troubleshooting
Troubleshooting Commit Errors
Problem
The CLI generates an invalid transient change error, and the commit fails.
user@host# commit check
error: invalid transient change generated by commit script: encap-ppp.xsl warning: 1 transient change was generated without [system scripts commit allow-transients] error: 1 error reported by commit scripts error: commit script failure
Solution
You must configure the allow-transients statement at the [edit system scripts commit] hierarchy level to enable commit scripts to load transient changes into the checkout configuration.
Issue the following configuration mode command to allow transient changes:
Related Documentation
- ACX, EX, M, MX, SRX, T Series
- Example: Generating a Persistent Change
- ACX, EX, M, MX, PTX, SRX, T Series
- Generating a Persistent or Transient Change
- Removing a Persistent or Transient Change
- jcs:emit-change Template
- ACX, EX, J, M, MX, PTX, QFX, SRX, T Series
- Overview of Generating Persistent or Transient Configuration Changes
Published: 2013-03-05
Supported Platforms
Related Documentation
- ACX, EX, M, MX, SRX, T Series
- Example: Generating a Persistent Change
- ACX, EX, M, MX, PTX, SRX, T Series
- Generating a Persistent or Transient Change
- Removing a Persistent or Transient Change
- jcs:emit-change Template
- ACX, EX, J, M, MX, PTX, QFX, SRX, T Series
- Overview of Generating Persistent or Transient Configuration Changes