Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Configuring Inter-PSD Forwarding on a PSD

To configure inter-PSD forwarding on a PSD:

  1. Use the xt-fpc/pic/slot statement at the [edit interfaces] hierarchy level to configure cross-connections with the other PSDs.
  2. Configure logical interfaces under the cross-connect interface using the unit logical-unit-number statement at the [edit interfaces xt-fpc/pic/slot] hierarchy level.

    The values for logical-unit-number must match values set in the Root System Domain (RSD) configuration.

  3. For each logical interface, include the following statements:
    • peer-psd psdn—Configure a peer PSD. The PSD identification is a numeric value with a range of 1 though 31.
    • peer-interface interface-name—Configure the tunnel peer interface that is bound to the logical interface.
    • encapsulation frame-relay—Configure Frame Relay encapsulation. Currently, only Frame Relay encapsulation is supported for inter-PSD forwarding.
    • point-to-point—Configure the interface as a point-to-point interface.
    • dlci dlci-number—Configure the data-link connection identifier (DLCI) for the point-to-point interface.
    • family family-name—Configure the protocol family for the interface.
  4. Repeat this procedure for each PSD that you want to include in inter-PSD forwarding.

In the example illustrated in Figure 1, a cross-connect using a tunnel interface transports packets between the logical interfaces configured on each PSD.

Figure 1: Example: Inter-PSD Forwarding

Example: Inter-PSD
Forwarding

Table 1: Example: Inter-PSD Forwarding

PSD

Interfaces

PSD 5

xt-4/3/0.1
	10.0.0.2
2121:2121::2/64
xt-4/3/0.2
10.0.1.2

PSD 7

xt-3/3/0.1
	10.0.0.1
2121:2121::1/64
xt-3/3/0.2
10.1.1.2

PSD 3

xt-3/3/0.1
	10.0.0.1
2121:2121::1/64
xt-2/3/0.2
10.1.1.1

In this example, the [edit interfaces] hierarchy on PSD 5 is configured as follows:

interfaces {
        xt-4/3/0 {
            unit 1 {
                peer-psd psd7;
                peer-interface xt-3/3/0.1;
                encapsulation frame-relay;
                point-to-point;
                dlci 1;
                family inet {
                    address 10.0.0.2/32 {
                        destination 10.0.0.1;
                    }
                }
                family inet6 {
                    address 2121:2121::2/64;
                }
            }
            unit 2 {
                peer-psd psd3;
                peer-interface xt-2/3/0.1;
                encapsulation frame-relay;
                point-to-point;
                dlci 2;
                family inet {
                    address 10.0.1.2/32 {
                        destination 10.0.1.1;
                    }
                }
            }
        }
    }

In this example, the [edit interfaces] hierarchy on PSD 7 is configured as follows:

interfaces {
        xt-3/3/0 {
            unit 1 {
                peer-psd psd5;
                peer-interface xt-4/3/0.1;
                encapsulation frame-relay;
                point-to-point;
                dlci 1;
                family inet {
                    address 10.0.0.1/32 {
                        destination 10.0.0.2;
                    }
                }
                family inet6 {
                    address 2121:2121::1/64;
                }
            }
            unit 2 {
                peer-psd psd3;
                peer-interface xt-2/3/0.2;
                encapsulation frame-relay;
                point-to-point;
                dlci 2;
                family inet {
                    address 10.1.1.1/32 {
                        destination 10.1.1.2;
                    }
                }
            }
        }
    }

In this example, the [edit interfaces] hierarchy on PSD 3 is configured as follows:

 interfaces {
        xt-2/3/0 {
            unit 1 {
                peer-psd psd5;
                peer-interface xt-4/3/0.2;
                encapsulation frame-relay;
                point-to-point;
                dlci 1;
                family inet {
                    address 10.0.1.1/32 {
                        destination 10.0.1.2;
                    }
                }
            }
            unit 2 {
                peer-psd psd7;
                peer-interface xt-3/3/0.2;
                encapsulation frame-relay;
                point-to-point;
                dlci 2;
                family inet {
                    address 10.1.1.2/32 {
                        destination 10.1.1.1;
                    }
                }
            }
        }
    }

Published: 2013-02-12