Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Example: Basic 6rd Configuration

Requirements

This example describes how a 6rd concentrator can be configured for a 6rd domain, D1, to provide IPv6 Internet connectivity.

The following hardware components can perform 6rd:

  • M Series Multiservice Edge routers with Multiservices PICs
  • T Series Core routers with Multiservices PICs
  • MX Series 3D Universal Edge routers with Multiservices DPCs

Overview

This configuration example describes how to configure a basic 6rd tunneling solution.

Configuration

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level.

set interfaces ge-1/2/0 unit 0 family inet service input service-set v6rd-dom1-service-setset interfaces ge-1/2/0 unit 0 family inet service output service-set v6rd-dom1-service-setset interfaces ge-1/2/0 unit 0 family inet address 10.10.10.1/24set interfaces ge-1/2/0 unit 0 family inet6 service input service-set v6rd-dom1-service-setset interfaces ge-1/2/0 unit 0 family inet6 service output service-set v6rd-dom1-service-setset interfaces ge-1/2/2 unit 0 family inet6 address 3abc::1/16set interfaces sp-0/2/0 unit 0 family inetset interfaces sp-0/2/0 unit 0 family inet6set services softwire softwire-concentrator v6rd v6rd-dom1 softwire-address 30.30.30.1set services softwire softwire-concentrator v6rd v6rd-dom1 ipv4-prefix 10.10.10.0/24set services softwire softwire-concentrator v6rd v6rd-dom1 v6rd-prefix 3040::0/16set services softwire softwire-concentrator v6rd v6rd-dom1 mtu-v4 9192set services softwire rule v6rd-dom1 match-direction inputset services softwire rule v6rd-dom1 term t1 then v6rd v6rd-dom1set services service-set v6rd-dom1-service-set softwire-rules v6rd-dom1set services service-set v6rd-dom1-service-set stateful-firewall-rules r1set services service-set v6rd-dom1-service-set interface-service service-interface sp-0/2/0set services stateful-firewall rule r1 match-direction input-outputset services stateful-firewall rule r1 term t1 then accept

Chassis Configuration

Step-by-Step Procedure

To configure the chassis:

  1. Define the ingress interface.
    user@host# edit interfaces ge-1/2/0
  2. Configure the ingress interface logical unit and input/output service options.
    [edit interfaces ge-1/2/0]user@host# set unit 0 family inet service input service-set v6rd-dom1-service-setuser@host# set unit 0 family inet service output service-set v6rd-dom1-service-setuser@host# set unit 0 family inet6 service input service-set v6rd-dom1-service-setuser@host# set unit 0 family inet6 service output service-set v6rd-dom1-service-set
  3. Configure the address of the ingress interface.
    [edit interfaces ge-1/2/0]user@host# set unit 0 family inet address 10.10.10.1/24
  4. Define the egress interface.
    user@host# up[edit interfaces]user@host# edit ge-1/2/2
  5. Define the logical unit and address for the egress interface.
    [edit interfaces ge-1/2/2]user@host# set unit 0 family inet6 address 3ABC::1/16
  6. Define the services PIC.
    [edit interfaces ge-1/2/2]user@host# up[edit interfaces]user@host# edit sp-0/2/0
  7. Configure the logical unit for the services PIC.
    [edit interfaces sp-0/2/0]user@host# up[edit interfaces]user@host# set unit 0 family inetuser@host# set unit 0 family inet6

Results

[edit interfaces]
user@router# show
sp-0/2/0 {
    unit 0 {
        family inet;
        family inet6;
    }
}
ge-1/2/0 {
    unit 0 {
        family inet {
            service {
                input {
                    service-set v6rd-dom1-service-set;
                }
                output {
                    service-set v6rd-dom1-service-set;
                }
            }
            address 10.10.10.1/24;
        }
        family inet6 {
            service {
                input {
                    service-set v6rd-dom1-service-set;
                }
                output {
                    service-set v6rd-dom1-service-set;
                }
            }
        }
    }
}
ge-1/2/2 {
    unit 0 {
        family inet6 {
            address 3abc::1/16;
        }
    }
}

Softwire Concentrator, Softwire Rule, and Stateful Firewall Rule Configuration

Step-by-Step Procedure

To configure the softwire concentrator, softwire rule, and stateful firewall rule:

  1. Define the 6rd softwire concentrator.
    user@host# topuser@host# edit services softwire softwire-concentrator v6rd v6rd-dom1
  2. Configure the softwire concentrator properties. Here, softwire address 30.30.30.1 is the softwire concentrator IPv4 address, 10.10.10.0/24 is the IPv4 prefix of the CE WAN side, and 3040::0/16 is the IPv6 prefix of the 6rd domain D1.
    [edit services softwire softwire-concentrator v6rd v6rd-dom1]user@host# set softwire-address 30.30.30.1user@host# set ipv4-prefix 10.10.10.0/24user@host# set v6rd-prefix 3040::0/16user@host# set mtu-v4 9192
  3. Define the softwire rule.
    [edit services softwire softwire-concentrator v6rd v6rd-dom1]user@host# up 2[edit services softwire]user@host# edit rule v6rd-dom1[edit services softwire rule v6rd-dom1]user@host# set match-direction input[edit services softwire rule v6rd-dom1]user@host# set term t1 then v6rd v6rd-dom1
  4. Define a stateful firewall rule and properties. You must configure a stateful firewall rule that accepts all traffic in both the input and output direction in order for 6rd to work; however, this is not enforced through the CLI. This is because in IPv6, gratuitous IPv6 packets are expected (due to Anycast) and should not be dropped. The service PIC can handle reverse traffic without seeing all forward traffic. This can also happen with service PIC switchover in the middle of a session. By default, the stateful firewall on the service PIC will drop all traffic unless a rule is configured explicitly to allow it.
    [edit services softwire softwire-concentrator v6rd v6rd-dom1]user@host# up 3[edit servicesl]user@host# edit services stateful-firewall[edit services stateful-firewall]user@host# edit rule r1[edit services stateful-firewall rule r1]user@host# set match-direction input-outputuser@host# set term t1 then accept

Results

[edit services softwire]
user@router# show
softwire-concentrator {
    v6rd v6rd-dom1 {
        softwire-address 30.30.30.1;
        ipv4-prefix 10.10.10.0/24;
        v6rd-prefix 3040::0/16;
        mtu-v4 9192;
    }
}
rule v6rd-dom1-r1 {
    match-direction input;
    term t1 {
        then {
            v6rd v6rd-dom1;
        }
    }
}

Service Set Configuration

Step-by-Step Procedure

To configure the service set:

  1. Define the service set for 6rd processing.
    user@host# topuser@host# edit services service-set v6rd-dom1-service-set
  2. Define the softwire and stateful firewall rules for the service set.
    [edit services service-set v6rd-dom1-service-set]user@host# set softwire-rules v6rd-dom1user@host# set stateful-firewall-rules r1
  3. Define the interface-service for the service set.
    [edit services service-set v6rd-dom1-service-set]user@host# set interface-service service-interface sp-0/2/0

Results

[edit service-set v6rd-dom1-service-set]
user@host# show
softwire-rules v6rd-dom1-r1
    interface-service {	
        service-interface sp-0/2/0;
    }

Published: 2013-08-29