Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation

Example: Configuring Virtual LAN Queuing and Shaping in PTX Series Packet Transport Routers

You can enable virtual LAN (VLAN) queuing on 100-Gigabit Ethernet interfaces on PTX Series Packet Transport Routers and specify a traffic-shaping rate for each VLAN.

Requirements

This example uses the following hardware and software components:

  • Junos OS Release 13.2 or later.
  • One PTX5000 router.

Overview

This example shows how to configure 10 VLANs, enable class-of-service (CoS) queuing, and specify a traffic-shaping rate for each VLAN. The total traffic-shaping rate for all VLANs cannot exceed 100 Gbps.

Configuration

CLI Quick Configuration

To configure VLAN queuing and traffic shaping on the PTX5000 router, copy the following commands and paste them into the terminal window of the router:

[edit]set interfaces et-5/0/0 vlan-taggingset interfaces et-5/0/0 per-unit-schedulerset interfaces et-5/0/0 unit 0 vlan-id 0set interfaces et-5/0/0 unit 1 vlan-id 1set interfaces et-5/0/0 unit 2 vlan-id 2set interfaces et-5/0/0 unit 3 vlan-id 3set interfaces et-5/0/0 unit 4 vlan-id 4set interfaces et-5/0/0 unit 5 vlan-id 5set interfaces et-5/0/0 unit 6 vlan-id 6set interfaces et-5/0/0 unit 7 vlan-id 7set interfaces et–5/0/0 unit 8 vlan-id 8set interfaces et-5/0/0 unit 9 vlan-id 9set class-of-service interfaces et-5/0/0 unit 0 shaping-rate 5gset class-of-service interfaces et-5/0/0 unit 1 shaping-rate 10gset class-of-service interfaces et-5/0/0 unit 2 shaping-rate 20gset class-of-service interfaces et-5/0/0 unit 3 shaping-rate 5gset class-of-service interfaces et-5/0/0 unit 4 shaping-rate 10gset class-of-service interfaces et-5/0/0 unit 5 shaping-rate 10gset class-of-service interfaces et-5/0/0 unit 6 shaping-rate 5gset class-of-service interfaces et-5/0/0 unit 7 shaping-rate 5gset class-of-service interfaces et-5/0/0 unit 8 shaping-rate 10gset class-of-service interfaces et-5/0/0 unit 9 shaping-rate 20g

Step-by-Step Procedure

To configure the PTX5000 router:

  1. Enable the reception and transmission of 8021.q VLAN-tagged frames on the interface:
    [edit interfaces]user@host# set et-5/0/0 vlan-tagging
  2. Specify a VLAN identifier for each logical interface:
    [edit interfaces]user@host# set et-5/0/0 unit 0 vlan-id 0user@host# set et-5/0/0 unit 1 vlan-id 1user@host# set et-5/0/0 unit 2 vlan-id 2user@host# set et-5/0/0 unit 3 vlan-id 3user@host# set et-5/0/0 unit 4 vlan-id 4user@host# set et–5/0/0 unit 5 vlan-id 5user@host# set et-5/0/0 unit 6 vlan-id 6user@host# set et-5/0/0 unit 7 vlan-id 7user@host# set et-5/0/0 unit 8 vlan-id 8user@host# set et-5/0/0 unit 9 vlan-id 9
  3. Configure per-VLAN traffic shaping by specifying the amount of bandwidth to be allocated to each logical interface:
    [edit class-of-service interfaces]user@host# set et-5/0/0 unit 0 shaping-rate 5guser@host# set et-5/0/0 unit 1 shaping-rate 10guser@host# set et-5/0/0 unit 2 shaping-rate 20guser@host# set et-5/0/0 unit 3 shaping-rate 5guser@host# set et-5/0/0 unit 4 shaping-rate 10guser@host# set et-5/0/0 unit 5 shaping-rate 10guser@host# set et-5/0/0 unit 6 shaping-rate 5 guser@host# set et-5/0/0 unit 7 shaping-rate 5guser@host# set et-5/0/0 unit 8 shaping-rate 10guser@host# set et-5/0/0 unit 0 shaping-rate 20g

Results

Confirm your results by entering the show interfaces and show class-of-service commands:

user@host# show interfaces
et-5/0/0  {
    vlan-tagging;
    unit 0 {
        vlan-id 0;
    }
    unit 1 {
        vlan-id 1;
    }
    unit 2 {
        vlan-id 2;
    }
    unit 3 {
        vlan-id 3;
    }
    unit 4 {
        vlan-id 4;
    }
    unit 5 {
        vlan-id 5;
    }
    unit 6 {
        vlan-id 6;
    }
    unit 7 {
        vlan-id 7;
    }
    unit 8 {
        vlan-id 8;
    }
    unit 9 {
        vlan-id 9;
    }
}
user@host# show class-of-service
interfaces {
    et-5/0/3 {
        unit 0 {
            shaping-rate 5g;
        }
        unit 1 {
            shaping-rate 10g;
        }
        unit 2 {
            shaping-rate 20g;
        }
        unit 3 {
            shaping-rate 5g;
        }
        unit 4 {
            shaping-rate 10g;
        }
        unit 5 {
            shaping-rate 10g;
        }
        unit 6 {
            shaping-rate 5g;
        }
        unit 7 {
            shaping-rate 5g;
        }
        unit 8 {
            shaping-rate 10g;
        }
        unit 9 {
            shaping-rate 20g;
        }
    }
}

Published: 2013-07-18