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Troubleshooting PPPoE Service Name Tables

Problem

A misconfiguration of a PPPoE service name table can prevent PPPoE services from being properly activated. Configuration options for PPPoE service name tables are simple, which should simplify discovering where a misconfiguration exists. PPPoE clients cannot connect if the service name table contains no match for the service name tag carried in the PADI packet.

The symptom of a service name table misconfiguration is that the client connection process stops at the negotiation stage and the PADI packets are ignored. You can use the show pppoe statistics command to examine the PPPoE packet counts for a problem.

When the service name table is properly configured, packets sent and received increment symmetrically. The following sample output shows a PADO sent count equal to the PADI received count, and PADS sent count equal to the PADR received count. This output indicates that the PPPoE negotiation is proceeding successfully and that the service name table is not misconfigured.

user@host> show pppoe statistics ge-2/0/3.1
	Active PPPoE sessions: 2
    PacketType                       Sent         Received
      PADI                              0               16
      PADO                             16                0
      PADR                              0               16
      PADS                             16                0
      PADT                              0                0
      Service name error                0                0
      AC system error                   0                0
      Generic error                     0                0
      Malformed packets                 0                0
      Unknown packets                   0                0

When the service name table is misconfigured, the output of the show pppoe statistics command indicates that the number of PADI packets received on the underlying interface is increasing, but the number of PADO packets sent remains at zero. The following sample output shows a PADI count of 100 and a PADO count of 0.

user@host> show pppoe statistics ge-2/0/3.1
Active PPPoE sessions: 0
    PacketType                       Sent         Received
      PADI                              0              100
      PADO                              0                0
      PADR                              0                0
      PADS                              0                0
      PADT                              0                0
      Service name error                0                0
      AC system error                   0                0
      Generic error                     0                0
      Malformed packets                 0                0
      Unknown packets                   0                0

When you believe a misconfiguration exists, use the monitor traffic interface command on the underlying interface to determine which service name is being requested by the PPPoE client. The following sample output shows that the client is requesting Service1 in the service name tag.

user@host> monitor traffic interface ge-2/0/3.1 print-hex print-ascii
	Listening on ge-2/0/3.1, capture size 96 bytes

	11:49:41.436682  In PPPoE PADI [Service-Name "Service1"] [Host-Uniq UTF8] [TAG-0x120 UTF8] [Vendor-Specific UTF8]
	0x0000   ffff ffff ffff 0090 1a42 0ac1 8100 029a     .........B......
	0x0010   8863 1109 0000 00c9 0101 0008 5365 7276     .c..........Serv
	0x0020   6963 6531 0103 0004 1200 9c43 0120 0002     ice1.......C....
	0x0030   044a 0105 00ab 0000 0de9 0124 783a 3132     .J.........$x:12
	0x0040   3030 3963                                   009c

You can then use the show pppoe service-name-tables command to determine whether you have misspelled the name of the service or perhaps not configured the service at all.

Cause

Typical misconfigurations appear in the service name table configurations.

Solution

Use the appropriate statements to correct the misconfiguration.

Published: 2013-08-29