The examples in this section show the following configurations:
The examples in this section include only the configuration of multilink interfaces. For information about configuring the constituent interfaces, see the JUNOS Network Interfaces Configuration Guide.
- [edit interfaces]
- ml-1/0/0 {
-
- unit 1 {
- fragment-threshold 128;
-
- family inet {
-
- address 192.168.5.1/32 {
- destination 192.168.200.200;
- }
- }
- }
-
- unit 10 {
-
- family inet {
-
- address 10.1.1.3/32 {
- destination 10.1.1.2;
- }
- }
- }
- }
- t1-5/1/0 {
-
- unit 0 {
-
- family mlppp {
- bundle ml-1/0/0.1;
- }
- }
- }
- t1-5/1/1 {
-
- unit 0 {
-
- family mlppp {
- bundle ml-1/0/0.1;
- }
- }
- }
- t1-5/1/2 {
-
- unit 0 {
-
- family mlppp {
- bundle ml-1/0/0.1;
- }
- }
- }
- [edit interfaces]
- at-0/0/0 {
-
- atm-options {
- pic-type atm2;
- vpi 10;
- }
-
- unit 0 {
- encapsulation atm-mlppp-llc;
-
- ppp-options {
-
- chap {
- access-profile pe-B-ppp-clients;
- local-name “pe-A-at-0/0/0”;
- }
- }
- keepalive interval 5 up-count 6 down-count 4;
- vci 10.120;
-
- family mlppp {
- bundle ls-0/3/0.0;
- }
- }
- }
- at-0/0/1 {
-
- atm-options {
- pic-type atm2;
- vpi 11;
- }
-
- unit 1 {
- encapsulation atm-mlppp-llc;
-
- ppp-options {
-
- chap {
- access-profile pe-B-ppp-clients;
- local-name “ pe-A-at-0/0/0”;
- }
- }
- keepalive interval 5 up-count 6 down-count 4;
- vci 11.120;
-
- family mlppp {
- bundle ls-0/3/0.0;
- }
- }
- }
- at-1/2/3 {
-
- atm-options {
- pic-type atm2;
- vpi 12;
- }
-
- unit 2 {
- encapsulation atm-mlppp-llc;
-
- ppp-options {
-
- chap {
- access-profile pe-B-ppp-clients;
- local-name “ pe-A-at-0/0/0”;
- }
- }
- keepalive interval 5 up-count 6 down-count 4;
- vci 12.120;
-
- family mlppp {
- bundle ls-0/3/0.0;
- }
- }
- }
- ...
- ls-0/3/0 {
- encapsulation multilink-ppp;
- interleave-fragments;
- keepalive;
-
- unit 0 {
- mrru 4500;
- short-sequence;
- fragment-threshold 16320;
- drop-timeout 2000;
- encapsulation multilink-ppp;
- interleave-fragments;
- minimum-links 8;
-
- family inet {
-
- address 10.10.0.1/32 {
- destination 10.10.0.2;
- }
- }
- family iso;
-
- family inet6 {
-
- address 2001:DB8:0:1/32 {
- destination 2001:DB8:0:2;
- }
- }
- }
- ...
- }
- [edit interfaces]
- ml-1/0/0 {
-
- unit 1 {
- encapsulation multilink-frame-relay-end-to-end;
-
- family inet {
-
- address 192.168.5.2/32 {
- destination 192.168.5.3;
- }
- }
- }
-
- unit 10 {
- encapsulation multilink-frame-relay-end-to-end;
-
- family inet {
-
- address 10.1.1.3/32 {
- destination 10.1.1.2;
- }
- }
- }
- }
- t1-5/1/0 {
-
- unit 0 {
- dlci 16;
- encapsulation multilink-frame-relay-end-to-end;
-
- family mlfr-end-to-end {
- bundle ml-1/0/0.1;
- }
- }
- }
- t1-5/1/1 {
-
- unit 0 {
- dlci 17;
- encapsulation multilink-frame-relay-end-to-end;
-
- family mlfr-end-to-end {
- bundle ml-1/0/0.10;
- }
- }
- }
- t1-5/1/2 {
-
- unit 0 {
- dlci 26;
- encapsulation multilink-frame-relay-end-to-end;
-
- family mlfr-end-to-end {
- bundle ml-1/0/0.10;
- }
- }
- }