You can configure failure recovery on M-series and T-series routing platforms that have multiple AS or MultiServices PICs with lsq- interfaces by specifying a virtual LSQ redundancy (rlsq) interface in which the primary Link Services IQ PIC is active and a secondary PIC is on standby. If the primary PIC fails, the secondary PIC becomes active, and all LSQ processing is transferred to it. To determine which PIC is currently active, issue the show interfaces redundancy command.
![]() |
Note: This configuration does not require the use of SONET APS for failover. Network interfaces that do not support SONET can be used, such as T1 or E1 interfaces. |
The following sections provide more information:
The physical interface type rlsq specifies the pairings between primary and secondary lsq interfaces to enable redundancy. To configure a backup lsq interface, include the redundancy-options statement at the [edit interfaces rlsqnumber] hierarchy level:
- [edit interfaces rlsqnumber]
- redundancy-options {
- (hot-standby | warm-standby);
- primary lsq-fpc/pic/port;
- secondary lsq-fpc/pic/port;
- }
For the rlsq interface, number can be from 0 through 1023. If the primary lsq interface fails, traffic processing switches to the secondary interface. The secondary interface remains active even after the primary interface recovers. If the secondary interface fails and the primary interface is active, processing switches to the primary interface.
The hot-standby option is used with one-to-one redundancy configurations, in which one working PIC is supported by one backup PIC. It sets the requirement for the failure detection and recovery time to be less than 5 seconds. The behavior is revertive, but you can manually switch between the primary and secondary PICs by issuing the request interfaces (revert | switchover) rlsqnumber operational mode command.
The warm-standby option is used with redundancy configurations in which one backup PIC supports multiple working PICs. Recovery times are not guaranteed, because the configuration must be completely restored on the backup PIC after a failure is detected.
![]() |
Note: The hot-standby option is supported only with MLPPP and CRTP configurations. The warm-standby option is also supported with LSQ FRF.15 and FRF.16 bundle configurations and with L2TP and flow monitoring services. |
Link Services IQ PIC failure occurs under the following conditions:
The following constraints apply to redundant LSQ configurations:
![]() |
Note: Adaptive Services and MultiServices PICs in layer-2 mode (running Layer 2 services) are not rebooted when a MAC flow-control situation is detected. |
Link state replication, also called interface preservation, is an addition to the SONET Automatic Protection Switching (APS) functionality that helps promote redundancy of the link PICs used in LSQ configurations.
Link state replication provides the ability to add two sets of links, one from the active (working) SONET PIC and the other from the backup (protect) SONET PIC to the same bundle. If the active SONET PIC fails, links from the standby PIC are used without causing a link renegotiation. All the negotiated state is replicated from the active links to the standby links to prevent link renegotiation. For more information about SONET APS configurations, see the JUNOS Network Interfaces Configuration Guide.
To configure link state replication, include the preserve-interface statement at the [edit interfaces interface-name sonet-options aps] hierarchy level on both network interfaces:
- edit interfaces interface-name sonet-options
aps]
- preserve-interface;
The following constraints apply to link PIC redundancy:
![]() |
Note: This renegotiation is more likely to take place for configurations with back-to-back Juniper Networks routers than in networks in which a Juniper Networks router is connected to an add/drop multiplexer (ADM). |
![]() |
Note: LCP renegotiation is more likely to take place for configurations with back-to-back Juniper Networks routers than in networks in which a Juniper Networks router is connected to an ADM. |
As an example, the following configuration shows the link state replication configuration between the ports coc3-1/0/0 and coc3-2/0/0.
- interfaces {
-
- coc3-1/0/0 {
-
- sonet-options {
-
- aps {
- preserve-interface;
- working-circuit aps-group-1;
- }
- }
- }
-
- coc3-2/0/0 {
-
- sonet-options {
-
- aps {
- preserve-interface;
- protect-circuit aps-group-1;
- }
- }
- }
- }
Configuring LSQ Interface Redundancy for MLPPP
The following configuration shows that lsq-1/1/0 and lsq-1/3/0 work as a pair and the redundancy type is hot-standby, which sets the requirement for the failure detection and recovery time to be less than 5 seconds:
- interfaces rlsq0 {
-
- redundancy-options {
- primary lsq-1/1/0;
- secondary lsq-1/3/0;
- hot-standby; #either hot-standby or warm-standby is supported
- }
- }
The following example shows a related MLPPP configuration:
![]() |
Note: MLPPP protocol configuration is required for this configuration. |
- interfaces {
-
- t1-/1/2/0 {
-
- unit 0 {
-
- family mlppp {
- bundle rlsq0.0;
- }
- }
- }
-
- rlsq0 {
-
- unit 0 {
-
- family inet {
- address 30.1.1.2/24;
- }
- }
- }
- }
The following example shows a related CoS configuration:
The following example shows a complete link state replication configuration for MLPPP. This example uses two bundles, each with four T1 links. The first four T1 links (t1-*:1 through t1-*:4) form the first bundle and the last four T1 links (t1-*:5 through t1-*:8) form the second bundle. To minimize the duplication in the configuration, this example uses the [edit groups] statement; for more information, see the JUNOS System Basics Configuration Guide. This type of configuration is not required; it simplifies the task and minimizes duplication.
- groups {
-
- ml-partition-group {
-
- interfaces {
-
- <coc3-*> {
- partition 1 oc-slice 1 interface-type coc1;
- }
-
- <coc1-*> {
- partition 1-8 interface-type t1;
- }
- }
- }
-
- ml-bundle-group-1 {
-
- interfaces {
-
- <t1-*:"[1-4]"> {
- encapsulation ppp;
-
- unit 0 {
-
- family mlppp {
- bundle lsq-0/1/0.0;
- }
- }
- }
- }
- }
-
- ml-bundle-group-2 {
-
- interfaces {
-
- <t1-*:"[5-8]"> {
- encapsulation ppp;
-
- unit 0 {
-
- family mlppp {
- bundle lsq-0/1/0.1;
- }
- }
- }
- }
- }
- }
- interfaces {
-
- lsq-0/1/0 {
-
- unit 0 {
- encapsulation multilink-ppp;
-
- family inet {
-
- address 1.1.1.1/32 {
- destination 1.1.1.2;
- }
- }
- }
-
- unit 1 {
- encapsulation multilink-ppp;
-
- family inet {
-
- address 1.1.2.1/32 {
- destination 1.1.2.2;
- }
- }
- }
- }
-
- coc3-1/0/0 {
- apply-groups ml-partition-group;
-
- sonet-options {
-
- aps {
- preserve-interface;
- working-circuit aps-group-1;
- }
- }
- }
-
- coc1-1/0/0:1 {
- apply-groups ml-partition-group;
- }
-
- t1-1/0/0:1:1 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-1/0/0:1:2 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-1/0/0:1:3 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-1/0/0:1:4 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-1/0/0:1:5 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-1/0/0:1:6 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-1/0/0:1:7 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-1/0/0:1:8 {
- apply-groups ml-bundle-group-2;
- }
-
- coc3-2/0/0 {
- apply-groups ml-partition-group;
-
- sonet-options {
-
- aps {
- preserve-interface;
- protect-circuit aps-group-1;
- }
- }
- }
-
- coc1-2/0/0:1 {
- apply-groups ml-partition-group;
- }
-
- t1-2/0/0:1:1 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-2/0/0:1:2 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-2/0/0:1:3 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-2/0/0:1:4 {
- apply-groups ml-bundle-group-1;
- }
-
- t1-2/0/0:1:5 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-2/0/0:1:6 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-2/0/0:1:7 {
- apply-groups ml-bundle-group-2;
- }
-
- t1-2/0/0:1:8 {
- apply-groups ml-bundle-group-2;
- }
- }
Configuring LSQ Interface Redundancy for an FRF.15 Bundle
The following example shows a configuration for an FRF.15 bundle:
- interfaces rlsq0 {
-
- redundancy-options {
- primary lsq-1/2/0;
- secondary lsq-1/3/0;
- warm-standby;
- }
-
- unit 0 {
- encapsulation multilink-frame-relay-end-to-end;
-
- family inet {
- address 30.1.1.1/24;
- }
- }
- }
Configuring LSQ Interface Redundancy for an FRF.16 Bundle
The following example shows a configuration for an FRF.16 bundle:
- interfaces rlsq0:0 {
- dce;
- encapsulation multilink-frame-relay-uni-nni;
-
- redundancy-options {
- primary lsq-1/2/0:0;
- secondary lsq-1/3/0:0;
- warm-standby;
- }
-
- unit 0 {
- dlci 1000;
-
- family inet {
- address 50.1.1.1/24;
- }
- }
- }