BGPのオン/リンク
論理システムを使用すると、内部セッションとBGPできます。詳細については、以下のトピックを参照してください。
例: 論理システムでのBGPピアリング セッションの設定
この例では、論理システム上で内部セッション セッションBGP ピア設定する方法を示しています。
要件
この例では、デバイス初期化以外の特別な設定は必要ありません。
概要
この例では、IBGP(internal BGP ピアリング セッションを設定します。
サンプル ネットワークでは、デバイス 17 のデバイスASピアで完全に メッシュされます。デバイスには、ループバック アドレス 192.168.6.5、192.163.6.4、192.168.40.4 があります。
図1は、 内部ピアセッションを持つ典型的なネットワークを示しています。
構成
CLI迅速な設定
この例を迅速に設定するには、以下のコマンドをコピーして、テキスト ファイルに貼り付け、改行を削除し、ネットワーク設定に一致する必要がある詳細情報を変更してから、コマンドを階層レベルで CLI にコピー アンド ペースト [edit]
します。
set logical-systems A interfaces lt-0/1/0 unit 1 description to-B set logical-systems A interfaces lt-0/1/0 unit 1 encapsulation ethernet set logical-systems A interfaces lt-0/1/0 unit 1 peer-unit 2 set logical-systems A interfaces lt-0/1/0 unit 1 family inet address 10.10.10.1/30 set logical-systems A interfaces lo0 unit 1 family inet address 192.168.6.5/32 set logical-systems A protocols bgp group internal-peers type internal set logical-systems A protocols bgp group internal-peers local-address 192.168.6.5 set logical-systems A protocols bgp group internal-peers export send-direct set logical-systems A protocols bgp group internal-peers neighbor 192.163.6.4 set logical-systems A protocols bgp group internal-peers neighbor 192.168.40.4 set logical-systems A protocols ospf area 0.0.0.0 interface lo0.1 passive set logical-systems A protocols ospf area 0.0.0.0 interface lt-0/1/0.1 set logical-systems A policy-options policy-statement send-direct term 2 from protocol direct set logical-systems A policy-options policy-statement send-direct term 2 then accept set logical-systems A routing-options router-id 192.168.6.5 set logical-systems A routing-options autonomous-system 17 set logical-systems B interfaces lt-0/1/0 unit 2 description to-A set logical-systems B interfaces lt-0/1/0 unit 2 encapsulation ethernet set logical-systems B interfaces lt-0/1/0 unit 2 peer-unit 1 set logical-systems B interfaces lt-0/1/0 unit 2 family inet address 10.10.10.2/30 set logical-systems B interfaces lt-0/1/0 unit 5 description to-C set logical-systems B interfaces lt-0/1/0 unit 5 encapsulation ethernet set logical-systems B interfaces lt-0/1/0 unit 5 peer-unit 6 set logical-systems B interfaces lt-0/1/0 unit 5 family inet address 10.10.10.5/30 set logical-systems B interfaces lo0 unit 2 family inet address 192.163.6.4/32 set logical-systems B protocols bgp group internal-peers type internal set logical-systems B protocols bgp group internal-peers local-address 192.163.6.4 set logical-systems B protocols bgp group internal-peers export send-direct set logical-systems B protocols bgp group internal-peers neighbor 192.168.40.4 set logical-systems B protocols bgp group internal-peers neighbor 192.168.6.5 set logical-systems B protocols ospf area 0.0.0.0 interface lo0.2 passive set logical-systems B protocols ospf area 0.0.0.0 interface lt-0/1/0.2 set logical-systems B protocols ospf area 0.0.0.0 interface lt-0/1/0.5 set logical-systems B policy-options policy-statement send-direct term 2 from protocol direct set logical-systems B policy-options policy-statement send-direct term 2 then accept set logical-systems B routing-options router-id 192.163.6.4 set logical-systems B routing-options autonomous-system 17 set logical-systems C interfaces lt-0/1/0 unit 6 description to-B set logical-systems C interfaces lt-0/1/0 unit 6 encapsulation ethernet set logical-systems C interfaces lt-0/1/0 unit 6 peer-unit 5 set logical-systems C interfaces lt-0/1/0 unit 6 family inet address 10.10.10.6/30 set logical-systems C interfaces lo0 unit 3 family inet address 192.168.40.4/32 set logical-systems C protocols bgp group internal-peers type internal set logical-systems C protocols bgp group internal-peers local-address 192.168.40.4 set logical-systems C protocols bgp group internal-peers export send-direct set logical-systems C protocols bgp group internal-peers neighbor 192.163.6.4 set logical-systems C protocols bgp group internal-peers neighbor 192.168.6.5 set logical-systems C protocols ospf area 0.0.0.0 interface lo0.3 passive set logical-systems C protocols ospf area 0.0.0.0 interface lt-0/1/0.6 set logical-systems C policy-options policy-statement send-direct term 2 from protocol direct set logical-systems C policy-options policy-statement send-direct term 2 then accept set logical-systems C routing-options router-id 192.168.40.4 set logical-systems C routing-options autonomous-system 17
デバイス A
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションについて、詳しくは CLI ガイド の 設定モードでの CLI エディターの使用 CLI を参照してください。
デバイス A で内部 BGP ピア セッションを設定するには、次の手順に示します。
インターフェイスを設定します。
[edit logical-systems A interfaces lt-0/1/0 unit 1] user@R1# set description to-B user@R1# set encapsulation ethernet user@R1# set peer-unit 2 user@R1# set family inet address 10.10.10.1/30 user@R1# set family inet address 192.168.6.5/32 user@R1# up user@R1# up [edit logical-systems A interfaces] user@R1# set lo0 unit 1 family inet address 192.168.6.5/32 user@R1# exit [edit] user@R1# edit logical-systems B interfaces lt-0/1/0 [edit logical-systems B interfaces lt-0/1/0] user@R1# set unit 2 description to-A user@R1# set unit 2 encapsulation ethernet user@R1# set unit 2 peer-unit 1 user@R1# set unit 2 family inet address 10.10.10.2/30 user@R1# set unit 5 description to-C user@R1# set unit 5 encapsulation ethernet user@R1# set unit 5 peer-unit 6 user@R1# set family inet address 10.10.10.5/30 user@R1# up [edit logical-systems B interfaces] user@R1# set lo0 unit 2 family inet address 192.163.6.4/32 user@R1# exit [edit] user@R1# edit logical-systems C interfaces lt-0/1/0 unit 6 [edit logical-systems C interfaces lt-0/1/0 unit 6] set description to-B set encapsulation ethernet set peer-unit 5 set family inet address 10.10.10.6/30 user@R1# up user@R1# up [edit logical-systems C interfaces] set lo0 unit 3 family inet address 192.168.40.4/32
設定BGP。
論理システム A では、論理システム A がデバイス C に直接接続されていない場合でも、ステートメントはデバイス B とデバイス C の両方
neighbor
に対して組み込まれます。[edit logical-systems A protocols bgp group internal-peers] user@R1# set type internal user@R1# set local-address 192.168.6.5 user@R1# set export send-direct user@R1# set neighbor 192.163.6.4 user@R1# set neighbor 192.168.40.4 [edit logical-systems B protocols bgp group internal-peers] user@R1# set type internal user@R1# set local-address 192.163.6.4 user@R1# set export send-direct user@R1# set neighbor 192.168.40.4 user@R1# set neighbor 192.168.6.5 [edit logical-systems C protocols bgp group internal-peers] user@R1# set type internal user@R1# set local-address 192.168.40.4 user@R1# set export send-direct user@R1# set neighbor 192.163.6.4 user@R1# set neighbor 192.168.6.5
設定OSPF。
[edit logical-systems A protocols ospf area 0.0.0.0] user@R1# set interface lo0.1 passive user@R1# set interface lt-0/1/0.1 [edit logical-systems A protocols ospf area 0.0.0.0] user@R1# set interface lo0.2 passive user@R1# set interface lt-0/1/0.2 user@R1# set interface lt-0/1/0.5 [edit logical-systems A protocols ospf area 0.0.0.0] user@R1# set interface lo0.3 passive user@R1# set interface lt-0/1/0.6
直接ルートを受け入れるポリシーを設定します。
このシナリオで役立つその他のオプションは、ネットワーク ルートまたはローカル ルートを通じて学習OSPF受け入れる場合です。
[edit logical-systems A policy-options policy-statement send-direct term 2] user@R1# set from protocol direct user@R1# set then accept [edit logical-systems B policy-options policy-statement send-direct term 2] user@R1# set from protocol direct user@R1# set then accept [edit logical-systems C policy-options policy-statement send-direct term 2] user@R1# set from protocol direct user@R1# set then accept
ルーター ID と自律システム(AS)番号を設定します。
[edit logical-systems A routing-options] user@R1# set router-id 192.168.6.5 user@R1# set autonomous-system 17 [edit logical-systems B routing-options] user@R1# set router-id 192.163.6.4 user@R1# set autonomous-system 17 [edit logical-systems C routing-options] user@R1# set router-id 192.168.40.4 user@R1# set autonomous-system 17
結果
設定モードから、 コマンドを入力して設定を確認 show logical-systems
します。出力結果に意図した設定結果が表示されない場合は、この例の設定手順を繰り返して設定を修正します。
user@R1# show logical-systems A { interfaces { lt-0/1/0 { unit 1 { description to-B; encapsulation ethernet; peer-unit 2; family inet { address 10.10.10.1/30; } } } lo0 { unit 1 { family inet { address 192.168.6.5/32; } } } } protocols { bgp { group internal-peers { type internal; local-address 192.168.6.5; export send-direct; neighbor 192.163.6.4; neighbor 192.168.40.4; } } ospf { area 0.0.0.0 { interface lo0.1 { passive; } interface lt-0/1/0.1; } } } policy-options { policy-statement send-direct { term 2 { from protocol direct; then accept; } } } routing-options { router-id 192.168.6.5; autonomous-system 17; } } B { interfaces { lt-0/1/0 { unit 2 { description to-A; encapsulation ethernet; peer-unit 1; family inet { address 10.10.10.2/30; } } unit 5 { description to-C; encapsulation ethernet; peer-unit 6; family inet { address 10.10.10.5/30; } } } lo0 { unit 2 { family inet { address 192.163.6.4/32; } } } } protocols { bgp { group internal-peers { type internal; local-address 192.163.6.4; export send-direct; neighbor 192.168.40.4; neighbor 192.168.6.5; } } ospf { area 0.0.0.0 { interface lo0.2 { passive; } interface lt-0/1/0.2; interface lt-0/1/0.5; } } } policy-options { policy-statement send-direct { term 2 { from protocol direct; then accept; } } } routing-options { router-id 192.163.6.4; autonomous-system 17; } } C { interfaces { lt-0/1/0 { unit 6 { description to-B; encapsulation ethernet; peer-unit 5; family inet { address 10.10.10.6/30; } } } lo0 { unit 3 { family inet { address 192.168.40.4/32; } } } } protocols { bgp { group internal-peers { type internal; local-address 192.168.40.4; export send-direct; neighbor 192.163.6.4; neighbor 192.168.6.5; } } ospf { area 0.0.0.0 { interface lo0.3 { passive; } interface lt-0/1/0.6; } } } policy-options { policy-statement send-direct { term 2 { from protocol direct; then accept; } } } routing-options { router-id 192.168.40.4; autonomous-system 17; } }
デバイスの設定が完了したら、設定モード から Commit を入力します。
検証
設定が正常に機能されていることを確認します。
ネイバー BGP検証
目的
設定されたインターフェイスBGP、ネイバー アドレスごとに設定されたセッションがアクティブBGPを確認します。
アクション
動作モードから コマンドを入力 show bgp neighbor
します。
user@R1> show bgp neighbor logical-system A Peer: 192.163.6.4+179 AS 17 Local: 192.168.6.5+58852 AS 17 Type: Internal State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: None Export: [ send-direct ] Options: <Preference LocalAddress Refresh> Local Address: 192.168.6.5 Holdtime: 90 Preference: 170 Number of flaps: 0 Peer ID: 192.163.6.4 Local ID: 192.168.6.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 0 BFD: disabled, down NLRI for restart configured on peer: inet-unicast NLRI advertised by peer: inet-unicast NLRI for this session: inet-unicast Peer supports Refresh capability (2) Restart time configured on the peer: 120 Stale routes from peer are kept for: 300 Restart time requested by this peer: 120 NLRI that peer supports restart for: inet-unicast NLRI that restart is negotiated for: inet-unicast NLRI of received end-of-rib markers: inet-unicast NLRI of all end-of-rib markers sent: inet-unicast Peer supports 4 byte AS extension (peer-as 17) Peer does not support Addpath Table inet.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 3 Accepted prefixes: 3 Suppressed due to damping: 0 Advertised prefixes: 2 Last traffic (seconds): Received 16 Sent 1 Checked 63 Input messages: Total 15713 Updates 4 Refreshes 0 Octets 298622 Output messages: Total 15690 Updates 2 Refreshes 0 Octets 298222 Output Queue[0]: 0 Peer: 192.168.40.4+179 AS 17 Local: 192.168.6.5+56466 AS 17 Type: Internal State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: None Export: [ send-direct ] Options: <Preference LocalAddress Refresh> Local Address: 192.168.6.5 Holdtime: 90 Preference: 170 Number of flaps: 0 Peer ID: 192.168.40.4 Local ID: 192.168.6.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 1 BFD: disabled, down NLRI for restart configured on peer: inet-unicast NLRI advertised by peer: inet-unicast NLRI for this session: inet-unicast Peer supports Refresh capability (2) Restart time configured on the peer: 120 Stale routes from peer are kept for: 300 Restart time requested by this peer: 120 NLRI that peer supports restart for: inet-unicast NLRI that restart is negotiated for: inet-unicast NLRI of received end-of-rib markers: inet-unicast NLRI of all end-of-rib markers sent: inet-unicast Peer supports 4 byte AS extension (peer-as 17) Peer does not support Addpath Table inet.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 2 Accepted prefixes: 2 Suppressed due to damping: 0 Advertised prefixes: 2 Last traffic (seconds): Received 15 Sent 22 Checked 68 Input messages: Total 15688 Updates 2 Refreshes 0 Octets 298111 Output messages: Total 15688 Updates 2 Refreshes 0 Octets 298184 Output Queue[0]: 0
ホスト グループBGP検証
目的
ネットワーク グループがBGPが正しく構成されていることを検証します。
アクション
動作モードから コマンドを入力 show bgp group
します。
user@A> show bgp group logical-system A Group Type: Internal AS: 17 Local AS: 17 Name: internal-peers Index: 0 Flags: <Export Eval> Export: [ send-direct ] Holdtime: 0 Total peers: 2 Established: 2 192.163.6.4+179 192.168.40.4+179 inet.0: 0/5/5/0 Groups: 1 Peers: 2 External: 0 Internal: 2 Down peers: 0 Flaps: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet.0 5 0 0 0 0 0
検証BGPサマリ情報の検証
目的
設定が正BGPを検証します。
アクション
動作モードから コマンドを入力 show bgp summary
します。
user@A> show bgp summary logical-system A Groups: 1 Peers: 2 Down peers: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet.0 5 0 0 0 0 0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped... 192.163.6.4 17 15723 15700 0 0 4d 22:13:15 0/3/3/0 0/0/0/0 192.168.40.4 17 15698 15699 0 0 4d 22:13:11 0/2/2/0 0/0/0/0
ルーティング テーブルBGPがインストールされていることを検証する
目的
エクスポート ポリシーの設定が機能している検証します。
アクション
動作モードから コマンドを入力 show route protocol bgp
します。
user@A> show route protocol bgp logical-system A inet.0: 7 destinations, 12 routes (7 active, 0 holddown, 0 hidden) + = Active Route, - = Last Active, * = Both 10.10.10.0/30 [BGP/170] 4d 11:05:55, localpref 100, from 192.163.6.4 AS path: I > to 10.10.10.2 via lt-0/1/0.1 10.10.10.4/30 [BGP/170] 4d 11:05:55, localpref 100, from 192.163.6.4 AS path: I > to 10.10.10.2 via lt-0/1/0.1 [BGP/170] 4d 11:03:10, localpref 100, from 192.168.40.4 AS path: I > to 10.10.10.2 via lt-0/1/0.1 192.163.6.4/32 [BGP/170] 4d 11:05:55, localpref 100, from 192.163.6.4 AS path: I > to 10.10.10.2 via lt-0/1/0.1 192.168.40.4/32 [BGP/170] 4d 11:03:10, localpref 100, from 192.168.40.4 AS path: I > to 10.10.10.2 via lt-0/1/0.1
例:IPv6インターフェイスを使用BGP上の外部インターフェイス インターフェイスの設定
この例では、IPv6 インターフェイスを使用して論理システムBGPポイントツーポイント ピア セッションを設定する方法を示しています。
要件
この例では、デバイス初期化以外の特別な設定は必要ありません。
概要
Junos OSは、IPv6 アドレスによって EBGP ピア セッションをサポートします。IPv6 ピア セッションは、ステートメントで IPv6 アドレスが指定されている場合に設定 neighbor
できます。この例では、EUI-64を使用して、インターフェイスに自動的に適用されるIPv6アドレスを生成します。EUI-64アドレスは、アドレスのインターフェイス識別子部分にIEEE EUI-64形式を使用するIPv6アドレスです(最後の64ビット)。
または、手動で割り当てた 128 ビット IPv6 アドレスを使用して、EBGP セッションを設定することもできます。
インターフェイスに128ビットのリンクローカル アドレスを使用する場合は、 ステートメントを含める必要 local-interface
があります。このステートメントは、128ビットIPv6リンクローカルアドレスでのみ有効であり、IPv6 EBGPリンクローカルピアセッションを設定する場合に必須です。
リンクローカル アドレスを使用した EBGP ピアリングの設定は、直接接続されたインターフェイスにのみ適用できます。マルチホープ ピアリングはサポートされていません。
インターフェイスが起動した後、 コマンドを使用してインターフェイス上で show interfaces terse
EUI-64が生成されたIPv6アドレスを表示できます。これらの生成されたアドレスは、指定されたステートメントBGP neighbor
する必要があります。この例では、エンドツーエンドの完全な手順を示しています。
この例では、フレーム リレー インターフェイスのカプセル化が論理トンネル(lt)インターフェイスに適用されています。ltインターフェイスでIPv6アドレスが設定されている場合、フレーム リレー カプセル化のみサポートされるので、これは要件です。
図 2 は、 セッション数が少ないBGP ピアを示しています。サンプル ネットワークでは、ルーター R1 には 5 つの論理システムが設定されています。自律システム(AS)のデバイスE 17は、BGP ピアピアと呼ばれるピアのグループにセッション を送信できます。ピア A、B、C は 22 のASされます。この例では、論理システム A および論理システム E 上の設定を手順を示します。
トポロジ
構成
手順
CLI迅速な設定
この例を迅速に設定するには、以下のコマンドをコピーして、テキスト ファイルに貼り付け、改行を削除し、ネットワーク設定に一致する必要がある詳細情報を変更し、コマンドを階層レベルで CLI にコピー アンド ペーストして、設定モードから を入力します。 [edit]
commit
デバイス A
set logical-systems A interfaces lt-0/1/0 unit 1 description to-E set logical-systems A interfaces lt-0/1/0 unit 1 encapsulation frame-relay set logical-systems A interfaces lt-0/1/0 unit 1 dlci 1 set logical-systems A interfaces lt-0/1/0 unit 1 peer-unit 25 set logical-systems A interfaces lt-0/1/0 unit 1 family inet6 address 2001:db8:0:1::/64 eui-64 set logical-systems A interfaces lo0 unit 1 family inet6 address 2001:db8::1/128 set logical-systems A protocols bgp group external-peers type external set logical-systems A protocols bgp group external-peers peer-as 17 set logical-systems A protocols bgp group external-peers neighbor 2001:db8:0:1:2a0:a502:0:19da set logical-systems A routing-options router-id 172.16.1.1 set logical-systems A routing-options autonomous-system 22
デバイス B
set logical-systems B interfaces lt-0/1/0 unit 6 description to-E set logical-systems B interfaces lt-0/1/0 unit 6 encapsulation frame-relay set logical-systems B interfaces lt-0/1/0 unit 6 dlci 6 set logical-systems B interfaces lt-0/1/0 unit 6 peer-unit 5 set logical-systems B interfaces lt-0/1/0 unit 6 family inet6 address 2001:db8:0:2::/64 eui-64 set logical-systems B interfaces lo0 unit 2 family inet6 address 2001:db8::2/128 set logical-systems B protocols bgp group external-peers type external set logical-systems B protocols bgp group external-peers peer-as 17 set logical-systems B protocols bgp group external-peers neighbor 2001:db8:0:2:2a0:a502:0:5da set logical-systems B routing-options router-id 172.16.2.2 set logical-systems B routing-options autonomous-system 22
デバイス C
set logical-systems C interfaces lt-0/1/0 unit 10 description to-E set logical-systems C interfaces lt-0/1/0 unit 10 encapsulation frame-relay set logical-systems C interfaces lt-0/1/0 unit 10 dlci 10 set logical-systems C interfaces lt-0/1/0 unit 10 peer-unit 9 set logical-systems C interfaces lt-0/1/0 unit 10 family inet6 address 2001:db8:0:3::/64 eui-64 set logical-systems C interfaces lo0 unit 3 family inet6 address 2001:db8::3/128 set logical-systems C protocols bgp group external-peers type external set logical-systems C protocols bgp group external-peers peer-as 17 set logical-systems C protocols bgp group external-peers neighbor 2001:db8:0:3:2a0:a502:0:9da set logical-systems C routing-options router-id 172.16.3.3 set logical-systems C routing-options autonomous-system 22
デバイス D
set logical-systems D interfaces lt-0/1/0 unit 7 description to-E set logical-systems D interfaces lt-0/1/0 unit 7 encapsulation frame-relay set logical-systems D interfaces lt-0/1/0 unit 7 dlci 7 set logical-systems D interfaces lt-0/1/0 unit 7 peer-unit 21 set logical-systems D interfaces lt-0/1/0 unit 7 family inet6 address 2001:db8:0:4::/64 eui-64 set logical-systems D interfaces lo0 unit 4 family inet6 address 2001:db8::4/128 set logical-systems D protocols bgp group external-peers type external set logical-systems D protocols bgp group external-peers peer-as 17 set logical-systems D protocols bgp group external-peers neighbor 2001:db8:0:4:2a0:a502:0:15da set logical-systems D routing-options router-id 172.16.4.4 set logical-systems D routing-options autonomous-system 79
デバイス E
set logical-systems E interfaces lt-0/1/0 unit 5 description to-B set logical-systems E interfaces lt-0/1/0 unit 5 encapsulation frame-relay set logical-systems E interfaces lt-0/1/0 unit 5 dlci 6 set logical-systems E interfaces lt-0/1/0 unit 5 peer-unit 6 set logical-systems E interfaces lt-0/1/0 unit 5 family inet6 address 2001:db8:0:2::/64 eui-64 set logical-systems E interfaces lt-0/1/0 unit 9 description to-C set logical-systems E interfaces lt-0/1/0 unit 9 encapsulation frame-relay set logical-systems E interfaces lt-0/1/0 unit 9 dlci 10 set logical-systems E interfaces lt-0/1/0 unit 9 peer-unit 10 set logical-systems E interfaces lt-0/1/0 unit 9 family inet6 address 2001:db8:0:3::/64 eui-64 set logical-systems E interfaces lt-0/1/0 unit 21 description to-D set logical-systems E interfaces lt-0/1/0 unit 21 encapsulation frame-relay set logical-systems E interfaces lt-0/1/0 unit 21 dlci 7 set logical-systems E interfaces lt-0/1/0 unit 21 peer-unit 7 set logical-systems E interfaces lt-0/1/0 unit 21 family inet6 address 2001:db8:0:4::/64 eui-64 set logical-systems E interfaces lt-0/1/0 unit 25 description to-A set logical-systems E interfaces lt-0/1/0 unit 25 encapsulation frame-relay set logical-systems E interfaces lt-0/1/0 unit 25 dlci 1 set logical-systems E interfaces lt-0/1/0 unit 25 peer-unit 1 set logical-systems E interfaces lt-0/1/0 unit 25 family inet6 address 2001:db8:0:1::/64 eui-64 set logical-systems E interfaces lo0 unit 5 family inet6 address 2001:db8::5/128 set logical-systems E protocols bgp group external-peers type external set logical-systems E protocols bgp group external-peers peer-as 22 set logical-systems E protocols bgp group external-peers neighbor 2001:db8:0:1:2a0:a502:0:1da set logical-systems E protocols bgp group external-peers neighbor 2001:db8:0:2:2a0:a502:0:6da set logical-systems E protocols bgp group external-peers neighbor 2001:db8:0:3:2a0:a502:0:ada set logical-systems E protocols bgp group external-peers neighbor 2001:db8:0:4:2a0:a502:0:7da peer-as 79 set logical-systems E routing-options router-id 172.16.5.5 set logical-systems E routing-options autonomous-system 17
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションの詳細については、「 CLI ガイド 」の「 設定モードでの CLI CLI エディター の使用 」を 参照してください。
以下の手順にBGP ピアします。
コマンドを
show interfaces terse
実行して、物理ルーターに論理トンネル(lt)インターフェイスが含か確認します。user@R1> show interfaces terse Interface Admin Link Proto Local Remote ... lt-0/1/0 up up ...
論理システム A で、インターフェイスのカプセル化、ピアユニット番号、DLCI を設定して論理システム E に到達します。
user@R1> set cli logical-system A Logical system: A [edit] user@R1:A> edit Entering configuration mode [edit] user@R1:A# edit interfaces [edit interfaces] user@R1:A# set lt-0/1/0 unit 1 encapsulation frame-relay user@R1:A# set lt-0/1/0 unit 1 dlci 1 user@R1:A# set lt-0/1/0 unit 1 peer-unit 25
論理システム A で、ピア E へのリンクのネットワーク アドレスを設定し、ループバック インターフェイスを設定します。
[edit interfaces] user@R1:A# set lt-0/1/0 unit 1 description to-E user@R1:A# set lt-0/1/0 unit 1 family inet6 address 2001:db8:0:1::/64 eui-64 user@R1:A# set lo0 unit 1 family inet6 address 2001:db8::1/128
論理システムEで、インターフェイスのカプセル化、ピアユニット番号、DLCIを設定して論理システム A に到達します。
user@R1> set cli logical-system E Logical system: E [edit] user@R1:E> edit Entering configuration mode [edit] user@R1:E# edit interfaces [edit interfaces] user@R1:E# set lt-0/1/0 unit 25 encapsulation frame-relay user@R1:E# set lt-0/1/0 unit 25 dlci 1 user@R1:E# set lt-0/1/0 unit 25 peer-unit 1
論理システム E で、ピア A へのリンクのネットワーク アドレスを設定し、ループバック インターフェイスを設定します。
[edit interfaces] user@R1:E# set lt-0/1/0 unit 25 description to-A user@R1:E# set lt-0/1/0 unit 25 family inet6 address 2001:db8:0:1::/64 eui-64 user@R1:E# set lo0 unit 5 family inet6 address 2001:db8::5/128
コマンドを
show interfaces terse
実行して、EUI-64によって生成されたIPv6アドレスを確認します。この例では、2001 アドレスが BGP
neighbor
されています。注:fe80アドレスはリンクローカルアドレスであり、この例では使用されません。
user@R1:A> show interfaces terse Interface Admin Link Proto Local Remote Logical system: A betsy@tp8:A> show interfaces terse Interface Admin Link Proto Local Remote lt-0/1/0 lt-0/1/0.1 up up inet6 2001:db8:0:1:2a0:a502:0:1da/64 fe80::2a0:a502:0:1da/64 lo0 lo0.1 up up inet6 2001:db8::1 fe80::2a0:a50f:fc56:1da
user@R1:E> show interfaces terse Interface Admin Link Proto Local Remote lt-0/1/0 lt-0/1/0.25 up up inet6 2001:db8:0:1:2a0:a502:0:19da/64 fe80::2a0:a502:0:19da/64 lo0 lo0.5 up up inet6 2001:db8::5 fe80::2a0:a50f:fc56:1da
他の論理システム上でインターフェイス設定を繰り返します。
外部セッションのBGP設定
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションの詳細については、「 CLI ガイド 」の「 設定モードでの CLI CLI エディター の使用 」を 参照してください。
以下の手順にBGP ピアします。
論理システム A で、デバイス グループをBGPし、外部ネイバー アドレスを追加します。
[edit protocols bgp group external-peers] user@R1:A# set neighbor 2001:db8:0:1:2a0:a502:0:19da
論理システム E で、デバイス グループをBGPし、外部ネイバー アドレスを追加します。
[edit protocols bgp group external-peers] user@R1:E# set neighbor 2001:db8:0:1:2a0:a502:0:1da
論理システム A で、外部デバイスの自律システム(AS)番号を指定AS。
[edit protocols bgp group external-peers] user@R1:A# set peer-as 17
論理システムEで、外部デバイスの自律システム(AS)番号をAS。
[edit protocols bgp group external-peers] user@R1:E# set peer-as 22
論理システム A で、ピア タイプを EBGP に設定します。
[edit protocols bgp group external-peers] user@R1:A# set type external
論理システム E で、ピア タイプを EBGP に設定します。
[edit protocols bgp group external-peers] user@R1:E# set type external
論理システム A で、自律システム(AS)番号とルーター ID を設定します。
[edit routing-options] user@R1:A# set router-id 172.16.1.1 user@R1:A# set autonomous-system 22
論理システムEで、デバイス番号とAS IDを設定します。
[edit routing-options] user@R1:E# set router-id 172.16.5.5 user@R1:E# set autonomous-system 17
ピア A、B、C、D に対してこれらの手順を繰り返します。
結果
設定モードから、 コマンドを入力して設定を確認 show logical-systems
します。出力結果に意図した設定結果が表示されない場合は、この例の手順を繰り返して設定を修正します。
[edit]
user@R1# show logical-systems
A {
interfaces {
lt-0/1/0 {
unit 1 {
description to-E;
encapsulation frame-relay;
dlci 1;
peer-unit 25;
family inet6 {
address 2001:db8:0:1::/64 {
eui-64;
}
}
}
}
lo0 {
unit 1 {
family inet6 {
address 2001:db8::1/128;
}
}
}
}
protocols {
bgp {
group external-peers {
type external;
peer-as 17;
neighbor 2001:db8:0:1:2a0:a502:0:19da;
}
}
routing-options {
router-id 172.16.1.1;
autonomous-system 22;
}
}
B {
interfaces {
lt-0/1/0 {
unit 6 {
description to-E;
encapsulation frame-relay;
dlci 6;
peer-unit 5;
family inet6 {
address 2001:db8:0:2::/64 {
eui-64;
}
}
}
}
lo0 {
unit 2 {
family inet6 {
address 2001:db8::2/128;
}
}
}
}
protocols {
bgp {
group external-peers {
type external;
peer-as 17;
neighbor 2001:db8:0:2:2a0:a502:0:5da;
}
}
routing-options {
router-id 172.16.2.2;
autonomous-system 22;
}
}
C {
interfaces {
lt-0/1/0 {
unit 10 {
description to-E;
encapsulation frame-relay;
dlci 10;
peer-unit 9;
family inet6 {
address 2001:db8:0:3::/64 {
eui-64;
}
}
}
}
lo0 {
unit 3 {
family inet6 {
address 2001:db8::3/128;
}
}
}
}
protocols {
bgp {
group external-peers {
type external;
peer-as 17;
neighbor 2001:db8:0:3:2a0:a502:0:9da;
}
}
}
routing-options {
router-id 172.16.3.3;
autonomous-system 22;
}
}
D {
interfaces {
lt-0/1/0 {
unit 7 {
description to-E;
encapsulation frame-relay;
dlci 7;
peer-unit 21;
family inet6 {
address 2001:db8:0:4::/64 {
eui-64;
}
}
}
}
lo0 {
unit 4 {
family inet6 {
address 2001:db8::4/128;
}
}
}
}
protocols {
bgp {
group external-peers {
type external;
peer-as 17;
neighbor 2001:db8:0:4:2a0:a502:0:15da;
}
}
routing-options {
router-id 172.16.4.4;
autonomous-system 79;
}
}
E {
interfaces {
lt-0/1/0 {
unit 5 {
description to-B;
encapsulation frame-relay;
dlci 6;
peer-unit 6;
family inet6 {
address 2001:db8:0:2::/64 {
eui-64;
}
}
}
unit 9 {
description to-C;
encapsulation frame-relay;
dlci 10;
peer-unit 10;
family inet6 {
address 2001:db8:0:3::/64 {
eui-64;
}
}
}
unit 21 {
description to-D;
encapsulation frame-relay;
dlci 7;
peer-unit 7;
family inet6 {
address 2001:db8:0:4::/64 {
eui-64;
}
}
}
unit 25 {
description to-A;
encapsulation frame-relay;
dlci 1;
peer-unit 1;
family inet6 {
address 2001:db8:0:1::/64 {
eui-64;
}
}
}
}
lo0 {
unit 5 {
family inet6 {
address 2001:db8::5/128;
}
}
}
}
protocols {
bgp {
group external-peers {
type external;
peer-as 22;
neighbor 2001:db8:0:1:2a0:a502:0:1da;
neighbor 2001:db8:0:2:2a0:a502:0:6da;
neighbor 2001:db8:0:3:2a0:a502:0:ada;
neighbor 2001:db8:0:4:2a0:a502:0:7da {
peer-as 79;
}
}
}
}
routing-options {
router-id 172.16.5.5;
autonomous-system 17;
}
}
デバイスの設定が完了したら、設定モード から Commit を入力します。
検証
設定が正常に機能されていることを確認します。
ネイバー BGP検証
目的
設定済みBGPで動作し、各ネイバー アドレスに対して BGP がアクティブな状態されていることを確認します。
アクション
動作モードから コマンドを実行 show bgp neighbor
します。
user@R1:E> show bgp neighbor Peer: 2001:db8:0:1:2a0:a502:0:1da+54987 AS 22 Local: 2001:db8:0:1:2a0:a502:0:19da+179 AS 17 Type: External State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: Open Message Error Options: <Preference PeerAS Refresh> Holdtime: 90 Preference: 170 Number of flaps: 0 Error: 'Open Message Error' Sent: 20 Recv: 0 Peer ID: 172.16.1.1 Local ID: 172.16.5.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 0 BFD: disabled, down Local Interface: lt-0/1/0.25 NLRI for restart configured on peer: inet6-unicast NLRI advertised by peer: inet6-unicast NLRI for this session: inet6-unicast Peer supports Refresh capability (2) Stale routes from peer are kept for: 300 Peer does not support Restarter functionality NLRI that restart is negotiated for: inet6-unicast NLRI of received end-of-rib markers: inet6-unicast NLRI of all end-of-rib markers sent: inet6-unicast Peer supports 4 byte AS extension (peer-as 22) Peer does not support Addpath Table inet6.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 0 Accepted prefixes: 0 Suppressed due to damping: 0 Advertised prefixes: 0 Last traffic (seconds): Received 7 Sent 18 Checked 81 Input messages: Total 1611 Updates 1 Refreshes 0 Octets 30660 Output messages: Total 1594 Updates 0 Refreshes 0 Octets 30356 Output Queue[0]: 0 Peer: 2001:db8:0:2:2a0:a502:0:6da+179 AS 22 Local: 2001:db8:0:2:2a0:a502:0:5da+55502 AS 17 Type: External State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: Open Message Error Options: <Preference PeerAS Refresh> Holdtime: 90 Preference: 170 Number of flaps: 0 Error: 'Open Message Error' Sent: 26 Recv: 0 Peer ID: 172.16.2.2 Local ID: 172.16.5.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 2 BFD: disabled, down Local Interface: lt-0/1/0.5 NLRI for restart configured on peer: inet6-unicast NLRI advertised by peer: inet6-unicast NLRI for this session: inet6-unicast Peer supports Refresh capability (2) Stale routes from peer are kept for: 300 Peer does not support Restarter functionality NLRI that restart is negotiated for: inet6-unicast NLRI of received end-of-rib markers: inet6-unicast NLRI of all end-of-rib markers sent: inet6-unicast Peer supports 4 byte AS extension (peer-as 22) Peer does not support Addpath Table inet6.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 0 Accepted prefixes: 0 Suppressed due to damping: 0 Advertised prefixes: 0 Last traffic (seconds): Received 15 Sent 8 Checked 8 Input messages: Total 1610 Updates 1 Refreshes 0 Octets 30601 Output messages: Total 1645 Updates 0 Refreshes 0 Octets 32417 Output Queue[0]: 0 Peer: 2001:db8:0:3:2a0:a502:0:ada+55983 AS 22 Local: 2001:db8:0:3:2a0:a502:0:9da+179 AS 17 Type: External State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: None Options: <Preference PeerAS Refresh> Holdtime: 90 Preference: 170 Number of flaps: 0 Peer ID: 172.16.3.3 Local ID: 172.16.5.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 3 BFD: disabled, down Local Interface: lt-0/1/0.9 NLRI for restart configured on peer: inet6-unicast NLRI advertised by peer: inet6-unicast NLRI for this session: inet6-unicast Peer supports Refresh capability (2) Stale routes from peer are kept for: 300 Peer does not support Restarter functionality NLRI that restart is negotiated for: inet6-unicast NLRI of received end-of-rib markers: inet6-unicast NLRI of all end-of-rib markers sent: inet6-unicast Peer supports 4 byte AS extension (peer-as 22) Peer does not support Addpath Table inet6.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 0 Accepted prefixes: 0 Suppressed due to damping: 0 Advertised prefixes: 0 Last traffic (seconds): Received 21 Sent 21 Checked 67 Input messages: Total 1610 Updates 1 Refreshes 0 Octets 30641 Output messages: Total 1587 Updates 0 Refreshes 0 Octets 30223 Output Queue[0]: 0 Peer: 2001:db8:0:4:2a0:a502:0:7da+49255 AS 79 Local: 2001:db8:0:4:2a0:a502:0:15da+179 AS 17 Type: External State: Established Flags: <Sync> Last State: OpenConfirm Last Event: RecvKeepAlive Last Error: None Options: <Preference PeerAS Refresh> Holdtime: 90 Preference: 170 Number of flaps: 0 Peer ID: 172.16.4.4 Local ID: 172.16.5.5 Active Holdtime: 90 Keepalive Interval: 30 Peer index: 1 BFD: disabled, down Local Interface: lt-0/1/0.21 NLRI for restart configured on peer: inet6-unicast NLRI advertised by peer: inet6-unicast NLRI for this session: inet6-unicast Peer supports Refresh capability (2) Stale routes from peer are kept for: 300 Peer does not support Restarter functionality NLRI that restart is negotiated for: inet6-unicast NLRI of received end-of-rib markers: inet6-unicast NLRI of all end-of-rib markers sent: inet6-unicast Peer supports 4 byte AS extension (peer-as 79) Peer does not support Addpath Table inet6.0 Bit: 10000 RIB State: BGP restart is complete Send state: in sync Active prefixes: 0 Received prefixes: 0 Accepted prefixes: 0 Suppressed due to damping: 0 Advertised prefixes: 0 Last traffic (seconds): Received 6 Sent 17 Checked 25 Input messages: Total 1615 Updates 1 Refreshes 0 Octets 30736 Output messages: Total 1593 Updates 0 Refreshes 0 Octets 30337 Output Queue[0]: 0
意味
近隣間でIPv6ユニキャストネットワークレイヤー到達可能性情報(NLRI)が交換されています。
ホスト グループBGP検証
目的
ネットワーク グループがBGPが正しく構成されていることを検証します。
アクション
動作モードから コマンドを実行 show bgp group
します。
user@R1:E> show bgp group Group Type: External Local AS: 17 Name: external-peers Index: 0 Flags: <> Holdtime: 0 Total peers: 4 Established: 4 2001:db8:0:1:2a0:a502:0:1da+54987 2001:db8:0:2:2a0:a502:0:6da+179 2001:db8:0:3:2a0:a502:0:ada+55983 2001:db8:0:4:2a0:a502:0:7da+49255 inet6.0: 0/0/0/0 Groups: 1 Peers: 4 External: 4 Internal: 0 Down peers: 0 Flaps: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet6.0 0 0 0 0 0 0 inet6.2 0 0 0 0 0 0
意味
グループ タイプは外部で、グループには 4 つのピアがあります。
検証BGPサマリ情報の検証
目的
ネットワークとBGP ピアが確立されているを検証します。
アクション
動作モードから コマンドを実行 show bgp summary
します。
user@R1:E> show bgp summary Groups: 1 Peers: 4 Down peers: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet6.0 0 0 0 0 0 0 inet6.2 0 0 0 0 0 0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped... 2001:db8:0:1:2a0:a502:0:1da 22 1617 1600 0 0 12:07:00 Establ inet6.0: 0/0/0/0 2001:db8:0:2:2a0:a502:0:6da 22 1616 1651 0 0 12:06:56 Establ inet6.0: 0/0/0/0 2001:db8:0:3:2a0:a502:0:ada 22 1617 1594 0 0 12:04:32 Establ inet6.0: 0/0/0/0 2001:db8:0:4:2a0:a502:0:7da 79 1621 1599 0 0 12:07:00 Establ inet6.0: 0/0/0/0
意味
ダウン ピア: 0 の出力は、ピアのBGPが確立された状態を示しています。
ルーティング テーブルの確認
目的
inet6.0 サーバーにローカル ルーティング テーブル直接ルートが追加されています。
アクション
動作モードから コマンドを実行 show route
します。
user@R1:E> show route inet6.0: 15 destinations, 18 routes (15 active, 0 holddown, 0 hidden) + = Active Route, - = Last Active, * = Both 2001:db8::5/128 *[Direct/0] 12:41:18 > via lo0.5 2001:db8:0:1::/64 *[Direct/0] 14:40:01 > via lt-0/1/0.25 2001:db8:0:1:2a0:a502:0:19da/128 *[Local/0] 14:40:01 Local via lt-0/1/0.25 2001:db8:0:2::/64 *[Direct/0] 14:40:02 > via lt-0/1/0.5 2001:db8:0:2:2a0:a502:0:5da/128 *[Local/0] 14:40:02 Local via lt-0/1/0.5 2001:db8:0:3::/64 *[Direct/0] 14:40:02 > via lt-0/1/0.9 2001:db8:0:3:2a0:a502:0:9da/128 *[Local/0] 14:40:02 Local via lt-0/1/0.9 2001:db8:0:4::/64 *[Direct/0] 14:40:01 > via lt-0/1/0.21 2001:db8:0:4:2a0:a502:0:15da/128 *[Local/0] 14:40:01 Local via lt-0/1/0.21 fe80::/64 *[Direct/0] 14:40:02 > via lt-0/1/0.5 [Direct/0] 14:40:02 > via lt-0/1/0.9 [Direct/0] 14:40:01 > via lt-0/1/0.21 [Direct/0] 14:40:01 > via lt-0/1/0.25 fe80::2a0:a502:0:5da/128 *[Local/0] 14:40:02 Local via lt-0/1/0.5 fe80::2a0:a502:0:9da/128 *[Local/0] 14:40:02 Local via lt-0/1/0.9 fe80::2a0:a502:0:15da/128 *[Local/0] 14:40:01 Local via lt-0/1/0.21 fe80::2a0:a502:0:19da/128 *[Local/0] 14:40:01 Local via lt-0/1/0.25 fe80::2a0:a50f:fc56:1da/128 *[Direct/0] 12:41:18 > via lo0.5
意味
inet6.0 にはルーティング テーブル直接ルートが含まれている必要があります。ルーティング テーブルのルートを追加するには、ルーティング ポリシーを設定する必要があります。
例: 内部ファイアウォール およびピア セッションBGP BFD の設定
この例では、BFD(Bidirectional Forwarding Detection)プロトコルを使用してIBGP(内部BGPピア セッションを設定して、ネットワークの障害を検出する方法を示しています。
要件
この例を設定する前に、デバイス初期化以外の特別な設定を行う必要はありません。
概要
IBGP セッションで BFD を有効にする最小設定は、ステートメントを BFD セッションに参加しているすべてのBGPデバイス設定に bfd-liveness-detection minimum-interval
含める必要があります。ステートメント minimum-interval
は、障害検知の最小送受信間隔を指定します。具体的には、この値は、ローカル ルーティング デバイスが hello パケットを送信する最小間隔と、BFD セッションを確立したネイバーからの応答を受信するとルーティング デバイスが期待する最小間隔を表します。1~255,000ミリ秒の値を設定できます。
必要に応じて、 および ステートメントを使用して、最小送信間隔と受信間隔 transmit-interval minimum-interval
を minimum-receive-interval
個別に指定できます。これらのステートメントおよび他のオプションの BFD 設定ステートメントについては、 を参照 bfd-liveness-detection
してください。
BFD は、システム リソースを消費する集中的なプロトコルです。ルーティング エンジンベースのセッションに100ミリ秒未満の BFD の最小間隔を指定し、分散 BFD セッションで 10 ミリ秒未満を指定すると、BFD フラッピングが不要になる可能性があります。
ネットワーク環境によっては、以下の推奨事項が追加される場合があります。
一般的なスイッチオーバー イベント中に BFD フラッピングをルーティング エンジンするには、アプリケーション ベース のセッションに対して 5,000 ミリ秒の最小間隔ルーティング エンジンします。この最小値は、一般的な ルーティング エンジン スイッチオーバー イベント中に、RPD、MIBD、SNMPD などのプロセスが指定したしきい値を超える CPU リソースを利用するために必要です。このため、CPU リソースが不足するため、BFD の処理とスケジューリングが影響を受ける可能性があります。
デュアル シャーシ クラスタ制御リンク シナリオ中に BFD セッションが維持される場合、最初の制御リンクに障害が発生した場合、最小間隔 6,000 ミリ秒を指定して、ルーティング エンジン ベースのセッションに対して LACP がセカンダリ ノードにフラッピングされるのを防ぐ。
多数の BFD セッションを持つ大規模なネットワーク導入の場合、ルーティング エンジン ベース のセッションに 300 ミリ秒、分散 BFD セッションで 100 ミリ秒の最小間隔を指定します。
非常に大規模なネットワーク導入と多数の BFD セッションについては、詳細については、カスタマー サポートジュニパーネットワークスにお問い合わせください。
ノンストップ アクティブ ルーティング(NSR)が設定されている場合に、ルーティング エンジン スイッチオーバー イベント中に BFD セッションを維持するには、ルーティング エンジン ベースのセッションに 2,500 ミリ秒の最小間隔を指定します。NSR が設定された分散 BFD セッションでは、最小間隔の推奨事項は変更されず、ネットワークの導入によってのみ異なります。
BFD は、デフォルトのルーティング インスタンス(メイン ルーター)、ルーティング インスタンス、論理システムでサポートされています。この例では、論理システムの BFD を示しています。
図3は、 内部ピアセッションを持つ典型的なネットワークを示しています。
構成
CLI構成の迅速な設定
この例を迅速に設定するには、以下のコマンドをコピーして、テキスト ファイルに貼り付け、改行を削除し、ネットワーク設定に一致する必要がある詳細情報を変更してから、コマンドを階層レベルで CLI にコピー アンド ペースト [edit]
します。
デバイス A
set logical-systems A interfaces lt-1/2/0 unit 1 description to-B set logical-systems A interfaces lt-1/2/0 unit 1 encapsulation ethernet set logical-systems A interfaces lt-1/2/0 unit 1 peer-unit 2 set logical-systems A interfaces lt-1/2/0 unit 1 family inet address 10.10.10.1/30 set logical-systems A interfaces lo0 unit 1 family inet address 192.168.6.5/32 set logical-systems A protocols bgp group internal-peers type internal set logical-systems A protocols bgp group internal-peers traceoptions file bgp-bfd set logical-systems A protocols bgp group internal-peers traceoptions flag bfd detail set logical-systems A protocols bgp group internal-peers local-address 192.168.6.5 set logical-systems A protocols bgp group internal-peers export send-direct set logical-systems A protocols bgp group internal-peers bfd-liveness-detection minimum-interval 1000 set logical-systems A protocols bgp group internal-peers neighbor 192.163.6.4 set logical-systems A protocols bgp group internal-peers neighbor 192.168.40.4 set logical-systems A protocols ospf area 0.0.0.0 interface lo0.1 passive set logical-systems A protocols ospf area 0.0.0.0 interface lt-1/2/0.1 set logical-systems A policy-options policy-statement send-direct term 2 from protocol direct set logical-systems A policy-options policy-statement send-direct term 2 then accept set logical-systems A routing-options router-id 192.168.6.5 set logical-systems A routing-options autonomous-system 17
デバイス B
set logical-systems B interfaces lt-1/2/0 unit 2 description to-A set logical-systems B interfaces lt-1/2/0 unit 2 encapsulation ethernet set logical-systems B interfaces lt-1/2/0 unit 2 peer-unit 1 set logical-systems B interfaces lt-1/2/0 unit 2 family inet address 10.10.10.2/30 set logical-systems B interfaces lt-1/2/0 unit 5 description to-C set logical-systems B interfaces lt-1/2/0 unit 5 encapsulation ethernet set logical-systems B interfaces lt-1/2/0 unit 5 peer-unit 6 set logical-systems B interfaces lt-1/2/0 unit 5 family inet address 10.10.10.5/30 set logical-systems B interfaces lo0 unit 2 family inet address 192.163.6.4/32 set logical-systems B protocols bgp group internal-peers type internal set logical-systems B protocols bgp group internal-peers local-address 192.163.6.4 set logical-systems B protocols bgp group internal-peers export send-direct set logical-systems B protocols bgp group internal-peers bfd-liveness-detection minimum-interval 1000 set logical-systems B protocols bgp group internal-peers neighbor 192.168.40.4 set logical-systems B protocols bgp group internal-peers neighbor 192.168.6.5 set logical-systems B protocols ospf area 0.0.0.0 interface lo0.2 passive set logical-systems B protocols ospf area 0.0.0.0 interface lt-1/2/0.2 set logical-systems B protocols ospf area 0.0.0.0 interface lt-1/2/0.5 set logical-systems B policy-options policy-statement send-direct term 2 from protocol direct set logical-systems B policy-options policy-statement send-direct term 2 then accept set logical-systems B routing-options router-id 192.163.6.4 set logical-systems B routing-options autonomous-system 17
デバイス C
set logical-systems C interfaces lt-1/2/0 unit 6 description to-B set logical-systems C interfaces lt-1/2/0 unit 6 encapsulation ethernet set logical-systems C interfaces lt-1/2/0 unit 6 peer-unit 5 set logical-systems C interfaces lt-1/2/0 unit 6 family inet address 10.10.10.6/30 set logical-systems C interfaces lo0 unit 3 family inet address 192.168.40.4/32 set logical-systems C protocols bgp group internal-peers type internal set logical-systems C protocols bgp group internal-peers local-address 192.168.40.4 set logical-systems C protocols bgp group internal-peers export send-direct set logical-systems C protocols bgp group internal-peers bfd-liveness-detection minimum-interval 1000 set logical-systems C protocols bgp group internal-peers neighbor 192.163.6.4 set logical-systems C protocols bgp group internal-peers neighbor 192.168.6.5 set logical-systems C protocols ospf area 0.0.0.0 interface lo0.3 passive set logical-systems C protocols ospf area 0.0.0.0 interface lt-1/2/0.6 set logical-systems C policy-options policy-statement send-direct term 2 from protocol direct set logical-systems C policy-options policy-statement send-direct term 2 then accept set logical-systems C routing-options router-id 192.168.40.4 set logical-systems C routing-options autonomous-system 17
デバイス A の設定
手順
次の例では、設定階層でさまざまなレベルに移動する必要があります。デバイスのナビゲーションの詳細については、「 CLI ガイド 」の「 設定モードでの CLI CLI エディター の使用 」を 参照してください。
デバイス A を設定するには、次の手順に示します。
物理リンクをCLIシステム A に設定します。
user@host> set cli logical-system A
インターフェイスを設定します。
[edit interfaces lt-1/2/0 unit 1] user@host:A# set description to-B user@host:A# set encapsulation ethernet user@host:A# set peer-unit 2 user@host:A# set family inet address 10.10.10.1/30 [edit interfaces lo0 unit 1] user@host:A# set family inet address 192.168.6.5/32
設定BGP。
デバイス A がデバイス C に直接接続されていない場合でも、ステートメントはデバイス B とデバイス C の両方
neighbor
に含まれます。[edit protocols bgp group internal-peers] user@host:A# set type internal user@host:A# set local-address 192.168.6.5 user@host:A# set export send-direct user@host:A# set neighbor 192.163.6.4 user@host:A# set neighbor 192.168.40.4
BFD を設定します。
[edit protocols bgp group internal-peers] user@host:A# set bfd-liveness-detection minimum-interval 1000
接続ピアで同じ最小間隔を設定する必要があります。
(オプション)BFD トレースを設定します。
[edit protocols bgp group internal-peers] user@host:A# set traceoptions file bgp-bfd user@host:A# set traceoptions flag bfd detail
設定OSPF。
[edit protocols ospf area 0.0.0.0] user@host:A# set interface lo0.1 passive user@host:A# set interface lt-1/2/0.1
直接ルートを受け入れるポリシーを設定します。
このシナリオで役立つその他のオプションは、ネットワーク ルートまたはローカル ルートを通じて学習OSPF受け入れる場合です。
[edit policy-options policy-statement send-direct term 2] user@host:A# set from protocol direct user@host:A# set then accept
ルーター ID と自律システム(AS)番号を設定します。
[edit routing-options] user@host:A# set router-id 192.168.6.5 user@host:A# set autonomous-system 17
デバイスの設定が完了したら、設定モード
commit
から を入力します。 これらの手順を繰り返して、デバイス B とデバイス C を設定します。
結果
設定モードから、 、および のコマンド show interfaces
を入力して show policy-options
show protocols
設定を確認 show routing-options
します。出力結果に意図した設定結果が表示されない場合は、この例の手順を繰り返して設定を修正します。
user@host:A# show interfaces lt-1/2/0 { unit 1 { description to-B; encapsulation ethernet; peer-unit 2; family inet { address 10.10.10.1/30; } } } lo0 { unit 1 { family inet { address 192.168.6.5/32; } } }
user@host:A# show policy-options policy-statement send-direct { term 2 { from protocol direct; then accept; } }
user@host:A# show protocols bgp { group internal-peers { type internal; traceoptions { file bgp-bfd; flag bfd detail; } local-address 192.168.6.5; export send-direct; bfd-liveness-detection { minimum-interval 1000; } neighbor 192.163.6.4; neighbor 192.168.40.4; } } ospf { area 0.0.0.0 { interface lo0.1 { passive; } interface lt-1/2/0.1; } }
user@host:A# show routing-options router-id 192.168.6.5; autonomous-system 17;
検証
設定が正常に機能されていることを確認します。
BFD が有効になっている検証
目的
IBGP ピア間で BFD が有効になっているか検証します。
アクション
動作モードから コマンドを入力 show bgp neighbor
します。フィルタを使用して | match bfd
出力を絞り込む
user@host:A> show bgp neighbor | match bfd Options: <BfdEnabled> BFD: enabled, up Trace file: /var/log/A/bgp-bfd size 131072 files 10 Options: <BfdEnabled> BFD: enabled, up Trace file: /var/log/A/bgp-bfd size 131072 files 10
意味
この出力では、論理システム A には BFD が有効になっている 2 つのネイバーが設定されています。BFD が有効になっていない場合、出力は表示 BFD: disabled, down
され、 <BfdEnabled>
オプションは大分になります。BFD が有効でセッションがダウンしている場合、出力に BFD: enabled, down
.出力はまた、トレース操作が設定されたため、BFD 関連イベントがログ ファイルに書き込されていることを示しています。
BFD セッションがアップの確認
目的
BFD セッションがアップしているのを検証し、BFD セッションの詳細を表示します。
アクション
動作モードから コマンドを入力 show bfd session extensive
します。
user@host:A> show bfd session extensive Detect Transmit Address State Interface Time Interval Multiplier 192.163.6.4 Up 3.000 1.000 3 Client BGP, TX interval 1.000, RX interval 1.000 Session up time 00:54:40 Local diagnostic None, remote diagnostic None Remote state Up, version 1 Logical system 12, routing table index 25 Min async interval 1.000, min slow interval 1.000 Adaptive async TX interval 1.000, RX interval 1.000 Local min TX interval 1.000, minimum RX interval 1.000, multiplier 3 Remote min TX interval 1.000, min RX interval 1.000, multiplier 3 Local discriminator 10, remote discriminator 9 Echo mode disabled/inactive Multi-hop route table 25, local-address 192.168.6.5 Detect Transmit Address State Interface Time Interval Multiplier 192.168.40.4 Up 3.000 1.000 3 Client BGP, TX interval 1.000, RX interval 1.000 Session up time 00:48:03 Local diagnostic None, remote diagnostic None Remote state Up, version 1 Logical system 12, routing table index 25 Min async interval 1.000, min slow interval 1.000 Adaptive async TX interval 1.000, RX interval 1.000 Local min TX interval 1.000, minimum RX interval 1.000, multiplier 3 Remote min TX interval 1.000, min RX interval 1.000, multiplier 3 Local discriminator 14, remote discriminator 13 Echo mode disabled/inactive Multi-hop route table 25, local-address 192.168.6.5 2 sessions, 2 clients Cumulative transmit rate 2.0 pps, cumulative receive rate 2.0 pps
意味
出力 TX interval 1.000, RX interval 1.000
は、 ステートメントで設定された設定を表 minimum-interval
します。その他のすべての出力は、BFD のデフォルト設定を表しています。デフォルト設定を変更するには、 ステートメントの下に オプションのステートメントを含 bfd-liveness-detection
める必要があります。
詳細な BFD イベントの表示
目的
BFD トレース ファイルの内容を表示して、必要に応じてトラブルシューティングをサポートします。
アクション
動作モードから コマンドを入力 file show /var/log/A/bgp-bfd
します。
user@host:A> file show /var/log/A/bgp-bfd Aug 15 17:07:25 trace_on: Tracing to "/var/log/A/bgp-bfd" started Aug 15 17:07:26.492190 bgp_peer_init: BGP peer 192.163.6.4 (Internal AS 17) local address 192.168.6.5 not found. Leaving peer idled Aug 15 17:07:26.493176 bgp_peer_init: BGP peer 192.168.40.4 (Internal AS 17) local address 192.168.6.5 not found. Leaving peer idled Aug 15 17:07:32.597979 task_connect: task BGP_17.192.163.6.4+179 addr 192.163.6.4+179: No route to host Aug 15 17:07:32.599623 bgp_connect_start: connect 192.163.6.4 (Internal AS 17): No route to host Aug 15 17:07:36.869394 task_connect: task BGP_17.192.168.40.4+179 addr 192.168.40.4+179: No route to host Aug 15 17:07:36.870624 bgp_connect_start: connect 192.168.40.4 (Internal AS 17): No route to host Aug 15 17:08:04.599220 task_connect: task BGP_17.192.163.6.4+179 addr 192.163.6.4+179: No route to host Aug 15 17:08:04.601135 bgp_connect_start: connect 192.163.6.4 (Internal AS 17): No route to host Aug 15 17:08:08.869717 task_connect: task BGP_17.192.168.40.4+179 addr 192.168.40.4+179: No route to host Aug 15 17:08:08.869934 bgp_connect_start: connect 192.168.40.4 (Internal AS 17): No route to host Aug 15 17:08:36.603544 advertising receiving-speaker only capabilty to neighbor 192.163.6.4 (Internal AS 17) Aug 15 17:08:36.606726 bgp_read_message: 192.163.6.4 (Internal AS 17): 0 bytes buffered Aug 15 17:08:36.609119 Initiated BFD session to peer 192.163.6.4 (Internal AS 17): address=192.163.6.4 ifindex=0 ifname=(none) txivl=1000 rxivl=1000 mult=3 ver=255 Aug 15 17:08:36.734033 advertising receiving-speaker only capabilty to neighbor 192.168.40.4 (Internal AS 17) Aug 15 17:08:36.738436 Initiated BFD session to peer 192.168.40.4 (Internal AS 17): address=192.168.40.4 ifindex=0 ifname=(none) txivl=1000 rxivl=1000 mult=3 ver=255 Aug 15 17:08:40.537552 BFD session to peer 192.163.6.4 (Internal AS 17) up Aug 15 17:08:40.694410 BFD session to peer 192.168.40.4 (Internal AS 17) up
意味
ルートが確立される前に、 No route to host
メッセージが出力に表示されます。ルートが確立された後、最後の 2 行には、両方の BFD セッションが設定されます。
ループバック インターフェイスの非アクティブ化と再有効化後の詳細な BFD イベントの表示
目的
ルーターやスイッチをダウンして動作を戻した後、何が起こっているかを確認します。ルーターやスイッチの停止をシミュレーションするには、論理システム B のループバック インターフェイスを非アクティブにします。
アクション
設定モードから コマンドを入力
deactivate logical-systems B interfaces lo0 unit 2 family inet
します。user@host:A# deactivate logical-systems B interfaces lo0 unit 2 family inet user@host:A# commit
動作モードから コマンドを入力
file show /var/log/A/bgp-bfd
します。user@host:A> file show /var/log/A/bgp-bfd ... Aug 15 17:20:55.995648 bgp_read_v4_message:9747: NOTIFICATION received from 192.163.6.4 (Internal AS 17): code 6 (Cease) subcode 6 (Other Configuration Change) Aug 15 17:20:56.004508 Terminated BFD session to peer 192.163.6.4 (Internal AS 17) Aug 15 17:21:28.007755 task_connect: task BGP_17.192.163.6.4+179 addr 192.163.6.4+179: No route to host Aug 15 17:21:28.008597 bgp_connect_start: connect 192.163.6.4 (Internal AS 17): No route to host
設定モードから コマンドを入力
activate logical-systems B interfaces lo0 unit 2 family inet
します。user@host:A# activate logical-systems B interfaces lo0 unit 2 family inet user@host:A# commit
動作モードから コマンドを入力
file show /var/log/A/bgp-bfd
します。user@host:A> file show /var/log/A/bgp-bfd ... Aug 15 17:25:53.623743 advertising receiving-speaker only capabilty to neighbor 192.163.6.4 (Internal AS 17) Aug 15 17:25:53.631314 Initiated BFD session to peer 192.163.6.4 (Internal AS 17): address=192.163.6.4 ifindex=0 ifname=(none) txivl=1000 rxivl=1000 mult=3 ver=255 Aug 15 17:25:57.570932 BFD session to peer 192.163.6.4 (Internal AS 17) up
例: 論理システムでのEBGPマルチホープセッションの設定
この例では、ローカル ルーターから 1 ホップ以上離BGP EBGP(外部ゲートウェイ ピア)を設定する方法を示しています。このタイプのセッションは、マルチホー プ EBGPセッションと呼ばれる。
要件
この例では、デバイス初期化以外の特別な設定は必要ありません。
概要
EBGP ピアが直接接続されていない場合は、1 つ以上の非接続ルーティング デバイスBGP相互に到達する必要があります。マルチホープ EBGP を設定すると、ピアは他のルーティング デバイスを通過して、ピアの関係を形成し、更新メッセージを交換できます。このタイプの設定は、一般的に、ジュニパーネットワークス ルーティング デバイスが、2 つの EBGP ピアの直接接続を許可しないサードパーティーのルーティング デバイスで EBGP を実行する必要がある場合に使用されます。EBGP マルチホープにより、直接接続されていない 2 つの EBGP ピア間のネイバー接続が可能になります。
マルチホープ EBGP セッションを有効にするには、2 つの EBGP ピア間の接続が必要です。この例では、静的ルートを使用してデバイス間の接続を提供しています。
直接接続された EBGP セッションの場合、通常、物理アドレスはステートメントで neighbor
使用されます。マルチホープ EBGP では、ループバック インターフェイス アドレスを使用し、間接的に接続されたピアのループバック インターフェイス アドレスを指定する必要があります。ループバック インターフェイス アドレスを使用する場合、EBGP マルチホープは内部インターフェイス(IBGP)BGP似ています。
最後に、 ステートメントを追加する multihop
必要があります。必要に応じて、 ステートメントを使用してTTL(最大TTL)値を設定 ttl
できます。TTL は、指定されたパケットの IP ヘッダー BGPされます。TTL値を指定しない場合は、システムのデフォルトの最大TTL値が使用されます。マルチホップEBGPセッションのデフォルトTTL値は64です。もう 1 つのオプションは、 ステートメントBGPを含めて、ルート アドバタイズメントのネクスト ホップ値を保持 no-nexthop-change
します。
図4は 、典型的なEBGPマルチホープネットワークを示しています。
デバイス C とデバイス E には、EBGP セッションが確立されています。デバイス D は、BGP対応デバイスではありません。すべてのデバイスが静的ルート経由で接続しています。
構成
CLI迅速な設定
この例を迅速に設定するには、以下のコマンドをコピーして、テキスト ファイルに貼り付け、改行を削除し、ネットワーク設定に一致する必要がある詳細情報を変更してから、コマンドを階層レベルで CLI にコピー アンド ペースト [edit]
します。
デバイス C
set logical-systems C interfaces lt-1/2/0 unit 9 description to-D set logical-systems C interfaces lt-1/2/0 unit 9 encapsulation ethernet set logical-systems C interfaces lt-1/2/0 unit 9 peer-unit 10 set logical-systems C interfaces lt-1/2/0 unit 9 family inet address 10.10.10.9/30 set logical-systems C interfaces lo0 unit 3 family inet address 192.168.40.4/32 set logical-systems C protocols bgp group external-peers type external set logical-systems C protocols bgp group external-peers multihop ttl 2 set logical-systems C protocols bgp group external-peers local-address 192.168.40.4 set logical-systems C protocols bgp group external-peers export send-static set logical-systems C protocols bgp group external-peers peer-as 18 set logical-systems C protocols bgp group external-peers neighbor 192.168.6.7 set logical-systems C policy-options policy-statement send-static term 1 from protocol static set logical-systems C policy-options policy-statement send-static term 1 then accept set logical-systems C routing-options static route 10.10.10.14/32 next-hop 10.10.10.10 set logical-systems C routing-options static route 192.168.6.7/32 next-hop 10.10.10.10 set logical-systems C routing-options router-id 192.168.40.4 set logical-systems C routing-options autonomous-system 17
デバイス D
set logical-systems D interfaces lt-1/2/0 unit 10 description to-C set logical-systems D interfaces lt-1/2/0 unit 10 encapsulation ethernet set logical-systems D interfaces lt-1/2/0 unit 10 peer-unit 9 set logical-systems D interfaces lt-1/2/0 unit 10 family inet address 10.10.10.10/30 set logical-systems D interfaces lt-1/2/0 unit 13 description to-E set logical-systems D interfaces lt-1/2/0 unit 13 encapsulation ethernet set logical-systems D interfaces lt-1/2/0 unit 13 peer-unit 14 set logical-systems D interfaces lt-1/2/0 unit 13 family inet address 10.10.10.13/30 set logical-systems D interfaces lo0 unit 4 family inet address 192.168.6.6/32 set logical-systems D routing-options static route 192.168.40.4/32 next-hop 10.10.10.9 set logical-systems D routing-options static route 192.168.6.7/32 next-hop 10.10.10.14 set logical-systems D routing-options router-id 192.168.6.6
デバイス E
set logical-systems E interfaces lt-1/2/0 unit 14 description to-D set logical-systems E interfaces lt-1/2/0 unit 14 encapsulation ethernet set logical-systems E interfaces lt-1/2/0 unit 14 peer-unit 13 set logical-systems E interfaces lt-1/2/0 unit 14 family inet address 10.10.10.14/30 set logical-systems E interfaces lo0 unit 5 family inet address 192.168.6.7/32 set logical-systems E protocols bgp group external-peers multihop ttl 2 set logical-systems E protocols bgp group external-peers local-address 192.168.6.7 set logical-systems E protocols bgp group external-peers export send-static set logical-systems E protocols bgp group external-peers peer-as 17 set logical-systems E protocols bgp group external-peers neighbor 192.168.40.4 set logical-systems E policy-options policy-statement send-static term 1 from protocol static set logical-systems E policy-options policy-statement send-static term 1 then accept set logical-systems E routing-options static route 10.10.10.8/30 next-hop 10.10.10.13 set logical-systems E routing-options static route 192.168.40.4/32 next-hop 10.10.10.13 set logical-systems E routing-options router-id 192.168.6.7 set logical-systems E routing-options autonomous-system 18
デバイス C
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションについて、詳しくは CLI ガイド の 設定モードでの CLI エディターの使用 CLI を参照してください。
デバイス C を設定するには、以下の手順にアクセスします。
物理リンクをCLIシステム C に設定します。
user@host> set cli logical-system C
直接接続されたデバイスに対してインターフェイスを設定し(-D)、ループバック インターフェイスを設定します。
[edit interfaces lt-1/2/0 unit 9] user@host:C# set description to-D user@host:C# set encapsulation ethernet user@host:C# set peer-unit 10 user@host:C# set family inet address 10.10.10.9/30 [edit interfaces lo0 unit 3] user@host:C# set family inet address 192.168.40.4/32
論理システム E との EBGP セッションを設定します。
ステートメント
neighbor
は、論理システム E 上のループバック インターフェイスを示しています。[edit protocols bgp group external-peers] user@host:C# set type external user@host:C# set local-address 192.168.40.4 user@host:C# set export send-static user@host:C# set peer-as 18 user@host:C# set neighbor 192.168.6.7
論理システム C および論理システム E が EBGP ピアになるには、マルチホープ ステートメントを設定します。
ピアが互いに2ホップ離れたため、この例ではステートメントを使用
ttl 2
しています。[edit protocols bgp group external-peers] user@host:C# set multihop ttl 2
静的ルートを使用して論理システム E への接続を設定します。
ループバック インターフェイス アドレスと物理インターフェイス上のアドレスへのルートを設定する必要があります。
[edit logical-systems C routing-options] user@host:C# set static route 10.10.10.14/32 next-hop 10.10.10.10 user@host:C# set static route 192.168.6.7/32 next-hop 10.10.10.10
ローカル ルーター ID と自律システム(AS)番号を設定します。
[edit routing-options] user@host:C# set router-id 192.168.40.4 user@host:C# set autonomous-system 17
直接ルートを受け入れるポリシーを設定します。
このシナリオで役立つその他のオプションは、ネットワーク ルートまたはローカル ルートを通じて学習OSPF受け入れる場合です。
[edit policy-options policy-statement send-static term 1] user@host:C# set from protocol static user@host:C# set then accept
結果
設定モードから、 、および のコマンド show interfaces
を入力して show protocols
show policy-options
設定を確認 show routing-options
します。出力結果に意図した設定結果が表示されない場合は、この例の手順を繰り返して設定を修正します。
user@host:C# show interfaces lt-1/2/0 { unit 9 { description to-D; encapsulation ethernet; peer-unit 10; family inet { address 10.10.10.9/30; } } } lo0 { unit 3 { family inet { address 192.168.40.4/32; } } }
user@host:C# show protocols bgp { group external-peers { type external; multihop { ttl 2; } local-address 192.168.40.4; export send-static; peer-as 18; neighbor 192.168.6.7; } }
user@host:C# show policy-options policy-statement send-static { term 1 { from protocol static; then accept; } }
user@host:C# show routing-options static { route 10.10.10.14/32 next-hop 10.10.10.10; route 192.168.6.7/32 next-hop 10.10.10.10; } router-id 192.168.40.4; autonomous-system 17;
デバイスの設定が完了したら、設定モード から Commit を入力します。トポロジー内のすべての BFD セッションに対して、これらの手順を繰り返します。
デバイス D
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションについて、詳しくは CLI ガイド の 設定モードでの CLI エディターの使用 CLI を参照してください。
デバイス D を設定するには、次の手順に示します。
デバイスのCLI論理システム D に設定します。
user@host> set cli logical-system D
直接接続されたデバイスへのインターフェイスを設定し、ループバック インターフェイスを設定します。
[edit interfaces lt-1/2/0 unit 10] user@host:D# set description to-C user@host:D# set encapsulation ethernet user@host:D# set peer-unit 9 user@host:D# set family inet address 10.10.10.10/30 [edit interfaces lt-1/2/0 unit 13] user@host:D# set description to-E user@host:D# set encapsulation ethernet user@host:D# set peer-unit 14 user@host:D# set family inet address 10.10.10.13/30 [edit interfaces lo0 unit 4] user@host:D# set family inet address 192.168.6.6/32
ループバック インターフェイス アドレスへの静的ルートを使用して、他のデバイスとの接続を設定します。
論理システムDは論理システムCと論理システムEに直接接続いので、論理システムDでは、物理アドレスへの静的ルートを必要としません。
[edit routing-options] user@host:D# set static route 192.168.40.4/32 next-hop 10.10.10.9 user@host:D# set static route 192.168.6.7/32 next-hop 10.10.10.14
ローカル ルーター ID と自律システム(AS)番号を設定します。
[edit routing-options] user@host:D# set router-id 192.168.6.6
結果
設定モードから、 および コマンドを入力して設定 show interfaces
を確認 show routing-options
します。出力結果に意図した設定結果が表示されない場合は、この例の手順を繰り返して設定を修正します。
user@host:D# show interfaces lt-1/2/0 { unit 10 { description to-C; encapsulation ethernet; peer-unit 9; family inet { address 10.10.10.10/30; } } unit 13 { description to-E; encapsulation ethernet; peer-unit 14; family inet { address 10.10.10.13/30; } } } lo0 { unit 4 { family inet { address 192.168.6.6/32; } } }
user@host:D# show protocols
user@host:D# show routing-options static { route 192.168.40.4/32 next-hop 10.10.10.9; route 192.168.6.7/32 next-hop 10.10.10.14; } router-id 192.168.6.6;
デバイスの設定が完了したら、設定モード から Commit を入力します。トポロジー内のすべての BFD セッションに対して、これらの手順を繰り返します。
デバイス E
手順
次の例では、設定階層内のさまざまなレベルに移動する必要があります。デバイスのナビゲーションの詳細については、「 CLI ガイド 」の「 設定モードでの CLI CLI エディター の使用 」を 参照してください。
デバイス E を設定するには、次の手順に示します。
物理リンクをCLIシステム E に設定します。
user@host> set cli logical-system E
直接接続されたデバイスに対してインターフェイスを設定し(-D)、ループバック インターフェイスを設定します。
[edit interfaces lt-1/2/0 unit 14] user@host:E# set description to-D user@host:E# set encapsulation ethernet user@host:E# set peer-unit 13 user@host:E# set family inet address 10.10.10.14/30 [edit interfaces lo0 unit 5] user@host:E# set family inet address 192.168.6.7/32
論理システム E との EBGP セッションを設定します。
ステートメント
neighbor
は、論理システム C 上のループバック インターフェイスを示しています。[edit protocols bgp group external-peers] user@host:E# set local-address 192.168.6.7 user@host:E# set export send-static user@host:E# set peer-as 17 user@host:E# set neighbor 192.168.40.4
論理システム C および論理システム E が EBGP ピアになるには、
multihop
ステートメントを設定します。ピアが互いに2ホップ離れたため、この例ではステートメントを使用
ttl 2
しています。[edit protocols bgp group external-peers] user@host:E# set multihop ttl 2
静的ルートを使用して論理システム E への接続を設定します。
ループバック インターフェイス アドレスと物理インターフェイス上のアドレスへのルートを設定する必要があります。
[edit routing-options] user@host:E# set static route 10.10.10.8/30 next-hop 10.10.10.13 user@host:E# set static route 192.168.40.4/32 next-hop 10.10.10.13
ローカル ルーター ID と自律システム(AS)番号を設定します。
[edit routing-options] user@host:E# set router-id 192.168.6.7 user@host:E# set autonomous-system 18
直接ルートを受け入れるポリシーを設定します。
このシナリオで役立つその他のオプションは、ネットワーク ルートまたはローカル ルートを通OSPF受け入れる場合です。
[edit policy-options policy-statement send-static term 1] user@host:E# set from protocol static user@host:E# set send-static then accept
結果
設定モードから、 、および のコマンド show interfaces
を入力して show protocols
show policy-options
設定を確認 show routing-options
します。出力結果に意図した設定結果が表示されない場合は、この例の手順を繰り返して設定を修正します。
user@host:E# show interfaces lt-1/2/0 { unit 14 { description to-D; encapsulation ethernet; peer-unit 13; family inet { address 10.10.10.14/30; } } } lo0 { unit 5 { family inet { address 192.168.6.7/32; } } }
user@host:E# show protocols bgp { group external-peers { multihop { ttl 2; } local-address 192.168.6.7; export send-static; peer-as 17; neighbor 192.168.40.4; } }
user@host:E# show policy-options policy-statement send-static { term 1 { from protocol static; then accept; } }
user@host:E# show routing-options static { route 10.10.10.8/30 next-hop 10.10.10.13; route 192.168.40.4/32 next-hop 10.10.10.13; } router-id 192.168.6.7; autonomous-system 18;
デバイスの設定が完了したら、設定モード から Commit を入力します。
検証
設定が正常に機能されていることを確認します。
接続の検証
目的
ping 要求の送信元としてループバック インターフェイス アドレスを指定して、デバイス C がデバイス E に ping を実行できる必要があります。
ループバック インターフェイス アドレスは、パケットが使用BGPアドレスです。
アクション
動作モードから、論理システム C から コマンドを入力し、論理システム ping 10.10.10.14 source 192.168.40.4
ping 10.10.10.9 source 192.168.6.7
E から コマンドを入力します。
user@host:C> ping 10.10.10.14 source 192.168.40.4PING 10.10.10.14 (10.10.10.14): 56 data bytes 64 bytes from 10.10.10.14: icmp_seq=0 ttl=63 time=1.262 ms 64 bytes from 10.10.10.14: icmp_seq=1 ttl=63 time=1.202 ms ^C --- 10.10.10.14 ping statistics --- 2 packets transmitted, 2 packets received, 0% packet loss round-trip min/avg/max/stddev = 1.202/1.232/1.262/0.030 ms
user@host:E> ping 10.10.10.9 source 192.168.6.7PING 10.10.10.9 (10.10.10.9): 56 data bytes 64 bytes from 10.10.10.9: icmp_seq=0 ttl=63 time=1.255 ms 64 bytes from 10.10.10.9: icmp_seq=1 ttl=63 time=1.158 ms ^C --- 10.10.10.9 ping statistics --- 2 packets transmitted, 2 packets received, 0% packet loss round-trip min/avg/max/stddev = 1.158/1.206/1.255/0.049 ms
意味
ping が機能している場合、静的ルートは機能します。
セッションのBGPの検証
目的
セッションのBGPがアップ示します。
アクション
動作モードから コマンドを入力 show bgp summary
します。
user@host:C> show bgp summaryGroups: 1 Peers: 1 Down peers: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet.0 2 0 0 0 0 0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped... 192.168.6.7 18 147 147 0 1 1:04:27 0/2/2/0 0/0/0/0
user@host:E> show bgp summary Groups: 1 Peers: 1 Down peers: 0 Table Tot Paths Act Paths Suppressed History Damp State Pending inet.0 2 0 0 0 0 0 Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped... 192.168.40.4 17 202 202 0 1 1:02:18 0/2/2/0 0/0/0/0
意味
出力では、両方のデバイスにそれぞれ1つのピアがあるという結果が表示されています。ピアがダウンする必要はありません。
アドバタイズされたルートの表示
目的
ネットワークによってルートがアドバタイズされているのを確認BGP。
アクション
動作モードから コマンドを入力 show route advertising-protocol bgp neighbor
します。
user@host:C> show route advertising-protocol bgp 192.168.6.7inet.0: 5 destinations, 7 routes (5 active, 0 holddown, 0 hidden) Prefix Nexthop MED Lclpref AS path * 10.10.10.14/32 Self I * 192.168.6.7/32 Self I
user@host:E> show route advertising-protocol bgp 192.168.40.4 inet.0: 5 destinations, 7 routes (5 active, 0 holddown, 0 hidden) Prefix Nexthop MED Lclpref AS path * 10.10.10.8/30 Self I * 192.168.40.4/32 Self I
意味
静的 送信アプリケーションルーティング ポリシー 静的ルートが、デバイスからデバイスにルーティング テーブルBGP。BGPが確立されたため、ピア間でこれらのBGP ピアを宣伝しています。