Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Announcement: Try the Ask AI chatbot for answers to your technical questions about Juniper products and solutions.

close
header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
list Table of Contents

Other MC-LAG Configurations

date_range 10-Dec-24

Configuring IGMP Snooping in MC-LAG Active-Active Mode

You can use the bridge-domain statement's service-id option to specify the multichassis aggregated Ethernet configuration on MX240 routers, MX480 routers, MX960 routers and QFX Series switches.

  • The service-id statement is mandatory for non-single VLAN type bridge domains (none, all, or vlan-id-tags:dual).

  • The statement is optional for bridge domains with a VID defined.

  • The bridge-level service-id is required to link related bridge domains across peers, and should be configured with the same value.

  • The service-id values share the name space across all bridging and routing instances, and across peers. Thus, duplicate service-id values are not permitted across these entities.

  • A change of bridge service-id is considered catastrophic, and the bridge domain is changed.

This procedure allows you to enable or disable the replication feature.

To configure IGMP snooping in MC-LAG active-active mode :

  1. Use the multichassis-lag-replicate-state statement at the [edit multicast-snooping-options] hierarchy level in the master instance.
    content_copy zoom_out_map
    multicast-snooping-options {
        ...
        multichassis-lag-replicate-state; # REQUIRED
    }
    
  2. Use the interface icl-intf-name statement at the [edit protocols igmp-snooping] hierarchy level, as shown in the following example:
    content_copy zoom_out_map
    protocols {
        igmp-snooping {
            interface icl-intf-name {
                multicast-router-interface;
            }
        }
    }
    
    Note:

    For QFX use the following configuration:

    content_copy zoom_out_map
    protocols {
        igmp-snooping {
            vlan vlan_name{
                }
                interface icl-intf-name {
                multicast-router-interface;
            }
        }
    }
    

    The interchassis link, interface icl-intf-name, of the learning domain should be a router-facing interface.

Increasing ARP and Network Discovery Protocol Entries for Enhanced MC-LAG and Layer 3 VXLAN Topologies

Understanding the Need for an Increase in ARP and Network Discovery Protocol (NDP) Entries

The number of ARP and NDP entries has increased to 256,000 to improve enhanced MC-LAG and Layer 3 VXLAN scenarios.

Here are some enhanced MC-LAG and Layer 3 VXLAN scenarios in which an increase in ARP and NDP entries is needed:

  • Enhanced MC-LAG topology with a large number of MC-AE interfaces that contain a large number of members per chassis.

  • Non-collapsed spine-leaf topology, in which the leaf devices operate as Layer 2 gateways and handle traffic within the VXLAN, and the spine devices operate as Layer 3 gateways and handle traffic between the VXLANs using IRB interfaces.

    In this scenario, the increase in ARP and NDP entries is needed at the spine level.

  • Leaf devices that operate as both Layer 2 and Layer 3 gateways.

    In this scenario, the transit spine devices provide Layer 3 routing functioning only, and the increased number of ARP and NDP entries in needed only at the leaf level.

Increasing ARP and Network Discovery Protocol Entries for Enhanced MC-LAG Using IPv4 Transport

To increase the number of ARP and NDP entries using IPv4 transport, follow these steps. We recommend that you use the values provided in this procedure for optimal performance:

  1. Enable the arp-enhanced-scale statement:
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-enhanced-scale
    
  2. Configure the maximum number of routes to be stored in the ARP cache.
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-system-cache-limit number
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-system-cache-limit 2000000
    
  3. Configure the amount of time between ARP updates.
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer minutes
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer 20
    
  4. Enable enhanced convergence on the MC-AE interface:
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set interface-name aggregated-ether-options mc-ae enhanced-convergence
    
  5. Enable enhanced convergence on the IRB interface that you have configured as part of an MC-AE.
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit number  enhanced-convergence
    
  6. Specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  7. Specify the amount time that elapses before the entries in the MAC-IP bindings database are timed out and deleted.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-time 1200
    
  8. Reboot the device in order for these changes to take effect.
    content_copy zoom_out_map
    user@switch# request system reboot 

Increasing ARP and Network Discovery Protocol Entries for Enhanced MC-LAG Using IPv6 Transport

To increase the number of ARP and Network Discovery Protocol entries using IPv6 transport. We recommend that you use the values provided in this procedure for optimal performance:

  1. Enable the arp-enhanced-scale statement:
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-enhanced-scale
    
  2. Specify the maximum system cache size for IPv6 next-hop addresses.
    content_copy zoom_out_map
    [edit system]
    user@switch# set nd-system-cache-limitnumber
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set nd-system-cache-limit 2000000
    
  3. Set the stale timer for IPv6 neighbor reachability confirmation.
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit 1 family inet6 nd6-stale-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit 1 family inet6 nd6-stale-time 1200
    
  4. Enable enhanced convergence on the MC-AE interface:
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set interface-name aggregated-ether-options mc-ae enhanced-convergence
    
  5. Enable enhanced convergence on the IRB interface that you have configured as part of an MC-AE.
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit number  enhanced-convergence
    
  6. Specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  7. Specify the amount time that elapses before the entries in the MAC-IP bindings database are timed out and deleted.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-time 1200
    
  8. Reboot the device in order for these changes to take effect.
    content_copy zoom_out_map
    user@switch# request system reboot 

Increasing ARP for EVPN-VXLAN Gateway for Border-Leaf in Edge Routed Bridge (ERB) or Spine in Centrally Routed Bridge (CRB) for IPv4 Tenant Traffic

To increase the number of ARP entries using IPv4 tenant traffic, follow these steps. We recommend that you use the values provided in this procedure for optimal performance:

  1. Enable the arp-enhanced-scale statement:
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-enhanced-scale
    
  2. Configure the maximum number of routes to be stored in the ARP cache.
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-system-cache-limit number
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-system-cache-limit 2000000
    
  3. Configure the amount of time between ARP updates.
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer minutes
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer 20
    
  4. On QFX10002-60C devices, configure the amount of time between ARP updates.
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer minutes
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set arp aging-timer 900
    
  5. Specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  6. Specify the amount time that elapses before the entries in the MAC-IP bindings database are timed out and deleted.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-time 1200
    
  7. On QFX10002-60C devices, specify the amount time that elapses before the entries in the MAC-IP bindings database are timed out and deleted.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-time 900
    
  8. For each leaf device, specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  9. On QFX10002-60C devices, for each leaf device, specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 1200
    
  10. Reboot the device in order for these changes to take effect.
    content_copy zoom_out_map
    user@switch# request system reboot 

Increasing ARP and Network Discovery Protocol Entries for EVPN-VXLAN gateway for Border-Leaf in Edge Routed Bridge (ERB) or Spine in Centrally Routed Bridge (CRB) for IPv6 Tenant Traffic

To increase the number of ARP and Network Discovery Protocol entries using IPv4 and IPv6 tenant traffic, follow these steps. We recommend that you use the values provided in this procedure for optimal performance:

  1. Enable the arp-enhanced-scale statement:
    content_copy zoom_out_map
    [edit system]
    user@switch# set arp-enhanced-scale
    
  2. Specify the maximum system cache size for IPv6 next-hop addresses.
    content_copy zoom_out_map
    [edit system]
    user@switch# set nd-system-cache-limitnumber
    

    For example:

    content_copy zoom_out_map
    [edit system]
    user@switch# set nd-system-cache-limit 2000000
    
  3. Set the stale timer for IPv6 neighbor reachability confirmation.
    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit 1 family inet6 nd6-stale-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit interfaces]
    user@switch# set irb unit 1 family inet6 nd6-stale-time 1200
    
  4. Specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  5. Specify the amount time that elapses before the entries in the MAC-IP bindings database are timed out and deleted.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-timeseconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-ip-table-aging-time 1200
    
  6. For each leaf device, specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 3600
    
  7. For each leaf device, specify the amount of time that elapses before the MAC table entries are timed out and entries are deleted from the table.
    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time seconds
    

    For example:

    content_copy zoom_out_map
    [edit protocols l2-learning]
    user@switch# set global-mac-table-aging-time 1200
    
  8. Reboot the device in order for these changes to take effect.
    content_copy zoom_out_map
    user@switch# request system reboot 

Synchronizing and Committing Configurations

To propagate, synchronize, and commit configuration changes from one device (Junos Fusion Provider Edge, Junos Fusion Enterprise, EX Series switches, and MX Series routers) to another, perform following tasks:

Configure Devices for Configuration Synchronization

Configure the hostnames or IP addresses for the devices that will be synchronizing their configurations as well as the usernames and authentication details for the users administering configuration synchronization. Additionally, enable a NETCONF connection so that the devices can synchronize their configurations. Secure Copy Protocol (SCP) copies the configurations securely between the devices.

For example, if you have a local device named Switch A and want to synchronize a configuration with remote devices named Switch B, Switch C, and Switch D, you need to configure the details for Switch B, Switch C, and Switch D on Switch A.

To specify the configuration details:

  1. On the local device, specify the configuration details for the remote device.
    content_copy zoom_out_map
    [edit system commit]
    user@switch# set peers hostname user username authentication password string

    For example, if the local device is Switch A, and the remote devices are Switch B, Switch C, and Switch D:

    content_copy zoom_out_map
    [edit system commit]
    user@Switch A# set peers Switch B user admin-SwitchB authentication "$ABC123"
    user@Switch A# set peers Switch C user admin-SwitchC authentication "$ABC123"
    user@Switch A# set peers Switch D user admin-SwitchD authentication "$ABC123"

    The password string is stored as an authenticated password string.

    The output for Switch A is as follows:

    content_copy zoom_out_map
    [edit system commit]
        peers {
        Switch B{
            user admin-SwitchB;
            authentication  "$ABC123";
        }
        Switch C{
            user admin-SwitchC;
            authentication  "$ABC123";
        }
        Switch D{
            user admin-SwitchD;
            authentication  "$ABC123";
        }
    }
    
  2. Statically map Switch A to Switch B, Switch C, and Switch D.

    For example:

    content_copy zoom_out_map
    [edit system ]
    user@Switch A# set static-host-mapping Switch A inet 10.92.76.2
    user@Switch A# set static-host-mapping Switch B inet 10.92.76.4
    user@Switch A# set static-host-mapping Switch C inet 10.92.76.6
    user@Switch A# set static-host-mapping Switch D inet 10.92.76.8

    The output is as follows:

    content_copy zoom_out_map
        [edit system] 
             static-host-mapping [
                SwitchA{
                    inet [ 10.92.76.2 ];
                }
                SwitchB{
                    inet [ 10.92.76.4 ];
                }
                SwitchC{
                    inet [ 10.92.76.6 ];
                }
                SwitchD{
                    inet [ 10.92.76.8 ];
                }
            }
        }
    
  3. Enable a NETCONF connection using SSH between all devices (Switch A, Switch B, Switch C, and Switch D).

    For example:

    content_copy zoom_out_map
    [edit]
    user@Switch A# set system services netconf ssh
    content_copy zoom_out_map
    [edit]
    user@Switch B# set system services netconf ssh
    content_copy zoom_out_map
    [edit]
    user@Switch C# set system services netconf ssh
    content_copy zoom_out_map
    [edit]
    user@Switch D# set system services netconf ssh

Create a Global Configuration Group

Create a global configuration group the local and remote devices.

To create a global configuration group:

  1. Specify the devices that will receive the configuration:
    content_copy zoom_out_map
    [edit]
    user@switch# set groups <name of group> when peers [<name of local peer> <name of remote peer>]

    For example:

    content_copy zoom_out_map
    [edit]
    user@switch# set groups global when peers [Switch A Switch B Switch C Switch D]
  2. Create the global configuration that will be shared between the devices.

    For example:

    content_copy zoom_out_map
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family inet {
                    address 10.1.1.1/8;
                }
            }
        }
        ge-0/0/1 {
            ether-options {
                802.3ad ae0;
            }
        }
        ge-0/0/2 {
            ether-options {
                802.3ad ae1;
            }
        }
        ae0 {
            aggregated-ether-options {
                lacp {
                    active;
                }
            }
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members v1;
                    }
                }
            }
        }
        ae1 {
            aggregated-ether-options {
                lacp {
                    active;
                    system-id 00:01:02:03:04:05;
                    admin-key 3;
                }
                mc-ae {
                    mc-ae-id 1;
                    redundancy-group 1;
                    mode active-active;
                }
            }
            unit 0 {
                family ethernet-switching {
                    interface-mode access;
                    vlan {
                        members v1;
                    }
                }
            }
        }
    }
    switch-options {
        service-id 1;
    }
    vlans {
        v1 {
            vlan-id 100;
            l3-interface irb.100;
        }
    }
    

The output for the configuration is as follows:

content_copy zoom_out_map
groups {
    global {
        when {
            peers [ Switch A Switch B Switch C Switch D ];
        }
        interfaces {
            ge-0/0/0 {
                unit 0 {
                    family inet {
                        address 10.1.1.1/8;
                    }
                }
            }
            ge-0/0/1 {
                ether-options {
                    802.3ad ae0;
                }
            }
            ge-0/0/2 {
                ether-options {
                    802.3ad ae1;
                }
            }
            ae0 {
                aggregated-ether-options {
                    lacp {
                        active;
                    }
                }
                unit 0 {
                    family ethernet-switching {
                        interface-mode trunk;
                        vlan {
                            members v1;
                        }
                    }
                }
            }
            ae1 {
                aggregated-ether-options {
                    lacp {
                        active;
                        system-id 00:01:02:03:04:05;
                        admin-key 3;
                    }
                    mc-ae {
                        mc-ae-id 1;
                        redundancy-group 1;
                        mode active-active;
                    }
                }
                unit 0 {
                    family ethernet-switching {
                        interface-mode access;
                        vlan {
                            members v1;
                        }
                    }
                }
            }
        }
        switch-options {
            service-id 1;
        }
        vlans {
            v1 {
                vlan-id 100;
                l3-interface irb.100;
            }
        }
    }
}

Create a Local Configuration Group

Create a local configuration group for the local device.

To create a local configuration group:

  1. Specify the local configuration group name.
    content_copy zoom_out_map
    [edit]
    user@switch# set groups name of group when peers [name of local peer]

    For example:

    content_copy zoom_out_map
    [edit]
    user@switch# set groups local when peers [Switch A]
  2. Include the local configuration that will be used by the local device.

    For example:

    content_copy zoom_out_map
    interfaces {
        ae1 {
            aggregated-ether-options {
                mc-ae {
                    chassis-id 0;
                    status-control active;
                    events {
                        iccp-peer-down {
                            prefer-status-control-active;
                        }
                    }
                }
            }
        }
        irb {
            unit 100 {
                family inet {
                    address 10.10.10.3/8 {
                        arp 10.10.10.2 l2-interface ae0.0 mac 00:00:5E:00:53:00;
                    }
                }
            }
        }
    }
            multi-chassis {
                multi-chassis-protection 10.1.1.1 {
                    interface ae0;
                }
            }
        }
    }
    

The output for the configuration is as follows:

content_copy zoom_out_map
groups {
    local {
        when {
            peers Switch A;
        }
        interfaces {
            ae1 {
                aggregated-ether-options {
                    mc-ae {
                        chassis-id 0;
                        status-control active;
                        events {
                            iccp-peer-down {
                                prefer-status-control-active;
                            }
                        }
                    }
                }
            }
            irb {
                unit 100 {
                    family inet {
                        address 10.10.10.3/8 {
                            arp 10.10.10.2 l2-interface ae0.0 mac 00:00:5E:00:53:00;
                        }
                    }
                }
            }
        }
        multi-chassis {
            multi-chassis-protection 10.1.1.1 {
                interface ae0;
            }
        }
    }
}

Create a Remote Configuration Group

Create a remote configuration group for remote devices.

To create a remote configuration group:

  1. Specify the remote configuration group name.
    content_copy zoom_out_map
    [edit]
    user@switch# set groups name of group when peers [names of remote peers]

    For example:

    content_copy zoom_out_map
    [edit]
    user@switch# set groups remote when peers [Switch B Switch C Switch D]
  2. Include the remote configuration that will be used by the remote devices.

    For example:

    content_copy zoom_out_map
    interfaces {
        ae1 {
            aggregated-ether-options {
                mc-ae {
                    chassis-id 1;
                    status-control standby;
                    events {
                        iccp-peer-down {
                            prefer-status-control-active;
                        }
                    }
                }
            }
        }
        irb {
            unit 100 {
                family inet {
                    address 10.10.10.3/8 {
                        arp 10.10.10.2 l2-interface ae0.0 mac 00:00:5E:00:53:00;
                    }
                }
            }
        }
    }
        multi-chassis {
            multi-chassis-protection 10.1.1.1 {
                interface ae0;
            }
        }
    }
    

The output for the configuration is as follows:

content_copy zoom_out_map
groups {
    remote {
        when {
            peers Switch B Switch C Switch D
        }
        interfaces {
            ae1 {
                aggregated-ether-options {
                    mc-ae {
                        chassis-id 1;
                        status-control standby;
                        events {
                            iccp-peer-down {
                                prefer-status-control-active;
                            }
                        }
                    }
                }
            }
            irb {
                unit 100 {
                    family inet {
                        address 10.10.10.3/8 {
                            arp 10.10.10.2 l2-interface ae0.0 mac 00:00:5E:00:53:00;
                        }
                    }
                }
            }
        }
        multi-chassis {
            multi-chassis-protection 10.1.1.1 {
                interface ae0;
            }
        }
    }
}

Create Apply Groups for the Local, Remote, and Global Configurations

Create apply groups so changes in the configuration are inherited by local, remote, and global configuration groups. List the configuration groups in order of inheritance, where the configuration data in the first configuration group takes priority over the data in subsequent configuration groups.

When you apply the configuration groups and issue the commit peers-synchronize command, changes are committed on both the local and remote devices. If there is an error on any of the devices, an error message is issued, and the commit is terminated.

To apply the configuration groups:

Specify the names of the configuration groups.
content_copy zoom_out_map
[edit]
user@switch# set apply-groups [<name of global configuration group> <name of local configuration group> <name of remote configuration group>]

For example:

content_copy zoom_out_map
[edit]
user@switch# set apply-groups [ global local remote ]

The output for the configuration is as follows:

content_copy zoom_out_map
apply-groups [ global local remote ];

Synchronizing and Committing Configurations

Note:

The commit at <"string"> command is not supported when performing configuration synchronization.

You can enable the peers-synchronize statement on the local (or requesting) device to copy and load its configuration to the remote (or responding) device by default. You can alternatively issue the commit peers-synchronize command.

  • Configure the commit command on the local (or requesting) to automatically perform a peers-synchronize action between devices.

    content_copy zoom_out_map
    [edit]
    user@switch# set system commit peers-synchronize

    The output for the configuration is as follows:

    content_copy zoom_out_map
    system {
        commit {
            peers-synchronize;
        }
    }
    
  • Issue the commit peers-synchronize command on the local (or requesting) device.

    content_copy zoom_out_map
    [edit]
    user@switch# commit peers-synchronize

Troubleshooting Remote Device Connections

Problem

Description

When you issue the commit command, the system issues the following error message:

content_copy zoom_out_map
root@Switch A# commit
error: netconf: could not read hello error: did not receive hello packet from server error: Setting up sessions for peer: 'Switch B' failed warning: Cannot connect to remote peers, ignoring it

The error message shows that there is a NETCONF connection issue between the local device and remote device.

Resolution

Resolution
  1. Verify that the SSH connection to the remote device (Switch B) is working.

    content_copy zoom_out_map
    root@Switch A# ssh root@Switch B
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY! Someone could be eavesdropping on you right now (man-in-the-middle attack)! It is also possible that a host key has just been changed. The fingerprint for the ECDSA key sent by the remote host is 21:e8:5a:58:bb:29:8b:96:a4:eb:cc:8a:32:95:53:c0. Please contact your system administrator. Add correct host key in /root/.ssh/known_hosts to get rid of this message. Offending ECDSA key in /root/.ssh/known_hosts:1 ECDSA host key for Switch A has changed and you have requested strict checking. Host key verification failed.

    The error message shows that the SSH connection is not working.

  2. Delete the key entry in the /root/.ssh/known_hosts:1 directory and try to connect to Switch B again.

    content_copy zoom_out_map
    root@Switch A# ssh root@Switch B
    The authenticity of host 'Switch B (10.92.76.235)' can't be established. ECDSA key fingerprint is 21:e8:5a:58:bb:29:8b:96:a4:eb:cc:8a:32:95:53:c0. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added 'Switch A,10.92.76.235' (ECDSA) to the list of known hosts. Password: Last login: Wed Apr 13 15:29:58 2016 from 192.168.61.129 - JUNOS 15.1I20160412_0929_dc-builder Kernel 64-bit FLEX JNPR-10.1-20160217.114153_fbsd-builder_stable_10 At least one package installed on this device has limited support. Run 'file show /etc/notices/unsupported.txt' for details.

    Connection to Switch B was successful.

  3. Log out of Switch B.

    content_copy zoom_out_map
    root@Switch B# exit
    logout Connection to Switch B closed.
  4. Verify that NETCONF over SSH is working.

    content_copy zoom_out_map
    root@Switch A# ssh root@Switch B -s netconf
    logout Connection to st-72q-01 closed.
    Password:
    <hello xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
    <capabilities>
    <capability>urn:ietf:params:netconf:base:1.0</capability>
    <capability>urn:ietf:params:netconf:capability:candidate:1.0</capability>

    The log message shows that the NETCONF over SSH was successful.

    If the error message showed that NETCONF over SSH was not successful, enable NETCONF over SSH by issuing the set system services netconf ssh command.

  5. Create configuration groups to synchronize if you have not done so already.

    You can issue the show | compare command to see if any configuration groups have been created.

    content_copy zoom_out_map
    root@Switch A# show | compare
  6. Issue the commit command.

    content_copy zoom_out_map
    root@Switch A# commit
    [edit chassis]
    
    configuration check succeeds 
    commit complete   
    {master:0}[edit]

    The log message shows that the commit was successful.

footer-navigation