Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
EVPN User Guide
Table of Contents Expand all
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring Basic EVPN Active-Active Multihoming

date_range 20-Dec-24

This example shows how to configure an active-active multihomed customer edge (CE) devices and provider edge (PE) devices in an Ethernet VPN (EVPN).

Requirements

This example uses the following hardware and software components:

  • Four MX Series 5G Universal Routing Platforms with MPC interfaces only, where:

    • Two devices are configured as provider edge (PE) routers connected to a common multihomed customer site.

    • One device is configured as a remote PE router connected to a single-homed customer site.

    • One device is configured as a provider router.

  • • Two customer edge (CE) devices, where:

    • Two CE devices that are multihomed.

    • One CE devices that is single-homed .

Before you begin:

  1. Configure the router interfaces.

  2. Configure OSPF or any other IGP protocol.

  3. Configure a BGP internal group.

  4. Configure MPLS.

Overview

Figure 1 illustrates a simple EVPN topology. Routers PE1 and PE2 are provider edge (PE) routers connected to multihomed customer edge (CE) router CE1. Router P is the provider router connected to Routers PE1, PE2, and PE3. Router PE3 is connected to customer edge router CE2.

Figure 1: Simple EVPN Multihomed TopologySimple EVPN Multihomed Topology

Configuration

CLI Quick Configuration

The configurations parameters for the routers are as follows:

CE1

content_copy zoom_out_map
chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
}
interfaces {
    ge-0/0/1 {
        description To-PE1;
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/2 {
        description To-PE2;
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/7 {
        unit 0 {
            family bridge {
                interface-mode access;
                vlan-id 10;
            }
        }
    }
    ge-0/0/8 {
        unit 0 {
            family bridge {
                interface-mode access;
                vlan-id 20;
            }
        }
    }
    ae0 {
        description To-PE1_and_PE2;
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list [ 10 20 ];
            }
        }
    }
}
bridge-domains { 
    BD {
        vlan-id-list [ 10 20 ];  
    }
}

PE1

content_copy zoom_out_map
interfaces {
    ge-0/0/1 {
        description To-CE1;
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        esi {
            00:11:11:11:11:11:11:11:11:11;
            all-active;
        }
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list [ 10 20 ];
            }
        }
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 10.3.3.1/30;
                }
            family mpls;
        }
    }
     lo0 {
        unit 0 {
            family inet {
                address 192.168.1.1/32;
            }
        }
    }
}
routing-options {
    router-id 192.168.1.1;
    autonomous-system 65432;
    forwarding-table {
        export evpn-pplb;
    }
}
protocols {
    rsvp {
        interface ge-0/0/3.0;
    }
    mpls {
        no-cspf;
        label-switched-path PE1-to-PE2 {
            to 192.168.2.2;
        }
        label-switched-path PE1-to-PE3 {
            to 192.168.3.3;
        }
        interface ge-0/0/3.0;
    }
    bgp {
        group EVPN-PE {
            type internal;
            local-address 192.168.1.1;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            neighbor 192.168.3.3;
            neighbor 192.168.2.2;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface all {
                interface-type p2p;
            }
            interface fxp0.0 {
                disable;
            }
        }
    }
}
routing-instances {
    evpn-ta {
        instance-type virtual-switch;         
        interface ge-0/0/1.10;   
        route-distinguisher 65432:10;    
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list [ 10 20 ];
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
            }
            bd20 {
                domain-type bridge;
                vlan-id 20;
            }
        }
    }
}
policy-statement evpn-pplb {
    from protocol evpn;
    then {
        load-balance per-packet;
    }
}

PE2

content_copy zoom_out_map
interfaces {
    ge-0/0/2 {
        description To-CE1;
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        esi {
            00:11:11:11:11:11:11:11:11:11;
            all-active;
        }
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list [ 10 20 ];
            }
        }
    }
    ge-0/0/4 {
        unit 0 {
            family inet {
                address 10.4.4.1/30;
                }
            family mpls;
        }
    }
     lo0 {
        unit 0 {
            family inet {
                address 192.168.2.2/32;
            }
        }
    }
}
routing-options {
    router-id 192.168.2.2;
    autonomous-system 65432;
    forwarding-table {
        export evpn-pplb;
    }
}
protocols {
    rsvp {
        interface ge-0/0/4.0;
    }
    mpls {
        no-cspf;
        label-switched-path PE2-to-PE1 {
            to 192.168.1.1;
        }
        label-switched-path PE2-to-PE3 {
            to 192.168.3.3;
        }
        interface ge-0/0/4.0;
    }
    bgp {
        group EVPN-PE {
            type internal;
            local-address 192.168.2.2;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            neighbor 192.168.1.1;
            neighbor 192.168.3.3;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface all {
                interface-type p2p;
            }
            interface fxp0.0 {
                disable;
            }
        }
    }
}
routing-instances {
    evpn-ta {
        instance-type virtual-switch;         
        interface ge-0/0/2.10;   
        route-distinguisher 65432:10;    
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list [ 10 20 ];
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
            }
            bd20 {
                domain-type bridge;
                vlan-id 20;
            }
        }
    }
}
policy-statement evpn-pplb {
    from protocol evpn;
    then {
        load-balance per-packet;
    }
}

Router PE3

content_copy zoom_out_map
interfaces {
    ge-0/0/5 {
        unit 0 {
            family inet {
                address 10.5.5.1/30;
                }
            family mpls;
        }
    }
    ge-0/0/6 {
        flexible-vlan-tagging;   
        encapsulation flexible-ethernet-services;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
        unit 20 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 20;
            }
        }
    }
     lo0 {
        unit 0 {
            family inet {
                address 192.168.3.3/32;
            }
        }
    }
    routing-options {
        router-id 192.168.3.3;
        autonomous-system 65432;
        forwarding-table {
            export evpn-pplb;
        }
    }
    protocols {
        rsvp {
            interface ge-0/0/5.0;
        }
        mpls {
            no-cspf;
            label-switched-path PE3-to-PE1 {
                to 192.168.1.1;
            }
            label-switched-path PE3-to-PE2 {
                to 192.168.2.2;
            }
            interface ge-0/0/5.0;
        }
        bgp {
            group EVPN-PE {
                type internal;
                local-address 192.168.3.3;
                family inet-vpn {
                    unicast;
                }
                family evpn {
                    signaling;
                }
                neighbor 192.168.1.1;
                neighbor 192.168.2.2;
            }
        }
        ospf {
            traffic-engineering;
            area 0.0.0.0 {
                interface all {
                    interface-type p2p;
                }
                interface fxp0.0 {
                    disable;
                }
            }
        }
    }
    routing-instances {
        evpn-ta {
            instance-type virtual-switch;         
            interface ge-0/0/6.10;   
            interface ge-0/0/6.20;   
            route-distinguisher 65432:10;    
            vrf-target target:65432:10;
            protocols {
                evpn {
                    extended-vlan-list [ 10 20 ];
                }
            }
            bridge-domains {
                bd10 {
                    domain-type bridge;
                    vlan-id 10;
                    bridge-options {
                        interface ge-0/0/6.10;
                    }
                }
                bd20 {
                    domain-type bridge;
                    vlan-id 20;
                    bridge-options {
                        interface ge-0/0/6.20;
                    }
                }
            }
        }
    }
}
policy-statement evpn-pplb {
    from protocol evpn;
    then {
        load-balance per-packet;
    }
}

Router P

content_copy zoom_out_map
interfaces {
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 10.3.3.2/30;
                }
            family mpls;
        }
    }
    ge-0/0/4 {
        unit 0 {
            family inet {
                address 10.4.4.2/30;
                }
            family mpls;
        }
    }
    ge-0/0/5 {
        unit 0 {
            family inet {
                address 10.5.5.2/30;
                }
            family mpls;
        }
    }
     lo0 {
        unit 0 {
            family inet {
                address 192.168.4.4/32;
            }
        }
    }
}
routing-options {
    router-id 192.168.4.4;
    autonomous-system 65432;
}
protocols {
    rsvp {
        interface all;
        interface fxp0.0 {
            disable;
        }
    }
    mpls {
        interface all;
        interface fxp0.0 {
            disable;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface all {
                interface-type p2p;
            }
            interface fxp0.0 {
                disable;
            }
        }
    }
}
footer-navigation