Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
{ "lCode": "en_US", "lName": "English", "folder": "en_US" }
English

Example: Configuring BA Classifiers on Transparent Mode Security Devices

date_range 04-Apr-19

This example shows how to configure BA classifiers on transparent mode devices to determine the forwarding treatment of packets entering the devices.

Requirements

Before you begin, configure a Layer 2 logical interface. See Example: Configuring Layer 2 Logical Interfaces on Security Devices.

Overview

In this example, you configure logical interface ge-0/0/4.0 as a trunk port that carries traffic for packets tagged with VLAN identifiers 200 through 390. You then configure forwarding classes and create BA classifier c1 for IEEE 802.1 traffic where incoming packets with IEEE 802.1p priority bits 110 are assigned to the forwarding class fc1 with a low loss priority. Finally, you apply the BA classifier c1 to interface ge-0/0/4.0.

Configuration

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set interfaces ge-0/0/4 vlan-tagging unit 0 family ethernet-switching interface-mode trunk vlan members 200-390
set class-of-service forwarding-classes queue 0 fc1
set class-of-service forwarding-classes queue 1 fc2
set class-of-service forwarding-classes queue 3 fc4
set class-of-service forwarding-classes queue 4 fc5
set class-of-service forwarding-classes queue 5 fc6
set class-of-service forwarding-classes queue 6 fc7
set class-of-service forwarding-classes queue 7 fc8
set class-of-service forwarding-classes queue 2 fc3
set class-of-service classifiers ieee-802.1 c1 forwarding-class fc1 loss-priority low code-point 110
set class-of-service interfaces ge-0/0/4 unit 0 classifiers ieee-802.1 c1

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For instructions on how to do that, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure BA classifiers on transparent mode devices:

  1. Configure the logical interface as a Layer 2 trunk port.
    content_copy zoom_out_map
    [edit]
    user@host# set interfaces ge-0/0/4 vlan-tagging unit 0 family ethernet-switching interface-mode trunk vlan members 200-390
  2. Configure the class of service.
    content_copy zoom_out_map
    [edit]
    user@host# edit class-of-service
  3. Configure the forwarding classes.
    content_copy zoom_out_map
    [edit class-of-service]
    user@host# set forwarding-classes queue 0 fc1
    user@host# set forwarding-classes queue 1 fc2
    user@host# set forwarding-classes queue 3 fc4
    user@host# set forwarding-classes queue 4 fc5
    user@host# set forwarding-classes queue 5 fc6
    user@host# set forwarding-classes queue 6 fc7
    user@host# set forwarding-classes queue 7 fc8
    user@host# set forwarding-classes queue 2 fc3
  4. Configure a BA classifier.
    content_copy zoom_out_map
    [edit class-of-service]
    user@host# set classifiers ieee-802.1 c1 forwarding-class fc1 loss-priority low code-points 110
  5. Apply the BA classifier to the interface.
    content_copy zoom_out_map
    [edit class-of-service]
    user@host# set interfaces ge-0/0/4 unit 0 classifiers ieee-802.1 c1

Results

From configuration mode, confirm your configuration by entering the show interfaces ge-0/0/4 and show class-of-service commands. If the output does not display the intended configuration, repeat the configuration instructions in this example to correct it.

content_copy zoom_out_map
[edit]
user@host> show interfaces ge-0/0/4
vlan-tagging;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan members 200-390;
}
}
[edit]
user@host> show class-of-service
classifiers {
ieee-802.1 c1 {
forwarding-class fc1 {
loss-priority low code-points 110;
}
}
}
forwarding-classes {
queue 0 fc1;
queue 1 fc2;
queue 3 fc4;
queue 4 fc5;
queue 5 fc6;
queue 6 fc7;
queue 7 fc8;
queue 2 fc3;
}
interfaces {
ge-0/0/4 {
unit 0 {
classifiers {
ieee-802.1 c1;
}
}
}
}

If you are done configuring the device, enter commit from configuration mode.

Verification

To confirm that the configuration is working properly, perform this task:

Verifying BA Classifiers on Transparent Mode Devices

Purpose

Verify that the BA classifier was configured on the transparent mode devices properly.

Action

From configuration mode, enter the show interfaces ge-0/0/4 and show class-of-service commands.

footer-navigation