Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
{ "lCode": "en_US", "lName": "English", "folder": "en_US" }
English

Example: Configuring VPLS with BGP Signaling

date_range 23-Dec-19

This example shows how to configure VPLS with BGP signaling between two devices.

Requirements

Before you begin, see Understanding Selective Stateless Packet-Based Services .

Overview

This example shows a minimum configuration for PE devices and CE devices to create a VPLS network with BGP signaling. The topology consists of two PE devices and two CE devices. In this example, you configure a VPLS routing instance vpls-instance between two PE devices, PE1 and PE2. You also configure the CE1 and CE2 devices that use Ethernet-based interfaces to connect VLAN 600 to their local PE devices. On the CE1 device, configure the Fast Ethernet interface that connects to the PE1 device. The VLAN identifier and IP address must match those of the CE2 device.

Figure 1 shows the topology used in this example.

Figure 1: Configuring VPLS with BGP Signaling
Configuring VPLS with BGP
Signaling

Configuration

Configuring the CE1 Device

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set interfaces fe-0/0/3 vlan-tagging
set interfaces fe-0/0/3 unit 0 vlan-id 600
set interfaces fe-0/0/3 unit 0 family inet address 10.11.3.1/24

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For instructions on how to do that, see Using the CLI Editor in Configuration Mode.

  1. Enable VLAN tagging on the VPLS interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3]
    user@host# set vlan-tagging
  2. Configure the VLAN ID on the logical interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3 unit 0]
    user@host# set vlan-id 600
  3. Configure the VPLS family on the logical interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3 unit 0]
    user@host# set family inet address 10.11.3.1/24

Results

From configuration mode, confirm your configuration by entering the show interfaces command. If the output does not display the intended configuration, repeat the configuration instructions in this example to correct it.

content_copy zoom_out_map
fe-0/0/3 {
vlan-tagging;
unit 0 {
vlan-id 600;
family inet {
address 10.11.3.1/24;
}
}
}

If you are done configuring the device, enter commit from configuration mode.

Configuring the PE1 Device

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set system host-name PE1
set interfaces fe-0/0/3 description "CE1 on PE1"
set interfaces fe-0/0/3 vlan-tagging
set interfaces fe-0/0/3 encapsulation vlan-vpls
set interfaces fe-0/0/3 unit 0 encapsulation vlan-vpls
set interfaces fe-0/0/3 unit 0 vlan-id 600
set interfaces fe-0/0/3 unit 0 family vpls
set interfaces fe-0/0/5 vlan-tagging
set interfaces fe-0/0/5 unit 37 vlan-id 37
set interfaces fe-0/0/5 unit 37 family inet address 172.28.2.133/30
set interfaces fe-0/0/5 unit 37 family mpls
set interfaces lo0 unit 0 family inet address 172.28.1.2/32
set routing-options router-id 172.28.1.2
set routing-options autonomous-system 65512
set protocols rsvp interface fe-0/0/5.37
set protocols mpls label-switched-path pe1-to-pe2 to 172.28.1.1
set protocols mpls interface fe-0/0/5.37
set protocols mpls interface lo0.0
set protocols bgp group vpls-peering type internal
set protocols bgp group vpls-peering local-address 172.28.1.2
set protocols bgp group vpls-peering family l2vpn signaling
set protocols bgp group vpls-peering neighbor 172.28.1.1
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-0/0/5.37
set routing-instances vpls-instance description "Routing instance from VPLS routing"
set routing-instances vpls-instance instance-type vpls
set routing-instances vpls-instance interface fe-0/0/3.0
set routing-instances vpls-instance route-distinguisher 172.28.1.2:1
set routing-instances vpls-instance vrf-target target:65512:1
set routing-instances vpls-instance protocols vpls site-range 10
set routing-instances vpls-instance protocols vpls no-tunnel-services site site10 automatic-site-id

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For instructions on how to do that, see Using the CLI Editor in Configuration Mode.

To configure PE1:

  1. Configure the hostname for the PE1 device.
    content_copy zoom_out_map
    [edit ]
    user@host# set system host-name PE1
  2. Configure VPLS VLAN encapsulation on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit interfaces]
    user@host# set fe-0/0/3 description "CE1 on PE1"
    user@host# set fe-0/0/3 vlan-tagging
    user@host# set fe-0/0/3 encapsulation vlan-vpls
    user@host# set fe-0/0/3 unit 0 encapsulation vlan-vpls
    user@host# set fe-0/0/3 unit 0 vlan-id 600
    user@host# set fe-0/0/3 unit 0 family vpls
  3. Configure the routing interface on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit interfaces]
    user@host# set fe-0/0/5 vlan-tagging
    user@host# set fe-0/0/5 unit 37 vlan-id 37
    user@host# set fe-0/0/5 unit 37 family inet address 172.28.2.133/30
    user@host# set fe-0/0/5 unit 37 family mpls
    user@host# set lo0 unit 0 family inet address 172.28.1.2/32
    Note

    For this example, it is optional to configure VLAN tagging. Remove the VLAN tagging configuration on the physical interfaces if you do not plan to configure VLAN tagging.

  4. Configure the routing options on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit routing-options]
    user@host# set router-id 172.28.1.2
    user@host# set autonomous-system 65512
  5. Configure RSVP on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set rsvp interface fe-0/0/5.37
  6. Configure MPLS on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set mpls label-switched-path pe1-to-pe2 to 172.28.1.1
    user@host# set mpls interface fe-0/0/5.37
    user@host# set mpls interface lo0.0
  7. Configure BGP on the VPLS PE1 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set bgp group vpls-peering type internal
    user@host# set bgp group vpls-peering local-address 172.28.1.2
    user@host# set bgp group vpls-peering family l2vpn signaling
    user@host# set bgp group vpls-peering neighbor 172.28.1.1
  8. (Optional) Configure OSPF on the VPLS PE1 device.
    Note

    For this example, it is optional to configure OFPF. You must configure OSPF only in cases where two PE devices are not connected directly.

    content_copy zoom_out_map
    [edit protocols]
    user@host# set ospf area 0.0.0.0 interface lo0.0 passive
    user@host# set ospf area 0.0.0.0 interface fe-0/0/5.37
  9. Create a VPLS routing instance.
    content_copy zoom_out_map
    [edit ]
    user@host# set routing-instances vpls-instance
  10. Configure a VPLS routing instance.
    content_copy zoom_out_map
    [edit routing-instances vpls-instance]
    user@host# set description "Routing instance from VPLS routing"
    user@host# set instance-type vpls
    user@host# set interface fe-0/0/3.0
    user@host# set route-distinguisher 172.28.1.2:1
    user@host# set vrf-target target:65512:1
    user@host# set protocols vpls site-range 10
    user@host# set protocols vpls no-tunnel-services site site10 automatic-site-id

Results

From configuration mode, confirm your configuration by entering the show command. If the output does not display the intended configuration, repeat the configuration instructions in this example to correct it.

content_copy zoom_out_map
[edit]
user@host# show system
host-name PE1;
content_copy zoom_out_map
[edit]
user@host# show interfaces
fe-0/0/5 {
vlan-tagging;
unit 37 {
vlan-id 37;
family inet {
address 172.28.2.133/30;
}
family mpls;
}
}
fe-0/0/3 {
description "CE1 on PE1";
vlan-tagging;
encapsulation vlan-vpls;
unit 0 {
encapsulation vlan-vpls;
vlan-id 600;
family vpls;
}
}
lo0 {
unit 0 {
family inet {
address 172.28.1.2/32;
}
}
}
content_copy zoom_out_map
[edit]
user@host# show routing-options
router-id 172.28.1.2;
autonomous-system 65512;
content_copy zoom_out_map
[edit]
user@host# show protocols
rsvp {
interface fe-0/0/5.37;
}
mpls {
label-switched-path pe1-to-pe2 {
to 172.28.1.1;
}
interface fe-0/0/5.37;
interface lo0.0;
}
bgp {
group vpls-peering {
type internal;
local-address 172.28.1.2;
family l2vpn {
signaling;
}
neighbor 172.28.1.1;
}
}
ospf {
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface fe-0/0/5.37;
}
}
content_copy zoom_out_map
[edit]
user@host# show routing-instances
vpls-instance {
description "Routing instance from VPLS routing";
instance-type vpls;
interface fe-0/0/3.0;
route-distinguisher 172.28.1.2:1;
vrf-target target:65512:1;
protocols {
vpls {
site-range 10;
no-tunnel-services;
site site10 {
automatic-site-id;
}
}
}
}

If you are done configuring the device, enter commit from configuration mode.

Configuring the PE2 Device

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set system host-name PE2
set interfaces fe-0/0/3 description "CE2 on PE2"
set interfaces fe-0/0/3 vlan-tagging
set interfaces fe-0/0/3 encapsulation vlan-vpls
set interfaces fe-0/0/3 unit 0 encapsulation vlan-vpls
set interfaces fe-0/0/3 unit 0 vlan-id 600
set interfaces fe-0/0/3 unit 0 family vpls
set interfaces fe-0/0/5 vlan-tagging
set interfaces fe-0/0/5 unit 37 vlan-id 37
set interfaces fe-0/0/5 unit 37 family inet address 172.28.2.133/30
set interfaces fe-0/0/5 unit 37 family mpls
set interfaces lo0 unit 0 family inet address 172.28.1.1/32
set routing-options router-id 172.28.1.1
set routing-options autonomous-system 65512
set protocols rsvp interface fe-0/0/5.37
set protocols mpls label-switched-path pe2-to-pe1 to 172.28.1.2
set protocols mpls interface fe-0/0/5.37
set protocols mpls interface lo0.0
set protocols bgp group vpls-peering type internal
set protocols bgp group vpls-peering local-address 172.28.1.1
set protocols bgp group vpls-peering family l2vpn signaling
set protocols bgp group vpls-peering neighbor 172.28.1.2
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-0/0/5.37
set routing-instances vpls-instance description "Routing instance for VPLS routing"
set routing-instances vpls-instance instance-type vpls
set routing-instances vpls-instance interface fe-0/0/3.0
set routing-instances vpls-instance route-distinguisher 172.28.1.1:1
set routing-instances vpls-instance vrf-target target:65512:1
set routing-instances vpls-instance protocols vpls site-range 10
set routing-instances vpls-instance protocols vpls no-tunnel-services site site11 automatic-site-id

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For instructions on how to do that, see Using the CLI Editor in Configuration Mode.

To configure PE2:

  1. Configure the hostname for the device.
    content_copy zoom_out_map
    [edit ]
    user@host# set system host-name PE2
  2. Configure VPLS VLAN encapsulation on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit interfaces]
    user@host# set fe-0/0/3 description "CE2 on PE2"
    user@host# set fe-0/0/3 vlan-tagging
    user@host# set fe-0/0/3 encapsulation vlan-vpls
    user@host# set fe-0/0/3 unit 0 encapsulation vlan-vpls
    user@host# set fe-0/0/3 unit 0 vlan-id 600
    user@host# set fe-0/0/3 unit 0 family vpls
  3. Configure the routing interface on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit interfaces]
    user@host# set fe-0/0/5 vlan-tagging
    user@host# set fe-0/0/5 unit 37 vlan-id 37
    user@host# set fe-0/0/5 unit 37 family inet address 172.28.2.133/30
    user@host# set fe-0/0/5 unit 37 family mpls
    user@host# set lo0 unit 0 family inet address 172.28.1.1/32
    Note

    For this example, it is optional to configure VLAN tagging. Remove the VLAN tagging configuration on the physical interfaces if you do not plan to configure VLAN tagging.

  4. Configure the routing options on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit routing-options]
    user@host# set router-id 172.28.1.1
    user@host# set autonomous-system 65512
  5. Configure RSVP on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set rsvp interface fe-0/0/5.37
  6. Configure MPLS on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set mpls label-switched-path pe2-to-pe1 to 172.28.1.2
    user@host# set mpls interface fe-0/0/5.37
    user@host# set mpls interface lo0.0
  7. Configure BGP on the VPLS PE2 device.
    content_copy zoom_out_map
    [edit protocols]
    user@host# set bgp group vpls-peering type internal
    user@host# set bgp group vpls-peering local-address 172.28.1.1
    user@host# set bgp group vpls-peering family l2vpn signaling
    user@host# set bgp group vpls-peering neighbor 172.28.1.2
  8. (Optional) Configure OSPF on the VPLS PE2 device.
    Note

    For this example, it is optional to configure OFPF. You must configure OSPF only in cases where two PE devices are not connected directly.

    content_copy zoom_out_map
    [edit protocols]
    user@host# set ospf area 0.0.0.0 interface lo0.0 passive
    user@host# set ospf area 0.0.0.0 interface fe-0/0/5.37
  9. Create a VPLS routing instance.
    content_copy zoom_out_map
    [edit ]
    user@host# set routing-instances vpls-instance
  10. Configure a VPLS routing instance.
    content_copy zoom_out_map
    [edit routing-instances vpls-instance]
    user@host# set description "Routing instance for VPLS routing"
    user@host# set instance-type vpls
    user@host# set interface fe-0/0/3.0
    user@host# set route-distinguisher 172.28.1.1:1
    user@host# set vrf-target target:65512:1
    user@host# set protocols vpls site-range 10
    user@host# set protocols vpls no-tunnel-services site site11 automatic-site-id

Results

From configuration mode, confirm your configuration by entering the show command. If the output does not display the intended configuration, repeat the configuration instructions in this example to correct it.

content_copy zoom_out_map
[edit]
user@host# show system
host-name PE2;
content_copy zoom_out_map
[edit]
user@host# show interfaces
fe-0/0/5 {
vlan-tagging;
unit 37 {
vlan-id 37;
family inet {
address 172.28.2.133/30;
}
family mpls;
}
}
fe-0/0/3 {
description "CE2 on PE2";
vlan-tagging;
encapsulation vlan-vpls;
unit 0 {
encapsulation vlan-vpls;
vlan-id 600;
family vpls;
}
}
lo0 {
unit 0 {
family inet {
address 172.28.1.1/32;
}
}
}
content_copy zoom_out_map
[edit]
user@host# show routing-options
router-id 172.28.1.1;
autonomous-system 65512;
content_copy zoom_out_map
[edit]
user@host# show protocols
rsvp {
interface fe-0/0/5.37;
}
mpls {
label-switched-path pe2-to-pe1 {
to 172.28.1.2;
}
interface fe-0/0/5.37;
interface lo0.0;
}
bgp {
group vpls-peering {
type internal;
local-address 172.28.1.1;
family l2vpn {
signaling;
}
neighbor 172.28.1.1;
}
}
ospf {
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface fe-0/0/5.37;
}
}
content_copy zoom_out_map
[edit]
user@host# show routing-instances
vpls-instance {
description "Routing instance from VPLS routing";
instance-type vpls;
interface fe-0/0/3.0;
route-distinguisher 172.28.1.1:1;
vrf-target target:65512:1;
protocols {
vpls {
site-range 10;
no-tunnel-services;
site site11 {
automatic-site-id;
}
}
}
}

If you are done configuring the device, enter commit from configuration mode.

Configuring the CE2 Device

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set interfaces fe-0/0/3 vlan-tagging
set interfaces fe-0/0/3 unit 0 vlan-id 600
set interfaces fe-0/0/3 unit 0 family inet address 10.11.3.2/24

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For instructions on how to do that, see Using the CLI Editor in Configuration Mode.

  1. Enable VLAN tagging on the VPLS interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3]
    user@host# set vlan-tagging
  2. Configure the VLAN ID on the logical interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3 unit 0]
    user@host# set vlan-id 600
  3. Configure the VPLS family on the logical interface.
    content_copy zoom_out_map
    [edit interfaces fe-0/0/3 unit 0]
    user@host# set family inet address 10.11.3.2/24

Results

From configuration mode, confirm your configuration by entering the show interfaces command. If the output does not display the intended configuration, repeat the configuration instructions in this example to correct it.

content_copy zoom_out_map
fe-0/0/3 {
vlan-tagging;
unit 0 {
vlan-id 600;
family inet {
address 10.11.3.2/24;
}
}
}

If you are done configuring the device, enter commit from configuration mode.

Note

If VLAN trunking is not needed between the CE devices, remove the configuration on VLAN tagging on the interfaces connecting the CE and PE devices. Also, use ethernet-VPLS-encapsulation instead of vlan-vpls on the CE facing interfaces of the PE devices.

Verification

Confirm that the configuration is working properly.

Verifying Interfaces

Purpose

Verify that the interfaces are configured correctly.

Action

From operational mode, enter the show interfaces terse command.

Verifying Routing Information

Purpose

Verify that the routing information is configured correctly.

Action

From operational mode, enter the following commands:

  • show route forwarding-table family mpls

  • show route forwarding-table family vpls (destination | extensive | matching | table)

  • show route instance (detail)

Verifying VPLS Information

Purpose

Verify that the VPLS is configured correctly.

Action

From operational mode, enter the following commands:

  • show system statistics vpls

  • show vpls connections

  • show vpls statistics

Verifying Automatic Site Identifier Generation

Purpose

Verify that the automatic site identifier has been generated.

Action

From operational mode, enter the show vpls connections command.

content_copy zoom_out_map
[edit]
user@host# show vpls connections
Layer-2 VPN connections:
Legend for connection status (St)
EI -- encapsulation invalid NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down NP -- interface hardware not present
CM -- control-word mismatch -> -- only outbound connection is up
CN -- circuit not provisioned <- -- only inbound connection is up
OR -- out of range Up -- operational
OL -- no outgoing label Dn -- down
LD -- local site signaled down CF -- call admission control failure
RD -- remote site signaled down SC -- local and remote site ID collision
LN -- local site not designated LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status IL -- no incoming label
MM -- MTU mismatch MI -- Mesh-Group ID not available
BK -- Backup connection ST -- Standby connection
PF -- Profile parse failure PB -- Profile busy
RS -- remote site standby SN -- Static Neighbor
VM -- VLAN ID mismatch
Legend for interface status
Up -- operational
Dn -- down
Instance: customer2
Local site: airwalk (2)
connection-site Type St Time last up # Up trans
4 rmt Up Mar 1 03:26:21 2012 1
Remote PE: 200.100.100.2, Negotiated control-word: No
Incoming label: 262148, Outgoing label: 262146
Local interface: lsi.1048838, Status: Up, Encapsulation: VPLS
Description: Intf - vpls customer2 local site 2 remote site 4
Instance: customer4
Local site: airwalk (6)
connection-site Type St Time last up # Up trans
8 rmt Up Feb 21 03:27:33 2012 1
Remote PE: 200.200.200.2, Negotiated control-word: No
Incoming label: 262160, Outgoing label: 262174
Local interface: lsi.1048836, Status: Up, Encapsulation: VPLS
Description: Intf - vpls customer4 local site 6 remote site 8
footer-navigation