[an error occurred while processing this directive] [an error occurred while processing this directive]

Example: Configuring Aggregated Ethernet High-Speed Uplinks Between a Virtual Chassis Access Switch and a Virtual Chassis Distribution Switch

EX Series switches allow you to combine one to eight Ethernet links into one logical interface for higher bandwidth and redundancy. The ports that are combined in this manner are referred to as a link aggregation group (LAG) or bundle.

This example describes how to configure uplink LAGs to connect a Virtual Chassis access switch to a Virtual Chassis distribution switch:

Requirements

This example uses the following software and hardware components:

  • JUNOS Release 9.0 or later for EX Series switches
  • Two EX4200-48P switches
  • Two EX4200-24F switches
  • Four XFP uplink modules

Before you configure the LAGs, be sure you have:

Overview and Topology

For maximum speed and resiliency, you can combine uplinks between an access switch and a distribution switch into LAGs. Using LAGs can be particularly effective when connecting a multimember Virtual Chassis access switch to a multimember Virtual Chassis distribution switch.

The Virtual Chassis access switch in this example is composed of two member switches. Each member switch has an uplink module with two 10-Gigabit Ethernet ports. These ports are configured as trunk ports, connecting the access switch with the distribution switch.

Configuring the uplinks as LAGs has the following advantages:

  • Link Aggregation Control Protocol (LACP) can optionally be configured for link negotiation.
  • It doubles the speed of each uplink from 10 Gbps to 20 Gbps.
  • If one physical port is lost for any reason (a cable is unplugged or a switch port fails, or one member switch is unavailable), the logical port transparently continues to function over the remaining physical port.

The topology used in this example consists of one Virtual Chassis access switch and one Virtual Chassis distribution switch. The access switch is composed of two EX4200-48P switches (SWA-0 and SWA-1), interconnected to each other with their Virtual Chassis ports (VCPs) as member switches of Host-A. The distribution switch is composed of two EX4200-24F switches (SWD-0 and SWD-1), interconnected with their VCPs as member switches of Host-D.

Each member of the access switch has an uplink module installed. Each uplink module has two ports. The uplinks are configured to act as trunk ports, connecting the access switch with the distribution switch. One uplink port from SWA-0 and one uplink port from SWA-1 are combined as a LAG ae0 to SWD-0. This link is used for one VLAN. The remaining uplink ports from SWA-0 and from SWA-1 are combined as a second LAG connection (ae1) to SWD-1. LAG ae1 is used for another VLAN.

Note: If the remote end of the LAG link is a security device, LACP might not be supported because security devices require a deterministic configuration. In this case, do not configure LACP. All links in the LAG are permanently operational unless the switch detects a link failure within the Ethernet physical layer or data link layers.

Figure 1: Topology for LAGs Connecting a Virtual Chassis Access Switch to a Virtual Chassis Distribution Switch

Image g020038.gif

Table 1 details the topology used in this configuration example.

Table 1: Components of the Topology for Connecting Virtual Chassis Access Switches to a Virtual Chassis Distribution Switch

Switch Hostname and VCID Base Hardware Uplink Module Member ID Trunk Port

SWA-0

Host-A Access switch

VCID 1

EX4200-48P switch

One XFP uplink module

0

xe-0/1/0 to SWD-0

xe-0/1/1 to SWD-1

SWA-1

Host-A Access switch

VCID 1

EX4200-48P switch

One XFP uplink module

1

xe-1/1/0 to SWD-0

xe-1/1/1 to SWD-1

SWD-0

Host-D Distribution switch

VCID 4

EX4200 L-24F switch

One XFP uplink module

0

xe-0/1/0 to SWA-0

xe-0/1/1 to SWA-1

SWD-1

Host-D Distribution switch

VCID 4

EX4200 L-24F switch

One XFP uplink module

1

xe-1/1/0 to SWA-0

xe-1/1/1 to SWA-1

Configuration

To configure two uplink LAGs from the Virtual Chassis access switch to the Virtual Chassis distribution switch:

CLI Quick Configuration

To quickly configure aggregated Ethernet high-speed uplinks between a Virtual Chassis access switch and a Virtual Chassis distribution switch, copy the following commands and paste them into the switch terminal window:


[edit]
set chassis aggregated-devices ethernet device-count 2
set interfaces ae0 aggregated-ether-options minimum-links 2
set interfaces ae0 aggregated-ether-options link-speed 10g
set interfaces ae1 aggregated-ether-options minimum-links 2
set interfaces ae1 aggregated-ether-options link-speed 10g
set interfaces ae0 unit 0 family inet address 192.0.2.0/25
set interfaces ae1 unit 1 family inet address 192.0.2.128/25
set interfaces xe-0/1/0 ether-options 802.ad ae0
set interfaces xe-1/1/0 ether-options 802.ad ae0
set interfaces xe-0/1/1 ether-options 802.ad ae1
set interfaces xe-1/1/1 ether-options 802.ad ae1

Step-by-Step Procedure

To configure aggregated Ethernet high-speed uplinks between a Virtual Chassis access switch and a Virtual Chassis distribution switch:

  1. Specify the number of LAGs to be created on the chassis:

    [edit chassis]
    user@Host-A# set aggregated-devices ethernet device-count 2
  2. Specify the number of links that need to be present for the ae0 LAG interface to be up:

    [edit interfaces]
    user@Host-A# set ae0 aggregated-ether-options minimum-links 2
  3. Specify the number of links that need to be present for the ae1 LAG interface to be up:

    [edit interfaces]
    user@Host-A# set ae1 aggregated-ether-options minimum-links 2
  4. Specify the media speed of the ae0 link:

    [edit interfaces]
    user@Host-A# set ae0 aggregated-ether-options link-speed 10g
  5. Specify the media speed of the ae1 link:

    [edit interfaces]
    user@Host-A# set ae1 aggregated-ether-options link-speed 10g
  6. Specify the interface ID of the uplinks to be included in LAG ae0:

    [edit interfaces]
    user@Host-A# set xe-0/1/0 ether-options 802.ad ae0
    user@Host-A# set xe-1/1/0 ether-options 802.ad ae0
  7. Specify the interface ID of the uplinks to be included in LAG ae1:

    [edit interfaces]
    user@Host-A# set xe-0/1/1 ether-options 802.ad ae1
    user@Host-A# set xe-1/1/1 ether-options 802.ad ae1
  8. Specify that LAG ae0 belongs to the subnet for the employee broadcast domain:

    [edit interfaces]
    user@Host-A# set ae0 unit 0 family inet address 192.0.2.0/25
  9. Specify that LAG ae1 belongs to the subnet for the guest broadcast domain:

    [edit interfaces]
    user@Host-A# set ae1 unit 1 family inet address 192.0.2.128/25

Results

Display the results of the configuration:

[edit]
chassis {
aggregated-devices {
ethernet {
device-count 2;
}
}
}
interfaces {
ae0 {
aggregated-ether-options {
link-speed 10g;
minimum-links 2;
}
unit 0 {
family inet {
address 192.0.2.0/25;
}
}
}
ae1 {
aggregated-ether-options {
link-speed 10g;
minimum-links 2;
}
unit 0 {
family inet {
address 192.0.2.128/25;
}
}
xe–0/1/0 {
ether-options {
802.ad ae0;
}
}
xe–1/1/0 {
ether-options {
802.ad ae0;
}
}
xe–0/1/1 {
ether-options {
802.ad ae1;
}
}
xe–1/1/1 {
ether-options {
802.ad ae1;
}
}
}

Verification

To verify that switching is operational and two LAGs have been created, perform these tasks:

Verifying That LAG ae0 Has Been Created

Purpose

Verify that LAG ae0 has been created on the switch.

Action

show interfaces ae0 terse

Interface             Admin      Link Proto      Local             Remote               
ae0                    up       up
ae0.0                  up       up     inet     10.10.10.2/24

Meaning

The output confirms that the ae0 link is up and shows the family and IP address assigned to this link.

Verifying That LAG ae1 Has Been Created

Purpose

Verify that LAG ae1 has been created on the switch

Action

show interfaces ae1 terse

Interface               Admin Link Proto    Local                 Remote
ae1                     up    down
ae1.0                   up    down inet

Meaning

The output shows that the ae1 link is down.

Troubleshooting

Troubleshooting a LAG That Is Down

Problem

The show interfaces terse command shows that the LAG is down:

Solution

Check the following:

  • Verify that there is no configuration mismatch.
  • Verify that all member ports are up.
  • Verify that a LAG is part of family ethernet switching (Layer 2 LAG) or family inet (Layer 3 LAG).
  • Verify that the LAG member is connected to the correct LAG at the other end.
  • Verify that the LAG members belong to the same switch (or the same Virtual Chassis).

Published: 2009-10-01

[an error occurred while processing this directive]