Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Configuring Tunnel Interfaces on ACX Series Routers

date_range 18-Dec-24

Guidelines for Configuring Logical Tunnel Interfaces on ACX Series Routers

Observe the following guidelines while configuring logical tunnel (lt-) interfaces on ACX Series routers:

  • You can use a logical tunnel interface to connect only bridge domains and pseudowires.

  • Logical tunnel interfaces cannot interconnect the following links:

    • Pesudowire and a routing instance (Pseudowire terminating on a VRF)

    • Two routing instances

    • VPLS instance and a routing instance

    • Two VPLS instances

    • Two Bridge domains

    • Bridge domain and a VPLS instance

  • Only one logical tunnel (physical interface) per bandwidth type (1 Gbps or 10 Gbps) can be configured on ACX routers. However, you can specify up to two logical tunnel interfaces (one with 1 Gb bandwidth and another with 10 Gb bandwidth) on ACX routes.

  • Guaranteed bandwidth for logical tunnels is 1 Gbps and certain platforms support up to an additional 10 Gbps bandwidth. All the services configured using logical tunnel interfaces share this bandwidth.

    The bandwidth configured on the logical tunnel interface is shared between upstream and downstream traffic on that interface. The effective bandwidth available for the service is half the configured bandwidth.

  • Multiple logical tunnel interfaces to enable configuration of separate services on each logical interface to obtain increased bandwidth for each individual interface separately or the bundling of individual logical tunnel interfaces is not supported.

  • You can configure Ethernet VLAN, Ethernet CCC, VLAN bridge on Ethernet interfaces, and VLAN on circuit cross-connects (CCC) as encapsulation types on logical tunnel interfaces. Other encapsulation types such as Ethernet, VLAN, Ethernet VPLS, or VLAN VPLS are not supported.

  • When the encapsulation configured on the logical interface units is one of the supported types such as Ethernet VLAN or VLAN bridge, you can enable only bridge domains or CCC protocols on logical tunnel interfaces. Other address families or protocols such as IPv4, IPv6, MPLS, or OSPF are not supported.

  • Classifier, rewrite and ingress policer configuration are supported on logical tunnel interfaces. Fixed, BA-based, and multifield classifiers are supported on the lt- interfaces at the physical interface-level.

    802.1p, 802.1ad, TOS and DSCP based BA classifiers are supported. Remarking rules can be configured at the port level on the LT interface. 802.1p, 802.1ad, TOS and DSCP fields in the packet can be rewritten in the LT interface. Ingress policers are supported.

    Simple, Single-rate tricolor marking (srTCM), two-rate tricolor marking (trTCM) policers are supported. Egress policers are not supported.

  • Default classifiers do not work properly when lt- interfaces are configured on non-Ethernet PICs.

  • Port-level queuing is supported; up to eight queues per lt- interface are supported. These eight queues are shared between the upstream and downstream traffic traversing through the lt- interface. If the configured bandwidth on the lt- interface is not adequate for the upstream and downstream traffic of the services configured on the interface, a failure occurs with traffic propagation because multiple lt- interfaces are not supported.

  • Eight forwarding classes (0-7) are mapped to the eight queues based on the global system configuration. The remainder of the scheduler configuration, buffer-size, transmit-rate, shaping-rate, priority and WRED or drop profiles maps can be configured on the lt- interface queues.

  • The following firewall filter types are supported on lt- interfaces:

    • Logical interface-level filters

    • Bridge family filters

    • CCC family filters

    All firewall configurations are supported. The scaling limitation with such filters is the same as the existing firewall filter restrictions.

  • OAM is not supported on lt- interfaces.

  • Similar to other physical interfaces, the number of logical interfaces that can be supported on logical tunnel physical interfaces is 30.

  • When a bridge domain is configured with a VLAN ID (bridge domain has normalized VLANs), the difference is behavior between MX and ACX Series routers is that the MX router does not match the user-vlan-id in output filter, whereas the ACX router matches the user-vlan-id specified in the output filter.

  • If the logical tunnel interface is created using non Ethernet PICs, then default classifier is not bound to the interface.

To create logical tunnel interfaces and the bandwidth in gigabits per second to reserve for tunnel services, include the tunnel-services bandwidth (1g | 10g) statement at the [edit chassis fpc slot-number pfe pfe-number core core-number channel channel-number] hierarchy level:

content_copy zoom_out_map
[edit interfaces]
    lt-fpc/pic/port {
        unit logical-unit-number {
            encapsulation encapsulation;
            peer-unit unit-number;   # peering logical system unit number
            dlci dlci-number;
            family (inet | inet6 | iso | mpls);
        }
    }

The ACX5048 and ACX5096 routers support ethernet-vpls and vlan-vpls encapsulations. These encapsulations are supported only on logical tunnel interface and are required for configuring hierarchial VPLS.

You can use any unused physical port on the ACX5048 and ACX5096 routers to create a logical tunnel interface as shown below:

content_copy zoom_out_map
user@host# edit chassis
fpc 0 {
    pic 0 {
        tunnel-services {
            port port-number;
        }
    }
}

The following sample configuration allows you to encapsulate vlan-ccc to vlan-vpls using LT interface in ACX5048 and ACX5096 routers:

content_copy zoom_out_map
user@host# edit interfaces
lt-0/0/1 {
    unit 0 {
        encapsulation vlan-ccc;
        vlan-id 1;
        peer-unit 1;
    }
    unit 1 {
        encapsulation vlan-vpls;
        vlan-id 1;
        peer-unit 0;
    }
}

Configuring Logical Tunnel Interfaces on ACX7K Series Routers

Starting with Junos Evolved OS Release 24.2R1, ACX7K Series routers support logical tunnel physical interface (IFD) configuration for Layer 2 services (BD).

  • Support for logical tunnel physical interface which includes:

    • Logical tunnel interface physical interface level configuration

    • Support stitchings of two disjoint services through the logical tunnel interface

    • Support SNMP on logical tunnel interface

  • Support logical tunnel interface (LT ifl) and Bridge Domain which includes:

    • Creation of logical tunnel interface, each unit of logical tunnel interface with a peer-unit configuration as a mandatory parameter. If unit X is configured unit Y as peer-unit, then unit Y must have unit X as a peer-unit.

    • Support encapsulation vlan-bridge on logical tunnel interface

    • Support encapsulation ethernet-bridge on logical tunnel interface

    • Support receiver and transmitter statistics on logical tunnel interface. The statistics of the receiver and transmitter of logical tunnel interface must work same as other logical interface statistics.

    • Support Layer 2 flooding on logical tunnel interface

    • Support MAC learning. This support includes addition of static MAC on logical tunnel interface, dynamic MAC learning on logical tunnel interface, and all MAC events and notifications handling.

Configuring Logical Tunnel Physical Interface on ACX7K Series Routers

To create logical tunnel interfaces and the bandwidth in Gbps to reserve for tunnel services, include the tunnel-services bandwidth value statement at the [edit chassis fpc slot-number | feb slot slot-number pfe pfe-number core core-number channel channel-number] hierarchy level.

The following sample configuration allows you to configure the logical tunnel on FPC based systems:

content_copy zoom_out_map
user@host# edit chassis
fpc 0 {
    pfe 0 {
        core 0 {
            channel 0 {
                tunnel-services {
                    bandwidth 10g;
                    }
                }
            }
        }
    }

For example, you can use the following sample configuration to create lt-0/0/0:2 with a bandwidth of 10Gbps on an FPC-based system with a bandwidth of 10Gbps:

content_copy zoom_out_map
set chassis fpc 0 pfe 0 core 0 channel 2 tunnel-services bandwidth 10g

The following sample configuration allows you to configure the logical tunnel on FEB based systems:

content_copy zoom_out_map
user@host# edit chassis
feb slot 0 {
    pfe 0 {
        core 0 {
            channel 0 {
                tunnel-services {
                    bandwidth 10g;
                    }
                }
            }
        }
    }

For example, to create lt-0/0/0:3 on an FEB-based system with a bandwidth of 10 Gbps, you can use this configuration:

content_copy zoom_out_map
set chassis feb 0 pfe 0 core 0 channel 3 tunnel-services bandwidth 10g 

Create logical tunnel interface and encapsulate the logical interface for service provider style bridging configuration.

content_copy zoom_out_map
set chassis fpc 0 pfe 0 core 0 channel 3 tunnel-services bandwidth 10G
set interfaces lt-0/0/0:3 flexible-vlan-tagging
set interfaces lt-0/0/0:3 unit 0 peer-unit 1 encapsulation vlan-bridge vlan-id 100 
set interfaces lt-0/0/0:3 unit 1 peer-unit 0 encapsulation vlan-bridge vlan-id 100
footer-navigation