Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Announcement: Try the Ask AI chatbot for answers to your technical questions about Juniper products and solutions.

close
header-navigation
keyboard_arrow_up
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring Multitopology Routing for Class-Based Forwarding of Voice, Video, and Data Traffic

date_range 24-Nov-23

This example shows how to use multitopology routing (MTR) to choose a topology path based on an application, either voice or video.

Requirements

This example requires that Junos OS Release 9.0 or later is running on the provider core devices.

Overview

In this example, the network is running OSPF and internal BGP (IBGP) in the core, but not MPLS. Even without traffic engineering, voice traffic uses one set of links, and video traffic uses a different set of links. This traffic might or might not be destined for the same IP address. In some cases, both applications traverse the same link. The solution uses MTR-based OSPF and BGP, along with firewall filters to direct different traffic types over designated links. The routers use a fairly similar set of configurations, which reduces complexity and improves network management.

The OSPF topologies are defined to support each service offering over the OSPF area. The links of a topology must be contiguous, consistent with a typical OSPF area. IBGP routes in each routing topology automatically use the associated OSPF topology routing table for protocol next-hop route resolution. No special route resolution configurations are required. In this solution, multiple topologies can be configured over the same link. However, traffic in each application service class cannot traverse links unless they are configured for the topology designated for that service. Figure 1 shows a diagram of this case. Contiguous paths for routing the voice topology are shown with dotted lines, and paths for routing the video topology are shown with dashed lines.

For a complete set of configurations for all of the devices in the topology, see CLI Quick Configuration. The remainder of the example focuses on Device CE1 and Device PE1.

Figure 1 shows the sample topology.

Figure 1: Multitopology OSPF and IBGP for Designating Links Belonging to Voice and Video ServicesMultitopology OSPF and IBGP for Designating Links Belonging to Voice and Video Services

Configuration

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level.

Device CE1

content_copy zoom_out_map
set interfaces fe-0/1/0 fastether-options loopback
set interfaces fe-0/1/0 unit 0 family inet address 11.19.130.1/24
set interfaces fe-0/1/0 unit 0 family inet address 11.19.131.1/24
set interfaces fe-0/1/0 unit 0 family inet address 11.19.132.1/24
set interfaces fe-1/2/0 unit 1 description to-PE1
set interfaces fe-1/2/0 unit 1 family inet address 10.0.0.1/30
set interfaces lo0 unit 97 family inet address 10.255.165.97/32 primary
set protocols bgp group ebgp type external
set protocols bgp group ebgp local-address 10.0.0.1
set protocols bgp group ebgp export set_community
set protocols bgp group ebgp export inject_directs
set protocols bgp group ebgp peer-as 100
set protocols bgp group ebgp neighbor 10.0.0.2
set policy-options policy-statement inject_directs term a from protocol direct
set policy-options policy-statement inject_directs term a from interface fe-0/1/0.0
set policy-options policy-statement inject_directs term a then next policy
set policy-options policy-statement inject_directs term a then accept
set policy-options policy-statement inject_directs term b then reject
set policy-options policy-statement set_community term a from route-filter 11.19.130.0/24 exact
set policy-options policy-statement set_community term a from route-filter 11.19.131.0/24 exact
set policy-options policy-statement set_community term a then community add voice
set policy-options policy-statement set_community term a then accept
set policy-options policy-statement set_community term b from route-filter 11.19.132.0/24 exact
set policy-options policy-statement set_community term b from route-filter 11.19.133.0/24 exact
set policy-options policy-statement set_community term b then community add video
set policy-options policy-statement set_community term b then accept
set policy-options policy-statement set_community term default then accept
set policy-options community video members target:50:50
set policy-options community voice members target:40:40
set routing-options autonomous-system 101

Device CE2

content_copy zoom_out_map
set interfaces fe-0/1/1 fastether-options loopback
set interfaces fe-0/1/1 unit 0 family inet address 11.19.140.1/24
set interfaces fe-0/1/1 unit 0 family inet address 11.19.141.1/24
set interfaces fe-0/1/1 unit 0 family inet address 11.19.142.1/24
set interfaces fe-1/2/0 unit 46 description to-PE2
set interfaces fe-1/2/0 unit 46 family inet address 10.0.0.46/30
set interfaces lo0 unit 20 family inet address 10.255.165.20/32 primary
set protocols bgp group ebgp type external
set protocols bgp group ebgp local-address 10.0.0.46
set protocols bgp group ebgp export set_community
set protocols bgp group ebgp export inject_directs
set protocols bgp group ebgp peer-as 100
set protocols bgp group ebgp neighbor 10.0.0.45
set policy-options policy-statement inject_directs term a from protocol direct
set policy-options policy-statement inject_directs term a from interface fe-0/1/1.0
set policy-options policy-statement inject_directs term a then next policy
set policy-options policy-statement inject_directs term a then accept
set policy-options policy-statement inject_directs term b then reject
set policy-options policy-statement set_community term a from route-filter 11.19.140.0/24 exact
set policy-options policy-statement set_community term a from route-filter 11.19.141.0/24 exact
set policy-options policy-statement set_community term a then community add voice
set policy-options policy-statement set_community term a then accept
set policy-options policy-statement set_community term b from route-filter 11.19.142.0/24 exact
set policy-options policy-statement set_community term b from route-filter 11.19.143.0/24 exact
set policy-options policy-statement set_community term b then community add video
set policy-options policy-statement set_community term b then accept
set policy-options policy-statement set_community term default then accept
set policy-options community video members target:50:50
set policy-options community voice members target:40:40
set routing-options autonomous-system 102

Device PE1

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 2 description to-CE1
set interfaces fe-1/2/0 unit 2 family inet filter input ef_path
set interfaces fe-1/2/0 unit 2 family inet address 10.0.0.2/30
set interfaces fe-1/2/1 unit 6 description to-P1
set interfaces fe-1/2/1 unit 6 family inet filter input ef_path
set interfaces fe-1/2/1 unit 6 family inet address 10.0.0.6/30
set interfaces fe-1/2/2 unit 9 description to-P3
set interfaces fe-1/2/2 unit 9 family inet filter input ef_path
set interfaces fe-1/2/2 unit 9 family inet address 10.0.0.9/30
set interfaces lo0 unit 93 family inet address 10.255.165.93/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.93
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp export nhs
set protocols bgp group ibgp neighbor 10.255.165.111
set protocols bgp group ibgp neighbor 10.255.165.203
set protocols bgp group ibgp neighbor 10.255.165.113
set protocols bgp group ibgp neighbor 10.255.165.95
set protocols bgp group ibgp neighbor 10.255.165.99
set protocols bgp group ebgp type external
set protocols bgp group ebgp local-address 10.0.0.2
set protocols bgp group ebgp family inet unicast topology voice community target:40:40
set protocols bgp group ebgp family inet unicast topology video community target:50:50
set protocols bgp group ebgp peer-as 101
set protocols bgp group ebgp neighbor 10.0.0.1
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/1.6 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.6 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.6 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/2.9 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/2.9 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/2.9 topology video
set protocols ospf area 0.0.0.0 interface lo0.93 passive
set policy-options policy-statement nhs then next-hop self
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 2 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 6 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 9 classifiers inet-precedence default

Device PE2

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 38 description to-P2
set interfaces fe-1/2/0 unit 38 family inet filter input ef_path
set interfaces fe-1/2/0 unit 38 family inet address 10.0.0.38/30
set interfaces fe-1/2/1 unit 42 description to-P4
set interfaces fe-1/2/1 unit 42 family inet filter input ef_path
set interfaces fe-1/2/1 unit 42 family inet address 10.0.0.42/30
set interfaces fe-1/2/2 unit 45 description to-CE2
set interfaces fe-1/2/2 unit 45 family inet filter input ef_path
set interfaces fe-1/2/2 unit 45 family inet address 10.0.0.45/30
set interfaces lo0 unit 203 family inet address 10.255.165.203/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.203
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp export nhs
set protocols bgp group ibgp neighbor 10.255.165.111
set protocols bgp group ibgp neighbor 10.255.165.93
set protocols bgp group ibgp neighbor 10.255.165.113
set protocols bgp group ibgp neighbor 10.255.165.95
set protocols bgp group ibgp neighbor 10.255.165.99
set protocols bgp group ebgp type external
set protocols bgp group ebgp local-address 10.0.0.45
set protocols bgp group ebgp family inet unicast topology voice community target:40:40
set protocols bgp group ebgp family inet unicast topology video community target:50:50
set protocols bgp group ebgp peer-as 102
set protocols bgp group ebgp neighbor 10.0.0.46
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/0.38 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/0.38 topology video metric 200
set protocols ospf area 0.0.0.0 interface fe-1/2/0.38 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/1.42 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.42 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.42 topology video
set protocols ospf area 0.0.0.0 interface lo0.203 passive
set policy-options policy-statement nhs then next-hop self
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 38 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 42 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 45 classifiers inet-precedence default

Device P1

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 5 description to-PE1
set interfaces fe-1/2/0 unit 5 family inet filter input ef_path
set interfaces fe-1/2/0 unit 5 family inet address 10.0.0.5/30
set interfaces fe-1/2/1 unit 13 description to-P3
set interfaces fe-1/2/1 unit 13 family inet filter input ef_path
set interfaces fe-1/2/1 unit 13 family inet address 10.0.0.13/30
set interfaces fe-1/2/2 unit 17 description to-P4
set interfaces fe-1/2/2 unit 17 family inet filter input ef_path
set interfaces fe-1/2/2 unit 17 family inet address 10.0.0.17/30
set interfaces fe-1/2/3 unit 33 description to-P2
set interfaces fe-1/2/3 unit 33 family inet filter input ef_path
set interfaces fe-1/2/3 unit 33 family inet address 10.0.0.33/30
set interfaces lo0 unit 99 family inet address 10.255.165.99/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.99
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp neighbor 10.255.165.93
set protocols bgp group ibgp neighbor 10.255.165.111
set protocols bgp group ibgp neighbor 10.255.165.203
set protocols bgp group ibgp neighbor 10.255.165.95
set protocols bgp group ibgp neighbor 10.255.165.113
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/3.33 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/3.33 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/3.33 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/2.17 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/2.17 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/2.17 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.13 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.13 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.13 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.5 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/0.5 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/0.5 topology video disable
set protocols ospf area 0.0.0.0 interface lo0.99 passive
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 5 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 13 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 17 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/3 unit 33 classifiers inet-precedence default

Device P2

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 22 description to-P3
set interfaces fe-1/2/0 unit 22 family inet filter input ef_path
set interfaces fe-1/2/0 unit 22 family inet address 10.0.0.22/30
set interfaces fe-1/2/1 unit 25 description to-P4
set interfaces fe-1/2/1 unit 25 family inet filter input ef_path
set interfaces fe-1/2/1 unit 25 family inet address 10.0.0.25/30
set interfaces fe-1/2/2 unit 34 description to-P1
set interfaces fe-1/2/2 unit 34 family inet filter input ef_path
set interfaces fe-1/2/2 unit 34 family inet address 10.0.0.34/30
set interfaces fe-1/2/3 unit 37 description to-PE2
set interfaces fe-1/2/3 unit 37 family inet filter input ef_path
set interfaces fe-1/2/3 unit 37 family inet address 10.0.0.37/30
set interfaces lo0 unit 113 family inet address 10.255.165.113/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.113
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp neighbor 10.255.165.93
set protocols bgp group ibgp neighbor 10.255.165.111
set protocols bgp group ibgp neighbor 10.255.165.203
set protocols bgp group ibgp neighbor 10.255.165.95
set protocols bgp group ibgp neighbor 10.255.165.99
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/2.34 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/2.34 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/2.34 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.22 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/0.22 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.22 topology video metric 20
set protocols ospf area 0.0.0.0 interface fe-1/2/1.25 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.25 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.25 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/3.37 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/3.37 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/3.37 topology video metric 200
set protocols ospf area 0.0.0.0 interface lo0.113 passive
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 22 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 25 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 34 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/3 unit 37 classifiers inet-precedence default

Device P3

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 10 description to-PE1
set interfaces fe-1/2/0 unit 10 family inet filter input ef_path
set interfaces fe-1/2/0 unit 10 family inet address 10.0.0.10/30
set interfaces fe-1/2/1 unit 14 description to-P1
set interfaces fe-1/2/1 unit 14 family inet filter input ef_path
set interfaces fe-1/2/1 unit 14 family inet address 10.0.0.14/30
set interfaces fe-1/2/2 unit 21 description to-P2
set interfaces fe-1/2/2 unit 21 family inet filter input ef_path
set interfaces fe-1/2/2 unit 21 family inet address 10.0.0.21/30
set interfaces fe-1/2/3 unit 29 description to-P4
set interfaces fe-1/2/3 unit 29 family inet filter input ef_path
set interfaces fe-1/2/3 unit 29 family inet address 10.0.0.29/30
set interfaces lo0 unit 111 family inet address 10.255.165.111/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.111
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp neighbor 10.255.165.93
set protocols bgp group ibgp neighbor 10.255.165.113
set protocols bgp group ibgp neighbor 10.255.165.203
set protocols bgp group ibgp neighbor 10.255.165.95
set protocols bgp group ibgp neighbor 10.255.165.99
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/3.29 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/3.29 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/3.29 topology video
set protocols ospf area 0.0.0.0 interface fe-1/2/2.21 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/2.21 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/2.21 topology video metric 20
set protocols ospf area 0.0.0.0 interface fe-1/2/1.14 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.14 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.14 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.10 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/0.10 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.10 topology video
set protocols ospf area 0.0.0.0 interface lo0.111 passive
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 10 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 14 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 21 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/3 unit 29 classifiers inet-precedence default

Device P4

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 18 description to-P1
set interfaces fe-1/2/0 unit 18 family inet filter input ef_path
set interfaces fe-1/2/0 unit 18 family inet address 10.0.0.18/30
set interfaces fe-1/2/1 unit 26 description to-P2
set interfaces fe-1/2/1 unit 26 family inet filter input ef_path
set interfaces fe-1/2/1 unit 26 family inet address 10.0.0.26/30
set interfaces fe-1/2/2 unit 30 description to-P3
set interfaces fe-1/2/2 unit 30 family inet filter input ef_path
set interfaces fe-1/2/2 unit 30 family inet address 10.0.0.30/30
set interfaces fe-1/2/3 unit 41 description to-PE2
set interfaces fe-1/2/3 unit 41 family inet filter input ef_path
set interfaces fe-1/2/3 unit 41 family inet address 10.0.0.41/30
set interfaces lo0 unit 95 family inet address 10.255.165.95/32 primary
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 10.255.165.95
set protocols bgp group ibgp family inet unicast topology voice community target:40:40
set protocols bgp group ibgp family inet unicast topology video community target:50:50
set protocols bgp group ibgp neighbor 10.255.165.93
set protocols bgp group ibgp neighbor 10.255.165.113
set protocols bgp group ibgp neighbor 10.255.165.203
set protocols bgp group ibgp neighbor 10.255.165.111
set protocols bgp group ibgp neighbor 10.255.165.99
set protocols ospf topology voice topology-id 126
set protocols ospf topology video topology-id 52
set protocols ospf area 0.0.0.0 interface fe-1/2/2.30 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/2.30 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/2.30 topology video
set protocols ospf area 0.0.0.0 interface fe-1/2/0.18 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/0.18 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.18 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/0.18 topology video metric 20
set protocols ospf area 0.0.0.0 interface fe-1/2/1.26 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/1.26 topology voice disable
set protocols ospf area 0.0.0.0 interface fe-1/2/1.26 topology video disable
set protocols ospf area 0.0.0.0 interface fe-1/2/3.41 metric 10
set protocols ospf area 0.0.0.0 interface fe-1/2/3.41 topology voice
set protocols ospf area 0.0.0.0 interface fe-1/2/3.41 topology video
set protocols ospf area 0.0.0.0 interface lo0.95 passive
set routing-options autonomous-system 100
set routing-options topologies family inet topology voice
set routing-options topologies family inet topology video
set firewall family inet filter ef_path term ef from forwarding-class expedited-forwarding
set firewall family inet filter ef_path term ef then topology voice
set firewall family inet filter ef_path term video from source-address 11.19.132.0/24
set firewall family inet filter ef_path term video from source-address 11.19.133.0/24
set firewall family inet filter ef_path term video from source-address 11.19.142.0/24
set firewall family inet filter ef_path term video from source-address 11.19.144.0/24
set firewall family inet filter ef_path term video then topology video
set firewall family inet filter ef_path term default then accept
set class-of-service interfaces fe-1/2/0 unit 18 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/1 unit 26 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/2 unit 30 classifiers inet-precedence default
set class-of-service interfaces fe-1/2/3 unit 41 classifiers inet-precedence default

Configuring Device CE1

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the Junos OS CLI User Guide.

To configure Device CE1:

  1. Configure the interfaces.

    For demonstration purposes, the example places an Ethernet interface into loopback mode and configures several addresses on this loopback interface. The addresses are then announced to the network.

    content_copy zoom_out_map
    [edit interfaces]
    user@CE1# set fe-0/1/0 fastether-options loopback
    user@CE1# set fe-0/1/0 unit 0 family inet address 11.19.130.1/24
    user@CE1# set fe-0/1/0 unit 0 family inet address 11.19.131.1/24
    user@CE1# set fe-0/1/0 unit 0 family inet address 11.19.132.1/24
    user@CE1# set fe-1/2/0 unit 1 description to-PE1
    user@CE1# set fe-1/2/0 unit 1 family inet address 10.0.0.1/30
    user@CE1# set lo0 unit 97 family inet address 10.255.165.97/32 primary
    
  2. Configure the external BGP (EBGP) connection to Device PE1.

    content_copy zoom_out_map
    [edit protocols bgp group ebgp]
    user@CE1# set type external
    user@CE1# set local-address 10.0.0.1
    user@CE1# set peer-as 100
    user@CE1# set neighbor 10.0.0.2
    
  3. Configure the routing policy that announces the addresses that are configured on interface fe-0/1/0.

    content_copy zoom_out_map
    [edit policy-options policy-statement inject_directs]
    user@CE1# set term a from protocol direct
    user@CE1# set term a from interface fe-0/1/0.0
    user@CE1# set term a then next policy
    user@CE1# set term a then accept
    user@CE1# set term b then reject
    
  4. Configure the routing policy that tags voice routes with the video community attribute, and video routes with the voice community attribute.

    content_copy zoom_out_map
    [edit policy-options policy-statement set_community]
    user@CE1# set term a from route-filter 11.19.130.0/24 exact
    user@CE1# set term a from route-filter 11.19.131.0/24 exact
    user@CE1# set term a then community add voice
    user@CE1# set term a then accept
    user@CE1# set term b from route-filter 11.19.132.0/24 exact
    user@CE1# set term b from route-filter 11.19.133.0/24 exact
    user@CE1# set term b then community add video
    user@CE1# set term b then accept
    user@CE1# set term default then accept
    [edit policy-options community]
    user@CE1# set video members target:50:50
    user@CE1# set voice members target:40:40
    
  5. Apply the set_community export policy so that direct routes are exported from the routing table into BGP.

    Apply the inject_directs export policy to announce the addresses that are configured on interface fe-0/1/0.

    content_copy zoom_out_map
    [edit protocols bgp group ebgp]
    user@CE1# set export set_community
    user@CE1# set export inject_directs
    
  6. Configure the autonomous system (AS) number.

    content_copy zoom_out_map
    [edit routing-options]
    user@CE1# set autonomous-system 101
    

Results

From configuration mode, confirm your configuration by entering the show interfaces, show protocols, show policy-options, and show routing-options commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

content_copy zoom_out_map
user@CE1# show interfaces
fe-0/1/0 {
    fastether-options {
        loopback;
    }
    unit 0 {
        family inet {
            address 11.19.130.1/24;
            address 11.19.131.1/24;
            address 11.19.132.1/24;
        }
    }
}
fe-1/2/0 {
    unit 1 {
        description to-PE1;
        family inet {
            address 10.0.0.1/30;
        }
    }
}
lo0 {
    unit 97 {
        family inet {
            address 10.255.165.97/32 {
                primary;
            }
        }
    }
}
content_copy zoom_out_map
user@CE1# show protocols
bgp {
    group ebgp {
        type external;
        local-address 10.0.0.1;
        export [ set_community inject_directs ];
        peer-as 100;
        neighbor 10.0.0.2;
    }
}
content_copy zoom_out_map
user@CE1# show policy-options
policy-statement inject_directs {
    term a {
        from {
            protocol direct;
            interface fe-0/1/0.0;
        }
        then {
            next policy;
            accept;
        }
    }
    term b {
        then reject;
    }
}
policy-statement set_community {
    term a {
        from {
            route-filter 11.19.130.0/24 exact;
            route-filter 11.19.131.0/24 exact;
        }
        then {
            community add voice;
            accept;
        }
    }
    term b {
        from {
            route-filter 11.19.132.0/24 exact;
            route-filter 11.19.133.0/24 exact;
        }
        then {
            community add video;
            accept;
        }
    }
    term default {
        then accept;
    }
}
community video members target:50:50;
community voice members target:40:40;
content_copy zoom_out_map
user@CE1# show routing-options
autonomous-system 101;

If you are done configuring the device, enter commit from configuration mode.

Configuring Device PE1

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the Junos OS CLI User Guide.

To configure Device PE1:

  1. Configure the interfaces.

    The forwarding plane uses a firewall filter to indicate which topology forwarding table traffic should use. In this case, you must configure a firewall filter on all interfaces related to routing topologies. In general, all multitopology OSPF interfaces in the core where topologies are configured have input firewall filters. In addition, the ingress interfaces, where traffic from a CE device enters a PE device toward the core, have firewall filters configured. This configuration on Device PE1 shows a firewall filter applied to the ingress interface (connected to the CE device) and to the two core-facing interfaces (connected to Device P1 and Device P3).

    content_copy zoom_out_map
    [edit interfaces]
    user@PE1# set fe-1/2/0 unit 2 description to-CE1
    user@PE1# set fe-1/2/0 unit 2 family inet filter input ef_path
    user@PE1# set fe-1/2/0 unit 2 family inet address 10.0.0.2/30
    user@PE1# set fe-1/2/1 unit 6 description to-P1
    user@PE1# set fe-1/2/1 unit 6 family inet filter input ef_path
    user@PE1# set fe-1/2/1 unit 6 family inet address 10.0.0.6/30
    user@PE1# set fe-1/2/2 unit 9 description to-P3
    user@PE1# set fe-1/2/2 unit 9 family inet filter input ef_path
    user@PE1# set fe-1/2/2 unit 9 family inet address 10.0.0.9/30
    user@PE1# set lo0 unit 93 family inet address 10.255.165.93/32 primary
    
  2. Configure the autonomous system (AS) number.

    content_copy zoom_out_map
    [edit routing-options]
    user@PE1# set autonomous-system 100
    
  3. Configure BGP.

    content_copy zoom_out_map
    [edit protocols bgp group ibgp]
    user@PE1# set type internal
    user@PE1# set local-address 10.255.165.93
    user@PE1# set neighbor 10.255.165.111
    user@PE1# set neighbor 10.255.165.203
    user@PE1# set neighbor 10.255.165.113
    user@PE1# set neighbor 10.255.165.95
    user@PE1# set neighbor 10.255.165.99
    [edit protocols bgp group ebgp]
    user@PE1# set type external
    user@PE1# set local-address 10.0.0.2
    user@PE1# set peer-as 101
    user@PE1# set neighbor 10.0.0.1
    
  4. Configure a next-hop self routing policy to ensure that the IBGP devices use the loopback address on Device PE1 as the next-hop address on all IBGP route advertisements.

    This way, Device PE1 serves as the gateway router for EBGP routes.

    content_copy zoom_out_map
    [edit policy-options policy-statement nhs]
    user@PE1# set then next-hop self
    
  5. Apply the next-hop self policy to the IBGP sessions.

    content_copy zoom_out_map
    [edit protocols bgp group ibgp]
    user@PE1# set export nhs
    
  6. Configure the voice and video topologies, which enable you to use these topologies with OSPF and BGP.

    The names voice and video are local to the router. The names are not propagated beyond this router. However, for management purposes, a consistent naming scheme across routers in a multitopology environment is convenient.

    content_copy zoom_out_map
    [edit routing-options topologies family inet]
    user@PE1# set topology voice
    user@PE1# set topology video
    
  7. Apply the community tags to identify the voice and video topologies by configuring a routing topology name and BGP community value.

    In Junos OS, multitopology support for BGP is based on the community value in a BGP route. This configuration determines the association between a topology and one or more community values and populates the topology routing tables. Arriving BGP updates that have a matching community value are replicated in the associated topology routing table. You decide which BGP community values are associated with a given topology.

    This configuration causes BGP updates that are received with community value target:40:40 to be added into topology routing table :voice.inet.0 (in addition to the default routing table inet.0). Updates that are received with community value target:50:50 are added into topology routing table :video.inet.0 (in addition to the default routing table inet.0).

    content_copy zoom_out_map
    [edit protocols bgp group ibgp family inet unicast]
    user@PE1# set topology voice community target:40:40
    user@PE1# set topology video community target:50:50
    [edit protocols bgp group ebgp family inet unicast]
    user@PE1# set topology voice community target:40:40
    user@PE1# set topology video community target:50:50
    
  8. Enable and disable multitopology OSPF on particular interfaces.

    Enable multitopology OSPF designations only on desired interfaces, as shown in Figure 1. On interface fe-1/2/1.6 facing Device P1, enable the voice topology, and disable the video topology. On interface fe-1/2/2.9 facing Device P3, enable the video topology, and disable the voice topology.

    When a topology ID is configured under OSPF, the topology is automatically enabled on all interfaces under OSPF. To disable a topology or to add a metric, you must add an explicit configuration.

    For readability purposes, each topology is configured under each desired OSPF interface even though this default behavior occurs when the topology ID is configured. Configure higher metric values on a link to make the link less preferred than another available link.

    content_copy zoom_out_map
    [edit protocols ospf ]
    user@PE1# set topology voice topology-id 126
    user@PE1# set topology video topology-id 52
    [edit protocols ospf area 0.0.0.0]
    user@PE1# set interface fe-1/2/1.6 metric 10
    user@PE1# set interface fe-1/2/1.6 topology video disable
    user@PE1# set interface fe-1/2/1.6 topology voice
    user@PE1# set interface fe-1/2/2.9 metric 10
    user@PE1# set interface fe-1/2/2.9 topology voice disable
    user@PE1# set interface fe-1/2/2.9 topology video
    user@PE1# set interface lo0.93 passive
    
  9. Configure the firewall filter.

    After routing topologies are configured, traffic must go through a firewall filter to make use of routing topology forwarding tables. For basic routing topologies, where traffic is first entering the core network, apply an input firewall filter to the ingress interface. Additionally, add firewall filters to interfaces where multitopology OSPF is configured. All routers must use the same firewall filter to associate packets with a topology to ensure consistent forwarding and to avoid routing loops or packet loss.

    The forwarding plane handles traffic as it enters the router and exits out a particular interface. To inspect traffic and use a specified topology forwarding table to perform next-hop lookups, configure an input firewall filter on each interface where routing topology support is desired. Use a regular firewall filter to identify packet characteristics.

    In general, for application-level differentiation, it is convenient to use DiffServ code points (DSCPs). When there is a firewall filter match, the firewall instructs the route lookup to use a particular topology forwarding table. Packet attributes are identified in the from clause, followed by a then clause indicating the topology forwarding table for use in forwarding next-hop lookups. This configuration notifies the router which traffic uses a routing topology forwarding table and which traffic uses the default forwarding table. The last term, which is named default, specifies the use of the default forwarding table.

    These firewall configurations show source addresses and DSCPs used to sort voice, video, and default traffic. DSCPs are practical because you can set them at or near a CE device and because the information is intact across the network. For instance, here class of service (CoS) is configured for expedited traffic. DSCPs are also practical when the same IP address is used for different applications.

    content_copy zoom_out_map
    [edit firewall family inet filter ef_path]
    user@PE1# set term ef from forwarding-class expedited-forwarding
    user@PE1# set term ef then topology voice
    user@PE1# set term video from source-address 11.19.132.0/24
    user@PE1# set term video from source-address 11.19.133.0/24
    user@PE1# set term video from source-address 11.19.142.0/24
    user@PE1# set term video from source-address 11.19.144.0/24
    user@PE1# set term video then topology video
    user@PE1# set term default then accept
    
  10. Enable CoS on the interfaces.

    content_copy zoom_out_map
    [edit class-of-service interfaces]
    user@PE1# set fe-1/2/0 unit 2 classifiers inet-precedence default
    user@PE1# set fe-1/2/1 unit 6 classifiers inet-precedence default
    user@PE1# set fe-1/2/2 unit 9 classifiers inet-precedence default
    

Results

From configuration mode, confirm your configuration by entering the show interfaces, show protocols, show policy-options, show routing-options, show firewall, and show class-of-service commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

content_copy zoom_out_map
user@PE1# show interfaces
fe-1/2/0 {
    unit 2 {
        description to-CE1;
        family inet {
            filter {
                input ef_path;
            }
            address 10.0.0.2/30;
        }
    }
}
fe-1/2/1 {
    unit 6 {
        description to-P1;
        family inet {
            filter {
                input ef_path;
            }
            address 10.0.0.6/30;
        }
    }
}
fe-1/2/2 {
    unit 9 {
        description to-P3;
        family inet {
            filter {
                input ef_path;
            }
            address 10.0.0.9/30;
        }
    }
}
lo0 {
    unit 93 {
        family inet {
            address 10.255.165.93/32 {
                primary;
            }
        }
    }
}
content_copy zoom_out_map
user@PE1# show protocols
bgp {
    group ibgp {
        type internal;
        local-address 10.255.165.93;
        family inet {
            unicast {
                topology voice {
                    community target:40:40;
                }
                topology video {
                    community target:50:50;
                }
            }
        }
        export nhs;
        neighbor 10.255.165.111;
        neighbor 10.255.165.203;
        neighbor 10.255.165.113;
        neighbor 10.255.165.95;
        neighbor 10.255.165.99;
    }
    group ebgp {
        type external;
        local-address 10.0.0.2;
        family inet {
            unicast {
                topology voice {
                    community target:40:40;
                }
                topology video {
                    community target:50:50;
                }
            }
        }
        peer-as 101;
        neighbor 10.0.0.1;
    }
}
ospf {
    topology voice topology-id 126;
    topology video topology-id 52;
    area 0.0.0.0 {
        interface fe-1/2/1.6 {
            metric 10;
            topology video disable;
            topology voice;
        }
        interface fe-1/2/2.9 {
            metric 10;
            topology voice disable;
            topology video;
        }
        interface lo0.93 {
            passive;
        }
    }
}
content_copy zoom_out_map
user@PE1# show policy-options
policy-statement nhs {
    then {
        next-hop self;
    }
}
content_copy zoom_out_map
user@PE1# show routing-options
autonomous-system 100;
topologies {
    family inet {
        topology voice;
        topology video;
    }
}
content_copy zoom_out_map
user@PE1# show firewall
family inet {
    filter ef_path {
        term ef {
            from {
                forwarding-class expedited-forwarding;
            }
            then topology voice;
        }
        term video {
            from {
                source-address {
                    11.19.132.0/24;
                    11.19.133.0/24;
                    11.19.142.0/24;
                    11.19.144.0/24;
                }
            }
            then topology video;
        }
        term default {
            then accept;
        }
    }
}
content_copy zoom_out_map
user@PE1# show class-of-service
interfaces {
    fe-1/2/0 {
        unit 2 {
            classifiers {
                inet-precedence default;
            }
        }
        unit 6 {
            classifiers {
                inet-precedence default;
            }
        }
        unit 9 {
            classifiers {
                inet-precedence default;
            }
        }
    }
}

If you are done configuring the device, enter commit from configuration mode.

Verification

Confirm that the configuration is working properly.

Verifying the OSPF Interfaces

Purpose

Verify that the OSPF interfaces are configured to belong to one or more topologies.

Action

From operational mode, enter the show (ospf | ospf3) interface interface-name detail command.

content_copy zoom_out_map
user@PE1> show ospf interface fe-1/2/1.6 detail
Interface           State   Area            DR ID           BDR ID          Nbrs
fe-1/2/1.6          DR      0.0.0.0         10.255.165.93   10.255.165.99      1
  Type: LAN, Address: 10.0.0.6, Mask: 255.255.255.252, MTU: 1500, Cost: 10
  DR addr: 10.0.0.6, BDR addr: 10.0.0.5, Priority: 128
  Adj count: 1
  Hello: 10, Dead: 40, ReXmit: 5, Not Stub
  Auth type: None
  Protection type: None
  Topology default (ID 0) -> Cost: 10
  Topology video (ID 52) -> Disabled, Cost: 10
  Topology voice (ID 126) -> Cost: 10

Meaning

This output shows that the voice topology was added to the fe-1/2/1.6 interface on Device PE1. The topology name is voice, and the MT-ID is 126. The video topology is disabled on this interface. The cost of the interface is 10.

The Router-LSA originated and flooded by the router includes all relevant topology information for specific interfaces, such as MT-ID and metric. If MTR is not configured on an OSPF interface, then the Router-LSA does not include any topology information for that interface. OSPF neighbors might or might not support multitopology OSPF. That is, a particular link is not used to calculate OSPF routes for a topology unless routers at both ends of the link announce that link as part of the topology. If multitopology OSPF is not supported in neighboring OSPF routers or is not configured to do so, then topology information in LSAs received by the neighbor is ignored.

Verifying the Routes

Purpose

Make sure that the routes are in the expected routing tables and that the expected communities are attached to the routes.

Action

From operational mode, enter the show route detail command on Device PE1.

content_copy zoom_out_map
user@PE1> show route 11.19.130.0/24 detail

inet.0: 29 destinations, 30 routes (29 active, 0 holddown, 0 hidden)
11.19.130.0/24 (1 entry, 1 announced)
        *BGP    Preference: 170/-101
                Next hop type: Router, Next hop index: 812
                Address: 0xb9f064c
                Next-hop reference count: 22
                Source: 10.0.0.1
                Next hop: 10.0.0.1 via fe-1/2/0.2, selected
                Session Id: 0x600004
                State: <Active Ext>
                Local AS:   100 Peer AS:   101
                Age: 3d 21:44:07 
                Task: BGP_101.10.0.0.1+51873
                Announcement bits (3): 0-KRT 3-BGP_RT_Background 4-Resolve tree 3 
                AS path: 101 I
                Communities: target:40:40
                Accepted
                Localpref: 100
                Router ID: 10.255.165.97
                Secondary Tables: :voice.inet.0

:voice.inet.0: 16 destinations, 16 routes (16 active, 0 holddown, 0 hidden)

11.19.130.0/24 (1 entry, 1 announced)
        *BGP    Preference: 170/-101
                Next hop type: Router, Next hop index: 812
                Address: 0xb9f064c
                Next-hop reference count: 22
                Source: 10.0.0.1
                Next hop: 10.0.0.1 via fe-1/2/0.2, selected
                Session Id: 0x600004
                State: <Secondary Active IndepResolution Ext>
                Local AS:   100 Peer AS:   101
                Age: 3d 21:44:07 
                Task: BGP_101.10.0.0.1+51873
                Announcement bits (2): 0-KRT 1-Resolve tree 1 
                AS path: 101 I
                Communities: target:40:40
                Accepted
                Localpref: 100
                Router ID: 10.255.165.97
                Primary Routing Table inet.0

Meaning

This output shows BGP route 11.19.130.0/24 with community value target:40:40. Because the route matches the criteria for the voice topology, it is added to both the default and voice topology routing tables (inet.0 and :voice.inet.0). Device PE1 learns the route from Device CE1 through EBGP and then injects the route into IBGP.

Checking the Resolving BGP Next Hops

Purpose

Check the protocol next hop and forwarding next hop.

Action

From operational mode, enter the show route detail command on Device PE2.

content_copy zoom_out_map
user@PE2> show route 11.19.130.0/24 detail
inet.0: 29 destinations, 30 routes (29 active, 0 holddown, 0 hidden)
11.19.130.0/24 (1 entry, 1 announced)
        *BGP    Preference: 170/-101
                Next hop type: Indirect
                Address: 0xb9f0e04
                Next-hop reference count: 12
                Source: 10.255.165.93
                Next hop type: Router, Next hop index: 262153
                Next hop: 10.0.0.37 via fe-1/2/0.38
                Session Id: 0x700004
                Next hop: 10.0.0.41 via fe-1/2/1.42, selected
                Session Id: 0x700005
                Protocol next hop: 10.255.165.93
                Indirect next hop: bb8c000 262154 INH Session ID: 0x700007
                State: <Active Int Ext>
                Local AS:   100 Peer AS:   100
                Age: 3d 4:27:40         Metric2: 30 
                Task: BGP_100.10.255.165.93+179
                Announcement bits (3): 0-KRT 3-BGP_RT_Background 4-Resolve tree 3 
                AS path: 101 I
                Communities: target:40:40
                Accepted
                Localpref: 100
                Router ID: 10.255.165.93
                Secondary Tables: :voice.inet.0

:voice.inet.0: 16 destinations, 16 routes (16 active, 0 holddown, 0 hidden)

11.19.130.0/24 (1 entry, 1 announced)
        *BGP    Preference: 170/-101
                Next hop type: Indirect
                Address: 0xb9f0f34
                Next-hop reference count: 6
                Source: 10.255.165.93
                Next hop type: Router, Next hop index: 1188
                Next hop: 10.0.0.37 via fe-1/2/0.38, selected
                Session Id: 0x700004
                Protocol next hop: 10.255.165.93
                Indirect next hop: bb8c1d8 262177 INH Session ID: 0x700007
                State: <Secondary Active IndepResolution Int Ext>
                Local AS:   100 Peer AS:   100
                Age: 3d 2:00:20         Metric2: 30 
                Task: BGP_100.10.255.165.93+179
                Announcement bits (2): 0-KRT 1-Resolve tree 1 
                AS path: 101 I
                Communities: target:40:40
                Accepted
                Localpref: 100          
                Router ID: 10.255.165.93
                Primary Routing Table inet.0

Meaning

A typical IBGP core has BGP routes with protocol next hops that resolve using the underlying IGP routes. IBGP routes in a topology routing table have protocol next-hop IP addresses. By default, the same topology routing table is used to look up and resolve the protocol next-hop IP address to a forwarding next hop. This output from Device PE2 shows the same BGP route as seen in the previous example: 11.19.130.0/24. The route is being shown from a different perspective, that is, from Device PE2 as an IBGP route. Similarly, this IBGP route is added to both inet.0 and :voice.inet.0 on Device PE2. However, while each route has the same protocol next hop, each route has a different forwarding next hop (ge-0/0/3.0 instead of ge-0/1/4.0). The reason for this difference is when the protocol next-hop IP address 10.255.165.93 is resolved, it uses the corresponding routing table (inet.0 or :voice.inet.0) to look up the protocol next hop.

Examining the Protocol Next Hop

Purpose

Check the protocol next hop and forwarding next hop.

Action

From operational mode, enter the show route command on Device PE2.

content_copy zoom_out_map
user@PE2> show route 10.255.165.93
inet.0: 29 destinations, 30 routes (29 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.255.165.93/32   *[OSPF/10] 3d 04:37:26, metric 30
                    > to 10.0.0.37 via fe-1/2/0.38
                      to 10.0.0.41 via fe-1/2/1.42

:voice.inet.0: 16 destinations, 16 routes (16 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.255.165.93/32   *[OSPF/10] 3d 02:10:04, metric 30
                    > to 10.0.0.37 via fe-1/2/0.38

:video.inet.0: 16 destinations, 16 routes (16 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.255.165.93/32   *[OSPF/10] 3d 02:03:16, metric 30
                    > to 10.0.0.41 via fe-1/2/1.42

Meaning

This output from Device PE2 shows the protocol next hop of 11.19.130.0/24, which is IP address 10.255.165.93, thus further demonstrating how IBGP route 11.19.130.0/24 resolves its protocol next hop. The forwarding next hops of 10.255.165.93 match the IBGP forwarding next hops of route 11.19.130/24 as shown in the previous example. Observe here that the IP address 10.255.165.93 is also in routing table :video.inet.0. This address is the loopback address of Device PE1, and as such, resides in all three routing tables. This example also shows how traffic entering Device PE2 destined to 11.19.130.0/24 exits out different interfaces depending on its associated topology. The actual traffic is marked in such a way that a firewall filter can direct the traffic to use a particular topology routing table.

Verifying the OSPF Neighbor

Purpose

Make sure that the expected topologies are enabled on the OSPF neighbor.

Action

From operational mode, enter the show ospf neighbor 10.0.0.21 extensive command on Device P2.

content_copy zoom_out_map
user@P2> show ospf neighbor 10.0.0.21 extensive
Address          Interface              State     ID               Pri  Dead
10.0.0.21        fe-1/2/0.22            Full      10.255.165.111   128    39
  Area 0.0.0.0, opt 0x52, DR 10.0.0.22, BDR 10.0.0.21
  Up 3d 06:09:50, adjacent 3d 06:09:50
   Topology default (ID 0) -> Bidirectional
   Topology video (ID 52) -> Bidirectional

Meaning

This Device P2 output shows OSPF neighbor PE2 (10.0.0.21), where multitopology OSPF default and video are multitopology OSPF participants. The Bidirectional flag shows that the neighbor is configured using the same multitopology OSPF ID.

Checking the Router LSA

Purpose

Check the links where video and voice topologies are enabled.

Action

From operational mode, enter the show ospf database lsa-id 10.255.165.203 extensive command on Device P2.

content_copy zoom_out_map
user@P2> show ospf database lsa-id 10.255.165.203 extensive

    OSPF database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len 
Router   10.255.165.203   10.255.165.203   0x80000063  1552  0x22 0xdff3  80
  bits 0x0, link count 3
  id 10.255.165.203, data 255.255.255.255, Type Stub (3)
    Topology count: 2, Default metric: 0
    Topology video (ID 52) -> Metric: 0
    Topology voice (ID 126) -> Metric: 0
  id 10.0.0.38, data 10.0.0.38, Type Transit (2)
    Topology count: 2, Default metric: 10
    Topology video (ID 52) -> Metric: 200
    Topology voice (ID 126) -> Metric: 10
  id 10.0.0.42, data 10.0.0.42, Type Transit (2)
    Topology count: 1, Default metric: 10
    Topology video (ID 52) -> Metric: 10
  Topology default (ID 0)
    Type: Transit, Node ID: 10.0.0.42
      Metric: 10, Bidirectional
    Type: Transit, Node ID: 10.0.0.38
      Metric: 10, Bidirectional
  Topology video (ID 52)
    Type: Transit, Node ID: 10.0.0.42
      Metric: 10, Bidirectional
    Type: Transit, Node ID: 10.0.0.38
      Metric: 200, Bidirectional
  Topology voice (ID 126)
    Type: Transit, Node ID: 10.0.0.38
      Metric: 10, Bidirectional
  Aging timer 00:34:08
  Installed 00:25:49 ago, expires in 00:34:08, sent 00:25:47 ago
  Last changed 3d 01:45:51 ago, Change count: 10

Meaning

This Device P2 output shows the Router-LSA originated by Device PE2. The LSA shows links where video and voice topologies are enabled (in addition to the default topology).

Checking How Traffic Traverses the Network

Purpose

Make sure that the expected paths are used.

Action

From operational mode, enter the traceroute command on Device CE1.

The first example output shows a traceroute over the voice topology goes from Device CE1 to Device CE2 where DSCPs are set. The routes are resolved over :voice.inet.0. This traceroute path follows the voice path CE1-PE1-P1-P2-PE2-CE2

content_copy zoom_out_map
user@CE1> traceroute 11.19.140.1 source 11.19.130.1 tos 160



traceroute to 11.19.140.1 (11.19.140.1) from 11.19.130.1, 30 hops max, 40 byte packets
 1  10.0.0.2 (10.0.0.2)  2.015 ms  1.924 ms  1.770 ms
 2  10.0.0.5 (10.0.0.5)  1.890 ms  1.010 ms  0.974 ms
 3  10.0.0.34 (10.0.0.34)  0.986 ms  1.031 ms  0.973 ms
 4  10.0.0.38 (10.0.0.38)  1.213 ms  1.065 ms  1.154 ms
 5  11.19.140.1 (11.19.140.1)  1.696 ms  4.286 ms  1.332 ms

This output shows a traceroute from Device CE1 to Device CE2 for voice where no DSCPs are set. The routes are resolved over inet.0, and the resulting path is different from the previous case where the DSCPs are set. This traceroute path follows the default path CE1-PE1-P4-PE2-CE2.

content_copy zoom_out_map
user@CE1> traceroute 11.19.140.1 source 11.19.130.1

traceroute to 11.19.140.1 (11.19.140.1) from 11.19.130.1, 30 hops max, 40 byte packets
 1  10.0.0.2 (10.0.0.2)  1.654 ms  1.710 ms  1.703 ms
 2  10.0.0.5 (10.0.0.5)  1.790 ms  1.045 ms  0.975 ms
 3  10.0.0.18 (10.0.0.18)  0.989 ms  1.041 ms  0.983 ms
 4  10.0.0.42 (10.0.0.42)  0.994 ms  1.036 ms  1.002 ms
 5  11.19.140.1 (11.19.140.1)  1.329 ms  2.248 ms  2.225 ms

This output shows a traceroute from Device CE1 to Device CE2 for video traffic where the firewall filter is based on the destination address. The routes are resolved over :video.inet.0 . This traceroute follows the video path CE1-PE1-P3-P4-PE2-CE2.

content_copy zoom_out_map
user@CE1> traceroute 11.19.142.1 source 11.19.132.1

traceroute to 11.19.142.1 (11.19.142.1) from 11.19.132.1, 30 hops max, 40 byte packets
 1  10.0.0.2 (10.0.0.2)  1.126 ms  1.300 ms  0.995 ms
 2  10.0.0.10 (10.0.0.10)  0.981 ms  1.018 ms  0.991 ms
 3  10.0.0.30 (10.0.0.30)  0.997 ms  1.886 ms  1.952 ms
 4  10.0.0.42 (10.0.0.42)  1.800 ms  1.038 ms  0.980 ms
 5  11.19.142.1 (11.19.142.1)  1.367 ms  1.352 ms  1.328 ms

This output shows a traceroute from Device CE1 to Device CE2 for video where DSCPs are set. The DSCP bits are directing Device PE1 to use the topology table :voice.inet.0. Because there is no entry in the voice routing table for video routes, traffic is dropped.

content_copy zoom_out_map
user@CE1> traceroute 11.19.142.1 source 11.19.132.1 tos 160


traceroute to 11.19.142.1 (11.19.142.1) from 11.19.132.1, 30 hops max, 40 byte packets
 1  10.0.0.2 (10.0.0.2)  1.135 ms !N  1.007 ms !N  0.954 ms !N
footer-navigation