Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Announcement: Try the Ask AI chatbot for answers to your technical questions about Juniper products and solutions.

close
header-navigation
keyboard_arrow_up
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring MPLS LSP Link Protection

date_range 04-Aug-23
Figure 1: MPLS LSP Link Protection Topology DiagramMPLS LSP Link Protection Topology Diagram

In Figure 1, a primary MPLS LSP is established from Router 1 through Router 3 to destination Router 2. To implement link protection, include the link-protection statement on the primary LSP at the ingress point and on the appropriate downstream RSVP interfaces you wish to protect. In this case, the primary LSP named Protected_LSP on Router 1 requires link protection, as does the so-7/3/2 RSVP interface of Router 1 and the so-6/0/0 RSVP interface of Router 3. After link protection is enabled for the protected LSP, bypass LSPs are established automatically for the LSP-traversed interfaces of Routers 1 and 3.

On Router 1, configure an interior gateway protocol (IGP) routing protocol (in this case, IS-IS), RSVP, and MPLS on the so-0/0/0 and so-7/3/2 interfaces. Next, configure the primary LSP on Router 1 to point to the loopback address of Router 2. The primary LSP’s strict path must travel though Router 3.

Enable link protection on both the LSP itself and the outgoing RSVP interface traversed by the primary LSP (in this case, the so-7/3/2 RSVP interface of Router 1). After you enable link protection, the router notices that the primary LSP is protected and prepares a bypass LSP.

Configure a static route of 10.31.5.1 in the LSP on Router 1. You can use this route for testing purposes. Also, if you want to enable Packet Forwarding Engine local repair, establish a policy that requires all traffic to use per-packet load balancing. Once this policy is configured, export it to the neighboring routers with the export statement at the [edit routing-options forwarding-table] hierarchy level.

Router 1

content_copy zoom_out_map
[edit]
interfaces {
    so-0/0/0 {
        unit 0 {
            family inet {
                address 10.31.3.1/30;
            }
            family iso;
            family mpls;
        }
    }
    so-7/3/2 {
        unit 0 {
            family inet {
                address 10.31.1.1/30;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.245.71.51/32;
            }
            family iso {
            }
        }
    }
    protocols {
        rsvp {
            interface so-7/3/2.0 {
                                     link-protection; # Enable link protection on the interface carrying the main LSP.
            }
            interface so-0/0/0.0 {
            }
            mpls {
                label-switched-path Protected_LSP {
                    to 10.245.71.52;
                                           install 10.31.5.1/32 active; # This route is used for testing the LSPs.
                                           link-protection;            # Enable link protection on the protected LSP.
                    primary path1;
                }
                path path1 {
                    10.31.1.2 strict;
                }
                interface so-0/0/0.0;
                interface so-7/3/2.0;
            }
            isis {
                level 2 wide-metrics-only;
                interface so-0/0/0.0 {
                    level 1 disable;
                    level 2 {
                        metric 100;
                        te-metric 100;
                    }
                }
                interface so-7/3/2.0 {
                    level 1 disable;
                    level 2 {
                        metric 10;
                        te-metric 10;
                    }
                }
                interface lo0.0 {
                    passive;
                }
            }
        }
        routing-options {
            forwarding-table { # Apply this policy to the forwarding table only
                                     export pplb; # if Packet Forwarding Engine local repair is needed.
            }
        }
        policy-options {
            policy-statement pplb {
                then {# Configure this policy only if
                    load-balance per-packet; # Packet Forwarding Engine local repair is needed.
                }
            }
        }
    }
}

On Router 2, no link protection configuration is needed. However, you should configure MPLS, RSVP, and IS-IS to communicate with the other routers.

Router 2

content_copy zoom_out_map
[edit]
interfaces {
    so-0/0/0 {
        unit 0 {
            family inet {
                address 10.31.3.2/30;
            }
            family iso;
            family mpls;
        }
    }
    so-7/1/0 {
        unit 0 {
            family inet {
                address 10.31.2.1/30;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.245.71.53/32;
            }
            family iso {
            }
        }
    }
    protocols {
        rsvp {
            interface so-0/0/0.0;
            interface so-7/1/0.0;
        }
        mpls {
            interface so-0/0/0.0;
            interface so-7/1/0.0;
        }
        isis {
            level 2 wide-metrics-only;
            interface so-0/0/0.0 {
                level 1 disable;
                level 2 {
                    metric 100;
                    te-metric 100;
                }
            }
            interface so-7/1/0.0 {
                level 1 disable;
                level 2 {
                    metric 10;
                    te-metric 10;
                }
            }
            interface lo0.0 {
                passive;
            }
        }
    }
}

On Router 3, include IS-IS, RSVP, and MPLS on the so-1/0/0 and so-6/0/0 interfaces. Enable link protection on the remaining RSVP interface traversed by the primary LSP (in this case, the so-6/0/0 RSVP interface). After you enable link protection, the router notices the primary LSP is protected and prepares a bypass LSP.

To enable Packet Forwarding Engine local repair, establish a policy that requires traffic to use per-packet load balancing. Once this policy is configured, export it to the neighboring routers.

Router 3

content_copy zoom_out_map
[edit]
interfaces {
    so-1/0/0 {
        unit 0 {
            family inet {
                address 10.31.1.2/30;
            }
            family iso;
            family mpls;
        }
    }
    so-6/0/0 {
        unit 0 {
            family inet {
                address 10.31.2.2/30;
            }
            family iso;
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.245.271.53/32;
            }
            family iso {
            }
        }
    }
    protocols {
        rsvp {
            interface so-1/0/0.0;
            interface so-6/0/0.0 { # Primary interface going to Router 2.
                                     link-protection;                   
            }
        }
        mpls {
            interface so-1/0/0.0;
            interface so-6/0/0.0;
        }
        isis {
            level 2 wide-metrics-only;
            interface so-1/0/0.0 {
                level 1 disable;
                level 2 {
                    metric 10;
                    te-metric 10;
                }
            }
            interface so-6/0/0.0 {
                level 1 disable;
                level 2 {
                    metric 10;
                    te-metric 10;
                }
            }
            interface lo0.0 {
                passive;
            }
        }
    }
    policy-options {
        policy-statement pplb {
            then {
                load-balance per-packet; # If Packet Forwarding Engine local repair is needed.
            }
        }
    }
    routing-options {
        forwarding-table {
            export pplb;       # If Packet Forwarding Engine local repair is needed.
        }
    }
}

Verifying Your Work

To verify proper operation of MPLS LSP link protection, use the following commands:

  • show mpls lsp

  • show route

  • show route forwarding-table

  • show rsvp interface detail

  • show rsvp neighbor detail

  • show rsvp session detail

The following sections show the output of these commands used with the configuration example:

Case 1: Normal Operation

Once link protection is enabled on the required RSVP interfaces and primary LSP, the bypass LSPs are prepared.

Router 1

content_copy zoom_out_map
user@Router1> show mpls lsp           
Ingress LSP: 1 sessions
To              From            State Rt ActivePath       P     LSPname
10.245.71.52    10.245.71.51    Up     1 path1            *     Protected_LSP

This is the main LSP.

content_copy zoom_out_map
Total 1 displayed, Up 1, Down 0
Egress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit LSP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.71.52    10.245.271.53   Up     1  1 SE  100003        0 
Bypass->10.31.2.1

This is the bypass LSP from Router 3 to Router 2.

content_copy zoom_out_map
Total 1 displayed, Up 1, Down 0

user@Router1>  show rsvp session detail  
Ingress RSVP: 2 sessions
10.245.71.52
   From: 10.245.71.51, LSPstate: Up, ActiveRoute: 1
  LSPname: Protected_LSP

This is the main LSP. Notice that a backup LSP is not signaled when the main LSP is still up.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: -, Label out: 100007
  Time left:    -,  Since: Thu Aug  8 12:13:24 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Link protected LSP
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.1.2 (so-7/3/2.0) 36 pkts
  RESV rcvfrom: 10.31.1.2  (so-7/3/2.0) 38 pkts
  Explct route: 10.31.1.2 10.31.2.1 
  Record route: <self>  10.31.1.2  10.31.2.1
10.245.271.53
   From: 10.245.71.51, LSPstate: Up, ActiveRoute: 0  
  LSPname: Bypass->10.31.1.2

This is the bypass from Router 1 to Router 2. This also appears in the show mpls lsp command output above.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: -, Label out: 100000
  Time left:    -,  Since: Thu Aug  8 12:14:31 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 51 protocol 0
  Type: Bypass LSP
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.3.2 (so-0/0/0.0) 32 pkts
  RESV rcvfrom: 10.31.3.2  (so-0/0/0.0) 32 pkts
  Explct route: 10.31.3.2 10.31.2.2 
  Record route: <self>  10.31.3.2  10.31.2.2
Total 2 displayed, Up 2, Down 0
Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit RSVP: 1 sessions
10.245.71.52
  From: 10.245.271.53, LSPstate: Up, ActiveRoute: 1
  LSPname: Bypass->10.31.2.1
  Resv style: 1 SE, Label in: 100003, Label out: 0
  Time left:   52,  Since: Thu Aug  8 12:03:27 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 19 protocol 0
  PATH rcvfrom: 10.31.1.2  (so-7/3/2.0) 76 pkts
  PATH sentto: 10.31.3.2 (so-0/0/0.0) 77 pkts
  RESV rcvfrom: 10.31.3.2  (so-0/0/0.0) 78 pkts
  Explct route: 10.31.3.2 
  Record route: 10.31.1.2  <self>  10.31.3.2
Total 1 displayed, Up 1, Down 0

user@Router1>  show rsvp interface detail
RSVP interface: 2 active
fxp0.0  Index 1, State Dis/Up
  NoAuthentication, NoAggregate, NoReliable, NoLinkProtection
  HelloInterval 9(second)
  Address 192.168.71.52
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path                 0             0           0             0
  PathErr              0             0           0             0
  PathTear             0             0           0             0
  Resv                 0             0           0             0
  ResvErr              0             0           0             0
  ResvTear             0             0           0             0
  Hello                0             0           0             0
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0
so-0/0/0.0  Index 8, State Ena/Up
  NoAuthentication, NoAggregate, NoReliable, NoLinkProtection
  HelloInterval 20(second)
  Address 10.31.3.1, 10.245.71.51
  ActiveResv 2, PreemptionCnt 0, Update threshold 10%
  Subscription 100%, StaticBW 622.08Mbps, AvailableBW 622.08Mbps
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path               441             0           0             0
  PathErr              0             0           0             0
  PathTear             3             0           0             0
  Resv                 0           431           0             0
  ResvErr              0             0           0             0
  ResvTear             0             0           0             0
  Hello              489           487           0             0
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0
so-7/3/2.0  Index 11, State Ena/Up
  NoAuthentication, NoAggregate, NoReliable,  LinkProtection

Link protection is enabled.

content_copy zoom_out_map
  HelloInterval 3(second)
  Address 10.31.1.1, 10.245.71.51
  ActiveResv 1, PreemptionCnt 0, Update threshold 10%
  Subscription 100%, StaticBW 2.48832Gbps, AvailableBW 2.48832Gbps
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path               225           138           0             0
  PathErr             12             4           0             0
  PathTear             5             3           0             0
  Resv               134           216           0             1
  ResvErr              0             0           0             0
  ResvTear             3             1           0             0
  Hello              750           799           1             1
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0

user@Router1>  show rsvp neighbor detail    
RSVP neighbor: 2 learned
Address: 10.31.1.2   via: so-7/3/2.0    status: Up
  Last changed time: 38:17, Idle: 5 sec, Up cnt: 1, Down cnt: 0
  Message received: 329
  Hello: sent 747, received: 747, interval: 3 sec
  Remote instance: 0x41b21a47, Local instance: 0x238fa919
  Refresh reduction:  not operational
  Link protection:   enabled            #   This should be enabled
    LSP name: Bypass->10.31.1.2
    Bypass LSP: operational,   Backup routes: 2 ,  Backup LSPs: 0

The number of backup routes equals 2 because the main LSP is already considered for protection.

content_copy zoom_out_map
    Bypass explicit route: 10.31.3.2 10.31.2.2 

Address: 10.31.3.2   via: so-0/0/0.0    status: Up
  Last changed time: 17:46, Idle: 5 sec, Up cnt: 4, Down cnt: 3
  Message received: 430
  Hello: sent 506, received: 486, interval: 20 sec
  Remote instance: 0x194fa7af, Local instance: 0x507b7c2a
  Refresh reduction:  not operational
  Link protection:  disabled 
    Bypass LSP: does not exist,  Backup routes: 0,  Backup LSPs: 0

user@Router1>show route 10.31.5.1 extensive  

inet.0: 24 destinations, 24 routes (22 active, 0 holddown, 2 hidden)
10.31.5.1/32 (1 entry, 1 announced)
        State: <FlashAll>
TSI:
KRT in-kernel 10.31.5.1/32 -> {0.0.0.0, 0.0.0.0}
        *RSVP   Preference: 7
                 Next hop: via so-7/3/2.0 weight 1, selected

This is the main LSP.

content_copy zoom_out_map
                Label-switched-path Protected_LSP
                Label operation: Push 100007
                 Next hop: via so-0/0/0.0 weight 20001

This is a backup route, though the backup LSP has not been signaled yet.

content_copy zoom_out_map
                Label-switched-path Bypass->10.31.1.2
                Label operation: Push 100007, Push 100000(top)[0]
                State: <Active Int>
                Local AS:    69 
                Age: 8:34       Metric: 20 
                Task: RSVP
                Announcement bits (1): 0-KRT 
                AS path: I

user@Router1>  show route forwarding-table destination 10.31.5.1 extensive
                           
Routing table: inet [Index 0]                 
Internet:
    Destination:  10.31.5.1/32
  Route type: user                Route reference: 0   
  Flags: sent to PFE 
  Next-hop type: unilist               Index: 39       Reference: 1    
   Next-hop type: Push  100007       
   Next-hop interface: so-7/3/2.0       Weight: 1

Packet Forwarding Engine local repair is enabled (otherwise, only one entry appears for Next-hop).

content_copy zoom_out_map
  Next-hop type: Push 100007, Push 100000(top)[0]
  Next-hop interface: so-0/0/0.0        Weight: 20001

The Weight value for the backup starts at 20000 .

Router 3

content_copy zoom_out_map
user@Router3> show mpls lsp           
Ingress LSP: 0 sessions

The ingress bypass LSP to Router 2 does not appear here.

content_copy zoom_out_map
Total 0 displayed, Up 0, Down 0
Egress LSP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.271.53   10.245.71.51    Up     0  1 SE       3        - 
Bypass->10.31.1.2
Total 1 displayed, Up 1, Down 0
Transit LSP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.71.52    10.245.71.51    Up     1  1 SE  100000        0 Protected_LSP
Total 1 displayed, Up 1, Down 0

user@Router3>  show rsvp session detail 
Ingress RSVP: 1 sessions

10.245.71.52
  From: 10.245.271.53, LSPstate: Up, ActiveRoute: 0
   LSPname: Bypass->10.31.2.1

This is the ingress bypass session to Router 2 from Router 1.

content_copy zoom_out_map
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: 100004
  Resv style: 1 SE, Label in: -, Label out: 100004
  Time left:    -,  Since: Thu Aug  8 12:27:07 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 16 protocol 0
  Type: Bypass LSP
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.1.1 (so-1/0/0.0) 3 pkts
  RESV rcvfrom: 10.31.1.1  (so-1/0/0.0) 3 pkts
  Explct route: 10.31.1.1 10.31.3.2 
  Record route: <self>  10.31.1.1  10.31.3.2
Total 1 displayed, Up 1, Down 0

Egress RSVP: 1 sessions

10.245.271.53
  From: 10.245.71.51, LSPstate: Up, ActiveRoute: 0
  LSPname: Bypass->10.31.1.2

This is the bypass from Router 1 to Router 3, arriving by way of Router 2.

content_copy zoom_out_map
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: -
  Resv style: 1 SE, Label in: 3, Label out: -
  Time left:   54,  Since: Thu Aug  8 12:26:48 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 52 protocol 0
  PATH rcvfrom: 10.31.2.1  (so-6/0/0.0) 5 pkts
  PATH sentto: localclient
  RESV rcvfrom: localclient 
  Record route: 10.31.3.1  10.31.2.1  <self>
Total 1 displayed, Up 1, Down 0
Transit RSVP: 1 sessions
10.245.71.52
  From: 10.245.71.51, LSPstate: Up, ActiveRoute: 1
  LSPname: Protected_LSP  

This is the main LSP.

content_copy zoom_out_map
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: 0
  Resv style: 1 SE, Label in: 100000, Label out: 0
  Time left:   41,  Since: Thu Aug  8 12:26:39 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Link protected LSP
  PATH rcvfrom: 10.31.1.1  (so-1/0/0.0) 9 pkts
  PATH sentto: 10.31.2.1 (so-6/0/0.0) 11 pkts
  RESV rcvfrom: 10.31.2.1  (so-6/0/0.0) 10 pkts
  Explct route: 10.31.2.1 
  Record route: 10.31.1.1  <self>  10.31.2.1
Total 1 displayed, Up 1, Down 0

user@Router3>  show rsvp neighbor detail    
RSVP neighbor: 2 learned
Address: 10.31.2.1   via: so-6/0/0.0    status: Up
  Last changed time: 27, Idle: 0 sec, Up cnt: 1, Down cnt: 0
  Message received: 19
  Hello: sent 6, received: 6, interval: 9 sec
  Remote instance: 0x625d2852, Local instance: 0x327317df
  Refresh reduction:  not operational
  Link protection:  enabled 
    LSP name: Bypass->10.31.2.1
    Bypass LSP: operational,   Backup routes: 1 ,  Backup LSPs: 0

The number of backup routes is 1.

content_copy zoom_out_map
    Bypass explicit route: 10.31.1.1 10.31.3.2 
Address: 10.31.1.1   via: so-1/0/0.0    status: Up
  Last changed time: 41, Idle: 0 sec, Up cnt: 1, Down cnt: 0
  Message received: 15
  Hello: sent 17, received: 17, interval: 3 sec
  Remote instance: 0x2ebdcf43, Local instance: 0x643d9e23
  Refresh reduction:  not operational
  Link protection:  disabled 
    Bypass LSP: does not exist,  Backup routes: 0,  Backup LSPs: 0

user@Router3>  show rsvp interface detail  
RSVP interface: 2 active
fxp0.0  Index 1, State Dis/Up
  NoAuthentication, NoAggregate, NoReliable, NoLinkProtection
  HelloInterval 9(second)
  Address 192.168.6.64
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path                 0             0           0             0
  PathErr              0             0           0             0
  PathTear             0             0           0             0
  Resv                 0             0           0             0
  ResvErr              0             0           0             0
  ResvTear             0             0           0             0
  Hello                0             0           0             0
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0
so-1/0/0.0  Index 6, State Ena/Up
  NoAuthentication, NoAggregate, NoReliable, NoLinkProtection
  HelloInterval 3(second)
  Address 10.31.1.2, 10.245.271.53
  ActiveResv 1, PreemptionCnt 0, Update threshold 10%
  Subscription 100%, StaticBW 2.48832Gbps, AvailableBW 2.48832Gbps
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path                 5            14           0             1
  PathErr              0             0           0             0
  PathTear             0             0           0             0
  Resv                 8             9           0             0
  ResvErr              0             0           0             0
  ResvTear             0             0           0             0
  Hello               23            25           2             2
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0
so-6/0/0.0  Index 9, State Ena/Up
  NoAuthentication, NoAggregate, NoReliable,  LinkProtection

Link protection is enabled.

content_copy zoom_out_map
  HelloInterval 9(second)
  Address 10.31.2.2, 10.245.271.53
  ActiveResv 1, PreemptionCnt 0, Update threshold 10%
  Subscription 100%, StaticBW 9.95328Gbps, AvailableBW 9.95328Gbps
  PacketType              Total                  Last 5 seconds
                   Sent      Received        Sent      Received
  Path                12             8           0             0
  PathErr              0             0           0             0
  PathTear             0             1           0             0
  Resv                 9            14           0             1
  ResvErr              0             0           0             0
  ResvTear             0             0           0             0
  Hello                8             8           1             1
  Ack                  0             0           0             0
  Srefresh             0             0           0             0
  EndtoEnd RSVP        0             0           0             0

user@Router3>  show route forwarding-table family mpls
Routing table: ccc
MPLS:
Destination        Type RtRef Next hop          Type Index NhRef Netif
default            perm     0                   dscd     1     1
0                  user     0                   recv     3     3
1                  user     0                   recv     3     3
2                  user     0                   recv     3     3
100000             user     0                   ulst    77     1

This is the main LSP.

content_copy zoom_out_map
                                                Swap       0     so-6/0/0.0
                                                Swap  100004[0]  so-1/0/0.0
100000(S=0)        user     0                   ulst    78     1
                                                Pop              so-6/0/0.0
                                                Swap  100004[0]  so-1/0/0.0
100007             user     0                   ulst    71     1

This is the bypass LSP from Router 1 to Router 2.

content_copy zoom_out_map
                                                Swap       0     so-6/0/0.0
                                                Swap  100003[0]  so-1/0/0.0
100007(S=0)        user     0                   ulst    73     1
                                                Pop              so-6/0/0.0
                                                Swap  100003[0]  so-1/0/0.0

Case 2: When the Link from Router 1 to Router 3 Is Disabled

content_copy zoom_out_map
[edit]
user@Router1# set interfaces so-7/3/2 disable

[edit]
user@Router1# commit  
commit complete

The primary interface from Router 1 to Router 3 is disabled.

Router 1

content_copy zoom_out_map
user@Router1> show mpls lsp           
Ingress LSP: 1 sessions
To              From             State  Rt ActivePath       P     LSPname
10.245.71.52    10.245.71.51     Up      0 path1            *     Protected_LSP

The main LSP is up.

content_copy zoom_out_map
Total 1 displayed, Up 1, Down 0
Egress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit LSP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.71.52    10.245.271.53   Up     0  1 SE  100004        0 
Bypass->10.31.2.1

This is the bypass LSP from Router 3 to Router 2.

content_copy zoom_out_map
Total 1 displayed, Up 1, Down 0

user@Router1>  show rsvp session detail
Ingress RSVP: 3 sessions
10.245.71.52
  From: 10.31.3.1, LSPstate: Up, ActiveRoute: 0
  LSPname: Protected_LSP

This is the newly signaled backup LSP, as indicated by the To/From field.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: -, Label out: 100000
  Time left:    -,  Since: Thu Aug  8 12:29:16 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Backup LSP at Point-of-Local-Repair
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.1.2 (so-0/0/0.0) 4 pkts
  RESV rcvfrom: 10.31.2.2  (so-0/0/0.0) 3 pkts
  Explct route: 10.31.2.2 10.31.2.1 
  Record route: <self>  10.31.2.2  10.31.2.1
10.245.71.52
  From: 10.245.71.51, LSPstate: Dn, ActiveRoute: 0

The original LSP is now down.

content_copy zoom_out_map
  LSPname: Protected_LSP
  Resv style: 0 -, Label in: -, Label out: -
  Time left:    -,  Since: Thu Aug  8 12:13:24 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Link protected LSP
  PATH rcvfrom: localclient 
  PATH sentto: [no route]
  Explct route: 10.31.1.2 10.31.2.1 
  Record route: <self>  ...incomplete

10.245.271.53
  From: 10.245.71.51, LSPstate: Up, ActiveRoute: 1
  LSPname: Bypass->10.31.1.2

This is the bypass LSP from Router 1 to Router 2.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: -, Label out: 100001
  Time left:    -,  Since: Thu Aug  8 12:26:48 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 52 protocol 0
  Type: Bypass LSP
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.3.2 (so-0/0/0.0) 13 pkts
  RESV rcvfrom: 10.31.3.2  (so-0/0/0.0) 13 pkts
  Explct route: 10.31.3.2 10.31.2.2 
  Record route: <self>  10.31.3.2  10.31.2.2
Total 3 displayed, Up 2, Down 1

Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit RSVP: 1 sessions

10.245.71.52
  From: 10.245.271.53, LSPstate: Up, ActiveRoute: 0
  LSPname: Bypass->10.31.2.1

This is the bypass LSP from Router 3 to Router 2, which will fail in the next case.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: 100004, Label out: 0
  Time left:   38,  Since: Thu Aug  8 12:27:07 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 16 protocol 0
  PATH rcvfrom: 10.31.1.2  (so-7/3/2.0) 11 pkts
  PATH sentto: 10.31.3.2 (so-0/0/0.0) 12 pkts
  RESV rcvfrom: 10.31.3.2  (so-0/0/0.0) 12 pkts
  Explct route: 10.31.3.2 
  Record route: 10.31.1.2  <self>  10.31.3.2
Total 1 displayed, Up 1, Down 0

user@Router1> show rsvp neighbor detail    
RSVP neighbor: 2 learned
Address: 10.31.1.2   via: so-7/3/2.0    status: Down

The neighbor is down.

content_copy zoom_out_map
  Last changed time: 25, Idle: 25 sec, Up cnt: 2, Down cnt: 2
  Message received: 397
  Hello: sent 900, received: 890, interval: 3 sec
  Remote instance: 0x0, Local instance: 0x41b41b17
  Refresh reduction:  not operational
  Link protection:  enabled
    LSP name: Bypass->10.31.1.2
    Bypass LSP: operational,  Backup routes: 2,  Backup LSPs: 1
    Bypass explicit route: 10.31.3.2 10.31.2.2 
Address: 10.31.3.2   via: so-0/0/0.0    status: Up
  Last changed time: 25:40, Idle: 5 sec, Up cnt: 4, Down cnt: 3
  Message received: 502
  Hello: sent 558, received: 538, interval: 20 sec
  Remote instance: 0x194fa7af, Local instance: 0x507b7c2a
  Refresh reduction:  not operational
  Link protection:  disabled 
    Bypass LSP: does not exist,  Backup routes: 0,  Backup LSPs: 0

user@Router1> show route 10.31.5.1
inet.0: 23 destinations, 23 routes (22 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both
10.31.5.1/32       *[RSVP/7] 00:03:04, metric 20 
                    > via so-0/0/0.0, label-switched-path Bypass->10.31.1.2

The route can be reached by way of the backup LSP.

content_copy zoom_out_map
user@Router1>  show route forwarding-table destination 10.31.5.1
Routing table: inet
Internet:
Destination        Type RtRef Next hop          Type Index NhRef Netif
10.31.5.1/32       user     0                   Push 100000, Push 100001(top)[0] 
so-0/0/0.0

Double-stacked labels appear on the backup LSP from Router 1 to Router 2 to Router 3.

Before proceeding to Case 3, reenable the so-7/3/2 interface on Router 1.

content_copy zoom_out_map
[edit]
user@Router1# delete interfaces so-7/3/2 disable

[edit]
user@Router1# commit  
commit complete

Case 3: When the Link from Router 3 to Router 2 Is Disabled

content_copy zoom_out_map
[edit]
user@Router3# set interfaces so-6/0/0 disable

[edit]
user@Router3# commit  
commit complete

The primary interface from Router 3 to Router 2 is disabled.

Router 3

content_copy zoom_out_map
user@Router3> show rsvp session           
Ingress RSVP: 2 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.71.52    10.245.271.53   Up     1  1 SE       -   100005 
Bypass->10.31.2.1
10.245.71.52    10.31.1.2       Up     0  1 SE       -        0 Protected_LSP

The backup is signaled from Router 3 to Router 2.

content_copy zoom_out_map
Total 2 displayed, Up 2, Down 0
Egress RSVP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname 
10.245.271.53   10.245.71.51    Up     0  1 SE       3        - 
Bypass->10.31.1.2
Total 1 displayed, Up 1, Down 0
Transit RSVP: 1 sessions
To              From             State  Rt Style Labelin Labelout LSPname 
10.245.71.52    10.245.71.51     Dn      0  0  -  100000        - Protected_LSP

The main LSP is down.

content_copy zoom_out_map
Total 1 displayed, Up 0, Down 1

user@Router3> show rsvp session detail  
Ingress RSVP: 2 sessions

10.245.71.52
  From: 10.245.271.53, LSPstate: Up, ActiveRoute: 1
  LSPname: Bypass->10.31.2.1
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: 100005
  Resv style: 1 SE, Label in: -, Label out: 100005
  Time left:    -,  Since: Thu Aug  8 12:31:09 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 17 protocol 0
  Type: Bypass LSP
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.1.1 (so-1/0/0.0) 6 pkts
  RESV rcvfrom: 10.31.1.1  (so-1/0/0.0) 6 pkts
  Explct route: 10.31.1.1 10.31.3.2 
  Record route: <self>  10.31.1.1  10.31.3.2

10.245.71.52
  From: 10.31.1.2, LSPstate: Up, ActiveRoute: 0
  LSPname: Protected_LSP
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: 0
  Resv style: 1 SE, Label in: -, Label out: 0
  Time left:    -,  Since: Thu Aug  8 12:31:59 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Backup LSP at Point-of-Local-Repair

This is the backup LSP.

content_copy zoom_out_map
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.2.1 (so-1/0/0.0) 5 pkts
  RESV rcvfrom: 10.31.3.2  (so-1/0/0.0) 2 pkts
  Explct route: 10.31.3.2 
  Record route: <self>  10.31.3.2
Total 2 displayed, Up 2, Down 0

Egress RSVP: 1 sessions

10.245.271.53
  From: 10.245.71.51, LSPstate: Up, ActiveRoute: 0
  LSPname: Bypass->10.31.1.2
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: -
  Resv style: 1 SE, Label in: 3, Label out: -
  Time left:   31,  Since: Thu Aug  8 12:26:48 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 52 protocol 0
  PATH rcvfrom: 10.31.2.1  (so-6/0/0.0) 23 pkts
  PATH sentto: localclient
  RESV rcvfrom: localclient 
  Record route: 10.31.3.1  10.31.2.1  <self>
Total 1 displayed, Up 1, Down 0

Transit RSVP: 1 sessions

10.245.71.52
  From: 10.245.71.51, LSPstate: Dn, ActiveRoute: 0
  LSPname: Protected_LSP
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: -
  Resv style: 0 -, Label in: 100000, Label out: -
  Time left:   53,  Since: Thu Aug  8 12:26:39 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  Type: Link protected LSP
  PATH rcvfrom: 10.31.1.1  (so-1/0/0.0) 30 pkts
  PATH sentto: [no route]
  Explct route: 10.31.2.1 
  Record route: 10.31.1.1  <self>  ...incomplete
Total 1 displayed, Up 0, Down 1

user@Router3> show route forwarding-table family mpls
Routing table: ccc                            
MPLS:
Destination        Type RtRef Next hop          Type Index NhRef Netif
default            perm     0                   dscd     1     1
0                  user     0                   recv     3     3
1                  user     0                   recv     3     3
2                  user     0                   recv     3     3
100000             user     0                   Swap  100005[0]  so-1/0/0.0

This shows label swapping for the main LSP traveling over the backup LSP through Router 2.

Router 1

content_copy zoom_out_map
user@Router1> show rsvp session detail           
Ingress RSVP: 1 sessions
10.245.71.52
  From: 10.245.71.51, LSPstate: Up, ActiveRoute: 1
  LSPname: Protected_LSP

The main LSP is not affected.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: -, Label out: 100000
  Time left:    -,  Since: Thu Aug  8 12:13:24 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 2 receiver 33 protocol 0
  Link protection desired
  PATH rcvfrom: localclient 
  PATH sentto: 10.31.1.2 (so-7/3/2.0) 95 pkts
  RESV rcvfrom: 10.31.1.2  (so-7/3/2.0) 87 pkts
  Explct route: 10.31.1.2 10.31.2.1 
  Record route: <self>  10.31.1.2  10.31.3.2
Total 1 displayed, Up 1, Down 0

Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0

Transit RSVP: 1 sessions

10.245.71.52
  From: 10.245.271.53, LSPstate: Up, ActiveRoute: 0
  LSPname: Bypass->10.31.2.1

The bypass LSP is listed, because Router 1 does not detect the backup from Router 3 to Router 2.

content_copy zoom_out_map
  Resv style: 1 SE, Label in: 100005, Label out: 0
  Time left:   53,  Since: Thu Aug  8 12:31:09 2002
  Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
  Port number: sender 1 receiver 17 protocol 0
  PATH rcvfrom: 10.31.1.2  (so-7/3/2.0) 11 pkts
  PATH sentto: 10.31.3.2 (so-0/0/0.0) 11 pkts
  RESV rcvfrom: 10.31.3.2  (so-0/0/0.0) 11 pkts
  Explct route: 10.31.3.2 
  Record route: 10.31.1.2  <self>  10.31.3.2
Total 1 displayed, Up 1, Down 0

user@Router1> show route forwarding-table family mpls  
Routing table: ccc                            
MPLS:
Destination        Type RtRef Next hop          Type Index NhRef Netif
default            perm     0                   dscd     8     1
0                  user     0                   recv    10     3
1                  user     0                   recv    10     3
2                  user     0                   recv    10     3
100005             user     0                   Swap       0     so-0/0/0.0

Labels are swapped on the bypass LSP.

content_copy zoom_out_map
100005(S=0)        user     0                   Pop              so-0/0/0.0
user@Router1> show route forwarding-table destination 10.31.5.1 extensive
Routing table: inet [Index 0]
Internet:
Destination:  10.31.5.1/32
  Route type: user                Route reference: 0   
  Flags: sent to PFE 
  Next-hop type: Push  100000

There is only one entry here. The bypass to Router 3 is broken because the connection between Router 3 and Router 2 is disabled.

content_copy zoom_out_map
Next-hop interface: so-7/3/2.0   
user@Router1> show isis adjacency 
Interface             System         L State        Hold (secs) SNPA
so-0/0/0.0            Router2        2 Up                   24
so-7/3/2.0            Router3        2 Up                   23

user@Router1>  show route 10.31.5.1 extensive

inet.0: 22 destinations, 22 routes (21 active, 0 holddown, 1 hidden)
10.31.5.1/32 (1 entry, 1 announced)
        State: <FlashAll>
TSI:
KRT in-kernel 10.31.5.1/32 -> {0.0.0.0}
        *RSVP   Preference: 7
                Next hop: via so-7/3/2.0 weight 1, selected

Only one entry is shown.

content_copy zoom_out_map
                Label-switched-path Protected_LSP
                Label operation: Push 100000
                State: <Active Int>
                Local AS:    69 
                Age: 2:21       Metric: 100
                Task: RSVP
                Announcement bits (1): 0-KRT
                AS path: I

user@Router1> show rsvp neighbor detail
RSVP neighbor: 2 learned
Address: 10.31.1.2   via: so-7/3/2.0    status: Up
  Last changed time: 2:58, Idle: 0 sec, Up cnt: 3, Down cnt: 2
  Message received: 433
  Hello: sent 965, received: 950, interval: 3 sec
  Remote instance: 0x74be7c42, Local instance: 0x41b41b17
  Refresh reduction:  not operational
  Link protection:  disabled 
    Bypass LSP: does not exist,  Backup routes: 0,  Backup LSPs: 0
Address: 10.31.3.2   via: so-0/0/0.0    status: Up
  Last changed time: 30:54, Idle: 0 sec, Up cnt: 4, Down cnt: 3
  Message received: 533
  Hello: sent 593, received: 573, interval: 20 sec
  Remote instance: 0x194fa7af, Local instance: 0x507b7c2a
  Refresh reduction:  not operational
  Link protection:  disabled 
    Bypass LSP: does not exist,  Backup routes: 0,  Backup LSPs: 0

user@Router1>  show rsvp session
Ingress RSVP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname
10.245.71.52    10.245.71.51    Up     1  1 SE       -   100000 Protected_LSP
Total 1 displayed, Up 1, Down 0
Egress RSVP: 0 sessions
Total 0 displayed, Up 0, Down 0
Transit RSVP: 1 sessions
To              From            State Rt Style Labelin Labelout LSPname
10.245.71.52    10.245.271.53   Up     0  1 SE  100005        0 
Bypass->10.31.2.1
Total 1 displayed, Up 1, Down 0
footer-navigation