Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

Example: Configuring Multichassis Link Aggregation with Layer 3 MAC Address Synchronization

Note: Multichassis link aggregation (MC-LAG) is supported on QFX3500 and QFX3600 standalone switches running the original CLI and QFX5100 standalone switches running Enhanced Layer 2 Software.

Note: Issuing a PING request on an MC-LAG with MAC synchronization enabled does not work.

There are two methods for enabling Layer 3 unicast functionality across a multichassis link aggregation group (MC-LAG) to control the traffic. You can choose either to synchronize the MAC addresses between the switches for the participating MC-LAG interfaces, or you can configure Virtual Router Redundancy Protocol (VRRP). The procedure to configure MAC address synchronization is included in this example. For more information about configuring VRRP for use in a Layer 3 unicast MC-LAG, see Example: Configuring Multichassis Link Aggregation for Layer 3 Unicast Using VRRP.

Requirements

This example uses the following hardware and software components:

  • Junos OS Release 12.3 or later for the QFX3500 and QFX3600 standalone switches and Junos OS Release 13.2X51-D10 or later for the QFX5100 standalone switches
  • Two QFX3500 or QFX3600 standalone switches, or two QFX5100 standalone switches

Before you configure an MC-LAG for Layer 3 unicast, be sure that you understand how to:

Overview

In this example, you configure an MC-LAG across two switches, consisting of two aggregated Ethernet interfaces, an interchassis control link-protection link (ICL-PL), multichassis protection link for the ICL-PL, Inter-Chassis Control Protocol (ICCP) for the peers hosting the MC-LAG, and Layer 3 connectivity between MC-LAG peers. Layer 3 connectivity is required for ICCP.

Topology

The topology used in this example consists of two switches hosting an MC-LAG. The two switches are connected to a server. Figure 1 shows the topology of this example.

Figure 1: Configuring a Multichassis LAG Between Switch A and Switch B

Configuring a Multichassis LAG Between
Switch A and Switch B

Table 1 details the topology used in this configuration example.

Table 1: Components of the Topology for Configuring a Multichassis LAG Between Two Switches

HostnameBase HardwareMultichassis Link Aggregation Group

Switch A

Switch B

QFX3500 or QFX3600 standalone switch, or QFX5100 standalone switch

QFX3500 or QFX3600 standalone switch, or QFX5100 standalone switch

ae0 is configured as an aggregated Ethernet interface, and is used as an ICL-PL. The following interfaces are part of ae0: xe-0/0/12 and xe-0/0/13 Switch A and
xe-0/0/12 and xe-0/0/13 on Switch B.

ae1 is configured as an MC-LAG, and the following two interfaces are part of ae1:
xe-0/0/44 on Switch A and
xe-0/0/46 on Switch B.
.

Configuration

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

Note: This example shows how to configure MC-LAG using both the original CLI and Enhanced Layer 2 Software (ELS).

In ELS, there are different statements and one additional statement that are different from the original CLI:

  • The port-mode statement in the [edit interfaces interface-name unit number family ethernet-switching] hierarchy is not supported. Use the interface-mode statement instead.
  • The vlan statement in the [edit interfaces interface-name] hierarchy is not supported. Use the irb statement instead.
  • The vlan.logical-interface-number hierarchy in the [edit vlans vlan-name l3-interface] option is not supported. Use the irb.logical-interface-number option instead.
  • The service-id statement in the [edit switch-options] hierarchy is required in the ELS CLI.

Switch A—Original CLI

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/12 ether-options 802.3ad ae0
set interfaces xe-0/0/13 ether-options 802.3ad ae0
set interfaces xe-0/0/44 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae0 unit 0 family ethernet-switching vlan members v100
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control active
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces vlan unit 500 family inet address 3.3.3.2/24
set vlans v100 vlan-id 100
set vlans v500 vlan-id 500
set vlans v500 l3-interface vlan.500
set protocols iccp local-ip-addr 3.3.3.2
set protocols iccp peer 3.3.3.1 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.1 backup-liveness-detection backup-peer-ip 10.207.64.233
set protocols iccp peer 3.3.3.1 liveness-detection minimum-receive-interval 1000
set protocols iccp peer 3.3.3.1 liveness-detection transmit-interval minimum-interval 1000
set protocols rstp interface ae0.0 disable
set protocols rstp interface ae1.0 edge
set protocols rstp interface all mode point-to-point
set protocols rstp bpdu-block-on-edge
set multi-chassis multi-chassis-protection 3.3.3.1 interface ae0

Switch A—ELS

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/12 ether-options 802.3ad ae0
set interfaces xe-0/0/13 ether-options 802.3ad ae0
set interfaces xe-0/0/44 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae0 unit 0 family ethernet-switching vlan members v100
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control active
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces irb unit 500 family inet address 3.3.3.2/24
set vlans v100 vlan-id 100
set vlans v500 vlan-id 500
set vlans v500 l3-interface irb.500
set protocols iccp local-ip-addr 3.3.3.2
set protocols iccp peer 3.3.3.1 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.1 backup-liveness-detection backup-peer-ip 10.207.64.233
set protocols iccp peer 3.3.3.1 liveness-detection minimum-receive-interval 1000
set protocols iccp peer 3.3.3.1 liveness-detection transmit-interval minimum-interval 1000
set protocols rstp interface ae1.0 edge
set protocols rstp interface ae1.0 mode point-to-point
set protocols rstp bpdu-block-on-edge
set multi-chassis multi-chassis-protection 3.3.3.1 interface ae0
set switch-options service-id 10

Switch B—Original CLI

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/12 ether-options 802.3ad ae0
set interfaces xe-0/0/13 ether-options 802.3ad ae0
set interfaces xe-0/0/46 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae0 unit 0 family ethernet-switching vlan members v100
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control standby
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces vlan unit 500 family inet address 3.3.3.1/24
set vlans v100 vlan-id 100
set vlans v500 vlan-id 500
set vlans v500 l3-interface vlan.500
set protocols iccp local-ip-addr 3.3.3.1
set protocols iccp peer 3.3.3.2 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.2 backup-liveness-detection backup-peer-ip 10.207.64.234
set protocols iccp peer 3.3.3.2 liveness-detection minimum-receive-interval 1000
set protocols iccp peer 3.3.3.2 liveness-detection transmit-interval minimum-interval 1000
set protocols rstp interface ae0.0 disable
set protocols rstp interface ae1.0 edge
set protocols rstp interface all mode point-to-point
set protocols rstp bpdu-block-on-edge
set multi-chassis multi-chassis-protection 3.3.3.2 interface ae0

Switch B—ELS

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/12 ether-options 802.3ad ae0
set interfaces xe-0/0/13 ether-options 802.3ad ae0
set interfaces xe-0/0/46 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae0 unit 0 family ethernet-switching vlan members v100
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control standby
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces irb unit 500 family inet address 3.3.3.1/24
set vlans v100 vlan-id 100
set vlans v500 vlan-id 500
set vlans v500 l3-interface irb.500
set protocols iccp local-ip-addr 3.3.3.1
set protocols iccp peer 3.3.3.2 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.2 backup-liveness-detection backup-peer-ip 10.207.64.234
set protocols iccp peer 3.3.3.2 liveness-detection minimum-receive-interval 1000
set protocols iccp peer 3.3.3.2 liveness-detection transmit-interval minimum-interval 1000
set protocols rstp interface ae1.0 edge
set protocols rstp interface ae1.0 mode point-to-point
set protocols rstp bpdu-block-on-edge
set multi-chassis multi-chassis-protection 3.3.3.2 interface ae0
set switch-options service-id 10

Configuring MC-LAG on Two Switches

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To enable multichassis protection link between MC-LAG peers:

  1. Configure the number of LAGs on both Switch A and Switch B.
    [edit chassis]user@switch# set aggregated-devices ethernet device-count 2
  2. Add member interfaces to the aggregated Ethernet interfaces on both Switch A and Switch B.
    [edit interfaces]
    user@switch# set xe-0/0/12 ether-options 802.3ad ae0
    [edit interfaces]
    user@switch# set xe-0/0/13 ether-options 802.3ad ae0

    Switch A:

    [edit interfaces]
    user@switch# set xe-0/0/44 ether-options 802.3ad ae1

    Switch B:

    [edit interfaces]
    user@switch# set xe-0/0/46 ether-options 802.3ad ae1
  3. Configure a trunk interface between Switch A and Switch B.

    Original CLI:

    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching port-mode trunk

    ELS:

    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching interface-mode trunk
  4. Configure a multichassis protection link between Switch A and Switch B.

    Switch A:

    [edit]
    user@switch# set multi-chassis multi-chassis-protection 3.3.3.1 interface ae0

    Switch B:

    [edit]
    user@switch# set multi-chassis multi-chassis-protection 3.3.3.2 interface ae0

Step-by-Step Procedure

To enable ICCP:

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

  1. Configure the local IP address to be in the ICCP connection on Switch A and Switch B.

    Switch A:

    [edit protocols]
    user@switch# set iccp local-ip-addr 3.3.3.2

    Switch B:

    [edit protocols]
    user@switch# set iccp local-ip-addr 3.3.3.1
  2. Configure the peer IP address and minimum receive interval for a (BFD) session for ICCP on Switch A and Switch B.

    Switch A:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 liveness-detection minimum-receive-interval 1000

    Switch B:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 liveness-detection minimum-receive-interval 1000
  3. Configure the peer IP address and minimum transmit interval for Bidirectional Forwarding Detection (BFD) session for ICCP on Switch A and Switch B.

    Switch A:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 liveness-detection transmit-interval minimum-interval 1000

    Switch B:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 liveness-detection transmit-interval minimum-interval 1000
  4. (Optional) Configure the time during which an ICCP connection must succeed between MC-LAG peers on Switch A and Switch B.

    Note: Configuring session establishment hold time helps to establish a faster ICCP connection . The recommended value is 50 seconds.

    Switch A:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 session-establishment-hold-time 50

    Switch B:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 session-establishment-hold-time 50
  5. (Optional) Configure the backup IP address to be used for backup liveness detection on both Switch A and Switch B.

    Note: By default, backup liveness detection is not enabled. Configuring a backup IP address helps achieve sub-second traffic loss during a MC-LAG peer reboot.

    Switch A:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 backup-liveness-detection backup-peer-ip 10.207.64.233

    Switch B:

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 backup-liveness-detection backup-peer-ip 10.207.64.234
  6. Configure Layer 3 connectivity between the MC-LAG peers on both Switch A and Switch B.

    Original CLI:

    [edit vlans]
    user@switch# set v100 vlan-id 100
    [edit vlans]
    user@switch# set v500 vlan-id 500
    [edit vlans]
    user@switch# set v500 l3-interface vlan.500
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching port-mode trunk
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching vlan members v500
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching vlan members v100

    ELS:

    [edit vlans]
    user@switch# set v500 vlan-id 500
    [edit vlans]
    user@switch# set v500 l3-interface irb.500
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching interface-mode trunk
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching vlan members v500
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching vlan members v100

Step-by-Step Procedure

To enable the MC-LAG interface:

  1. Enable LACP on the MC-LAG interface on Switch A and Switch B.

    Note: At least one end needs to be active. The other end can be either active or passive.

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp active
  2. Specify the same multichassis aggregated Ethernet identification number on both MC-LAG peers on Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae mc-ae-id 3
  3. Specify the same service ID on Switch A and Switch B.

    ELS:

    [edit]
    user@switch# set switch-options service-id 10
  4. Specify a unique chassis ID for the MC-LAG on the MC-LAG peers on Switch A and Switch B.

    Switch A:

    [edit interfaces]
    set ae1 aggregated-ether-options mc-ae chassis-id 0

    Switch B:

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae chassis-id 1
  5. Specify the operating mode of the MC-LAG on both Switch A and Switch B.

    Note: Only active-active mode is supported at this time.

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae mode active-active
  6. Specify the status control for MC-LAG on Switch A and Switch B.

    Note: You must configure status control on both Switch A and Switch B hosting the MC-LAG. If one peer is in active mode, the other must be in standby mode.

    Switch A:

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae status-control active

    Switch B:

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae status-control standby
  7. Specify the number of seconds by which the bring-up of the multichassis aggregated Ethernet interface should be deferred after you reboot Switch A and Switch B.

    Note: The recommended value for maximum VLAN configuration (for example, 4,000 VLANS) is 240 seconds. If IGMP snooping is enabled on all of the VLANs, the recommended value is 420 seconds.

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae init-delay-time 240
  8. Specify the same LACP system ID for the MC-LAG on Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp system-ID 00:01:02:03:04:05
  9. Specify the same LACP administration key on both Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp admin-key 3
  10. Enable a VLAN on the MC-LAG on Switch A and Switch B-—Original CLI:
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching port-mode trunk
    [edit]
    user@switch# set vlans v100 vlan-id 100
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching vlan members v100
  11. Enable a VLAN on the MC-LAG on Switch A and Switch B using ELS:
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching interface-mode trunk
    [edit]
    user@switch# set vlans v100 vlan-id 100
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching vlan members v100

Step-by-Step Procedure

To enable RSTP:

  1. Enable RSTP globally on all interfaces on Switch A and Switch B.

    Note: The all option is not available on ELS, so you cannot issue this command on ELS.

    [edit]
    user@switch# set protocols rstp interface all mode point-to-point

    ELS:

    [edit]
    user@switch# set protocols rstp interface ae1.0 mode point-to-point
  2. Disable RSTP on the ICL-PL interfaces on Switch A and Switch B.

    Note: This command is not needed on ELS.

    [edit]
    user@switch# set protocols rstp interface ae0.0 disable
  3. Configure the MC-LAG interfaces as edge ports on Switch A and Switch B.

    Note: The ae1 interface is a downstream interface. This is why RSTP and bpdu-block-on-edge need to be configured.

    [edit]
    user@switch# set protocols rstp interface ae1.0 edge
  4. Enable BPDU blocking on all interfaces except for the ICL-PL interfaces on Switch A and Switch B.

    Note: The ae1 interface is a downstream interface. This is why RSTP and bpdu-block-on-edge need to be configured.

    [edit]
    user@switch# set protocols rstp bpdu-block-on-edge

Results

From configuration mode, confirm your configuration by entering the show chassis, show interfaces, show protocols, show multi-chassis, and show vlans commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

Switch A—Original CLI

user@SwitchA# show chassis
aggregated-devices {ethernet {device-count 2;}}
user@SwitchA# show interfaces
xe-0/0/12 {ether-options {802.3ad ae0;}}
xe-0/0/13 {ether-options {802.3ad ae0;}}
xe-0/0/44 {ether-options {802.3ad ae1;}}
ae0 {unit 0 {family ethernet-switching {port-mode trunk;vlan {members v500;}}}}
ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 0;mode active-active;status-control active;init-delay-time 240;}}unit 0 {family ethernet-switching {port-mode trunk;vlan {members v100;}}}}
vlan {unit 500 {family inet {address 3.3.3.2/24;}}}
user@SwitchA# show protocols
iccp {local-ip-addr 3.3.3.2;peer 3.3.3.1 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.233;}liveness-detection {minimum-receive-interval 1000;transmit-interval {minimum-interval 1000;}}}}
rstp {interface ae0.0 {disable;}interface ae1.0 {edge;}interface all {mode point-to-point;}bpdu-block-on-edge;}
user@SwitchA# show multi-chassis
multi-chassis-protection 3.3.3.1 {interface ae0;}
user@SwitchA# show vlans
v100 {vlan-id 100;}
v500 {vlan-id 500;l3-interface vlan.500;}

Switch A--ELS

user@SwitchA# show chassis
aggregated-devices {ethernet {device-count 2;}}
user@SwitchA# show interfaces
xe-0/0/12 {ether-options {802.3ad ae0;}}
xe-0/0/13 {ether-options {802.3ad ae0;}}
xe-0/0/44 {ether-options {802.3ad ae1;}}
ae0 {unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v500;}}}}
ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 0;mode active-active;status-control active;init-delay-time 240;}}unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v100;}}}}
vlan {unit 500 {family inet {address 3.3.3.2/24;}}}
user@SwitchA# show protocols
iccp {local-ip-addr 3.3.3.2;peer 3.3.3.1 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.233;}liveness-detection {minimum-receive-interval 1000;transmit-interval {minimum-interval 1000;}}}}
rstp {interface ae1.0 {edge;}mode point-to-point;}bpdu-block-on-edge;}
user@SwitchA# show multi-chassis
multi-chassis-protection 3.3.3.1 {interface ae0;}
user@SwitchA# show switch-optionsservice-id 10;
user@SwitchA# show vlans
v100 {vlan-id 100;}
v500 {vlan-id 500;l3-interface irb.500;}

Switch B—Original CLI

user@SwitchB# show chassis
aggregated-devices {ethernet {device-count 2;}}
user@SwitchB# show interfaces
xe-0/0/12 {ether-options {802.3ad ae0;}}
xe-0/0/13 {ether-options {802.3ad ae0;}}
xe-0/0/46 {ether-options {802.3ad ae1;}}
ae0 {unit 0 {family ethernet-switching {port-mode trunk;vlan {members v500;}}}}
ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 1;mode active-active;status-control standby;init-delay-time 240;}}unit 0 {family ethernet-switching {port-mode trunk;vlan {members v100;}}}}
vlan {unit 500 {family inet {address 3.3.3.1/24;}}}
user@SwitchB# show protocols
iccp {local-ip-addr 3.3.3.1;peer 3.3.3.2 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.234;}liveness-detection {minimum-receive-interval 1000;transmit-interval {minimum-interval 1000;}}}}
rstp {interface ae0.0 {disable;}interface ae1.0 {edge;}interface all {mode point-to-point;}bpdu-block-on-edge;}
user@SwitchB# show multi-chassis
multi-chassis-protection 3.3.3.2 {interface ae0;}
user@SwitchB# show vlans
v100 {vlan-id 100;}
v500 {vlan-id 500;l3-interface vlan.500;}

Switch B--ELS

user@SwitchB# show chassis
aggregated-devices {ethernet {device-count 2;}}
user@SwitchB# show interfaces
xe-0/0/12 {ether-options {802.3ad ae0;}}
xe-0/0/13 {ether-options {802.3ad ae0;}}
xe-0/0/46 {ether-options {802.3ad ae1;}}
ae0 {unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v500;}}}}
ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 1;mode active-active;status-control standby;init-delay-time 240;}}unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v100;}}}}
vlan {unit 500 {family inet {address 3.3.3.1/24;}}}
user@SwitchB# show protocols
iccp {local-ip-addr 3.3.3.1;peer 3.3.3.2 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.234;}liveness-detection {minimum-receive-interval 1000;transmit-interval {minimum-interval 1000;}}}}
rstp {interface ae1.0 {edge;}mode point-to-point;}bpdu-block-on-edge;}
user@SwitchB# show multi-chassis
multi-chassis-protection 3.3.3.2 {interface ae0;}
user@SwitchB# show switch-optionsservice-id 10;
user@SwitchB# show vlans
v100 {vlan-id 100;}
v500 {vlan-id 500;l3-interface irb.500;}

Verification

Verify that the configuration is working properly.

Verifying That ICCP Is Working on Switch A

Purpose

Verify that ICCP is running on Switch A.

Action

[edit]
user@switch> show iccp
Redundancy Group Information for peer 3.3.3.1
TCP Connection : Established Liveliness Detection : Up Client Application: MCSNOOPD Client Application: eswd

Meaning

This output shows that the TCP connection between the peers hosting the MC-LAG is up, liveness detection is up, and MCSNOOPD and ESWD client applications are running.

Verifying That ICCP Is Working on Switch B

Purpose

Verify that ICCP is running on Switch B.

Action

show iccp

[edit]
user@switch> show iccp
Redundancy Group Information for peer 3.3.3.2
TCP Connection : Established Liveliness Detection : Up Client Application: MCSNOOPD Client Application: eswd

Meaning

This output shows that the TCP connection between the peers hosting the MC-LAG is up, liveness detection is up, and MCSNOOPD and ESWD client applications are running.

Verifying That LACP Is Active on Switch A

Purpose

Verify that LACP is active on Switch A.

Action

[edit]
user@switch> show lacp interfaces
Aggregated interface: ae1
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/46      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/46    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/46                 Current   Fast periodic Collecting distributing

Meaning

This output shows that Switch A is participating in LACP negotiation.

Verifying That LACP Is Active on Switch B

Purpose

Verify that LACP is active on Switch B.

Action

[edit]
user@switch> show lacp interfaces
Aggregated interface: ae1
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/44      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/44    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/44                 Current   Fast periodic Collecting distributing

Meaning

This output shows that Switch B is participating in LACP negotiation.

Verifying That the Multichassis Aggregated Ethernet and ICL-PL Interfaces Are Up on Switch A

Purpose

Verify that the multichassis aggregated Ethernet and ICL-PL interfaces are up on Switch A.

Action

[edit]
user@switch> show interfaces mc-ae
Member Link                  : ae1
 Current State Machine's State: mcae active state
 Local Status                 : active
 Local State                  : up
 Peer Status                  : active
 Peer State                   : up
     Logical Interface        : ae1.0
     Topology Type            : bridge
     Local State              : up
     Peer State               : up
     Peer Ip/MCP/State        : 3.3.3.1 ae0.0 up

Meaning

This output shows that the multichassis aggregated Ethernet and ICL-PL interfaces on Switch A is up and active.

Verifying That the Multichassis Aggregated Ethernet and ICL-PL Interfaces Are Up on Switch B

Purpose

Verify that the multichassis aggregated Ethernet and ICL-PL interfaces are up on Switch B.

Action

[edit]
user@switch> show interfaces mc-ae
Member Link                  : ae1
 Current State Machine's State: mcae active state
 Local Status                 : active
 Local State                  : up
 Peer Status                  : active
 Peer State                   : up
     Logical Interface        : ae1.0
     Topology Type            : bridge
     Local State              : up
     Peer State               : up
     Peer Ip/MCP/State        : 3.3.3.2 ae0.0 up

Meaning

This output shows that the multichassis aggregated Ethernet and ICL-PL interface on Switch B is up and active.

Verifying That MAC Learning Is Occurring on Switch A and Switch B

Purpose

Verify that MAC learning is working on Switch A and B.

Action

[edit]
user@switch> show ethernet-switching table
Ethernet-switching table: 10 entries, 4 learned, 0 persistent entries
  VLAN              MAC address       Type         Age Interfaces
  v222              *                 Flood          - All-members
  v222              00:00:5e:00:01:01 Static         - Router
  v222              00:10:94:00:00:05 Learn(L)       33 ae0.0 (MCAE)
  v222              84:18:88:df:ac:ae Learn(R)        0 ae2.0

Meaning

The output shows four learned MAC addresses entries.

Troubleshooting

Troubleshooting a LAG That Is Down

Problem

The show interfaces terse command shows that the MC-LAG is down.

Solution

Check the following:

  1. Verify that there is no configuration mismatch.
  2. Verify that all member ports are up.
  3. Verify that the MC-LAG is part of family Ethernet switching (Layer 2 LAG).
  4. Verify that the MC-LAG member is connected to the correct MC-LAG member at the other end.

Published: 2015-03-16