IP Demultiplexing Interfaces
Demultiplexing (demux) interfaces are logical interfaces that share a common, underlying interface. You can create logical subscriber interfaces using static or dynamic demultiplexing interfaces. In addition, you can use IP demultiplexing interfaces or VLAN demultiplexing interfaces when creating logical subscriber interfaces.
Demultiplexing Interface Overview
Demux interfaces support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, or aggregated Ethernet underlying interfaces.
Demux interfaces are supported on M120 or MX Series routers only.
You can also configure demux interfaces dynamically. For information about how to configure dynamic IP demux or dynamic VLAN demux interfaces, see Configuring Dynamic Subscriber Interfaces Using IP Demux Interfaces in Dynamic Profiles or Configuring Dynamic Subscriber Interfaces Using VLAN Demux Interfaces in Dynamic Profiles.
To configure static demux interfaces, see Configuring a VLAN Demultiplexing Interface and Configuring an IP Demultiplexing Interface.
- IP Demux Interface Overview
- VLAN Demux Interface Overview
- Guidelines to Remember When Configuring A Demux Interface
- MAC Address Validation on Static Demux Interfaces
IP Demux Interface Overview
IP demux interfaces use the IP source address or IP destination address to demultiplex received packets when the subscriber is not uniquely identified by a Layer 2 circuit.
To determine which IP demux interface to use, the destination or source prefix is matched against the destination or source address of packets that the underlying interface receives. The underlying interface family type must match the demux interface prefix type.
VLAN Demux Interface Overview
VLAN demux interfaces use the VLAN ID to demultiplex received packets when the subscriber is not uniquely identified. A VLAN demux interface uses an underlying logical interface to receive packets.
To determine which VLAN demux interface to use, the VLAN ID is matched against that which the underlying interface receives.
VLAN demux subscriber interfaces over aggregated Ethernet physical interfaces are supported only for MX Series routers that have only Trio MPCs installed. If the router has other MPCs in addition to Trio MPCs, theCLI accepts the configuration but errors are reported when the subscriber interfaces are brought up.
Guidelines to Remember When Configuring A Demux Interface
Keep the following guidelines in mind when configuring the demux interface:
Demux interfaces are supported on M120 or MX Series routers only.
Only demux0 is supported. If you configure another demux interface, such as demux1, the configuration commit fails.
You can configure only one
demux0
interface per chassis, but you can define logical demux interfaces on top of it (for example,demux0.1
,demux0.2
, and so on).If the address in a received packet does not match any demux prefix, the packet is logically received on the underlying interface. For this reason, the underlying interface is often referred to as the primary interface.
- Points to Remember When Configuring an IP Demux Interface
- Points to Remember When Configuring a VLAN Demux Interface
Points to Remember When Configuring an IP Demux Interface
In addition to the guidelines in Guidelines to Remember When Configuring A Demux Interface, the following guidelines are to be noted when configuring an IP demux interface:
You must associate demux interfaces with an underlying logical interface.
Note:IP demux interfaces currently support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, and aggregated Ethernet underlying interfaces.
The demux underlying interface must reside on the same logical system as the demux interfaces that you configure over it.
IP demux interfaces currently supports the Internet Protocol version 4 (IPv4) suite inet and Internet Protocol version 6 (IPv6) suite inet6 family types.
You can configure more than one demux prefix for a given demux unit. However, you cannot configure the exact same demux prefix on two different demux units with the same underlying interface.
You can configure overlapping demux prefixes on two different demux units with the same underlying prefix. However, under this configuration, best match rules apply (in other words, the most specific prefix wins).
Points to Remember When Configuring a VLAN Demux Interface
In addition to the guidelines in Guidelines to Remember When Configuring A Demux Interface, the following guidelines are to be noted when configuring a VLAN demux interface:
You must associate VLAN demux interfaces with an underlying logical interface.
Note:VLAN demux interfaces currently support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, and aggregated Ethernet underlying interfaces.
The demux underlying interface must reside on the same logical system as the demux interfaces that you configure over it.
VLAN demux interfaces currently supports the Internet Protocol version 4 (IPv4) suite inet and Internet Protocol version 6 (IPv6) suite inet6 family types.
MAC Address Validation on Static Demux Interfaces
MAC address validation enables the router to validate that received packets contain a trusted IP source and an Ethernet MAC source address.
MAC address validation is supported on static demux interfaces on MX Series routers only.
There are two types of MAC address validation that you can configure:
Loose
Forwards packets when both the IP source address and the MAC source address match one of the trusted address tuples.
Drops packets when the IP source address matches one of the trusted tuples, but the MAC address does not support the MAC address of the tuple
Continues to forward packets when the source address of the incoming packet does not match any of the trusted IP addresses.
Strict
Forwards packets when both the IP source address and the MAC source address match one of the trusted address tuples.
Drops packets when the MAC address does not match the tuple's MAC source address, or when IP source address of the incoming packet does not match any of the trusted IP addresses.
See Also
Configuring an IP Demultiplexing Interface
Demultiplexing (demux) interfaces are logical interfaces that share a common, underlying interface. You can configure IP demultiplexing interfaces or VLAN demultiplexing interfaces.
To configure an IP demux interface, you must configure the demux prefixes that are used by the underlying interface and then configure the IP demultiplexing interface as explained in the following tasks:
- Configuring an IP Demux Underlying Interface
- Configuring the IP Demux Interface
- Configuring MAC Address Validation on Static IP Demux Interfaces
Configuring an IP Demux Underlying Interface
An IP demux interface uses an underlying logical interface to receive packets. To determine which IP demux interface to use, the destination or source prefix is matched against the destination or source address of packets that the underlying interface receives. The underlying interface family type must match the demux interface prefix type.
IP demux interfaces currently support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, and aggregated Ethernet underlying interfaces.
To configure a logical interface as an IP demux underlying interface with demux source:
To configure a logical interface as an IP demux underlying interface with demux destination:
In configuration mode, go to the
[edit interfaces]
hierarchy level:[edit] user@host# edit interfaces
Configure the interface as fe-x/y/z and the logical interface with the
unit
statement. Note that IP demux interfaces currently support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, and aggregated Ethernet underlying interfaces.[edit interfaces] user@host# edit fe-x/y/z unit logical-unit-number unit logical-unit-number
Configure the logical demux destination family type on the IP demux underlying interface as inet or inet6.
[edit interfaces fe-x/y/z unit logical-unit-number] user@host# set demux-destination (inet | inet6)
Save the configuration and move to top of the hierarchy level.
[edit interfaces fe-x/y/z unit logial-unit-number] user@host# commit user@host# top
Configuring the IP Demux Interface
You can configure one or more logical demux source prefixes or destination prefixes after specifying an underlying interface for the static demux interface to use. This underlying interface must reside on the same logical system as the demux interface.
You configure demux prefixes for use by the underlying interface. The demux prefixes can represent individual hosts or networks. For a given demux interface unit, you can configure either demux source or demux destination prefixes but not both.
You can choose not to configure a demux source or demux destination prefix. This type of configuration results in a transmit-only interface.
To configure the IP demux interface with source prefix:
To configure the IP demux interface with destination prefix:
In configuration mode, go to the
[edit interfaces]
hierarchy level:[edit] user@host# edit interfaces
Configure the interface as a logical demux interface (for example, demux0 interface) and configure the logical interface with the
unit
statement.Note:You can configure only one demux0 interface per chassis, but you can define logical demux interfaces on top of it (for example, demux0.1, demux0.2, and so on).
[edit interfaces] user@host# edit demux0 unit logical-unit-number
Configure the underlying interface on which the demux interface is running under the
demux-options
statement.[edit interfaces demux0 unit logical-unit-number] user@host# set demux-options underlying-interface interface-name
Configure the protocol family.
[edit interfaces demux0 unit logical-unit-number] user@host# edit family family
Configure one or more logical demux destination prefixes. The prefixes are matched against the destination address of packets that the underlying interface receives. When a match occurs, the packet is processed as if it was received on the demux interface.
[edit interfaces demux0 unit logical-unit-number family family] user@host# set demux-destination destination-prefix
Save the configuration and move to top of the hierarchy level.
[edit interfaces demux0 unit logical-unit-number family family] user@host# commit user@host# top
Configuring MAC Address Validation on Static IP Demux Interfaces
MAC address validation enables the router to validate that received packets contain a trusted IP source and an Ethernet MAC source address.
To configure MAC address validation for an IP demux interface:
Configuring a VLAN Demultiplexing Interface
Demultiplexing (demux) interfaces are logical interfaces that share a common, underlying interface. You can configure IP demultiplexing interfaces or VLAN demultiplexing interfaces.
To configure a VLAN demux interface, you must configure the demux prefixes that are used by the underlying interface and then configure the VLAN demultiplexing interface as explained by the following tasks:
- Configuring a VLAN Demux Underlying Interface
- Configuring the VLAN Demux Interface
- Configuring MAC Address Validation on Static VLAN Demux Interfaces
- Verifying a Demux Interface Configuration
Configuring a VLAN Demux Underlying Interface
A VLAN demux interface uses an underlying logical interface to receive packets. To determine which VLAN demux interface to use, the VLAN ID is matched against that which the underlying interface receives.
VLAN demux interfaces currently support only Gigabit Ethernet, Fast Ethernet, 10-Gigabit Ethernet, and aggregated Ethernet underlying interfaces.
VLAN demux subscriber interfaces over aggregated Ethernet physical interfaces are supported only for MX Series routers that have only Trio MPCs installed. If the router has other MPCs in addition to Trio MPCs, the CLI accepts the configuration but errors are reported when the subscriber interfaces are brought up
To configure a logical interface as a VLAN demux underlying interface with demux source:
To configure a logical interface as a VLAN demux underlying interface with demux destination:
In configuration mode, go to the
[edit interfaces]
hierarchy level:[edit] user@host# edit interfaces
Configure the interface as fe-x/y/z and the logical interface with the
unit
option.[edit interfaces] user@host# edit fe-x/y/z unit logical-unit-number unit logical-unit-number
Configure the VLAN ID. The VLAN ID is used to determine which VLAN demux interface to use, that is the VLAN ID is matched against that which the underlying interface receives.
[edit interfaces fe-x/y/z unit logical-unit-number] user@host# set vlan-id number
Configure the logical demux destination family type on the VLAN demux underlying interface as inet or inet6.
[edit interfaces fe-x/y/z unit logical-unit-number] user@host# set demux-destination (inet | inet6)
Save the configuration and move to top of the hierarchy level.
[edit interfaces fe-x/y/z unit logial-unit-number] user@host# commit user@host# top
Configuring the VLAN Demux Interface
You can configure one or more logical demux source prefixes or destination prefixes after specifying an underlying interface for the static demux interface to use. This underlying interface must reside on the same logical system as the demux interface.
You configure demux prefixes for use by the underlying interface. The demux prefixes can represent individual hosts or networks. For a given demux interface unit, you can configure either demux source prefix or demux destination prefixes but not both.
You can choose not to configure a demux source prefix or a demux destination prefix. This type of configuration results in a transmit-only interface
To configure VLAN demux interface with demux source prefix:
To configure VLAN demux interface with demux destination prefix:
In configuration mode, go to the
[edit interfaces]
hierarchy level:[edit] user@host# edit interfaces
Configure the interface as a logical demux interface (for example, demux0 interface) and configure the logical interface with the
unit
statement.Note:You can configure only one demux0 interface per chassis, but you can define logical demux interfaces on top of it (for example, demux0.1, demux0.2, and so on).
[edit interfaces] user@host# edit demux0 unit logical-unit-number
Configure the underlying interface on which the demux interface is running under the
demux-options
statement.[edit interfaces demux0 unit logical-unit-number] user@host# set demux-options underlying-interface interface-name
Configure the protocol family for the interface.
[edit interfaces demux0 unit logical-unit-number] user@host# edit family family
Configure one or more logical demux destination prefixes. The prefixes are matched against the destination address of packets that the underlying interface receives. When a match occurs, the packet is processed as if it was received on the demux interface.
[edit interfaces demux0 unit logical-unit-number family family] user@host# set demux-destination destination-prefix
Save the configuration and move to top of the hierarchy level.
[edit interfaces demux0 unit logical-unit-number] user@host# commit user@host# top
Configuring MAC Address Validation on Static VLAN Demux Interfaces
MAC address validation enables the router to validate that received packets contain a trusted IP source and an Ethernet MAC source address.
To configure MAC address validation for a VLAN demux interface:
Verifying a Demux Interface Configuration
Purpose
Check the configuration of a demux interface and its underlying interface when the following are configured:
Two VLANs are configured, where each VLAN consists of two IP demux interfaces.
One VLAN demultiplexes based on the source address
The other VLAN demultiplexes based on the destination address.
Action
From configuration mode on the MX Series router, run
the show interfaces fe-0/0/0
and show interfaces demux0
configuration mode commands.
user@host> show interfaces fe-0/0/0
vlan-tagging;
unit 100 {
vlan-id 100;
demux-source inet; # Enable demux of inet prefixes
family inet {
address 10.1.1.1/24;
filter {
input vlan1-primary-in-filter;
output vlan1-primary-out-filter;
}
mac-validate loose;
}
}
unit 200 {
vlan-id 200;
demux-destination inet; # Enable demux of inet using destination addresses
family inet {
address 20.1.1.1/24;
}
}
unit 300 {
vlan-id 300;
demux-source inet; # Enable demux of inet using source addresses
family inet {
address 20.1.2.1/24;
}
}
user@host> show interfaces demux0
unit 101 {
description vlan1-sub1;
demux-options {
underlying-interface fe-0/0/0.100;
}
family inet {
demux-source 10.1.1.0/24;
filter {
input vlan1-sub1-in-filter;
output vlan1-sub1-out-filter;
}
mac-validate loose;
}
}
unit 102 {
description vlan1-sub2;
demux-options {
underlying-interface fe-0/0/0.100;
}
family inet {
demux-source {
10.1.0.0/16;
10.2.1.0/24;
}
filter {
input vlan1-sub2-in-filter;
output vlan1-sub2-out-filter;
}
mac-validate loose;
}
}
unit 202 {
description vlan2-sub2;
demux-options {
underlying-interface fe-0/0/0.200;
}
family inet {
demux-destination 100.1.2.0/24;
}
}
unit 302 {
description vlan2-sub2;
demux-options {
underlying-interface fe-0/0/0.300;
}
family inet {
demux-source 100.1.2.0/24;
}
}