Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

Example: Configuring Multichassis Link Aggregation for Layer 3 Unicast Using VRRP on EX9200 Switches

There are two methods for enabling Layer 3 unicast functionality across a multichassis link aggregation group (MC-LAG). You can choose either to configure Virtual Router Redundancy Protocol (VRRP) over the integrated routing and bridging (IRB) interface or to synchronize the MAC addresses for the Layer 3 interfaces of the switches participating in the MC-LAG. The procedure to configure VRRP for use in a Layer 3 unicast MC-LAG is included in this example.

Requirements

This example uses the following hardware and software components:

  • Two EX9200 switches
  • Junos OS Release 13.2R1 or later

Before you configure an MC-LAG, be sure that you understand how to:

For a list of best practice configuration guidelines and important functional behavior for MC-LAGs, see the “MC-LAG Configuration Guidelines and Functional Behavior” section in the topic Understanding Multichassis Link Aggregation.

Overview

In this example, you configure an MC-LAG between two switches by including interfaces from both switches in an aggregated Ethernet interface (ae1). To support the MC-LAG, create a second aggregated Ethernet interface (ae0) for the interchassis link (ICL). Configure a multichassis protection link for the ICL, Interchassis Control Protocol (ICCP) for the peers hosting the MC-LAG, and Layer 3 connectivity between MC-LAG peers.

Note: Layer 3 connectivity is required for ICCP.

To complete the MC-LAG configuration, enable VRRP by completing the following tasks:

  1. Create an integrated routing and bridging (IRB) interface.
  2. Create a VRRP group and assign a virtual IP address that is shared between each switch in the VRRP group.
  3. Enable a member of a VRRP group to accept all packets destined for the virtual IP address if it is the master in the VRRP group.
  4. Configure Layer 3 connectivity between the VRRP groups.

Topology

The topology used in this example consists of two switches that host an MC-LAG, ae1. The two switches are connected to a server. Figure 1 shows the topology for this example.

Figure 1: Configuring an MC-LAG Between Switch A and Switch B

Configuring an MC-LAG Between Switch
A and Switch B

Table 1 details the topology used in this configuration example.

Table 1: Components of the Topology for Configuring an MC-LAG Between Two Switches

HostnameBase HardwareLink Aggregation Groups

Switch A

Switch B

EX9200 switch

  • ae0 is configured as an aggregated Ethernet interface, and is used as an ICL. The following interfaces are part of ae0:
    xe-0/0/2 and xe-0/0/3 on Switch A and
    xe-0/0/2 and xe-0/0/3 on Switch B.
  • ae1 is configured as an MC-LAG, and the following two interfaces are part of ae1:
    xe-0/0/4 on Switch A and
    xe-0/0/6 on Switch B.

Configuration

CLI Quick Configuration

To quickly configure this example:

  • Copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, and paste the commands into the CLI at the [edit] hierarchy level of Switch A.
set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/2 ether-options 802.3ad ae0
set interfaces xe-0/0/3 ether-options 802.3ad ae0
set interfaces xe-0/0/4 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control active
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces irb unit 100 family inet address 100.1.1.11/24 vrrp-group 1 virtual-address 100.1.1.1
set interfaces irb unit 100 family inet address 100.1.1.11/24 vrrp-group 1 priority 200
set interfaces irb unit 100 family inet address 100.1.1.11/24 vrrp-group 1 accept-data
set interfaces irb unit 500 family inet address 3.3.3.2/24
set vlans v100 vlan-id 100
set vlans v100 l3-interface irb.100
set vlans v500 vlan-id 500
set vlans v500 l3-interface irb.500
set protocols iccp local-ip-addr 3.3.3.2
set protocols iccp peer 3.3.3.1 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.1 backup-liveness-detection backup-peer-ip 10.207.64.233
set protocols iccp peer 3.3.3.1 liveness-detection minimum-receive-interval 60
set protocols iccp peer 3.3.3.1 liveness-detection transmit-interval minimum-interval 60
set protocols rstp interface ae0.0 disable
set multi-chassis multi-chassis-protection 3.3.3.1 interface ae0
  • Copy the following commands, paste them in a text file, remove any line breaks, change any details necessary to match your network configuration, and paste the commands into the CLI at the [edit] hierarchy level of Switch B.
set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/2 ether-options 802.3ad ae0
set interfaces xe-0/0/3 ether-options 802.3ad ae0
set interfaces xe-0/0/6 ether-options 802.3ad ae1
set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v500
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp system-id 00:01:02:03:04:05
set interfaces ae1 aggregated-ether-options lacp admin-key 3
set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 3
set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
set interfaces ae1 aggregated-ether-options mc-ae mode active-active
set interfaces ae1 aggregated-ether-options mc-ae status-control standby
set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members v100
set interfaces irb unit 100 family inet address 100.1.1.10/24 vrrp-group 1 virtual-address 100.1.1.1
set interfaces irb unit 100 family inet address 100.1.1.10/24 vrrp-group 1 priority 150
set interfaces irb unit 100 family inet address 100.1.1.10/24 vrrp-group 1 accept-data
set interfaces irb unit 500 family inet address 3.3.3.1/24
set vlans v100 vlan-id 100
set vlans v100 l3-interface irb.100
set vlans v500 vlan-id 500
set vlans v500 l3-interface irb.500
set protocols iccp local-ip-addr 3.3.3.1
set protocols iccp peer 3.3.3.2 session-establishment-hold-time 50
set protocols iccp peer 3.3.3.2 backup-liveness-detection backup-peer-ip 10.207.64.234
set protocols iccp peer 3.3.3.2 liveness-detection minimum-receive-interval 60
set protocols iccp peer 3.3.3.2 liveness-detection transmit-interval minimum-interval 60
set protocols rstp interface ae0.0 disable
set multi-chassis multi-chassis-protection 3.3.3.2 interface ae0

Configuring MC-LAG for Layer 3 Unicast Using VRRP on Two Switches

Step-by-Step Procedure

To enable a multichassis protection link between MC-LAG peers:

The following procedure requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

  1. Configure the number of LAGs on both Switch A and Switch B.
    [edit chassis]
    user@switch# set aggregated-devices ethernet device-count 2
  2. Add member interfaces to the aggregated Ethernet interfaces on both Switch A and Switch B.

    Switch A and Switch B

    [edit interfaces]
    user@switch# set xe-0/0/2 ether-options 802.3ad ae0
    [edit interfaces]
    user@switch# set xe-0/0/3 ether-options 802.3ad ae0

    Switch A

    [edit interfaces]
    user@switch# set xe-0/0/4 ether-options 802.3ad ae1

    Switch B

    [edit interfaces]
    user@switch# set xe-0/0/6 ether-options 802.3ad ae1
  3. Configure a trunk interface between Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching interface-mode trunk
  4. Configure a multichassis protection link between Switch A and Switch B.

    Switch A

    [edit]
    user@switch# set multi-chassis multi-chassis-protection 3.3.3.2 interface ae0

    Switch B

    [edit]
    user@switch# set multi-chassis multi-chassis-protection 3.3.3.1 interface ae0

Step-by-Step Procedure

To enable ICCP:

The following procedure requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

  1. Configure the local IP address to be in the ICCP connection on Switch A and Switch B.

    Switch A

    [edit protocols]
    user@switch# set iccp local-ip-addr 3.3.3.2

    Switch B

    [edit protocols]
    user@switch# set iccp local-ip-addr 3.3.3.1
  2. Configure the peer IP address, minimum receive interval, and minimum transmit interval for a Bidirectional Forwarding Detection (BFD) session for ICCP on Switch A and Switch B.

    Note: Configuring the minimum receive interval is required to enable BFD. We recommend a minimum receive interval value of 6 seconds.

    Switch A

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 liveness-detection minimum-receive-interval 60
    user@switch# set iccp peer 3.3.3.1 liveness-detection transmit-interval minimum-interval 60

    Switch B

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 liveness-detection minimum-receive-interval 60
    user@switch# set iccp peer 3.3.3.2 liveness-detection transmit-interval minimum-interval 60
  3. (Optional) Configure the time during which an ICCP connection must be established between MC-LAG peers on Switch A and Switch B.

    Note: Configuring session establishment hold time helps in faster ICCP connection establishment. The recommended value is 50 seconds.

    Switch A

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 session-establishment-hold-time 50

    Switch B

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 session-establishment-hold-time 50
  4. (Optional) We recommend that you configure the backup liveness detection feature to implement faster failover of data traffic during an MC-LAG peer reboot. Configure the backup-liveness-detection statement on the management interface (fxp0) only.

    Note: The backup-liveness-detection statement is supported starting in Junos OS Release 13.2R1.

    Switch A

    [edit protocols]
    user@switch# set iccp peer 3.3.3.1 backup-liveness-detection backup-peer-ip 10.207.64.233

    Switch B

    [edit protocols]
    user@switch# set iccp peer 3.3.3.2 backup-liveness-detection backup-peer-ip 10.207.64.234
  5. Configure Layer 3 connectivity between the MC-LAG peers on both Switch A and Switch B.

    Switch A and B

    [edit vlans]
    user@switch# set v500 vlan-id 500
    user@switch# set v500 l3-interface irb.500
    [edit interfaces]
    user@switch# set ae0 unit 0 family ethernet-switching vlan members v500

    Switch A

    user@switch# set vlan unit 500 family inet address 3.3.3.2/24

    Switch B

    user@switch# set vlan unit 500 family inet address 3.3.3.1/24

Step-by-Step Procedure

To enable the MC-LAG interface:

The following procedure requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

  1. Enable LACP on the MC-LAG interface on Switch A and Switch B.

    Note: At least one end needs to be active. The other end can be either active or passive.

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp active
  2. Specify the same multichassis aggregated Ethernet identification number on both MC-LAG peers on Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae mc-ae-id 3
  3. Specify a unique chassis ID for the MC-LAG on the MC-LAG peers on Switch A and Switch B.

    Switch A

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae chassis-id 0

    Switch B

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae chassis-id 1
  4. Specify the operating mode of the MC-LAG on both Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae mode active-active
  5. Specify the status control for MC-LAG on Switch A and Switch B.

    Note: You must configure status control on both Switch A and Switch B hosting the MC-LAG. If one peer is in active mode, the other must be in standby mode.

    Switch A

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae status-control active

    Switch B

    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae status-control standby

    Note: You can configure the prefer-status-control-active statement with the mc-ae status-control standby configuration to prevent the LACP MC-LAG system ID from reverting to the default LACP system ID on ICCP failure. Use this configuration only if you can ensure that ICCP will not go down unless the router or switch is down. You must also configure the hold-time down value (at the [edit interfaces interface-name] hierarchy level) for the ICL with the mc-ae status-control standby configuration to be higher than the ICCP BFD timeout. This configuration prevents data traffic loss by ensuring that when the router or switch with the mc-ae status-control active configuration goes down, the router or switch with the mc-ae status-control standby configuration does not go into standby mode.

    To make the prefer-status-control-active configuration work with the mc-ae status-control standby configuration when an ICL logical interface is configured on an aggregate Ethernet interface, you must either configure the lacp periodic interval statement at the [edit interfaces interface-name aggregated-ether-options] hierarchy level as slow or configure the detection-time threshold statement at the [edit protocols iccp peer liveness-detection] hierarchy level as less than 3 seconds.

    The prefer-status-control-active statement is supported starting in Junos OS Release 13.2R1.

  6. To minimize traffic loss, specify the number of seconds by which to delay bringing the mc-ae interface back to the up state when you reboot Switch A or Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options mc-ae init-delay-time 240
  7. Specify the same LACP system ID for the MC-LAG on Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp system-ID 00:01:02:03:04:05
  8. Specify the same LACP administration key on both Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 aggregated-ether-options lacp admin-key 3
  9. Enable a VLAN on the MC-LAG on Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching vlan members v100
    [edit]
    user@switch# set vlans v100 vlan-id 100
  10. Configure ae1 as the trunk interface between Switch A and Switch B.
    [edit interfaces]
    user@switch# set ae1 unit 0 family ethernet-switching interface-mode trunk

Step-by-Step Procedure

To enable VRRP on the MC-LAGs on Switch A and Switch B:

  1. Create an integrated routing and bridging (IRB) interface for each MC-LAG, assign a virtual IP address that is shared between each switch in the VRRP group, and assign an individual IP address for each switch in the VRRP group.

    Switch A

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.11/24 vrrp-group 1 virtual-address 10.1.1.1

    Switch B

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.10/24 vrrp-group 1 virtual-address 10.1.1.1
  2. Assign the priority for each switch in the VRRP group:

    Note: The switch configured with the highest priority is the master.

    Switch A

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.11/24 vrrp-group 1 priority 200

    Switch B

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.10/24 vrrp-group 1 priority 150
  3. Enable the switch to accept all packets destined for the virtual IP address if it is the master in a VRRP group:

    Switch A

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.11/24 vrrp-group 1 accept-data

    Switch B

    [edit interfaces]
    user@switch# set irb unit 100 family inet address 10.1.1.10/24 vrrp-group 1 accept-data
  4. Configure Layer 3 connectivity between Switch A and Switch B.
    [edit]
    user@switch# set vlans v100 l3-interface irb.100

Step-by-Step Procedure

To disable RSTP:

Note: STP is not supported on the ICL or MC-LAG interfaces.

The following procedure requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

  1. Disable RSTP on the ICL interfaces on Switch A and Switch B:
    [edit]
    user@switch# set protocols rstp interface ae0.0 disable

Results

Display the results of the configuration on Switch A.

chassis {aggregated-devices {ethernet {device-count 2;}}}interfaces {xe-0/0/2 {ether-options {802.3ad ae0;}}xe-0/0/3 {ether-options {802.3ad ae0;}}xe-0/0/4 {ether-options {802.3ad ae1;}}ae0 {unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v500;}}}}ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 0;mode active-active;status-control active;init-delay-time 240;}}unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v100;}}}}irb {unit 100 {family inet {address 100.1.1.11/24 {vrrp-group 1 {virtual-address 100.1.1.1;priority 200;accept-data;}}}}unit 500 {family inet {address 3.3.3.2/24;}}}}protocols {iccp {local-ip-addr 3.3.3.2;peer 3.3.3.1 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.233;}liveness-detection {minimum-receive-interval 60;transmit-interval {minimum-interval 60;}}}}rstp {interface ae0.0 {disable;}}}multi-chassis {multi-chassis-protection 3.3.3.1 {interface ae0;}}vlans {v100 {vlan-id 100;l3-interface irb.100;}v500 {vlan-id 500;l3-interface irb.500;}}

Display the results of the configuration on Switch B.

chassis {aggregated-devices {ethernet {device-count 2;}}}interfaces {xe-0/0/2 {ether-options {802.3ad ae0;}}xe-0/0/3 {ether-options {802.3ad ae0;}}xe-0/0/4 {ether-options {802.3ad ae1;}}ae0 {unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v500;}}}}ae1 {aggregated-ether-options {lacp {active;system-id 00:01:02:03:04:05;admin-key 3;}mc-ae {mc-ae-id 3;chassis-id 1;mode active-active;status-control active;init-delay-time 240;}}unit 0 {family ethernet-switching {interface-mode trunk;vlan {members v100;}}}}irb {unit 100 {family inet {address 100.1.1.10/24 {vrrp-group 1 {virtual-address 100.1.1.1;priority 200;accept-data;}}}}unit 500 {family inet {address 3.3.3.1/24;}}}}protocols {iccp {local-ip-addr 3.3.3.1;peer 3.3.3.2 {session-establishment-hold-time 50;backup-liveness-detection {backup-peer-ip 10.207.64.234;}liveness-detection {minimum-receive-interval 60;transmit-interval {minimum-interval 60;}}}}rstp {interface ae0.0 {disable;}}}multi-chassis {multi-chassis-protection 3.3.3.2 {interface ae0;}}vlans {v100 {vlan-id 100;l3-interface irb.100;}v500 {vlan-id 500;l3-interface irb.500;}}

Verification

To verify that the MC-LAG group has been created and is working properly, perform these tasks:

Verifying That ICCP Is Working on Switch A

Purpose

Verify that ICCP is running on Switch A.

Action

[edit]
user@switch# show iccp
Redundancy Group Information for peer 3.3.3.1
TCP Connection : Established Liveliness Detection : Up Client Application: MCSNOOPD Client Application: eswd

Meaning

This output shows that the TCP connection between the peers hosting the MC-LAG is up, liveness detection is up, and MCSNOOPD and ESWD client applications are running.

Verifying That ICCP Is Working on Switch B

Purpose

Verify that ICCP is running on Switch B.

Action

show iccp

[edit]
user@switch# show iccp
Redundancy Group Information for peer 3.3.3.2
TCP Connection : Established Liveliness Detection : Up Client Application: MCSNOOPD Client Application: eswd

Meaning

This output shows that the TCP connection between the peers hosting the MC-LAG is up, liveness detection is up, and MCSNOOPD and ESWD client applications are running.

Verifying That LACP Is Active on Switch A

Purpose

Verify that LACP is active on Switch A.

Action

[edit]
user@switch# show lacp interfaces
Aggregated interface: ae1
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/6       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/6     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/6                  Current   Fast periodic Collecting distributing

Meaning

This output shows that Switch A is participating in LACP negotiation.

Verifying That LACP Is Active on Switch B

Purpose

Verify that LACP is active on Switch B

Action

[edit]
user@switch# show lacp interfaces
Aggregated interface: ae1
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/4       Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/4     Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      xe-0/0/4                  Current   Fast periodic Collecting distributing

Meaning

This output shows that Switch B is participating in LACP negotiation.

Verifying That the MC-AE and ICL Interfaces Are Up on Switch A

Purpose

Verify that the MC-AE and ICL interfaces are up on Switch A.

Action

[edit]
user@switch# show interfaces mc-ae
Member Link                  : ae1
 Current State Machine's State: mcae active state
 Local Status                 : active
 Local State                  : up
 Peer Status                  : active
 Peer State                   : up
     Logical Interface        : ae1.0
     Topology Type            : bridge
     Local State              : up
     Peer State               : up
     Peer Ip/MCP/State        : 3.3.3.1 ae0.0 up

Meaning

This output shows that the MC-AE interface on Switch A is up and active.

Verifying That the MC-AE and ICL Interfaces Are Up on Switch B

Purpose

Verify that the MC-AE and ICL interfaces are up on Switch B.

Action

[edit]
user@switch# show interfaces mc-ae
Member Link                  : ae1
 Current State Machine's State: mcae active state
 Local Status                 : active
 Local State                  : up
 Peer Status                  : active
 Peer State                   : up
     Logical Interface        : ae1.0
     Topology Type            : bridge
     Local State              : up
     Peer State               : up
     Peer Ip/MCP/State        : 3.3.3.2 ae0.0 up

Meaning

This output shows that the MC-AE interface on Switch B is up and active.

Verifying That MAC Learning Is Occurring on Switch A

Purpose

Verify that MAC learning is working on Switch A.

Action

[edit]
user@switch# show ethernet-switching table
Ethernet-switching table: 6 entries, 1 learned, 0 persistent entriesC
  VLAN              MAC address       Type         Age Interfaces
  v100              *                 Flood          - All-members
  v100              00:00:5e:00:01:01 Static         - Router
  v100              78:fe:3d:5a:07:42 Static         - Router
  v100              78:fe:3d:5b:ad:c2 Learn(R)        0 ae0.0
  v500              *                 Flood          - All-members
  v500              78:fe:3d:5a:07:42 Static         - Router

Meaning

The output shows two static MAC address in VLAN v100 and one static MAC address in VLAN v500. These addresses belong to the Layer 3 IRB addresses on both Switch A and Switch B that you configured in the MC-LAG. The ICL interface configured on the VRRP master member learned the VLAN v100 Learn (R) MAC address of the VRRP backup member.

Verifying That MAC Learning Is Occurring on Switch B

Purpose

Verify that MAC learning is working on Switch B.

Action

[edit]
user@switch# show ethernet-switching table
Ethernet-switching table: 7 entries, 1 learned, 0 persistent entries
  VLAN              MAC address       Type         Age Interfaces
  v100              *                 Flood          - All-members
  v100              00:00:5e:00:01:01 Static         - Router
  v100              78:fe:3d:5a:07:42 Learn(R)        0 ae0.0
  v100              78:fe:3d:5b:ad:c2 Static         - Router
  v200              78:fe:3d:5b:ad:c2 Static         - Router
  v500              *                 Flood          - All-members
  v500              78:fe:3d:5b:ad:c2 Static         - Router

Meaning

The output shows two static MAC address in VLAN v100 and one static MAC address in VLAN v500. These addresses belong to the Layer 3 IRB addresses on both Switch A and Switch B that you configured in the MC-LAG. The ICL interface configured on the VRRP backup member learned the VLAN v100 Learn (R) MAC address of the VRRP master member.

Verifying That Switch A is the Master in the VRRP Group

Purpose

Verify that Switch A is the master member in the VRRP group.

Action

[edit]
user@switch# show vrrp
Interface     State       Group   VR state VR Mode   Timer    Type   Address
 irb.100      up              1   master   Active      A  0.605 lcl    100.1.1.11     
                                                                vip    100.1.1.1     

Meaning

The output shows that Switch A is the master member in the VRRP group.

Verifying That Switch B is the Backup Member in the VRRP Group

Purpose

Verify that Switch B is the backup member in the VRRP group.

Action

[edit]
user@switch# show vrrp
Interface     State       Group   VR state VR Mode   Timer    Type   Address
  irb.100       up              1   backup   Active      A  0.605 lcl    100.1.1.10     
                                                                vip    100.1.1.1     

Meaning

The output shows that Switch B is the backup member in the VRRP group.

Verifying That the Virtual IP Address is Attached to an Individual Address on Switch A

Purpose

Action

[edit]
user@switch# run show interfaces terse vlan
Interface               Admin Link Proto    Local                 Remote
irb                     up    up  
irb.100                 up    up   inet     100.1.1.1/24    
                                            100.1.1.11/24   
irb.500                 up    up   inet     3.3.3.2/24      

Meaning

The output shows that the virtual IP address (100.1.1.1/24) is bound to the individual IP address (100.1.1.11/24) on Switch A.

Verifying That the Virtual IP Address is Attached to an Individual Address on Switch B

Purpose

Action

[edit]
user@switch# run show interfaces terse vlan
Interface               Admin Link Proto    Local                 Remote
irb                     up    up  
irb.100                 up    up   inet     100.1.1.1/24    
                                            100.1.1.10/24   
irb.500                 up    up   inet     3.3.3.1/24      

Meaning

The output shows that the virtual IP address (100.1.1.1/24) is bound to the individual IP address (100.1.1.10/24) on Switch B.

Troubleshooting

Troubleshooting a LAG That Is Down

Problem

The show interfaces terse command shows that the MC-LAG is down

Solution

Check the following:

  • Verify that there is no configuration mismatch.
  • Verify that all member ports are up.
  • Verify that the MC-LAG is part of family Ethernet switching (Layer 2 LAG).
  • Verify that the MC-LAG member is connected to the correct MC-LAG member at the other end.

Published: 2015-03-16