Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
OSPF User Guide
Table of Contents Expand all
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Configuring OSPF on Logical Systems

date_range 22-Nov-23

OSPF Support for Logical Systems

This topic describes the following information:

Introduction to Logical Systems

With Junos OS, you can partition a single physical router into multiple logical devices that perform independent routing tasks. Because logical systems perform a subset of the tasks once handled by the main router, logical systems offer an effective way to maximize the use of a single routing or switching platform. Logical systems have their own unique routing tables, interfaces, policies, and routing instances.

OSPF and Logical Systems

You can configure both OSPF Version 2 (OSPFv2) and OSPF Version 3 (OSPFv3) for logical systems. In the case of OSPFv3, you can also configure OSPFv3 realms for logical systems, which allows OSPFv3 to advertise address families other than unicast IPv6.

You configure OSPF for logical systems at the following hierarchy levels:

  • [edit logical-systems logical-system-name protocols (ospf | ospf3)]

  • [edit logical-systems logical-system-name protocols ospf3 realm (ipv4-unicast | ipv4-multicast | ipv6-multicast)]

  • [edit logical-systems logical-system-name routing-instances routing-instance-name protocols (ospf | ospf3)]

  • [edit logical-systems logical-system-name routing-instances routing-instance-name protocols ospf3 realm (ipv4-unicast | ipv4-multicast | ipv6-multicast)]

Example: Configuring OSPF on Logical Systems Within the Same Router

This example shows how to configure an OSPF network using multiple logical systems that are running on a single physical router. The logical systems are connected by logical tunnel interfaces.

Requirements

Overview

This example shows the configuration of a single OSPF area with three logical systems running on one physical router. Each logical system has its own routing table. The configuration enables the protocol on all logical system interfaces that participate in the OSPF domain and specifies the area that the interfaces are in.

Topology

Figure 1 shows the sample network.

Figure 1: OSPF on Logical SystemsOSPF on Logical Systems

Configuration

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

content_copy zoom_out_map
set logical-systems LS1 interfaces lt-1/2/0 unit 0 description LS1->LS3 
set logical-systems LS1 interfaces lt-1/2/0 unit 0 encapsulation ethernet 
set logical-systems LS1 interfaces lt-1/2/0 unit 0 peer-unit 5 
set logical-systems LS1 interfaces lt-1/2/0 unit 0 family inet address 10.0.1.2/30 
set logical-systems LS1 interfaces lt-1/2/0 unit 2 description LS1->LS2 
set logical-systems LS1 interfaces lt-1/2/0 unit 2 encapsulation ethernet 
set logical-systems LS1 interfaces lt-1/2/0 unit 2 peer-unit 1 
set logical-systems LS1 interfaces lt-1/2/0 unit 2 family inet address 10.0.0.1/30 
set logical-systems LS1 protocols ospf area 0.0.0.0 interface lt-1/2/0.0 
set logical-systems LS1 protocols ospf area 0.0.0.0 interface lt-1/2/0.2 
set logical-systems LS2 interfaces lt-1/2/0 unit 1 description LS2->LS1 
set logical-systems LS2 interfaces lt-1/2/0 unit 1 encapsulation ethernet 
set logical-systems LS2 interfaces lt-1/2/0 unit 1 peer-unit 2 
set logical-systems LS2 interfaces lt-1/2/0 unit 1 family inet address 10.0.0.2/30 
set logical-systems LS2 interfaces lt-1/2/0 unit 4 description LS2->LS3 
set logical-systems LS2 interfaces lt-1/2/0 unit 4 encapsulation ethernet 
set logical-systems LS2 interfaces lt-1/2/0 unit 4 peer-unit 3 
set logical-systems LS2 interfaces lt-1/2/0 unit 4 family inet address 10.0.2.2/30 
set logical-systems LS2 protocols ospf area 0.0.0.0 interface lt-1/2/0.1 
set logical-systems LS2 protocols ospf area 0.0.0.0 interface lt-1/2/0.4 
set logical-systems LS3 interfaces lt-1/2/0 unit 3 description LS3->LS2 
set logical-systems LS3 interfaces lt-1/2/0 unit 3 encapsulation ethernet 
set logical-systems LS3 interfaces lt-1/2/0 unit 3 peer-unit 4 
set logical-systems LS3 interfaces lt-1/2/0 unit 3 family inet address 10.0.2.1/30 
set logical-systems LS3 interfaces lt-1/2/0 unit 5 description LS3->LS1 
set logical-systems LS3 interfaces lt-1/2/0 unit 5 encapsulation ethernet 
set logical-systems LS3 interfaces lt-1/2/0 unit 5 peer-unit 0 
set logical-systems LS3 interfaces lt-1/2/0 unit 5 family inet address 10.0.1.1/30 
set logical-systems LS3 protocols ospf area 0.0.0.0 interface lt-1/2/0.5 
set logical-systems LS3 protocols ospf area 0.0.0.0 interface lt-1/2/0.3

Procedure

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure OSPF on logical systems:

  1. Configure the logical tunnel interface on Logical System LS1 connecting to Logical System LS2.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 2 description LS1->LS2 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 2 encapsulation ethernet 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 2 peer-unit 1 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 2 family inet address 10.0.0.1/30
    
  2. Configure the logical tunnel interface on Logical System LS1 connecting to Logical System LS3.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 0 description LS1->LS3 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 0 encapsulation ethernet 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 0 peer-unit 5 
    user@host# set logical-systems LS1 interfaces lt-1/2/0 unit 0 family inet address 10.0.1.2/30
    
  3. Configure the logical tunnel interface on Logical System LS2 connecting to Logical System LS1.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 1 description LS2->LS1 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 1 encapsulation ethernet 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 1 peer-unit 2 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 1 family inet address 10.0.0.2/30
    
  4. Configure the logical tunnel interface on Logical System LS2 connecting to Logical System LS3.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 4 description LS2->LS3 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 4 encapsulation ethernet 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 4 peer-unit 3 
    user@host# set logical-systems LS2 interfaces lt-1/2/0 unit 4 family inet address 10.0.2.2/30
    
  5. Configure the logical tunnel interface on Logical System LS3 connecting to Logical System LS2.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 3 description LS3->LS2 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 3 encapsulation ethernet 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 3 peer-unit 4 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 3 family inet address 10.0.2.1/30
    
  6. Configure the logical tunnel interface on Logical System LS3 connecting to Logical System LS1.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 5 description LS3->LS1 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 5 encapsulation ethernet 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 5 peer-unit 0 
    user@host# set logical-systems LS3 interfaces lt-1/2/0 unit 5 family inet address 10.0.1.1/30
    
  7. Configure OSPF on all the interfaces.

    content_copy zoom_out_map
    [edit]
    user@host# set logical-systems LS1 protocols ospf area 0.0.0.0 interface lt-1/2/0.0 
    user@host# set logical-systems LS1 protocols ospf area 0.0.0.0 interface lt-1/2/0.2 
    user@host# set logical-systems LS2 protocols ospf area 0.0.0.0 interface lt-1/2/0.1 
    user@host# set logical-systems LS2 protocols ospf area 0.0.0.0 interface lt-1/2/0.4 
    user@host# set logical-systems LS3 protocols ospf area 0.0.0.0 interface lt-1/2/0.5 
    user@host# set logical-systems LS3 protocols ospf area 0.0.0.0 interface lt-1/2/0.3
    
  8. If you are done configuring the device, commit the configuration.

    content_copy zoom_out_map
    [edit]
    user@host# commit
    

Results

Confirm your configuration by issuing the show logical-systems command.

content_copy zoom_out_map
show logical-systems
LS1 {
    interfaces {
        lt-1/2/0 {
            unit 0 {
                description LS1->LS3;
                encapsulation ethernet;
                peer-unit 5;
                family inet {
                    address 10.0.1.2/30;
                }
            }
            unit 2 {
                description LS1->LS2;
                encapsulation ethernet;
                peer-unit 1;
                family inet {
                    address 10.0.0.1/30;
                }
            }
        }
    }
    protocols {
        ospf {
            area 0.0.0.0 {
                interface lt-1/2/0.0;
                interface lt-1/2/0.2;
            }
        }
    }
}
LS2 {
    interfaces {
        lt-1/2/0 {
            unit 1 {
                description LS2->LS1;
                encapsulation ethernet;
                peer-unit 2;
                family inet {
                    address 10.0.0.2/30;
                }
            }
            unit 4 {
                description LS2->LS3;
                encapsulation ethernet;
                peer-unit 3;
                family inet {
                    address 10.0.2.2/30;
                }
            }
        }
    }
    protocols {
        ospf {
            area 0.0.0.0 {
                interface lt-1/2/0.1;
                interface lt-1/2/0.4;
            }
        }
    }
}
LS3 {
    interfaces {
        lt-1/2/0 {
            unit 3 {
                description LS3->LS2;
                encapsulation ethernet;
                peer-unit 4;
                family inet {
                    address 10.0.2.1/30;
                }
            }
            unit 5 {
                description LS3->LS1;
                encapsulation ethernet;
                peer-unit 0;
                family inet {
                    address 10.0.1.1/30;
                }
            }
        }
    }
    protocols {
        ospf {
            area 0.0.0.0 {
                interface lt-1/2/0.5;
                interface lt-1/2/0.3;
            }
        }
    }
}

Verification

Confirm that the configuration is working properly.

Verifying That the Logical Systems Are Up

Purpose

Make sure that the interfaces are properly configured.

Action
content_copy zoom_out_map
user@host> show interfaces terse
Interface               Admin Link Proto    Local                 Remote
...
lt-1/2/0                up    up  
lt-1/2/0.0              up    up   inet     10.0.1.2/30     
lt-1/2/0.1              up    up   inet     10.0.0.2/30     
lt-1/2/0.2              up    up   inet     10.0.0.1/30     
lt-1/2/0.3              up    up   inet     10.0.2.1/30     
lt-1/2/0.4              up    up   inet     10.0.2.2/30     
lt-1/2/0.5              up    up   inet     10.0.1.1/30     
...

Verifying Connectivity Between the Logical Systems

Purpose

Make sure that the OSPF adjacencies are established by checking the OSPF neighbor tables, checking the routing tables, and pinging the logical systems.

Action
content_copy zoom_out_map
user@host> show ospf neighbor logical-system LS1
Address          Interface              State     ID               Pri  Dead
10.0.1.1         lt-1/2/0.0             Full      10.0.1.1         128    37
10.0.0.2         lt-1/2/0.2             Full      10.0.0.2         128    33
content_copy zoom_out_map
user@host> show ospf neighbor logical-system LS2
Address          Interface              State     ID               Pri  Dead
10.0.0.1         lt-1/2/0.1             Full      10.0.0.1         128    32
10.0.2.1         lt-1/2/0.4             Full      10.0.1.1         128    36
content_copy zoom_out_map
user@host> show ospf neighbor logical-system LS3
Address          Interface              State     ID               Pri  Dead
10.0.2.2         lt-1/2/0.3             Full      10.0.0.2         128    36
10.0.1.2         lt-1/2/0.5             Full      10.0.0.1         128    37
content_copy zoom_out_map
user@host> show route logical-system LS1
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.0.0/30        *[Direct/0] 00:28:00
                    > via lt-1/2/0.2
10.0.0.1/32        *[Local/0] 00:28:00
                      Local via lt-1/2/0.2
10.0.1.0/30        *[Direct/0] 00:28:00
                    > via lt-1/2/0.0
10.0.1.2/32        *[Local/0] 00:28:00
                      Local via lt-1/2/0.0
10.0.2.0/30        *[OSPF/10] 00:27:05, metric 2
                    > to 10.0.1.1 via lt-1/2/0.0
                      to 10.0.0.2 via lt-1/2/0.2
224.0.0.5/32       *[OSPF/10] 00:28:03, metric 1
                      MultiRecv
content_copy zoom_out_map
user@host> show route logical-system LS2
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.0.0/30        *[Direct/0] 00:28:31
                    > via lt-1/2/0.1
10.0.0.2/32        *[Local/0] 00:28:32
                      Local via lt-1/2/0.1
10.0.1.0/30        *[OSPF/10] 00:27:38, metric 2
                    > to 10.0.0.1 via lt-1/2/0.1
                      to 10.0.2.1 via lt-1/2/0.4
10.0.2.0/30        *[Direct/0] 00:28:32
                    > via lt-1/2/0.4
10.0.2.2/32        *[Local/0] 00:28:32
                      Local via lt-1/2/0.4
224.0.0.5/32       *[OSPF/10] 00:28:34, metric 1
                      MultiRecv
content_copy zoom_out_map
user@host> show route logical-system LS3
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.0.0/30        *[OSPF/10] 00:28:23, metric 2
                    > to 10.0.2.2 via lt-1/2/0.3
                      to 10.0.1.2 via lt-1/2/0.5
10.0.1.0/30        *[Direct/0] 00:29:13
                    > via lt-1/2/0.5
10.0.1.1/32        *[Local/0] 00:29:15
                      Local via lt-1/2/0.5
10.0.2.0/30        *[Direct/0] 00:29:14
                    > via lt-1/2/0.3
10.0.2.1/32        *[Local/0] 00:29:15
                      Local via lt-1/2/0.3
224.0.0.5/32       *[OSPF/10] 00:29:16, metric 1
                      MultiRecv

From LS1, Ping LS3

content_copy zoom_out_map
user@host> set cli logical-system LS1
content_copy zoom_out_map
user@host:LS1> ping 10.0.2.1
PING 10.0.2.1 (10.0.2.1): 56 data bytes
64 bytes from 10.0.2.1: icmp_seq=0 ttl=64 time=1.215 ms
64 bytes from 10.0.2.1: icmp_seq=1 ttl=64 time=1.150 ms
64 bytes from 10.0.2.1: icmp_seq=2 ttl=64 time=1.134 ms

From LS3, Ping LS1

content_copy zoom_out_map
user@host> set cli logical-system LS3
content_copy zoom_out_map
user@host:LS3> ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1): 56 data bytes
64 bytes from 10.0.0.1: icmp_seq=0 ttl=64 time=1.193 ms
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=1.114 ms
64 bytes from 10.0.0.1: icmp_seq=2 ttl=64 time=1.190 ms
footer-navigation