The router is shipped with the Junos operating system (OS) preinstalled
and ready to be configured when the router is powered on. Two 16-MB
internal NAND Flash memory devices are located on the baseboard for
BIOS storage. The USB storage device can be inserted into the USB
slot on the chassis faceplate. The router also supports two built-in
M.2-based solid-state drive (SSD) slots. These two SSD devices act
as the primary boot devices (SSD0 and SSD1). When the router boots, it first attempts to start
the Junos OS image on the USB flash drive if it detects one. If a
USB flash drive is not inserted into the router, or the attempt otherwise
fails, the router next tries the primary boot device, and then tries
the secondary boot device.
You configure the router by issuing Junos OS command-line interface
(CLI) commands, either on a console device attached to the CON port on the front panel, or over a Telnet connection
to a network connected to the MGMT port on the
front panel.
Gather the following information before configuring the
router:
Name the router will use on the network
Domain name the router will use
IP address and prefix length information for the Ethernet
interface
IP address of a default router
IP address of a DNS server
Password for the root user
This procedure connects the router to the network but
does not enable it to forward traffic. For complete information about
enabling the router to forward traffic, including examples, see the
Junos OS configuration guides.
To configure the software:
- Verify that the router is powered on.
- Log in as the “root” user. There is no password.
- Start the CLI. For more information about CLI commands,
see the CLI Explorer.
- Enter configuration mode.
cli> configure
[edit]
root@#
- Configure the name of
the router. If the name includes spaces, enclose the name in quotation
marks (“ ”).
[edit]
root@# set system host-name host-name
- Create a management console user account.
[edit]
root@# set system login user user-name authentication plain-text-password
New password: password
Retype new password: password
- Set the user account class to super-user.
[edit]
root@# set system login user user-name class super-user
- Configure the router’s domain name.
[edit]
root@# set system domain-name domain-name
- Configure the IP address and prefix length for the router’s
Ethernet interface.
[edit]
root@# set interfaces fxp0 unit 0 family inet address address/prefix-length
- Configure the IP address of a backup router, which is
used only while the routing protocol is not running.
[edit]
root@# set system backup-router address
- Configure the IP address of a DNS server.
[edit]
root@# set system name-server address
- Set the root authentication password by entering either
a cleartext password, an encrypted password, or an SSH public key
string (DSA or RSA).
[edit]
root@# set system root-authentication plain-text-password
New password: password
Retype new password: password
or
[edit]
root@# set system root-authentication encrypted-password encrypted-password
or
[edit]
root@# set system root-authentication ssh-dsa public-key
or
[edit]
root@# set system root-authentication ssh-rsa public-key
- (Optional) Configure the static routes to remote subnets
with access to the management port. Access to the management port
is limited to the local subnet. To access the management port from
a remote subnet, you need to add a static route to that subnet within
the routing table. For more information about static routes, see the Junos OS Administration Library for Routing Devices.
[edit]
root@# set routing-options static route remote-subnet next-hop destination-IP retain no-readvertise
- Configure the Telnet service at the
[edit system
services]
hierarchy level.[edit]
root@# set system services telnet
- (Optional) Display the configuration to verify that it
is correct.
[edit]
root@# show
system {
host-name host-name;
domain-name domain-name;
backup-router address;
root-authentication {
authentication-method (password | public-key);
}
name-server {
address;
}
}
interfaces {
fxp0 {
unit 0 {
family inet {
address address/prefix-length;
}
}
}
}
- Commit the configuration
to activate it on the router.
- (Optional) Configure
additional properties by adding the necessary configuration statements.
Then commit the changes to activate them on the router.
- When you have finished configuring the router, exit configuration
mode.
[edit]
root@host# exit
root@host>