RIPng Timers
Example: Configuring RIPng Update Interval
This example shows how to configure the RIPng update interval and how to monitor the impact of the change.
Requirements
No special configuration beyond device initialization is required before configuring this example.
Overview
In this example, Device R2 has an update interval of 60 seconds for its neighbor Device R1, and an update interval of 10 seconds for its neighbor Device R3.
This example is not necessarily practical, but it is shown for demonstration purposes. Generally, we recommend against changing the RIPng timers, unless the effects of a change are well understood. Normally, the default values are best left in effect for standard operations.
An export policy is also shown because an export policy is required as part of the minimum configuration for RIPng.
Figure 1 shows the topology used in this example.
CLI Quick Configuration shows the configuration for all of the devices in Figure 1. The section #d37e66__d37e190 describes the steps on Device R2.
Topology
Configuration
Procedure
CLI Quick Configuration
To quickly configure
this example, copy the following commands, paste them into a text
file, remove any line breaks, change any details necessary to match
your network configuration, and then copy and paste the commands into
the CLI at the [edit]
hierarchy level.
Device R1
set interfaces fe-1/2/0 unit 1 description to-R2 set interfaces fe-1/2/0 unit 1 family inet6 address 2001:db8:0:1::/64 eui-64 set interfaces lo0 unit 1 family inet6 address 2001:db8::1/128 set protocols ripng group ripng-group export advertise-routes-through-ripng set protocols ripng group ripng-group neighbor fe-1/2/0.1 set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol direct set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol ripng set policy-options policy-statement advertise-routes-through-ripng term 1 then accept
Device R2
set interfaces fe-1/2/0 unit 2 description to-R1 set interfaces fe-1/2/0 unit 2 family inet6 address 2001:db8:0:2::/64 eui-64 set interfaces fe-1/2/1 unit 5 description to-R3 set interfaces fe-1/2/1 unit 5 family inet6 address 2001:db8:0:3::/64 eui-64 set interfaces lo0 unit 2 family inet6 address 2001:db8::2/128 set protocols ripng group ripng-group export advertise-routes-through-ripng set protocols ripng group ripng-group neighbor fe-1/2/0.2 update-interval 60 set protocols ripng group ripng-group neighbor fe-1/2/1.5 update-interval 10 set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol direct set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol ripng set policy-options policy-statement advertise-routes-through-ripng term 1 then accept
Device R3
set interfaces fe-1/2/0 unit 6 description to-R2 set interfaces fe-1/2/0 unit 6 family inet6 address 2001:db8:0:4::/64 eui-64 set interfaces lo0 unit 3 family inet6 address 2001:db8::3/128 set protocols ripng group ripng-group export advertise-routes-through-ripng set protocols ripng group ripng-group neighbor fe-1/2/0.6 set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol direct set policy-options policy-statement advertise-routes-through-ripng term 1 from protocol ripng set policy-options policy-statement advertise-routes-through-ripng term 1 then accept
Step-by-Step Procedure
The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.
To configure the RIPng update interval:
Configure the network interfaces.
This example shows multiple loopback interface addresses to simulate attached networks.
[edit interfaces] user@R2# set fe-1/2/0 unit 2 description to-R1 user@R2# set fe-1/2/0 unit 2 family inet6 address 2001:db8:0:2::/64 eui-64 user@R2# set fe-1/2/1 unit 5 description to-R3 user@R2# set fe-1/2/1 unit 5 family inet6 address 2001:db8:0:3::/64 eui-64 user@R2# set lo0 unit 2 family inet6 address 2001:db8::2/128
Configure different update intervals for the two RIPng neighbors.
To configure RIPng in Junos OS, you must configure a group that contains the interfaces on which RIPng is enabled. You do not need to enable RIPng on the loopback interface.
[edit protocols ripng group ripng-group] user@R2# set neighbor fe-1/2/0.2 update-interval 60 user@R2# set neighbor fe-1/2/1.5 update-interval 10
Create the routing policy to advertise both direct and RIPng-learned routes.
[edit policy-options policy-statement advertise-routes-through-ripng term 1] user@R2# set from protocol direct user@R2# set from protocol ripng user@R2# set then accept
Apply the routing policy.
In Junos OS, you can only apply RIPng export policies at the group level.
[edit protocols ripng group ripng-group] user@R2# set export advertise-routes-through-ripng
Results
From configuration mode, confirm your configuration
by entering the show interfaces
, show protocols
, and show policy-options
commands. If the output does
not display the intended configuration, repeat the configuration instructions
in this example to correct it.
user@R2# show interfaces
fe-1/2/0 {
unit 2 {
description to-R1;
family inet6 {
address 2001:db8:0:2::/64 {
eui-64;
}
}
}
}
fe-1/2/1 {
unit 5 {
description to-R3;
family inet6 {
address 2001:db8:0:3::/64 {
eui-64;
}
}
}
}
lo0 {
unit 2 {
family inet6 {
address 2001:db8::2/128;
}
}
}
user@R2# show protocols
ripng {
group ripng-group {
export advertise-routes-through-ripng;
neighbor fe-1/2/0.2 {
update-interval 60;
}
neighbor fe-1/2/1.5 {
update-interval 10;
}
}
}
user@R2# show policy-options
policy-statement advertise-routes-through-ripng {
term 1 {
from protocol [ direct ripng ];
then accept;
}
}
If you are done configuring the device, enter commit from configuration mode.
Verification
Confirm that the configuration is working properly.
- Checking the RIPng Updates Sent by Device R2
- Checking the RIPng Updates Received by Device R2
- Checking the RIPng Updates Received by Device R3
Checking the RIPng Updates Sent by Device R2
Purpose
Make sure that the RIPng update packets are sent at the expected interval.
Action
From operational mode, enter the show ripng statistics
command.
user@R2> show ripng statistics RIPng info: port 521; holddown 120s. rts learned rts held down rqsts dropped resps dropped 4 0 0 0 fe-1/2/0.2: 2 routes learned; 5 routes advertised; timeout 180s; update interval 60s Counter Total Last 5 min Last minute ------- ----------- ----------- ----------- Updates Sent 1 1 1 Triggered Updates Sent 0 0 0 Responses Sent 0 0 0 Bad Messages 0 0 0 Updates Received 1 0 0 Bad Route Entries 0 0 0 Updates Ignored 0 0 0 RIPng Requests Received 0 0 0 RIPng Requests Ignored 0 0 0 fe-1/2/1.5: 2 routes learned; 5 routes advertised; timeout 180s; update interval 10s Counter Total Last 5 min Last minute ------- ----------- ----------- ----------- Updates Sent 6 2 2 Triggered Updates Sent 0 0 0 Responses Sent 0 0 0 Bad Messages 0 0 0 Updates Received 2 0 0 Bad Route Entries 0 0 0 Updates Ignored 0 0 0 RIPng Requests Received 0 0 0 RIPng Requests Ignored 0 0 0
Meaning
The update interval field shows that the interval is 60 seconds for its neighbor Device R1 and 10 seconds for its neighbor Device R3. The Updates Sent field shows that Device R2 is sending updates to Device R1 at roughly 1/6 of the rate that it is sending updates to Device R3.
Checking the RIPng Updates Received by Device R2
Purpose
Make sure that the RIPng update packets are sent at the expected interval.
Action
From operational mode, enter the show ripng statistics
command.
user@R1> show ripng statistics RIPng info: port 521; holddown 120s. rts learned rts held down rqsts dropped resps dropped 5 8 0 0 fe-1/2/0.1: 5 routes learned; 2 routes advertised; timeout 180s; update interval 30s Counter Total Last 5 min Last minute ------- ----------- ----------- ----------- Updates Sent 6 5 2 Triggered Updates Sent 0 0 0 Responses Sent 0 0 0 Bad Messages 0 0 0 Updates Received 3 3 1 Bad Route Entries 0 0 0 Updates Ignored 0 0 0 RIPng Requests Received 0 0 0 RIPng Requests Ignored 0 0 0
Meaning
The Updates Received field shows the number of updates received from Device R2.
Checking the RIPng Updates Received by Device R3
Purpose
Make sure that the RIPng update packets are sent at the expected interval.
Action
From operational mode, enter the show ripng statistics
command.
user@R3> show ripng statistics RIPng info: port 521; holddown 120s. rts learned rts held down rqsts dropped resps dropped 5 0 0 0 fe-1/2/0.6: 5 routes learned; 2 routes advertised; timeout 180s; update interval 30s Counter Total Last 5 min Last minute ------- ----------- ----------- ----------- Updates Sent 5 5 2 Triggered Updates Sent 0 0 0 Responses Sent 0 0 0 Bad Messages 0 0 0 Updates Received 16 15 6 Bad Route Entries 0 0 0 Updates Ignored 0 0 0 RIPng Requests Received 0 0 0 RIPng Requests Ignored 0 0 0
Meaning
The Updates Received field shows the number of updates received from Device R2.