サービスの改善にご協力お願いします。

お客様のご意見をお聞かせください。

アンケートの所要時間はおよそ 2 分です。

close
keyboard_arrow_left
list Table of Contents
このページで
keyboard_arrow_right

この機械翻訳はお役に立ちましたでしょうか?

starstarstarstarstar
Go to English page
免責事項:

このページは、サードパーティー製機械翻訳ソフトウェアを使用して翻訳されます。質の高い翻訳を提供するために合理的な対応はされていますが、ジュニパーネットワークスがその正確性を保証することはできかねます。この翻訳に含まれる情報の正確性について疑問が生じた場合は、英語版を参照してください. ダウンロード可能なPDF (英語版のみ).

例:ポリシーチェーンとルートフィルターの設定

date_range 04-Aug-24

ポリシー チェーンとは、設定の特定のセクション内で複数のポリシーを適用することです。ルート フィルターは、一致するプレフィックスの集合です。

要件

この例を設定する前に、デバイス初期化以外の特別な設定を行う必要はありません。

概要

BGPに適用されるポリシーチェーンの例を以下に示します。

content_copy zoom_out_map
user@R1# show protocols bgp
group int {
    type internal;
    local-address 192.168.0.1;
    export [ adv-statics adv-large-aggregates adv-small-aggregates ];
    neighbor 192.168.0.2;
    neighbor 192.168.0.3;
}

デフォルトのBGPポリシーに加えて、 adv-staticsadv-large-aggregates、および adv-small-aggregates ポリシーが、デバイスR1のBGPピアに適用されるポリシーチェーンを構成します。そのうちの 2 つのポリシーは、異なる一致タイプのルート フィルターを示しています。もう一方のポリシーはすべてのスタティック ルートに一致するため、ルート フィルターは必要ありません。

content_copy zoom_out_map
user@R1# show policy-options
policy-statement adv-large-aggregates {
    term between-16-and-18 {
        from {
            protocol aggregate;
            route-filter 172.16.0.0/16 upto /18;
        }
        then accept;
    }
}
policy-statement adv-small-aggregates {
    term between-19-and-24 {
        from {
            protocol aggregate;
            route-filter 172.16.0.0/16 prefix-length-range /19-/24;
        }
        then accept;
    }
}
policy-statement adv-statics {
    term statics {
        from protocol static;
        then accept;
    }
}

オプションとして、このポリシー チェーンを、内部 BGP(IBGP)ピア用の単一のマルチボックス ポリシーに変換できます。これを行うと、ポリシー チェーンの利点の 1 つである、ポリシーをさまざまな目的で再利用できるようになります。

図 1 AS 64510にあるデバイスR1を、そのIBGPピア、デバイスR2、デバイスR3とともに表示します。また、デバイスR1は、AS 64511内のデバイスR4およびAS 64512内のデバイスR5との外部BGP(EBGP)接続を持っています。AS 64510内の現在の管理ポリシーは、カスタマーの静的ルートのみを他のIBGPピアに送信することです。トランジットサービスを提供するEBGPピアは、マスク長が18ビット未満の集約ルートのみを受信します。ピアリングサービスを提供するEBGPピアは、すべての顧客ルートと、マスク長が19ビットを超えるすべてのアグリゲートを受信します。これらの管理ポリシーの各部分は、 [edit policy-opitons] 設定階層内の個別のルーティング ポリシーで設定されます。これらのポリシーは、AS 64510の管理者に対し、ピアへのルートアドバタイズメントについて複数の設定オプションを提供します。

デバイスR4は、AS 64510へのトランジットサービスを提供し、割り当てられたルーティングスペースをインターネットにアドバタイズすることを可能にします。一方、デバイスR5によって提供されるピアリングサービスでは、AS 64510が、すべてのカスタマールートの自律システム(AS)間で直接トラフィックをルーティングできます。

トポロジー

図 1は、サンプルのネットワークを示しています。

図 1: ポリシーチェーンのBGPトポロジーポリシーチェーンのBGPトポロジー

CLIクイック構成は、図 1でのすべてのデバイスの設定を示しています。

「手順」セクションでは、デバイス R1 の手順を説明します。

設定

CLIクイック構成

この例をすばやく設定するには、次のコマンドをコピーしてテキストファイルに貼り付け、改行を削除して、ネットワーク構成に合わせて必要な詳細を変更し、[edit]階層レベルのCLIにコマンドをコピー&ペーストしてください。

デバイスR1

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 0 description to_R2
set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.1/30
set interfaces fe-1/2/2 unit 0 description to_R3
set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.5/30
set interfaces fe-1/2/3 unit 0 description to_R4
set interfaces fe-1/2/3 unit 0 family inet address 10.1.0.5/30
set interfaces fe-1/2/1 unit 0 description to_R5
set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.10/30
set interfaces lo0 unit 0 family inet address 192.168.0.1/32
set protocols bgp group int type internal
set protocols bgp group int local-address 192.168.0.1
set protocols bgp group int export adv-statics
set protocols bgp group int export adv-large-aggregates
set protocols bgp group int export adv-small-aggregates
set protocols bgp group int neighbor 192.168.0.2
set protocols bgp group int neighbor 192.168.0.3
set protocols bgp group to_64511 type external
set protocols bgp group to_64511 export adv-large-aggregates
set protocols bgp group to_64511 neighbor 10.1.0.6 peer-as 64511
set protocols bgp group to_64512 type external
set protocols bgp group to_64512 export adv-small-aggregates
set protocols bgp group to_64512 export adv-statics
set protocols bgp group to_64512 neighbor 10.0.0.9 peer-as 64512
set protocols ospf area 0.0.0.0 interface fe-1/2/0.0
set protocols ospf area 0.0.0.0 interface fe-1/2/2.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set policy-options policy-statement adv-large-aggregates term between-16-and-18 from protocol aggregate
set policy-options policy-statement adv-large-aggregates term between-16-and-18 from route-filter 172.16.0.0/16 upto /18
set policy-options policy-statement adv-large-aggregates term between-16-and-18 then accept
set policy-options policy-statement adv-small-aggregates term between-19-and-24 from protocol aggregate
set policy-options policy-statement adv-small-aggregates term between-19-and-24 from route-filter 172.16.0.0/16 prefix-length-range /19-/24
set policy-options policy-statement adv-small-aggregates term between-19-and-24 then accept
set policy-options policy-statement adv-statics term statics from protocol static
set policy-options policy-statement adv-statics term statics then accept
set routing-options static route 172.16.1.16/28 discard
set routing-options static route 172.16.1.32/28 discard
set routing-options static route 172.16.1.48/28 discard
set routing-options static route 172.16.1.64/28 discard
set routing-options aggregate route 172.16.0.0/16
set routing-options aggregate route 172.16.1.0/24
set routing-options router-id 192.168.0.1
set routing-options autonomous-system 64510

デバイスR2

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 0 description to_R1
set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.2/30
set interfaces fe-1/2/1 unit 0 description to_R3
set interfaces fe-1/2/1 unit 0 family inet address 10.1.0.1/30
set interfaces lo0 unit 0 family inet address 192.168.0.2/32
set protocols bgp group int type internal
set protocols bgp group int local-address 192.168.0.2
set protocols bgp group int neighbor 192.168.0.1 export send-static-aggregate
set protocols bgp group int neighbor 192.168.0.3
set protocols ospf area 0.0.0.0 interface fe-1/2/0.0
set protocols ospf area 0.0.0.0 interface fe-1/2/1.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set policy-options policy-statement send-static-aggregate term 1 from protocol static
set policy-options policy-statement send-static-aggregate term 1 from protocol aggregate
set policy-options policy-statement send-static-aggregate term 1 then accept
set routing-options static route 172.16.2.16/28 discard
set routing-options static route 172.16.2.32/28 discard
set routing-options static route 172.16.2.48/28 discard
set routing-options static route 172.16.2.64/28 discard
set routing-options aggregate route 172.16.2.0/24
set routing-options aggregate route 172.16.0.0/16
set routing-options router-id 192.168.0.2
set routing-options autonomous-system 64510

デバイスR3

content_copy zoom_out_map
set interfaces fe-1/2/1 unit 0 description to_R2
set interfaces fe-1/2/1 unit 0 family inet address 10.1.0.2/30
set interfaces fe-1/2/2 unit 0 description to_R1
set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.6/30
set interfaces lo0 unit 0 family inet address 192.168.0.3/32
set protocols bgp group int type internal
set protocols bgp group int local-address 192.168.0.3
set protocols bgp group int neighbor 192.168.0.1 export send-static-aggregate
set protocols bgp group int neighbor 192.168.0.2
set protocols ospf area 0.0.0.0 interface fe-1/2/2.0
set protocols ospf area 0.0.0.0 interface fe-1/2/1.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set policy-options policy-statement send-static-aggregate from protocol static
set policy-options policy-statement send-static-aggregate from protocol aggregate
set policy-options policy-statement send-static-aggregate then accept
set routing-options static route 172.16.3.16/28 discard
set routing-options static route 172.16.3.32/28 discard
set routing-options static route 172.16.3.48/28 discard
set routing-options static route 172.16.3.64/28 discard
set routing-options aggregate route 172.16.0.0/16
set routing-options aggregate route 172.16.3.0/24
set routing-options router-id 192.168.0.3
set routing-options autonomous-system 64510

デバイス R4

content_copy zoom_out_map
set interfaces fe-1/2/3 unit 0 description to_R1
set interfaces fe-1/2/3 unit 0 family inet address 10.1.0.6/30
set interfaces lo0 unit 0 family inet address 192.168.0.4/32
set protocols bgp group ext type external
set protocols bgp group ext peer-as 64510
set protocols bgp group ext neighbor 10.1.0.5
set routing-options autonomous-system 64511

デバイス R5

content_copy zoom_out_map
set interfaces fe-1/2/1 unit 0 description to_R1
set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.9/30
set interfaces lo0 unit 0 family inet address 192.168.0.5/32
set protocols bgp group ext type external
set protocols bgp group ext neighbor 10.0.0.10 peer-as 64510
set routing-options autonomous-system 64512

手順

ステップバイステップでの手順

次の例では、設定階層内のさまざまなレベルに移動する必要があります。CLIのナビゲーションについては、Junos OS CLIユーザーガイドの「設定モードでのCLIエディターの使用」を参照してください。

Device R1を設定するには:

  1. デバイスインターフェイスを設定します。

    content_copy zoom_out_map
    [edit interfaces]
    user@R1# set fe-1/2/0 unit 0 description to_R2
    user@R1# set fe-1/2/0 unit 0 family inet address 10.0.0.1/30
    user@R1# set fe-1/2/2 unit 0 description to_R3
    user@R1# set fe-1/2/2 unit 0 family inet address 10.0.0.5/30
    user@R1# set fe-1/2/3 unit 0 description to_R4
    user@R1# set fe-1/2/3 unit 0 family inet address 10.1.0.5/30
    user@R1# set fe-1/2/1 unit 0 description to_R5
    user@R1# set fe-1/2/1 unit 0 family inet address 10.0.0.10/30
    user@R1# set lo0 unit 0 family inet address 192.168.0.1/32
    
  2. デバイスR2およびデバイスR3へのIBGP接続を設定します。

    content_copy zoom_out_map
    [edit protocols bgp group int]
    user@R1# set type internal
    user@R1# set local-address 192.168.0.1
    user@R1# set neighbor 192.168.0.2
    user@R1# set neighbor 192.168.0.3
    
  3. 内部ピアにエクスポートポリシーを適用します。

    content_copy zoom_out_map
    [edit protocols bgp group int]
    user@R1# set export adv-statics
    user@R1# set export adv-large-aggregates
    user@R1# set export adv-small-aggregates
    
  4. デバイスR4へのEBGP接続を設定します。

    content_copy zoom_out_map
    [edit protocols bgp group to_64511]
    user@R1# set type external
    user@R1# set neighbor 10.1.0.6 peer-as 64511
    
  5. デバイスR4にエクスポートポリシーを適用します。

    content_copy zoom_out_map
    [edit protocols bgp group to_64511]
    user@R1# set export adv-large-aggregates
    
  6. デバイスR5へのEBGP接続を設定します。

    content_copy zoom_out_map
    [edit protocols bgp group to_64512]
    user@R1# set type external
    user@R1# set neighbor 10.0.0.9 peer-as 64512
    
  7. デバイスR5のエクスポートポリシーを適用します。

    content_copy zoom_out_map
    [edit protocols bgp group to_64512]
    user@R1# set export adv-small-aggregates
    user@R1# set export adv-statics
    
  8. デバイスR2、デバイスR3へのOSPF接続を構成します。

    content_copy zoom_out_map
    [edit protocols ospf area 0.0.0.0]
    user@R1# set interface fe-1/2/0.0
    user@R1# set interface fe-1/2/2.0
    user@R1# set interface lo0.0 passive
    
  9. ルーティングポリシーを設定します。

    content_copy zoom_out_map
    [edit policy-options policy-statement adv-large-aggregates term between-16-and-18]
    user@R1# set from protocol aggregate
    user@R1# set from route-filter 172.16.0.0/16 upto /18
    user@R1# set then accept
    [edit policy-options policy-statement adv-small-aggregates term between-19-and-24]
    user@R1# set from protocol aggregate
    user@R1# set from route-filter 172.16.0.0/16 prefix-length-range /19-/24
    user@R1# set then accept
    [edit policy-options policy-statement adv-statics term statics]
    user@R1# set from protocol static
    user@R1# set then accept
    
  10. スタティックルートと集約ルートを設定します。

    content_copy zoom_out_map
    [edit routing-options static]
    user@R1# set route 172.16.1.16/28 discard
    user@R1# set route 172.16.1.32/28 discard
    user@R1# set route 172.16.1.48/28 discard
    user@R1# set route 172.16.1.64/28 discard
    [edit routing-options aggregate]
    user@R1# set route 172.16.0.0/16
    user@R1# set route 172.16.1.0/24
    
  11. 自律システム(AS)番号とルーターIDを設定します。

    content_copy zoom_out_map
    [edit routing-options]
    user@R1# set router-id 192.168.0.1
    user@R1# set autonomous-system 64510
    

結果

設定モードから、show interfacesshow protocolsshow policy-options、およびshow routing-options のコマンドを入力して設定を確認します。出力結果に意図した設定内容が表示されない場合は、この例の手順を繰り返して設定を修正します。

content_copy zoom_out_map
user@R1# show interfaces
fe-1/2/0 {
    unit 0 {
        description to_R2;
        family inet {
            address 10.0.0.1/30;
        }
    }
}
fe-1/2/2 {
    unit 0 {
        description to_R3;
        family inet {
            address 10.0.0.5/30;
        }
    }
}
fe-1/2/3 {
    unit 0 {
        description to_R4;
        family inet {
            address 10.1.0.5/30;
        }
    }
}
fe-1/2/1 {
    unit 0 {
        description to_R5;
        family inet {
            address 10.0.0.10/30;
        }
    }
}
lo0 {
    unit 0 {
        family inet {
            address 192.168.0.1/32;
        }
    }
}
content_copy zoom_out_map
user@R1# show protocols
bgp {
    group int {
        type internal;
        local-address 192.168.0.1;
        export [ adv-statics adv-large-aggregates adv-small-aggregates ];
        neighbor 192.168.0.2;
        neighbor 192.168.0.3;
    }
    group to_64511 {
        type external;
        export adv-large-aggregates;
        neighbor 10.1.0.6 {
            peer-as 64511;
        }
    }
    group to_64512 {
        type external;
        export [ adv-small-aggregates adv-statics ];
        neighbor 10.0.0.9 {
            peer-as 64512;
        }
    }
}
ospf {
    area 0.0.0.0 {
        interface fe-1/2/0.0;
        interface fe-1/2/2.0;
        interface lo0.0 {
            passive;
        }
    }
}
content_copy zoom_out_map
user@R1# show policy-options
policy-statement adv-large-aggregates {
    term between-16-and-18 {
        from {
            protocol aggregate;
            route-filter 172.16.0.0/16 upto /18;
        }
        then accept;
    }
}
policy-statement adv-small-aggregates {
    term between-19-and-24 {
        from {
            protocol aggregate;
            route-filter 172.16.0.0/16 prefix-length-range /19-/24;
        }
        then accept;
    }
}
policy-statement adv-statics {
    term statics {
        from protocol static;
        then accept;
    }
}
content_copy zoom_out_map
user@R1# show routing-options
static {
    route 172.16.1.16/28 discard;
    route 172.16.1.32/28 discard;
    route 172.16.1.48/28 discard;
    route 172.16.1.64/28 discard;
}
aggregate {
    route 172.16.0.0/16;
    route 172.16.1.0/24;
}
router-id 192.168.0.1;
autonomous-system 64510;

デバイスの設定が完了したら、設定モードから commit を入力します。

検証

設定が正常に機能していることを確認します。

デバイスR4へのルートアドバタイズを検証する

目的

デバイスR1上で、顧客ルートがデバイスR4へアドバタイズされることを確認します。

アクション

content_copy zoom_out_map
user@R1> show route advertising-protocol bgp 10.1.0.6

inet.0: 29 destinations, 31 routes (29 active, 0 holddown, 0 hidden)
  Prefix                  Nexthop              MED     Lclpref    AS path
* 172.16.0.0/16           Self                                    I
* 172.16.2.0/24           Self                                    I
* 172.16.2.16/28          Self                                    I
* 172.16.2.32/28          Self                                    I
* 172.16.2.48/28          Self                                    I
* 172.16.2.64/28          Self                                    I
* 172.16.3.0/24           Self                                    I
* 172.16.3.16/28          Self                                    I
* 172.16.3.32/28          Self                                    I
* 172.16.3.48/28          Self                                    I
* 172.16.3.64/28          Self                                    I

意味

adv-large-aggregatesポリシーは、デバイスR4とのピアリングセッションに適用され、16〜18ビットのサブネットマスク長で集約ルートをアドバタイズします。172.16.0.0/16 集約ルートは管理ポリシーの定義に従って送信されていますが、より大きなサブネット マスクを持つ他の多くのルートもデバイス R4 に送信されています。

長いルートの発信元を確認する

目的

デバイスR1で、他のルートがどこから来ているかを見つけます。

アクション

content_copy zoom_out_map
user@R1> show route 172.16.3.16/28

inet.0: 29 destinations, 31 routes (29 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.3.16/28     *[BGP/170] 20:16:00, localpref 100, from 192.168.0.3
                      AS path: I, validation-state: unverified
                    > to 10.0.0.6 via fe-1/2/2.0

意味

デバイスR1は、デバイスR3とのBGPセッションを通じてこのルートを学習しました。これはアクティブな BGP ルートであるため、BGP のデフォルト ポリシーによって自動的にアドバタイズされます。デフォルトポリシーは、常にすべてのポリシーチェーンの最後に適用されることに注意してください。必要なのは、より具体的なルートがアドバタイズされないようにブロックするポリシーです。

より具体的なルートのブロック

目的

172.16.0.0 /16 アドレス空間内で、サブネット マスク長が 19 ビット以上のルートをすべて拒否する not-larger-than-18 というポリシーを作成します。これにより、16〜18ビットのマスクを持つすべてのアグリゲートがアドバタイズされ、管理ポリシーの目標が達成されます。

アクション

  1. デバイスR1で、 not-larger-than-18 ポリシーを設定します。

    content_copy zoom_out_map
    [edit policy-options policy-statement not-larger-than-18 term reject-greater-than-18-bits]
    user@R1# set from route-filter 172.16.0.0/16 prefix-length-range /19-/32
    user@R1# set then reject
    
  2. デバイスR1で、デバイスR4とのピアリングセッションにポリシーを適用します。

    content_copy zoom_out_map
    [edit  protocols bgp group to_64511]
    user@R1# set export not-larger-than-18
    user@R1# commit
    
  3. デバイスR1で、デバイスR4へアドバタイズされているルートを確認します。

    content_copy zoom_out_map
    user@R1> show route advertising-protocol bgp 10.1.0.6
    
    inet.0: 29 destinations, 31 routes (29 active, 0 holddown, 0 hidden)
      Prefix                  Nexthop              MED     Lclpref    AS path
    * 172.16.0.0/16           Self                                    I

意味

ポリシー チェーンは正しく機能しています。172.16.0.0 /16ルートのみがデバイスR4にアドバタイズされます。

デバイスR5へのルートアドバタイズを検証する

目的

デバイスR1上で、顧客ルートがデバイスR5にアドバタイズされていることを確認します。

デバイスR5は、AS 64512にあるデバイスR1のEBGPピアです。管理ポリシーでは、このピアは長さが 18 ビットを超える集合ルートとすべてのカスタマールートのみを受信すると規定されています。デバイスR4 で同様の問題が発生することを想定して、マスク長が 16〜18 ビットのすべてのアグリゲートを拒否する not-smaller- than-18 というポリシーを作成できます。

アクション

  1. デバイスR2で、172.16.128.0/17の集約ルートを設定します。

    content_copy zoom_out_map
    [edit routing-options aggregate]
    user@R2# set route 172.16.128.0/17 discard
    user@R2# commit
    
  2. デバイスR1で、デバイスR5にアドバタイズされているルートを確認します。

    content_copy zoom_out_map
    user@R1> show route advertising-protocol bgp 10.0.0.9
    
    
    inet.0: 30 destinations, 32 routes (30 active, 0 holddown, 0 hidden)
      Prefix                  Nexthop              MED     Lclpref    AS path
    * 172.16.1.0/24           Self                                    I
    * 172.16.1.16/28          Self                                    I
    * 172.16.1.32/28          Self                                    I
    * 172.16.1.48/28          Self                                    I
    * 172.16.1.64/28          Self                                    I
    * 172.16.2.0/24           Self                                    I
    * 172.16.2.16/28          Self                                    I
    * 172.16.2.32/28          Self                                    I
    * 172.16.2.48/28          Self                                    I
    * 172.16.2.64/28          Self                                    I
    * 172.16.3.0/24           Self                                    I
    * 172.16.3.16/28          Self                                    I
    * 172.16.3.32/28          Self                                    I
    * 172.16.3.48/28          Self                                    I
    * 172.16.3.64/28          Self                                    I
    * 172.16.128.0/17         Self                                    I

    集約ルート 172.16.128.0/17 は、管理ポリシーに違反してアドバタイズされます

  3. デバイスR1で、 not-smaller-than-18 ポリシーを設定します。

    content_copy zoom_out_map
    [edit policy-options policy-statement not-smaller-than-18 term reject-less-than-18-bits]
    user@R1# set from protocol aggregate
    user@R1# set from route-filter 172.16.0.0/16 upto /18
    user@R1# set then reject
    
  4. デバイスR1で、デバイスR5とのピアリングセッションにポリシーを適用します。

    content_copy zoom_out_map
    [edit  protocols bgp group to_64512]
    user@R1# set export not-smaller-than-18
    user@R1# commit
    
  5. デバイスR1で、デバイスR5にアドバタイズされているルートを確認します。

    content_copy zoom_out_map
    user@R1> show route advertising-protocol bgp 10.0.0.9
    
    inet.0: 29 destinations, 31 routes (29 active, 0 holddown, 0 hidden)
      Prefix                  Nexthop              MED     Lclpref    AS path
    * 172.16.1.0/24           Self                                    I
    * 172.16.1.16/28          Self                                    I
    * 172.16.1.32/28          Self                                    I
    * 172.16.1.48/28          Self                                    I
    * 172.16.1.64/28          Self                                    I
    * 172.16.2.0/24           Self                                    I
    * 172.16.2.16/28          Self                                    I
    * 172.16.2.32/28          Self                                    I
    * 172.16.2.48/28          Self                                    I
    * 172.16.2.64/28          Self                                    I
    * 172.16.3.0/24           Self                                    I
    * 172.16.3.16/28          Self                                    I
    * 172.16.3.32/28          Self                                    I
    * 172.16.3.48/28          Self                                    I
    * 172.16.3.64/28          Self                                    I

意味

ポリシー チェーンは正しく機能しています。長さが 18 ビットを超える集約ルートとすべてのカスタマー ルートのみがデバイス R5 にアドバタイズされます。

external-footer-nav
Ask AI
close

How can I help you today?

LLMs can make mistakes. Verify important information.
chat_add_on New topic
send progress_activity
This conversation will be monitored and recorded. Any information you provide will be subject to our Privacy Notice and may be used for quality assurance purposes. Do not include any personal or sensitive information. Ask AI can make mistakes. Verify generated output for accuracy.
Protected by hCaptcha arrow_drop_down arrow_drop_up
Juniper Networks, Inc. | Privacy Notice | Terms of Use