Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Announcement: Try the Ask AI chatbot for answers to your technical questions about Juniper products and solutions.

close
header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring a Static Subscriber Interface on an IP Demux Interface over Aggregated Ethernet

date_range 06-Dec-23

This example shows how you can configure a subscriber interface using a static IP demultiplexing (demux) interface stacked on a two-link aggregated Ethernet logical interface. In this example, the underlying aggregated Ethernet logical interface is configured for one-to-one active/backup redundancy at the DPC level.

  1. Define the number of aggregated Ethernet interfaces on the router.

    In this example, only one aggregated Ethernet logical interface is configured on the router:

    content_copy zoom_out_map
    [edit]
    chassis {
        aggregated-devices {
            ethernet {
                device-count 1;
            }
        }
    }
    
  2. Configure ae0, a two-link aggregated Ethernet logical interface to serve as the underlying interface for the static IP demux subscriber interface.

    In this example, the LAG bundle is configured for one-to-one active/backup link redundancy. To support link redundancy at the DPC level, the LAG bundle attaches ports from two different EQ DPCs.

    content_copy zoom_out_map
    [edit]
    interfaces {
        ge-5/0/3 {
            gigether-options {
                802.3ad {
                    ae0;
                    primary;
                }
            }
        }
        ge-5/1/2 {
            gigether-options {
                802.3ad {
                    ae0;
                    backup;
                }
            }
        }
    }
    
  3. Configure the aggregated Ethernet logical interface with link protection enabled, and specify the logical demultiplexing source family type for both the active and backup links.

    content_copy zoom_out_map
    [edit]
    interfaces {
        ae0 {
            aggregated-ether-options {
                link-protection;
                minimum-links 1;
                link-speed 1g;
            }
            unit 0 {
                demux-source inet {
                family inet {
                    address 203.0.113.110/24;
                }
            }
            unit 1 {
                demux-source inet {
                family inet {
                    address  203.0.113.111/24;
                }
            }
        }
    }
    
  4. Configure the IP demux interface over the aggregated Ethernet logical interface.

    content_copy zoom_out_map
    [edit]
    interfaces {
        demux0 {
            unit 101 {
                demux-options {
                    underlying-interface ae0.0;
                }
                family inet {
                    demux-source 203.0.113.100/16;
                    address 203.0.113.0/24;
                }
            }
            unit 101 {
                demux-options {
                    underlying-interface ae0.1;
                }
                family inet {
                    demux-source 203.0.113.221/16;
                    address 203.0.113.0/24;
                }
            }
        }
    }
    
footer-navigation