Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
SRX5800 Firewall Hardware Guide
Table of Contents Expand all
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Performing the Initial Software Configuration for the SRX5800

date_range 25-Jul-23

SRX5800 Firewall Software Configuration Overview

The firewall is shipped with the Junos operating system (Junos OS) preinstalled and ready to be configured when the device is powered on. There are three copies of the software: one on a CompactFlash card (if installed) in the Routing Engine, one on the hard disk in the Routing Engine, and one on a USB flash drive that can be inserted into the slot in the Routing Engine faceplate.

When the device boots, it first attempts to start the image on the USB flash drive. If a USB flash drive is not inserted into the Routing Engine or the attempt otherwise fails, the device next tries the CompactFlash card (if installed), and finally the hard disk.

You configure the firewall by issuing Junos OS command-line interface (CLI) commands, either on a console device attached to the CONSOLE port on the Routing Engine, or over a telnet connection to a network connected to the ETHERNET port on the Routing Engine.

Gather the following information before configuring the device:

  • Name the device will use on the network

  • Domain name the device will use

  • IP address and prefix length information for the Ethernet interface

  • IP address of a default router

  • IP address of a DNS server

  • Password for the root user

Initially Configuring the SRX5800 Firewall

This procedure connects the device to the network but does not enable it to forward traffic. For complete information about enabling the device to forward traffic, including examples, see the appropriate Junos OS configuration guides.

To configure the software:

  1. Verify that the device is powered on.
  2. Log in as the root user. There is no password.
  3. Start the CLI.
    content_copy zoom_out_map
    root# cli
    root@>
    
  4. Enter configuration mode.
    content_copy zoom_out_map
    configure 
    [edit]
    root@#
    
  5. Set the root authentication password by entering either a cleartext password, an encrypted password, or an SSH public key string (DSA or RSA).
    content_copy zoom_out_map
    [edit]
    root@# set system root-authentication plain-text-password
    New password: password 
    Retype new password: password 
    
  6. Configure an administrator account on the device. When prompted, enter the password for the administrator account.
    content_copy zoom_out_map
    [edit]
    root@# set system login user admin class super-user authentication plain-text-password 
    New password: password 
    Retype new password: password 
    
  7. Commit the configuration to activate it on the device.
    content_copy zoom_out_map
    [edit]
    root@# commit
    
  8. Log in as the administrative user you configured in Step 6.
  9. Configure the name of the device. If the name includes spaces, enclose the name in quotation marks (“ ”).
    content_copy zoom_out_map
    configure 
    [edit]
    admin@# set system host-name host-name
    
  10. Configure the IP address and prefix length for the Ethernet management interface on the firewall’s Routing Engine.
    content_copy zoom_out_map
    [edit]
    admin@# set interfaces fxp0 unit 0 family inet address address/prefix-length
    
  11. Configure the traffic interface.
    content_copy zoom_out_map
    [edit]
    admin@# set interfaces ge-6/2/0 unit 0 family inet address address/prefix-length
    admin@# set interfaces ge-6/3/5 unit 0 family inet address address/prefix-length
    
  12. Configure the default route.
    content_copy zoom_out_map
    [edit]
    admin@# set routing-options static route 0.0.0.0/0 next-hop gateway
    
  13. Configure basic security zones and bind them to traffic interfaces.
    content_copy zoom_out_map
    [edit]
    admin@# set security zones security-zone trust interfaces ge-6/3/5 
    admin@# set security zones security-zone untrust interfaces ge-6/2/0 
    
  14. Configure basic security policies.
    content_copy zoom_out_map
    [edit]
    admin@# set security policies from-zone trust to-zone untrust policy policy-name match source-address any destination-address any application any 
    root@# set security policies from-zone trust to-zone untrust policy policy-name then permit 
    
  15. Check the configuration for validity.
    content_copy zoom_out_map
    [edit]
    admin@# commit check
    configuration check succeeds
    
  16. Commit the configuration to activate it on the device.
    content_copy zoom_out_map
    [edit]
    admin@# commit
    commit complete
    
  17. Optionally, display the configuration to verify that it is correct.
    content_copy zoom_out_map
    admin@# show
    ## Last changed: 2008-05-07 22:43:25 UTC
    version "9.2I0 [builder]";
    system {
        autoinstallation;
        host-name henbert;
        root-authentication {
            encrypted-password "$1$oTVn2KY3$uQe4xzQCxpR2j7sKuV.Pa0"; ## SECRET-DATA
        }
        login {
            user admin {
                uid 928;
                class super-user;
                authentication {
                    encrypted-password "$1$cdOPmACd$QvreBsJkNR1EF0uurTBkE."; ## SECRET-DATA
                }
            }
        }
        services {
            ssh;
           web-management {
                http {
                    interface ge-0/0/0.0;
                }
            }
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any any;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
        }
        license {
            autoupdate {
                url https://ae1.juniper.net/junos/key_retrieval;
            }
        }
    }
    interfaces {
        ge-0/0/0 {
            unit 0;
        }
        ge-6/2/0 {
            unit 0 {
                family inet {
                    address 5.1.1.1/24;
                }
            }
        }
        ge-6/3/5 {
            unit 0 {
                family inet {
                    address 192.1.1.1/24;
                }
            }
        }
        fxp0 {
            unit 0 {
                family inet {
                    address 192.168.10.2/24;
                }
            }
        }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 5.1.1.2;
        }
    }
    security {
        zones {
            security-zone trust {
                interfaces {
                    ge-6/3/5.0;
                }
            }
            security-zone untrust {
                interfaces {
                    ge-6/2/0.0;
                }
            }
        }
        policies {
            from-zone trust to-zone untrust {
                policy bob {
                    match {
                        source-address any;
                        destination-address any;
                        application any;
                    }
                    then {
                        permit;
                    }
                }
            }
        }
    }
  18. Commit the configuration to activate it on the device.
    content_copy zoom_out_map
    [edit]
    admin@# commit
    
  19. Optionally, configure additional properties by adding the necessary configuration statements. Then commit the changes to activate them on the device.
    content_copy zoom_out_map
    [edit]
    admin@# commit
    
  20. When you have finished configuring the device, exit configuration mode.
    content_copy zoom_out_map
    [edit]
    admin@# exit
    admin@host>
    

Performing Initial Software Configuration Using J-Web

Configuring Root Authentication and the Management Interface from the CLI

Before you can use J-Web to configure your device, you must access the CLI to perform the initial configuration.

To configure root authentication and the management interface:

  1. Log in as root. There is no password.
  2. Start the CLI and enter configuration mode.
    content_copy zoom_out_map
    root@% cli
    root@>configure
    root@#
    
  3. Set the root authentication password by entering a cleartext password, an encrypted password, or an SSH public key string (DSA or RSA).
    content_copy zoom_out_map
    [edit]
    root@# set system root-authentication plain-text-password
    New password: password
    Retype new password: password
    
  4. Commit the configuration to activate it on the device.
    content_copy zoom_out_map
    [edit]
    root@# commit
    
  5. Configure the IP address and prefix length for the Ethernet management interface on the device.
    content_copy zoom_out_map
    [edit]
    root@# set interfaces fxp0 unit 0 family inet address address/prefix-length
    
  6. Configure the default route.
    content_copy zoom_out_map
    [edit]
    root@# set routing-options static route 0.0.0.0/0 next-hop gateway
    
  7. Enable Web access to launch J-Web.
    content_copy zoom_out_map
    [edit]
    root@# set system services web-management http
    
  8. Commit the configuration changes.
    content_copy zoom_out_map
    [edit]
    root@# commit
    

Configuring Interfaces, Zones, and Policies with J-Web

You can configure hostnames, interfaces, zones, and security policies using J-Web.

Note:

You cannot use J-Web to configure SRX5400, SRX5600, and SRX5800 Firewalls in Junos OS Release 15.1X49-D10.

Before you begin:

Configure the device with J-Web using the following procedures.

Configuring the Hostname

To configure the hostname:

  1. Launch a Web browser from the management device.
  2. Enter the IP address of the device in the URL address field.
  3. Specify the default username as root and enter the password. See Performing Initial Software Configuration Using J-Web.
  4. Click Log In. The J-Web Dashboard page appears.
  5. Select Configure>System Properties>System Identity, and then select Edit. The Edit System Identity dialog box appears.
  6. Enter the hostname and click OK.
  7. Select Commit Options>Commit to apply the configuration changes.

You have successfully configured the hostname for the system.

Configuring Interfaces

To configure two physical interfaces:

  1. From the J-Web Dashboard page, select Configure>Interfaces and select a physical interface you want to configure.
  2. Select Add>Logical Interface. The Add interface dialog box appears.
  3. Set Unit = 0.
  4. Select the check box for IPv4 Address to enable IPv4 addressing.
  5. Click Add and enter the IPv4 address.
  6. Click OK.

    A message appears after your configuration changes are validated successfully.

  7. Click OK.
  8. Select Commit Options>Commit to apply the configuration changes.

    A message appears after your configuration changes are applied successfully.

  9. Click OK.

You have successfully configured the physical interface. Repeat these steps to configure the second physical interface for the device.

Configuring Zones and Assigning Interfaces

To assign interfaces within a trust zone and an untrust zone:

  1. From the J-Web Dashboard page, select Configure>Security>Zones/Screens and click Add. The Add Zone dialog box appears.
  2. In the Main tab, enter trust for zone name and enter the description.
  3. Set the zone type to Security.
  4. Select the interfaces listed under Available and move them under Selected.
  5. Click OK.

    A message appears after your configuration changes are validated successfully.

  6. Click OK.
  7. Select Commit Options>Commit to apply the configuration changes.

    A message appears after your configuration changes are applied successfully.

  8. Click OK.
  9. Repeat Step 1 through Step 8 and assign another interface to an untrust zone.

You have successfully configured interfaces in a trust zone and in an untrust zone.

Configuring Security Policies

To configure security policies:

  1. From the J-Web Dashboard page, select Configure>Security>Security Policy and click Add. The Add Policy dialog box appears.
  2. In the Policy tab, enter the policy name and set the policy action to permit. Then select Zone and set the From Zone to trust and the To Zone to untrust.
  3. Configure the source IP address by selecting any listed under Available and moving it under Selected.
  4. Configure the destination IP address by selecting any listed under Available and moving it under Selected.
  5. Configure the application by selecting any listed under Available and moving it under Selected.
  6. Click OK.

    A message appears after your configuration changes are validated successfully.

  7. Click OK.
  8. Select Commit Options>Commit to apply the configuration changes.

    A message appears after your configuration changes are applied successfully.

  9. Click OK.

You have successfully configured the security policy.

footer-navigation