Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring H-VPLS BGP-Based and LDP-Based VPLS Interoperation

date_range 12-Dec-23

This example shows how to configure the hierarchical virtual private LAN service (H-VPLS) in a scenario that uses both LDP-based VPLS and BGP-based VPLS interoperating in a multihoming deployment. This scenario is useful when a customer deployment has the two different types of VPLS in use, and you need to integrate them. Another example is when ISP-A is running BGP-based VPLS and ISP-B is running the LDP-based VPLS, and the two ISPs are merging their networks.

Requirements

No special configuration beyond device initialization is required before configuring this example.

Overview

In this example, Device PE2 and Device PE3 are acting as internetworking provider edge (PE) routers with BGP-based as well as LDP-based VPLS termination.

The devices in this example have the following roles:

  • BGP VPLS only PE—Device PE1

  • LDP VPLS only PE—Device PE4

  • BGP-LDP VPLS PE—Device PE2 and Device PE3

Figure 1 shows the topology used in this example.

Figure 1: H-VPLS with LDP-Based and BGP-Based VPLS InteroperationH-VPLS with LDP-Based and BGP-Based VPLS Interoperation

From Device PE4, the pseudowire to Device PE3 is the primary or working path. The pseudowire Device PE2 is the backup path.

CLI Quick Configuration shows the configuration for all of the devices in Figure 1. The section Step-by-Step Procedure describes the steps on Device PE1, Device PE2, and Device PE4.

Configuration

Procedure

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level.

Device PE1

content_copy zoom_out_map
set interfaces ge-2/0/5 encapsulation ethernet-vpls
set interfaces ge-2/0/5 unit 0 description to_CE1
set interfaces ge-2/0/5 unit 0 family vpls
set interfaces fe-2/0/9 unit 0 description to_PE2
set interfaces fe-2/0/9 unit 0 family inet address 10.10.3.1/30
set interfaces fe-2/0/9 unit 0 family mpls
set interfaces fe-2/0/10 unit 0 description to_PE3
set interfaces fe-2/0/10 unit 0 family inet address 10.10.1.1/30
set interfaces fe-2/0/10 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 192.0.2.1/24
set protocols mpls interface fe-2/0/10.0
set protocols mpls interface fe-2/0/9.0
set protocols ldp interface fe-2/0/10.0
set protocols ldp interface fe-2/0/9.0
set protocols ldp interface lo0.0
set protocols bgp group internal-peers type internal
set protocols bgp group internal-peers local-address 192.0.2.1
set protocols bgp group internal-peers family l2vpn signaling
set protocols bgp group internal-peers neighbor 192.0.2.2
set protocols bgp group internal-peers neighbor 192.0.2.3
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-2/0/10.0
set protocols ospf area 0.0.0.0 interface fe-2/0/9.0
set routing-instances h-vpls-PE1 instance-type vpls
set routing-instances h-vpls-PE1 interface ge-2/0/5.0
set routing-instances h-vpls-PE1 route-distinguisher 1:1
set routing-instances h-vpls-PE1 vrf-target target:1:1
set routing-instances h-vpls-PE1 protocols vpls interface ge-2/0/5.0
set routing-instances h-vpls-PE1 protocols vpls site PE1-vpls site-identifier 2
set routing-options autonomous-system 64510  

Device PE2

content_copy zoom_out_map
set interfaces ge-2/0/6 encapsulation ethernet-vpls
set interfaces ge-2/0/6 unit 0 description to_CE2
set interfaces ge-2/0/6 unit 0 family vpls
set interfaces fe-2/0/8 unit 0 description to_PE3
set interfaces fe-2/0/8 unit 0 family inet address 10.10.4.2/30
set interfaces fe-2/0/8 unit 0 family mpls
set interfaces fe-2/0/9 unit 0 description to_PE4
set interfaces fe-2/0/9 unit 0 family inet address 10.10.5.1/30
set interfaces fe-2/0/9 unit 0 family mpls
set interfaces fe-2/0/10 unit 0 description to_PE1
set interfaces fe-2/0/10 unit 0 family inet address 10.10.3.2/30
set interfaces fe-2/0/10 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 192.0.2.2/24
set protocols mpls interface fe-2/0/10.0
set protocols mpls interface fe-2/0/9.0
set protocols mpls interface fe-2/0/8.0
set protocols ldp interface fe-2/0/10.0
set protocols ldp interface fe-2/0/9.0
set protocols ldp interface fe-2/0/8.0
set protocols ldp interface lo0.0
set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 192.0.2.2
set protocols bgp group ibgp family l2vpn signaling
set protocols bgp group ibgp neighbor 192.0.2.3
set protocols bgp group ibgp neighbor 192.0.2.1
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-2/0/10.0
set protocols ospf area 0.0.0.0 interface fe-2/0/9.0
set protocols ospf area 0.0.0.0 interface fe-2/0/8.0
set routing-instances h-vpls-PE2 instance-type vpls
set routing-instances h-vpls-PE2 interface ge-2/0/6.0
set routing-instances h-vpls-PE2 route-distinguisher 1:2
set routing-instances h-vpls-PE2 vrf-target target:1:1
set routing-instances h-vpls-PE2 protocols vpls interface ge-2/0/6.0
set routing-instances h-vpls-PE2 protocols vpls site PE2-vpls site-identifier 1
set routing-instances h-vpls-PE2 protocols vpls site PE2-vpls multi-homing
set routing-instances h-vpls-PE2 protocols vpls site PE2-vpls mesh-group h-vpls-PE2
set routing-instances h-vpls-PE2 protocols vpls vpls-id 100
set routing-instances h-vpls-PE2 protocols vpls mesh-group h-vpls-PE2 vpls-id 100
set routing-instances h-vpls-PE2 protocols vpls mesh-group h-vpls-PE2 local-switching
set routing-instances h-vpls-PE2 protocols vpls mesh-group h-vpls-PE2 neighbor 192.0.2.4
set routing-options autonomous-system 64510 

Device PE3

content_copy zoom_out_map
set interfaces fe-2/0/8 unit 0 description to_PE2
set interfaces fe-2/0/8 unit 0 family inet address 10.10.4.1/30
set interfaces fe-2/0/8 unit 0 family mpls
set interfaces fe-2/0/9 unit 0 description to_PE4
set interfaces fe-2/0/9 unit 0 family inet address 10.10.6.1/30
set interfaces fe-2/0/9 unit 0 family mpls
set interfaces fe-2/0/10 unit 0 description to_PE1
set interfaces fe-2/0/10 unit 0 family inet address 10.10.1.2/30
set interfaces fe-2/0/10 unit 0 family mpls
set interfaces ge-2/1/3 encapsulation ethernet-vpls
set interfaces ge-2/1/3 unit 0 description to_CE3
set interfaces ge-2/1/3 unit 0 family vpls
set interfaces lo0 unit 0 family inet address 192.0.2.3/24
set protocols mpls interface fe-2/0/10.0
set protocols mpls interface fe-2/0/8.0
set protocols mpls interface fe-2/0/9.0
set protocols ldp interface fe-2/0/10.0
set protocols ldp interface fe-2/0/9.0
set protocols ldp interface fe-2/0/8.0
set protocols ldp interface lo0.0
set protocols bgp group internal-peers type internal
set protocols bgp group internal-peers local-address 192.0.2.3
set protocols bgp group internal-peers family l2vpn signaling
set protocols bgp group internal-peers neighbor 192.0.2.2
set protocols bgp group internal-peers neighbor 192.0.2.1
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-2/0/10.0
set protocols ospf area 0.0.0.0 interface fe-2/0/8.0
set protocols ospf area 0.0.0.0 interface fe-2/0/9.0
set routing-instances h-vpls-PE3 instance-type vpls
set routing-instances h-vpls-PE3 interface ge-2/1/3.0
set routing-instances h-vpls-PE3 route-distinguisher 1:3
set routing-instances h-vpls-PE3 vrf-target target:1:1
set routing-instances h-vpls-PE3 protocols vpls interface ge-2/1/3.0
set routing-instances h-vpls-PE3 protocols vpls site PE3-vpls site-identifier 1
set routing-instances h-vpls-PE3 protocols vpls site PE3-vpls multi-homing
set routing-instances h-vpls-PE3 protocols vpls site PE3-vpls mesh-group h-vpls-PE3
set routing-instances h-vpls-PE3 protocols vpls vpls-id 100
set routing-instances h-vpls-PE3 protocols vpls mesh-group h-vpls-PE3 vpls-id 100
set routing-instances h-vpls-PE3 protocols vpls mesh-group h-vpls-PE3 local-switching
set routing-instances h-vpls-PE3 protocols vpls mesh-group h-vpls-PE3 neighbor 192.0.2.4
set routing-options autonomous-system 64510 

Device PE4

content_copy zoom_out_map
set interfaces fe-2/0/9 unit 0 description to_PE3
set interfaces fe-2/0/9 unit 0 family inet address 10.10.6.2/30
set interfaces fe-2/0/9 unit 0 family mpls
set interfaces fe-2/0/10 unit 0 description to_PE2
set interfaces fe-2/0/10 unit 0 family inet address 10.10.5.2/30
set interfaces fe-2/0/10 unit 0 family mpls
set interfaces ge-2/1/7 encapsulation ethernet-vpls
set interfaces ge-2/1/7 unit 0 description to_CE4
set interfaces ge-2/1/7 unit 0 family vpls
set interfaces lo0 unit 0 family inet address 192.0.2.4/24
set protocols mpls interface fe-2/0/10.0
set protocols mpls interface fe-2/0/9.0
set protocols ldp interface fe-2/0/10.0
set protocols ldp interface fe-2/0/9.0
set protocols ldp interface lo0.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fe-2/0/10.0
set protocols ospf area 0.0.0.0 interface fe-2/0/9.0
set routing-instances ldp-vpls instance-type vpls
set routing-instances ldp-vpls interface ge-2/1/7.0
set routing-instances ldp-vpls protocols vpls vpls-id 100
set routing-instances ldp-vpls protocols vpls neighbor 192.0.2.3
set routing-instances ldp-vpls protocols vpls neighbor 192.0.2.2

Device CE1

content_copy zoom_out_map
set interfaces ge-2/0/8 unit 0 description to_PE1
set interfaces ge-2/0/8 unit 0 family inet address 172.16.0.1/24
set interfaces lo0 unit 0 family inet address 10.255.14.214/32
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ge-2/0/8.0 

Device CE2

content_copy zoom_out_map
set interfaces ge-2/1/5 unit 0 description to_PE2
set interfaces ge-2/1/5 unit 0 family inet address 172.16.0.2/24
set interfaces lo0 unit 0 family inet address 10.255.14.215/32
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ge-2/1/5.0 

Device CE3

content_copy zoom_out_map
set interfaces ge-2/0/9 unit 0 description to_PE3
set interfaces ge-2/0/9 unit 0 family inet address 172.16.0.3/24
set interfaces lo0 unit 0 family inet address 10.255.14.218/32
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ge-2/0/9.0 

Device CE4

content_copy zoom_out_map
set interfaces ge-2/1/6 unit 0 description to_PE4
set interfaces ge-2/1/6 unit 0 family inet address 172.16.0.4/24
set interfaces lo0 unit 0 family inet address 10.255.14.219/32
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ge-2/1/6.0

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure the BGP-based VPLS PE device:

  1. Configure the interfaces.

    On the device interface that connects to the customer edge, enable VPLS encapsulation and the VPLS address family.

    On the core-facing interfaces, enable MPLS labels.

    content_copy zoom_out_map
    [edit interfaces]
    user@PE1# set ge-2/0/5 encapsulation ethernet-vpls
    user@PE1# set ge-2/0/5 unit 0 description to_CE1
    user@PE1# set ge-2/0/5 unit 0 family vpls
    user@PE1# set fe-2/0/10 unit 0 description to_PE3
    user@PE1# set fe-2/0/10 unit 0 family inet address 10.10.1.1/30
    user@PE1# set fe-2/0/10 unit 0 family mpls
    user@PE1# set fe-2/0/9 unit 0 description to_PE2
    user@PE1# set fe-2/0/9 unit 0 family inet address 10.10.3.1/30
    user@PE1# set fe-2/0/9 unit 0 family mpls
    user@PE1# set lo0 unit 0 family inet address 192.0.2.1/24
    
  2. Enable MPLS and LDP on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure MPLS and LDP.

    content_copy zoom_out_map
    [edit protocols mpls]
    user@PE1# set interface fe-2/0/10.0
    user@PE1# set interface fe-2/0/9.0
    [edit protocols ldp ]
    user@PE1# set interface fe-2/0/10.0
    user@PE1# set interface fe-2/0/9.0
    user@PE1# set interface lo0.0
    
  3. Enable routing on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure an interior gateway protocol (IGP), such as OSPF or IS-IS.

    content_copy zoom_out_map
    [edit protocols ospf area 0.0.0.0]
    user@PE1# set interface lo0.0 passive
    user@PE1# set interface fe-2/0/10.0
    user@PE1# set interface fe-2/0/9.0
    
  4. Configure BGP with Layer 2 VPN signaling.

    The l2vpn signaling statement enables support for both VPLS and Layer 2 VPN advertisement under the same network layer reachability information (NLRI).

    The internal IBGP (IBGP) full mesh includes Device PE1, Device PE2, and Device PE3. Device PE4 is not included.

    content_copy zoom_out_map
    [edit protocols bgp group internal-peers]
    user@PE1# set type internal
    user@PE1# set local-address 192.0.2.1
    user@PE1# set family l2vpn signaling
    user@PE1# set neighbor 192.0.2.2
    user@PE1# set neighbor 192.0.2.3
    
  5. Configure the VPLS routing instance.

    Because this is BGP-based VPLS, include a route distinguisher, a VRF target, and a site name and ID.

    content_copy zoom_out_map
    [edit routing-instances h-vpls-PE1]
    user@PE1# set instance-type vpls
    user@PE1# set interface ge-2/0/5.0
    user@PE1# set route-distinguisher 1:1
    user@PE1# set vrf-target target:1:1
    [edit routing-instances h-vpls-PE1 protocols vpls]
    user@PE1# set interface ge-2/0/5.0
    user@PE1# set site PE1-vpls site-identifier 2
    
  6. Configure the autonomous system (AS) number.

    content_copy zoom_out_map
    [edit routing-options]
    user@PE1# set autonomous-system 64510  
    

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure the BGP-LDP-based VPLS PE device:

  1. Configure the interfaces.

    On the PE-r device interface that connects to the customer edge, configure one of the VPLS encapsulation types and the VPLS address family. This enables VPLS.

    On the core-facing interfaces, enable MPLS labels.

    content_copy zoom_out_map
    [edit interfaces]
    user@PE2# set ge-2/0/6 encapsulation ethernet-vpls
    user@PE2# set ge-2/0/6 unit 0 description to_CE2
    user@PE2# set ge-2/0/6 unit 0 family vpls
    user@PE2# set fe-2/0/10 unit 0 description to_PE1
    user@PE2# set fe-2/0/10 unit 0 family inet address 10.10.3.2/30
    user@PE2# set fe-2/0/10 unit 0 family mpls
    user@PE2# set fe-2/0/9 unit 0 description to_PE4
    user@PE2# set fe-2/0/9 unit 0 family inet address 10.10.5.1/30
    user@PE2# set fe-2/0/9 unit 0 family mpls
    user@PE2# set fe-2/0/8 unit 0 description to_PE3
    user@PE2# set fe-2/0/8 unit 0 family inet address 10.10.4.2/30
    user@PE2# set fe-2/0/8 unit 0 family mpls
    user@PE2# set lo0 unit 0 family inet address 192.0.2.2/24
    
  2. Enable MPLS and LDP on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure MPLS and LDP.

    content_copy zoom_out_map
    [edit protocols mpls]
    user@PE2# set interface fe-2/0/10.0
    user@PE2# set interface fe-2/0/9.0
    user@PE2# set interface fe-2/0/8.0
    [edit protocols ldp]
    user@PE2# set interface fe-2/0/10.0
    user@PE2# set interface fe-2/0/9.0
    user@PE2# set interface fe-2/0/8.0
    user@PE2# set interface lo0.0
    
  3. Enable routing on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure an interior gateway protocol (IGP), such as OSPF or IS-IS.

    content_copy zoom_out_map
    [edit protocols ospf area 0.0.0.0]
    user@PE2# set interface lo0.0 passive
    user@PE2# set interface fe-2/0/10.0
    user@PE2# set interface fe-2/0/9.0
    user@PE2# set interface fe-2/0/8.0
    
  4. Configure BGP with Layer 2 VPN signaling.

    The l2vpn signaling statement enables support for both VPLS and Layer 2 VPN advertisement under the same network layer reachability information (NLRI)

    The internal IBGP (IBGP) full mesh includes Device PE1, Device PE2, and Device PE3. Device PE4 is not included.

    content_copy zoom_out_map
    [edit protocols bgp group ibgp]
    user@PE2# set type internal
    user@PE2# set local-address 192.0.2.2
    user@PE2# set family l2vpn signaling
    user@PE2# set neighbor 192.0.2.3
    user@PE2# set neighbor 192.0.2.1
    
  5. Configure VPLS.

    The vpls-id statement enables LDP signaling for the VPLS instance.

    content_copy zoom_out_map
    [edit routing-instances h-vpls-PE2]
    user@PE2# set instance-type vpls
    user@PE2# set interface ge-2/0/6.0
    user@PE2# set route-distinguisher 1:2
    user@PE2# set vrf-target target:1:1
    [edit routing-instances h-vpls-PE2 protocols vpls]
    user@PE2# set interface ge-2/0/6.0
    user@PE2# set site PE2-vpls site-identifier 1
    user@PE2# set site PE2-vpls multi-homing
    user@PE2# set site PE2-vpls mesh-group h-vpls-PE2
    user@PE2# set vpls-id 100
    user@PE2# set mesh-group h-vpls-PE2 vpls-id 100
    user@PE2# set mesh-group h-vpls-PE2 local-switching
    user@PE2# set mesh-group h-vpls-PE2 neighbor 192.0.2.4
    
  6. Configure the autonomous system (AS) number.

    content_copy zoom_out_map
    [edit routing-options]
    user@PE2# set autonomous-system 64510 
    

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure LDP-based VPLS PE device:

  1. Configure the interfaces.

    On the PE-r device interface that connects to the customer edge, configure one of the VPLS encapsulation types and the VPLS address family. This enables VPLS.

    On the core-facing interfaces, enable MPLS labels.

    content_copy zoom_out_map
    [edit interfaces]
    user@PE4# set fe-2/0/10 unit 0 description to_PE2
    user@PE4# set fe-2/0/10 unit 0 family inet address 10.10.5.2/30
    user@PE4# set fe-2/0/10 unit 0 family mpls
    user@PE4# set fe-2/0/9 unit 0 description to_PE3
    user@PE4# set fe-2/0/9 unit 0 family inet address 10.10.6.2/30
    user@PE4# set fe-2/0/9 unit 0 family mpls
    user@PE4# set ge-2/1/7 encapsulation ethernet-vpls
    user@PE4# set ge-2/1/7 unit 0 description to_CE4
    user@PE4# set ge-2/1/7 unit 0 family vpls
    user@PE4# set lo0 unit 0 family inet address 192.0.2.4/24
    
  2. Enable MPLS and LDP on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure MPLS and LDP.

    content_copy zoom_out_map
    [edit protocols mpls]
    user@PE4# set interface fe-2/0/10.0
    user@PE4# set interface fe-2/0/9.0
    [edit protocols ldp]
    user@PE4# set interface fe-2/0/10.0
    user@PE4# set interface fe-2/0/9.0
    user@PE4# set interface lo0.0
    
  3. Enable routing on the interfaces.

    On the MTU device interfaces that connect to other PE devices, configure an interior gateway protocol (IGP), such as OSPF or IS-IS.

    content_copy zoom_out_map
    [edit protocols ospf area 0.0.0.0]
    user@PE4# set interface lo0.0 passive
    user@PE4# set interface fe-2/0/10.0
    user@PE4# set interface fe-2/0/9.0
    
  4. Configure VPLS.

    The vpls-id statement enables LDP signaling for the VPLS instance.

    content_copy zoom_out_map
    [edit routing-instances ldp-vpls]
    user@PE4# set instance-type vpls
    user@PE4# set interface ge-2/1/7.0
    user@PE4# set protocols vpls vpls-id 100
    [edit routing-instances ldp-vpls protocols vpls]
    user@PE4# set neighbor 192.0.2.3
    user@PE4# set neighbor 192.0.2.2
    

Results

From configuration mode, confirm your configuration by entering the show interfaces, show protocols, show routing-instances, and show routing-options commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

Device PE1

content_copy zoom_out_map
user@PE1# show interfaces
ge-2/0/5 {
    encapsulation ethernet-vpls;
    unit 0 {
        description to_CE1;
        family vpls;
    }
}
fe-2/0/9 {
}
    unit 0 {
        description to_PE2;
        family inet {
            address 10.10.3.1/30;
        }
        family mpls;
    }
}
fe-2/0/10 {
    unit 0 {
        description to_PE3;
        family inet {
            address 10.10.1.1/30;
        }
        family mpls;
    }
}
lo0 {
    unit 0 {
        family inet {
            address 192.0.2.1/24;
        }
    }
}
content_copy zoom_out_map
user@PE1# show protocols
mpls {
    interface fe-2/0/10.0;
    interface fe-2/0/9.0;
}
bgp {
    group internal-peers {
        type internal;
        local-address 192.0.2.1;
        family l2vpn {
            signaling;
        }
        neighbor 192.0.2.2;
        neighbor 192.0.2.3;
    }
}
ospf {
    area 0.0.0.0 {
        interface lo0.0 {
            passive;
        }
        interface fe-2/0/10.0;
        interface fe-2/0/9.0;
    }
}
ldp {
    interface fe-2/0/10.0;
    interface fe-2/0/9.0;
    interface lo0.0;
}
content_copy zoom_out_map
user@PE1# show routing-instances
h-vpls-PE1 {
    instance-type vpls;
    interface ge-2/0/5.0;
    route-distinguisher 1:1;
    vrf-target target:1:1;
    protocols {
        vpls {
            interface ge-2/0/5.0;
            site PE1-vpls {
                site-identifier 2;
            }
        }
    }
}
content_copy zoom_out_map
user@PE1# show routing-options
autonomous-system 64510;

Device PE2

content_copy zoom_out_map
user@PE2# show interfaces
ge-2/0/6 {
    encapsulation ethernet-vpls;
    unit 0 {
        description to_CE2;
        family vpls;
    }
}
fe-2/0/8 {
    unit 0 {
        description to_PE3;
        family inet {
            address 10.10.4.2/30;
        }
        family mpls;
    }
}
fe-2/0/9 {
    unit 0{
        description to_PE4;
        family inet {
            address 10.10.5.1/30;
        }
        family mpls;
    }
}
fe-2/0/10 {
    unit 0 {
        description to_PE1;
        family inet {
            address 10.10.3.2/30;
        }
        family mpls;
    }
}
lo0 {
    unit 0 {
        family inet {
            address 192.0.2.2/24;
        }
    }
}
content_copy zoom_out_map
user@PE2# show protocols
mpls {
    interface fe-2/0/10.0;
    interface fe-2/0/9.0;
    interface fe-2/0/8.0;
}
bgp {
    group ibgp {
        type internal;
        local-address 192.0.2.2;
        family l2vpn {
            signaling;
        }
        neighbor 192.0.2.3;
        neighbor 192.0.2.1;
    }
}
ospf {
    area 0.0.0.0 {
        interface lo0.0 {
            passive;
        }
        interface fe-2/0/10.0;
        interface fe-2/0/9.0;
        interface fe-2/0/8.0;
    }
}
ldp {
    interface fe-2/0/10.0;
    interface fe-2/0/9.0;
    interface fe-2/0/8.0;
    interface lo0.0;
}
content_copy zoom_out_map
user@PE2# show routing-instances
h-vpls-PE2 {
    instance-type vpls;
    interface ge-2/0/6.0;
    route-distinguisher 1:2;
    vrf-target target:1:1;
    protocols {
        vpls {
            interface ge-2/0/6.0;
            site PE2-vpls {
                site-identifier 1;
                multi-homing;
                mesh-group h-vpls-PE2;
            }
            vpls-id 100;
            mesh-group h-vpls-PE2 {
                vpls-id 100;
                local-switching;
                neighbor 192.0.2.4;
            }
        }
    }
}
content_copy zoom_out_map
user@PE2# show routing-options
autonomous-system 64510;

Device PE4

content_copy zoom_out_map
user@PE4# show interfaces
ge-2/1/7 {
    encapsulation ethernet-vpls;
    unit 0 {
        description to_CE4;
        family vpls;
    }
}
fe-2/0/9 {
    unit 0 {
        description to_PE3;
        family inet {
            address 10.10.6.2/30;
        }
        family mpls;
    }
}
fe-2/0/10 {
    unit 0 {
        description to_PE2;
        family inet {
            address 10.10.5.2/30;
        }
        family mpls;
    }
}
lo0 {
    unit 0 {
        family inet {
            address 192.0.2.4/24;
        }
    }
}
content_copy zoom_out_map
user@PE4# show protocols
mpls {
    interface fe-2/0/9.0;
    interface fe-2/0/10.0;
}
ospf {
    area 0.0.0.0 {
        interface lo0.0 {
            passive;
        }
        interface fe-2/0/9.0;
        interface fe-2/0/10.0;
    }
}
ldp {
    interface fe-2/0/10.0;
    interface fe-2/0/9.0;
    interface lo0.0;
}
content_copy zoom_out_map
user@PE4# show routing-instances
ldp-vpls {
    instance-type vpls;
    interface ge-2/1/7.0;
    protocols {
        vpls {
            vpls-id 100;
            neighbor 192.0.2.3;
            neighbor 192.0.2.2;
        }
    }
}

If you are done configuring the devices, enter commit from configuration mode.

Verification

Confirm that the configuration is working properly. In a multihoming scenario with BGP-LDP VPLS, the LDP pseudowires are in the down state for the backup PE (Device PE2). Whereas on the LDP-only VPLS PE (Device PE4), the pseudowires to the primary and backup BGP-LDP PE devices are in the up state.

Verifying the VPLS Connections

Purpose

Verify that the VPLS connections are working as expected.

Action

From operational mode, enter the show vpls connections command.

content_copy zoom_out_map
user@PE1> show vpls connections
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status 
Up -- operational           
Dn -- down

Instance: h-vpls-PE1
  Local site: PE1-vpls (2)
    connection-site           Type  St     Time last up          # Up trans
    1                         rmt   Up     Oct 16 16:52:27 2012           1
      Remote PE: 192.0.2.2, Negotiated control-word: No
      Incoming label: 800016, Outgoing label: 800009
      Local interface: vt-2/0/10.51380738, Status: Up, Encapsulation: VPLS
        Description: Intf - vpls h-vpls-PE1 local site 2 remote site 1
content_copy zoom_out_map
user@PE2> show vpls connections
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status 
Up -- operational           
Dn -- down

Instance: h-vpls-PE2
  BGP-VPLS State
  Local site: PE2-vpls (1)
    connection-site           Type  St     Time last up          # Up trans
    1                         rmt   RN   
    2                         rmt   Up     Oct 16 17:12:31 2012           1
      Remote PE: 192.0.2.1, Negotiated control-word: No
      Incoming label: 800257, Outgoing label: 800000
      Local interface: vt-2/0/10.118489089, Status: Up, Encapsulation: VPLS
        Description: Intf - vpls h-vpls-PE2 local site 1 remote site 2
  LDP-VPLS State
  VPLS-id: 100
  Mesh-group connections: h-vpls-PE2
    Neighbor                  Type  St     Time last up          # Up trans
    192.0.2.4(vpls-id 100)      rmt   Up     Oct 16 17:12:30 2012           1
      Remote PE: 192.0.2.4, Negotiated control-word: No
      Incoming label: 800000, Outgoing label: 800001
      Negotiated PW status TLV: No
      Local interface: vt-2/0/10.118489088, Status: Up, Encapsulation: ETHERNET
        Description: Intf - vpls h-vpls-PE2 neighbor 192.0.2.4 vpls-id 100
content_copy zoom_out_map
user@PE3> show vpls connections
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status 
Up -- operational           
Dn -- down

Instance: h-vpls-PE3
  BGP-VPLS State
  Local site: PE3-vpls (1)
    connection-site           Type  St     Time last up          # Up trans
    1                         rmt   LN   
    2                         rmt   LN   
  LDP-VPLS State
  VPLS-id: 100
  Mesh-group connections: h-vpls-PE3
    Neighbor                  Type  St     Time last up          # Up trans
    192.0.2.4(vpls-id 100)      rmt   LN   
content_copy zoom_out_map
user@PE4> show vpls connections
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status 
Up -- operational           
Dn -- down

Instance: ldp-vpls
  VPLS-id: 100
    Neighbor                  Type  St     Time last up          # Up trans
    192.0.2.2(vpls-id 100)      rmt   Up     Oct 16 17:12:23 2012           1
      Remote PE: 192.0.2.2, Negotiated control-word: No
      Incoming label: 800001, Outgoing label: 800000
      Negotiated PW status TLV: No
      Local interface: vt-2/0/10.17825793, Status: Up, Encapsulation: ETHERNET
        Description: Intf - vpls ldp-vpls neighbor 192.0.2.2 vpls-id 100
    192.0.2.3(vpls-id 100)      rmt   Up     Oct 16 17:12:20 2012           1
      Remote PE: 192.0.2.3, Negotiated control-word: No
      Incoming label: 800000, Outgoing label: 800000
      Negotiated PW status TLV: No
      Local interface: vt-2/0/10.17825792, Status: Up, Encapsulation: ETHERNET
        Description: Intf - vpls ldp-vpls neighbor 192.0.2.3 vpls-id 100

Meaning

On Device PE1, the BGP-VPLS connection to Device PE2 is up. In a steady-state condition, Device PE2 is the primary router and has all pseudowires terminating on it. Traffic flows from CE1 to PE1 to PE2 to PE4 to CE4.

On Device PE2, the BGP-VPLS connection to Device PE1 is up. The connection to Device PE3 is in the RN state. The LDP-VPLS connection to Device PE4 is up.

On Device PE3, all VPLS connections are in the LN state. This is expected because Device PE3 is the backup.

On Device PE4, the LDP-only VPLS router, the primary pseudowire to Device PE2 and the backup pseudowire to Device PE3 are in the up state.

Manually Triggering a Switch from the Active Pseudowire to the Backup Pseudowire

Purpose

Verify that when Device PE2 becomes unavailable, the traffic flow shifts to Device PE3.

Action

  1. On Device PE2, deactivate the interfaces.

    content_copy zoom_out_map
    user@PE2# deactivate interfaces
    user@PE2# commit
    
  2. Rerun the show vpls connections command on all of the PE devices.

    content_copy zoom_out_map
    user@PE1> show vpls connections
    Layer-2 VPN connections:
    
    Legend for connection status (St)   
    EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
    EM -- encapsulation mismatch     WE -- interface and instance encaps not same
    VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
    CM -- control-word mismatch      -> -- only outbound connection is up
    CN -- circuit not provisioned    <- -- only inbound connection is up
    OR -- out of range               Up -- operational
    OL -- no outgoing label          Dn -- down                      
    LD -- local site signaled down   CF -- call admission control failure      
    RD -- remote site signaled down  SC -- local and remote site ID collision
    LN -- local site not designated  LM -- local site ID not minimum designated
    RN -- remote site not designated RM -- remote site ID not minimum designated
    XX -- unknown connection status  IL -- no incoming label
    MM -- MTU mismatch               MI -- Mesh-Group ID not available
    BK -- Backup connection          ST -- Standby connection
    PF -- Profile parse failure      PB -- Profile busy
    RS -- remote site standby        SN -- Static Neighbor
    LB -- Local site not best-site   RB -- Remote site not best-site
    VM -- VLAN ID mismatch
    
    Legend for interface status 
    Up -- operational           
    Dn -- down
    
    Instance: h-vpls-PE1
      Local site: PE1-vpls (2)
        connection-site           Type  St     Time last up          # Up trans
        1                         rmt   Up     Oct 17 12:24:01 2012           2
          Remote PE: 192.0.2.3, Negotiated control-word: No
          Incoming label: 800000, Outgoing label: 800257
          Local interface: vt-2/0/10.84934656, Status: Up, Encapsulation: VPLS
            Description: Intf - vpls h-vpls-PE1 local site 2 remote site 1
    content_copy zoom_out_map
    user@PE2> show vpls connections
    Layer-2 VPN connections:
    
    Legend for connection status (St)   
    EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
    EM -- encapsulation mismatch     WE -- interface and instance encaps not same
    VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
    CM -- control-word mismatch      -> -- only outbound connection is up
    CN -- circuit not provisioned    <- -- only inbound connection is up
    OR -- out of range               Up -- operational
    OL -- no outgoing label          Dn -- down                      
    LD -- local site signaled down   CF -- call admission control failure      
    RD -- remote site signaled down  SC -- local and remote site ID collision
    LN -- local site not designated  LM -- local site ID not minimum designated
    RN -- remote site not designated RM -- remote site ID not minimum designated
    XX -- unknown connection status  IL -- no incoming label
    MM -- MTU mismatch               MI -- Mesh-Group ID not available
    BK -- Backup connection          ST -- Standby connection
    PF -- Profile parse failure      PB -- Profile busy
    RS -- remote site standby        SN -- Static Neighbor
    LB -- Local site not best-site   RB -- Remote site not best-site
    VM -- VLAN ID mismatch
    
    Legend for interface status 
    Up -- operational           
    Dn -- down
    
    Instance: h-vpls-PE2
      BGP-VPLS State
      Local site: PE2-vpls (1)
      LDP-VPLS State
      VPLS-id: 100
      Mesh-group connections: h-vpls-PE2
        Neighbor                  Type  St     Time last up          # Up trans
        192.0.2.4(vpls-id 100)      rmt   OL 
    content_copy zoom_out_map
    user@PE3> show vpls connections
    Layer-2 VPN connections:
    
    Legend for connection status (St)   
    EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
    EM -- encapsulation mismatch     WE -- interface and instance encaps not same
    VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
    CM -- control-word mismatch      -> -- only outbound connection is up
    CN -- circuit not provisioned    <- -- only inbound connection is up
    OR -- out of range               Up -- operational
    OL -- no outgoing label          Dn -- down                      
    LD -- local site signaled down   CF -- call admission control failure      
    RD -- remote site signaled down  SC -- local and remote site ID collision
    LN -- local site not designated  LM -- local site ID not minimum designated
    RN -- remote site not designated RM -- remote site ID not minimum designated
    XX -- unknown connection status  IL -- no incoming label
    MM -- MTU mismatch               MI -- Mesh-Group ID not available
    BK -- Backup connection          ST -- Standby connection
    PF -- Profile parse failure      PB -- Profile busy
    RS -- remote site standby        SN -- Static Neighbor
    LB -- Local site not best-site   RB -- Remote site not best-site
    VM -- VLAN ID mismatch
    
    Legend for interface status 
    Up -- operational           
    Dn -- down
    
    Instance: h-vpls-PE3
      BGP-VPLS State
      Local site: PE3-vpls (1)
        connection-site           Type  St     Time last up          # Up trans
        2                         rmt   Up     Oct 17 12:24:01 2012           1
          Remote PE: 192.0.2.1, Negotiated control-word: No
          Incoming label: 800257, Outgoing label: 800000
          Local interface: vt-2/0/10.135266304, Status: Up, Encapsulation: VPLS
            Description: Intf - vpls h-vpls-PE3 local site 1 remote site 2
      LDP-VPLS State
      VPLS-id: 100
      Mesh-group connections: h-vpls-PE3
        Neighbor                  Type  St     Time last up          # Up trans
        192.0.2.4(vpls-id 100)      rmt   Up     Oct 17 12:24:02 2012           1
          Remote PE: 192.0.2.4, Negotiated control-word: No
          Incoming label: 800000, Outgoing label: 800000
          Negotiated PW status TLV: No
          Local interface: vt-2/0/10.135266305, Status: Up, Encapsulation: ETHERNET
            Description: Intf - vpls h-vpls-PE3 neighbor 192.0.2.4 vpls-id 100
    content_copy zoom_out_map
    user@PE4> show vpls connections
    Layer-2 VPN connections:
    
    Legend for connection status (St)   
    EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
    EM -- encapsulation mismatch     WE -- interface and instance encaps not same
    VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
    CM -- control-word mismatch      -> -- only outbound connection is up
    CN -- circuit not provisioned    <- -- only inbound connection is up
    OR -- out of range               Up -- operational
    OL -- no outgoing label          Dn -- down                      
    LD -- local site signaled down   CF -- call admission control failure      
    RD -- remote site signaled down  SC -- local and remote site ID collision
    LN -- local site not designated  LM -- local site ID not minimum designated
    RN -- remote site not designated RM -- remote site ID not minimum designated
    XX -- unknown connection status  IL -- no incoming label
    MM -- MTU mismatch               MI -- Mesh-Group ID not available
    BK -- Backup connection          ST -- Standby connection
    PF -- Profile parse failure      PB -- Profile busy
    RS -- remote site standby        SN -- Static Neighbor
    LB -- Local site not best-site   RB -- Remote site not best-site
    VM -- VLAN ID mismatch
    
    Legend for interface status 
    Up -- operational           
    Dn -- down
    
    Instance: ldp-vpls
      VPLS-id: 100
        Neighbor                  Type  St     Time last up          # Up trans
        192.0.2.2(vpls-id 100)      rmt   OL   
        192.0.2.3(vpls-id 100)      rmt   Up     Oct 16 17:12:20 2012           1
          Remote PE: 192.0.2.3, Negotiated control-word: No
          Incoming label: 800000, Outgoing label: 800000
          Negotiated PW status TLV: No
          Local interface: vt-2/0/10.17825792, Status: Up, Encapsulation: ETHERNET
            Description: Intf - vpls ldp-vpls neighbor 192.0.2.3 vpls-id 100

Meaning

On Device PE1, the BGP-VPLS connection to Device PE3 is up. Traffic flows from CE1 to PE1 to PE3 to PE4 to CE4.

On Device PE2, the BGP-VPLS connection to Device PE1 is in the OL state.

On Device PE3, all VPLS connections are up.

On Device PE4, the VPLS connection to Device PE2 is in the OL state. The VPLS connection to Device PE3 is up.

If you reactivate the interfaces on Device PE2, the connections revert to their previous state and traffic flow.

Checking Connectivity

Purpose

Verify that Device CE1 can ping Device CE4.

Action

content_copy zoom_out_map
user@CE1> ping 10.255.14.219

PING 10.255.14.219 (10.255.14.219): 56 data bytes
64 bytes from 10.255.14.219: icmp_seq=0 ttl=64 time=1.149 ms
64 bytes from 10.255.14.219: icmp_seq=1 ttl=64 time=0.779 ms
^C
--- 10.255.14.219 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.779/0.964/1.149/0.185 ms

Meaning

The output shows that VPLS is operational.

Checking the BGP Layer 2 VPN Routing Tables

Purpose

Verify that the VPLS routes are learned from BGP.

Action

content_copy zoom_out_map
user@PE1> show route table bgp.l2vpn.0
bgp.l2vpn.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1:3:1:1/96                
                   *[BGP/170] 20:00:11, localpref 100, from 192.0.2.3
                      AS path: I, validation-state: unverified
                    > to 10.10.1.2 via fe-2/0/10.0

user@PE3> show route table bgp.l2vpn.0
bgp.l2vpn.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1:1:2:1/96                
                   *[BGP/170] 20:00:11, localpref 100, from 192.0.2.1
                      AS path: I, validation-state: unverified
                    > to 10.10.1.1 via fe-2/0/10.0

Checking the Layer 2 Circuit Routing Tables

Purpose

Verify that the VPLS routes are learned from LDP.

Action

content_copy zoom_out_map
user@PE3> show route table l2circuit.0
l2circuit.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

192.0.2.4:NoCtrlWord:5:100:Local/96                
                   *[VPLS/7] 01:30:11, metric2 1
                    > to 10.10.6.2 via fe-2/0/9.0
192.0.2.4:NoCtrlWord:5:100:Remote/96                
                   *[LDP/9] 20:41:57
                      Discard
user@PE4> show route table bgp.l2vpn.0
l2circuit.0: 3 destinations, 3 routes (2 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

192.0.2.3:NoCtrlWord:5:100:Local/96                
                   *[VPLS/7] 20:42:51, metric2 1
                    > to 10.10.6.1 via fe-2/0/9.0
192.0.2.3:NoCtrlWord:5:100:Remote/96                
                   *[LDP/9] 20:41:57
                      Discard
footer-navigation