Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
IS-IS User Guide
Table of Contents Expand all
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring the Transmission Frequency for Link-State PDUs on IS-IS Interfaces

date_range 24-Nov-23

This example shows how to modify the link-state PDU interval time.

Requirements

Before you begin, configure IS-IS. See Example: Configuring IS-IS for information about the sample IS-IS configuration.

Overview

To keep reachability information in the network current, link-state protocols need to originate, distribute, and revoke or time-out topology information. In IS-IS, topology information is encoded in link-state PDUs.

By default, the routing device sends one link-state PDU out an interface every 100 milliseconds. To modify this interval, include the lsp-interval statement:

content_copy zoom_out_map
lsp-interval milliseconds;

To disable the transmission of all link-state PDUs, set the interval to 0.

Link-state PDU throttling by use of the lsp-interval statement controls the flooding pace to neighboring routing devices in order to not overload them and also to ensure that user traffic is not delayed on low-bandwidth links.

In this example, an IS-IS routing device on a LAN segment is configured to send link-state PDUs every 1000 milliseconds.

Figure 1 shows the topology used in this example.

Figure 1: IS-IS Link-State PDU Interval TopologyIS-IS Link-State PDU Interval Topology

This example describes the steps on Device R1.

Configuration

Procedure

CLI Quick Configuration

To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, and then copy and paste the commands into the CLI at the [edit] hierarchy level.

Device R1

content_copy zoom_out_map
set interfaces fe-1/2/0 unit 0 description to-R2
set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.1/30
set interfaces fe-1/2/0 unit 0 family iso
set interfaces lo0 unit 0 family inet address 192.168.0.1/32
set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0001.00
set protocols isis traceoptions file isis-trace
set protocols isis traceoptions flag lsp
set protocols isis interface fe-1/2/0.0 lsp-interval 1000
set protocols isis interface lo0.0

Step-by-Step Procedure

The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

To configure the link-state PDU interval:

  1. Configure the interfaces.

    content_copy zoom_out_map
    [edit interfaces]
    user@R1# set fe-1/2/0 unit 0 description to-R2
    user@R1# set fe-1/2/0 unit 0 family inet address 10.0.0.1/30
    user@R1# set fe-1/2/0 unit 0 family iso
    user@R1# set lo0 unit 0 family inet address 192.168.0.1/32
    user@R1# set lo0 unit 0 family iso address 49.0002.0192.0168.0001.00
    
  2. Enable IS-IS on the interfaces.

    content_copy zoom_out_map
    [edit protocols isis]
    user@R1# set interface fe-1/2/0.0 
    user@R1# set interface lo0.0
    
  3. Modify the link-state PDU interval.

    content_copy zoom_out_map
    [edit protocols isis interface fe-1/2/0.0]
    user@R1# set lsp-interval 1000
    
  4. (Optional) Enable tracing for tracking link-state PDU operations.

    content_copy zoom_out_map
    [edit protocols isis traceoptions]
    user@R1# set file isis-trace
    user@R1# set flag lsp
    

Results

From configuration mode, confirm your configuration by entering the show interfaces and show protocols commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

content_copy zoom_out_map
user@R1# show interfaces
fe-1/2/0 {
    unit 0 {
        description to-R2;
        family inet {
            address 10.0.0.1/30;
        }
        family iso;
    }
}
lo0 {
    unit 0 {
        family inet {
            address 192.168.0.1/32;
        }
        family iso {
            address 49.0002.0192.0168.0001.00;
        }
    }
}
content_copy zoom_out_map
user@R1# show protocols
isis {
    traceoptions {
        file isis-trace;
        flag lsp;
    }
    interface fe-1/2/0.0 {
        lsp-interval 1000;
    }
    interface lo0.0;
}

If you are done configuring the device, enter commit from configuration mode. Repeat the configuration on Device R2.

Verification

Confirm that the configuration is working properly.

Verifying the Link-State PDU Interval

Purpose

Check the link-state PDU interval setting on the IS-IS interface.

Action

From operational mode, enter the show isis interface extensive command.

content_copy zoom_out_map
user@R1> show isis interface extensive
fe-1/2/0.0
  Index: 70, State: 0x6, Circuit id: 0x1, Circuit type: 3
  LSP interval: 1000 ms, CSNP interval: 10 s, Loose Hello padding
  Adjacency advertisement: Advertise
  Level 1
    Adjacencies: 1, Priority: 64, Metric: 10
    Hello Interval: 9.000 s, Hold Time: 27 s
    Designated Router: R2.02 (not us)
  Level 2
    Adjacencies: 1, Priority: 64, Metric: 10
    Hello Interval: 9.000 s, Hold Time: 27 s
    Designated Router: R2.02 (not us)

Meaning

The output shows that the link-state PDU interval is set to 1000 milliseconds.

Checking the Link-State PDU Statistics

Purpose

Check the number of link-state PDUs sent and received.

Action

From operational mode, enter the show isis statistics command.

content_copy zoom_out_map
user@R1> show isis statistics

IS-IS statistics for R1:
PDU type       Received    Processed        Drops         Sent       Rexmit
LSP                  24           24            0           13            0
IIH                2467           24            0          836            0
CSNP                474          474            0            0            0
PSNP                  0            0            0            0            0
Unknown               0            0            0            0            0
Totals             2965          522            0          849            0

Total packets received: 2965 Sent: 849

SNP queue length: 0 Drops: 0
LSP queue length: 0 Drops: 0
SPF runs: 14
Fragments rebuilt: 15
LSP regenerations: 6
Purges initiated: 0
content_copy zoom_out_map
user@R2> show isis statistics
IS-IS statistics for R2:
PDU type       Received    Processed        Drops         Sent       Rexmit
LSP                  13           13            0           24            0
IIH                 828           15            0         2459            0
CSNP                  0            0            0          474            0
PSNP                  0            0            0            0            0
Unknown               0            0            0            0            0
Totals              841           28            0         2957            0

Total packets received: 841 Sent: 2957

SNP queue length: 0 Drops: 0
LSP queue length: 0 Drops: 0
SPF runs: 17
Fragments rebuilt: 26
LSP regenerations: 11
Purges initiated: 0

Meaning

The output shows the number of link-state PDUs sent and received on Device R1 and Device R2.

Checking the Trace Log

Purpose

Check the IS-IS trace log to view the interval between packets.

Action

From operational mode, enter the show log isis-trace | match lsp command.

content_copy zoom_out_map
user@R1> show log isis | match lsp

Jun 18 15:27:02.692031 Received L1 LSP R2.00-00, on interface fe-1/2/0.0
Jun 18 15:27:02.692753 Updating L1 LSP R2.00-00 in TED
Jun 18 15:27:44.396480 Updating L1 LSP R1.00-00 in TED
Jun 18 15:27:45.398077 Sending L1 LSP R1.00-00 on interface fe-1/2/0.0
Jun 18 15:28:44.689024 Received L1 LSP R2.02-00, on interface fe-1/2/0.0
Jun 18 15:28:44.689663 Updating L1 LSP R2.02-00 in TED
Jun 18 15:29:15.954900 Updating L2 LSP R1.00-00 in TED
Jun 18 15:29:16.955620 Sending L2 LSP R1.00-00 on interface fe-1/2/0.0
Jun 18 15:29:28.789986 Received L2 LSP R2.00-00, on interface fe-1/2/0.0
Jun 18 15:29:28.790620 Updating L2 LSP R2.00-00 in TED
Jun 18 15:30:27.727892 Received L2 LSP R2.02-00, on interface fe-1/2/0.0
Jun 18 15:30:27.728519 Updating L2 LSP R2.02-00 in TED

Meaning

The output shows that Level 1 and Level 2 link-state PDUs are being sent and received roughly every 1000 milliseconds (1 second).

footer-navigation