- play_arrow Overview
- play_arrow Introduction to IS-IS
-
- play_arrow Monitoring and Troubleshooting Network Issues
- play_arrow Monitoring Networks
- play_arrow Troubleshooting Network Issues
- Working with Problems on Your Network
- Isolating a Broken Network Connection
- Identifying the Symptoms of a Broken Network Connection
- Isolating the Causes of a Network Problem
- Taking Appropriate Action for Resolving the Network Problem
- Evaluating the Solution to Check Whether the Network Problem Is Resolved
- play_arrow Troubleshooting IS-IS
-
- play_arrow Configuration Statements and Operational Commands
ON THIS PAGE
Example: Configuring Mesh Groups of IS-IS Interfaces
This example shows how to configure mesh groups of IS-IS interfaces.
Requirements
No special configuration beyond device initialization is required before configuring this example.
Overview
When link-state PDUs are being flooded throughout an area, each router within a mesh group receives only a single copy of a link-state PDU instead of receiving one copy from each neighbor, thus minimizing the overhead associated with the flooding of link-state PDUs.
To create a mesh group and designate that an interface be part of the group, assign a mesh-group number to all the routing device interfaces in the group:
mesh-group value;
To prevent an interface in the mesh group from flooding link-state PDUs, configure blocking on that interface:
mesh-group blocked;
Figure 1 shows the topology used in this example.
CLI Quick Configuration shows the configuration for all of the devices in Figure 1. The section #configuration663__isis-mesh-step-by-step describes the steps on Device R1.
Configuration
Procedure
CLI Quick Configuration
To quickly configure this
example, copy the following commands, paste them into a text file,
remove any line breaks, change any details necessary to match your
network configuration, and then copy and paste the commands into the
CLI at the [edit]
hierarchy level.
Device R1
set interfaces fe-1/2/0 unit 0 description to-R2 set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.1/30 set interfaces fe-1/2/0 unit 0 family iso set interfaces fe-1/2/1 unit 0 description to-R4 set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.5/30 set interfaces fe-1/2/1 unit 0 family iso set interfaces fe-1/2/2 unit 0 description to-R3 set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.9/30 set interfaces fe-1/2/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.0.1/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0001.00 set protocols isis interface fe-1/2/0.0 mesh-group 1 set protocols isis interface fe-1/2/1.0 mesh-group 1 set protocols isis interface fe-1/2/2.0 mesh-group 1 set protocols isis interface lo0.0
Device R2
set interfaces fe-1/2/0 unit 0 description to-R1 set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.2/30 set interfaces fe-1/2/0 unit 0 family iso set interfaces fe-1/2/1 unit 0 description to-R1 set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.14/30 set interfaces fe-1/2/1 unit 0 family iso set interfaces fe-1/2/2 unit 0 description to-R1 set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.21/30 set interfaces fe-1/2/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.0.2/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0002.00 set protocols isis interface fe-1/2/0.2 mesh-group 1 set protocols isis interface fe-1/2/1.0 mesh-group 1 set protocols isis interface fe-1/2/2.0 mesh-group 1 set protocols isis interface lo0.0
Device R3
set interfaces fe-1/2/0 unit 0 description to-R1 set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.10/30 set interfaces fe-1/2/0 unit 0 family iso set interfaces fe-1/2/1 unit 0 description to-R2 set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.13/30 set interfaces fe-1/2/1 unit 0 family iso set interfaces fe-1/2/2 unit 0 description to-R4 set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.17/30 set interfaces fe-1/2/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.0.3/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0003.00 set protocols isis interface fe-1/2/0.0 mesh-group 1 set protocols isis interface fe-1/2/1.0 mesh-group 1 set protocols isis interface fe-1/2/2.0 mesh-group 1 set protocols isis interface lo0.0
Device R4
set interfaces fe-1/2/0 unit 0 description to-R1 set interfaces fe-1/2/0 unit 0 family inet address 10.0.0.6/30 set interfaces fe-1/2/0 unit 0 family iso set interfaces fe-1/2/1 unit 0 description to-R3 set interfaces fe-1/2/1 unit 0 family inet address 10.0.0.18/30 set interfaces fe-1/2/1 unit 0 family iso set interfaces fe-1/2/2 unit 0 description to-R2 set interfaces fe-1/2/2 unit 0 family inet address 10.0.0.22/30 set interfaces fe-1/2/2 unit 0 family iso set interfaces lo0 unit 0 family inet address 192.168.0.4/32 set interfaces lo0 unit 0 family iso address 49.0002.0192.0168.0004.00 set protocols isis interface fe-1/2/0.0 mesh-group 1 set protocols isis interface fe-1/2/1.0 mesh-group 1 set protocols isis interface fe-1/2/2.0 mesh-group 1 set protocols isis interface lo0.0
Step-by-Step Procedure
The following example requires you to navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.
To configure an IS-IS mesh group:
Configure the interfaces.
content_copy zoom_out_map[edit interfaces] user@R1# set fe-1/2/0 unit 0 description to-R2 user@R1# set fe-1/2/0 unit 0 family inet address 10.0.0.1/30 user@R1# set fe-1/2/0 unit 0 family iso user@R1# set fe-1/2/1 unit 0 description to-R4 user@R1# set fe-1/2/1 unit 0 family inet address 10.0.0.5/30 user@R1# set fe-1/2/1 unit 0 family iso user@R1# set fe-1/2/2 unit 0 description to-R3 user@R1# set fe-1/2/2 unit 0 family inet address 10.0.0.9/30 user@R1# set fe-1/2/2 unit 0 family iso user@R1# set lo0 unit 0 family inet address 192.168.0.1/32 user@R1# set lo0 unit 0 family iso address 49.0002.0192.0168.0001.00
Enable IS-IS on the interfaces, and assign a mesh group number.
content_copy zoom_out_map[edit protocols isis] user@R1# set interface fe-1/2/0.0 mesh-group 1 user@R1# set interface fe-1/2/1.0 mesh-group 1 user@R1# set interface fe-1/2/2.0 mesh-group 1 user@R1# set interface lo0.0
Results
From configuration mode, confirm your configuration
by entering the show interfaces
and show protocols
commands. If the output does not display the intended configuration,
repeat the instructions in this example to correct the configuration.
user@R1# show interfaces
fe-1/2/0 {
unit 0 {
description to-R2;
family inet {
address 10.0.0.1/30;
}
family iso;
}
}
fe-1/2/1 {
unit 0 {
description to-R4;
family inet {
address 10.0.0.5/30;
}
family iso;
}
}
fe-1/2/2 {
unit 0 {
description to-R3;
family inet {
address 10.0.0.9/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 192.168.0.1/32;
}
family iso {
address 49.0002.0192.0168.0001.00;
}
}
}
user@R1# show protocols
isis {
interface fe-1/2/0.0 {
mesh-group 1;
}
interface fe-1/2/1.0 {
mesh-group 1;
}
interface fe-1/2/2.0 {
mesh-group 1;
}
interface lo0.0;
}
If you are done configuring the device, enter commit from configuration mode.
Verification
Confirm that the configuration is working properly.
Checking the Interface Mesh Group
Purpose
Verify that the mesh group is enabled on the IS-IS interfaces.
Action
From operational mode, enter the show isis interface
extensive
command.
user@R1> show isis interface extensive IS-IS interface database: lo0.0 Index: 68, State: 0x6, Circuit id: 0x1, Circuit type: 0 LSP interval: 100 ms, CSNP interval: disabled, Loose Hello padding Adjacency advertisement: Advertise Level 1 Adjacencies: 0, Priority: 64, Metric: 0 Passive Level 2 Adjacencies: 0, Priority: 64, Metric: 0 Passive fe-1/2/0.1 Index: 73, State: 0x206, Circuit id: 0x1, Circuit type: 3 LSP interval: 100 ms, CSNP interval: 10 s, Loose Hello padding Adjacency advertisement: Advertise CSNP interval: disabled, Mesh group: 1 Level 1 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R2.03 (not us) Level 2 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R2.03 (not us) fe-1/2/1.0 Index: 75, State: 0x206, Circuit id: 0x1, Circuit type: 3 LSP interval: 100 ms, CSNP interval: 10 s, Loose Hello padding Adjacency advertisement: Advertise CSNP interval: disabled, Mesh group: 1 Level 1 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R4.03 (not us) Level 2 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R4.03 (not us) fe-1/2/2.0 Index: 76, State: 0x206, Circuit id: 0x1, Circuit type: 3 LSP interval: 100 ms, CSNP interval: 10 s, Loose Hello padding Adjacency advertisement: Advertise CSNP interval: disabled, Mesh group: 1 Level 1 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R3.02 (not us) Level 2 Adjacencies: 1, Priority: 64, Metric: 10 Hello Interval: 9.000 s, Hold Time: 27 s Designated Router: tp5-R3.02 (not us)
Meaning
Mesh group: 1
in the
output shows that the mesh group is enabled as expected.
Checking the IS-IS Statistics
Purpose
Verify that the number of link-state PDUs received and sent is less than what it would be if the mesh group were not enabled.
Action
From operational mode, enter the show isis statistics
command.
user@R1> show isis statistics IS-IS statistics for tp5-R1: PDU type Received Processed Drops Sent Rexmit LSP 73 73 0 37 0 IIH 4463 85 0 1525 0 CSNP 1294 1294 0 0 0 PSNP 0 0 0 2 0 Unknown 0 0 0 0 0 Totals 5830 1452 0 1564 0 Total packets received: 5830 Sent: 1564 SNP queue length: 0 Drops: 0 LSP queue length: 0 Drops: 0 SPF runs: 26 Fragments rebuilt: 15 LSP regenerations: 4 Purges initiated: 0
Meaning
After the adjacencies have been up for about 38 minutes, the output shows that Device R1 has received 73 link-state PDUs and sent 37 link-state PDUs. In the same topology in the same amount of time without the mesh group enabled, Device R1 would have received roughly 156 link-state PDUs and sent roughly 117 link-state PDUs.