Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Examples: Configuring Real-Time Performance Monitoring on MX, M, T and PTX Series Routers

date_range 01-Dec-23

Configure an RPM instance identified by the probe name probe1 and the test name test1:

content_copy zoom_out_map
[edit services rpm]
probe probe1{
    test test1 {
        dscp-code-points 001111;
        probe-interval 1;
        probe-type icmp-ping;
        target address 172.17.20.182;
        test-interval 20;
        thresholds rtt 10;
        traps rtt-exceeded;
    }
}
probe-server {
    tcp {
        destination-interface lt-0/0/0.0
        port 50000;
    }
    udp {
        destination-interface lt-0/0/0.0
        port 50001;
    }
}
probe-limit 200;

Configure packet classification, using lt- interfaces to send the probe packets to a logical tunnel input interface. By sending the packet to the logical tunnel interface, you can configure regular and multifield classifiers, firewall filters, and header rewriting for the probe packets. To use the existing tunnel framework, the dlci and encapsulation statements must be configured.

content_copy zoom_out_map
[edit services rpm]
probe p1 {
    test t1 {
        probe-type icmp-ping;
        target address 10.8.4.1;
        probe-count 10;
        probe-interval 10;
        test-interval 10;
        source-address 10.8.4.2;
        dscp-code-points ef;
        data-size 100;
        destination-interface lt-0/0/0.0;
    }
}
[edit interfaces]
lt-0/0/0 {
    unit 0 {
        encapsulation frame-relay;
        dlci 10;
        peer-unit 1;
        family inet;
    }
    unit 1 {
        encapsulation frame-relay;
        dlci 10;
        peer-unit 0;
        family inet;
    }
}
[edit class-of-service]
interfaces {
    lt-0/0/0 {
        unit 1 {
            classifiers {
                dscp default;
            }
        }
    }
}

Configure an input filter on the interface on which the RPM probes are received. This filter enables prioritization of the received RPM packets, separating them from the regular data packets received on the same interface.

content_copy zoom_out_map
[edit firewall]
filter recos {
    term recos {
        from {
            source-address {
                10.8.4.1/32;
            }
            destination-address {
                10.8.4.2/32;
            }
        }
        then {
            loss-priority high;
            forwarding-class network-control;
        }
    }
}
[edit interfaces]
fe-5/0/0 {
    unit 0 {
        family inet {
            filter {
                input recos;
            }
            address 10.8.4.2/24;
        }
    }
}

Configure an RPM instance and enable RPM for the extension-provider packages on the adaptive services interface:

content_copy zoom_out_map
[edit services rpm]
probe probe1{
    test test1 {
        data-size 1024;
        data-fill 0;
        destination-interface ms-1/2/0.10;
        dscp-code-points 001111;
        probe-count 10;
        probe-interval 1;
        probe-type icmp-ping;
        target address 172.17.20.182;
        test-interval 20;
        thresholds rtt 10;
        traps rtt-exceeded;
    }
}
[edit interfaces]
ms-1/2/0 {
    unit 0 {
        family inet;
    }
    unit 10 {
        rpm client;
        family inet {
            address 192.0.2.1/32;
        }
}
[edit chassis]
fpc 1 {
    pic 2 {
        adaptive-services {
            service-package {
                extension-provider {
                    control-cores 1;
                    data-cores 1;
                    object-cache-size 512;
                    policy-db-size 64;
                    package jservices-rpm;
                    syslog {
                    
                        daemon any;
                    }
                }
            }
        }
    }
}

Configure the minimum statements necessary to enable TWAMP:

content_copy zoom_out_map
[edit services]
rpm {
    twamp {
        server {
            authentication-mode none;
            port 10000;                       # Twamp server's listening port
            client-list LIST-1 {              # LIST-1 is the name of the client-list. Multiple lists can be configured.
                address {
                    198.51.100.2/30;              # IP address of the control client.
                }
            }
        }
    }
[edit interfaces sp-5/0/0]
unit 0 {
    family inet;
}
unit 10 {
    rpm {
        twamp-server;                       # You must configure a separate logical interface on the service PIC interface for the TWAMP server.
    }
    family inet {
        address 203.0.113.50/32;             # This address must be a host address with a 32-bit mask.
    }
}
[edit chassis]
fpc 5 {
    pic 0 {
        adaptive-services {
            service-package layer-2;      # Configure the service PIC to run in Layer 2 mode.
        }
    }
}

Configure additional TWAMP settings:

content_copy zoom_out_map
[edit services]
rpm {
    twamp {
        server {
            maximum-sessions 5;
            maximum-sessions-per-connection 2;
            maximum-connections 3;
            maximum-connections-per-client 1;
            port 10000;
            server-inactivity-timeout ;
            client-list LIST-1 {
                address {
                    198.51.100.2/30;
                }
            }
        }
    }
}
footer-navigation