Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Announcement: Try the Ask AI chatbot for answers to your technical questions about Juniper products and solutions.

close
header-navigation
keyboard_arrow_up
close
keyboard_arrow_left
list Table of Contents
file_download PDF
{ "lLangCode": "en", "lName": "English", "lCountryCode": "us", "transcode": "en_US" }
English
keyboard_arrow_right

Example: Configuring DSCP Classification for VPLS

date_range 26-Jan-21

This example shows how to configure a DSCP classifier for a virtual private LAN service (VPLS).

Requirements

This example uses the following hardware and software components:

  • An M Series Multiservice Edge Router (M120 and M320 only), MX Series 5G Universal Routing Platform, or T Series Core Router (TX Matrix and TX Matrix Plus only) with an ATM interface.

  • Junos OS Release 10.4 or later.

Overview

In this example, you configure a DSCP classifier dscp_vpls on ATM interface at-4/1/1 with ether-vpls-over-atm-llc encapsulation. The classifier dscp_vpls is applied to the interface and the interface is listed in the VPLS routing instance vpls1 on the ingress PE router.

Configuration

CLI Quick Configuration

To quickly configure the DSCP classifier for a virtual private LAN service (VPLS), copy the following commands to a text file, remove any line breaks, and then paste the commands into the CLI.

content_copy zoom_out_map
user@host# set interfaces at-4/1/1 mtu 9192
user@host# set interfaces at-4/1/1 atm-options vpi 10
user@host# set interfaces at-4/1/1 unit 0 encapsulation ether-vpls-over-atm-llc
user@host# set interfaces at-4/1/1 unit 0 vci 10.128
user@host# set interfaces at-4/1/1 unit 0 family vpls
user@host# set class-of-service classifiers dscp dscp_vpls forwarding-class expedited-forwarding loss-priority low code-points 000010
user@host# set interfaces at-4/1/1 unit 0 classifiers dscp dscp_vpls
user@host# set routing-instances vpls1 instance-type vpls 
user@host# set routing-instances vpls1 interface at-4/1/1.0
user@host# set routing-instances vpls1 route-distinguisher 10.255.245.51:1
user@host# set routing-instances vpls1 vrf-target target:1234:1
user@host# set routing-instances vpls1 protocols vpls site-range 10
user@host# set routing-instances vpls1 protocols vpls no-tunnel-services
user@host# set routing-instances vpls1 protocols vpls site vpls-1-site-1 site-identifier 1

Configuring the DSCP Classifier for a Virtual Private LAN Service (VPLS)

Step-by-Step Procedure

The following example requires that you navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the Junos OS CLI User Guide.

To configure the DSCP classifier for a virtual private LAN service (VPLS:

  1. Configure the ATM interface at-4/1/1.0 and the encapsulation as ether-vpls-over-atm-llc.

    content_copy zoom_out_map
    [edit interfaces]
    user@host# set at-4/1/1 mtu 9192
    user@host# set at-4/1/1 atm-options vpi 10
    user@host# set at-4/1/1 unit 0 encapsulation ether-vpls-over-atm-llc
    user@host# set at-4/1/1 unit 0 vci 10.128
    user@host# set at-4/1/1 unit 0 family vpls
    
  2. Configure the DSCP classifier dscp_vpls.

    content_copy zoom_out_map
    [edit class-of-service]
    user@host# set classifiers dscp dscp_vpls forwarding-class expedited-forwarding loss-priority low code-points 000010
    
  3. Apply the classifier dscp_vpls to the ATM interface at-4/1/1.0.

    content_copy zoom_out_map
    [edit interfaces]
    user@host# set at-4/1/1 unit 0 classifiers dscp dscp_vpls
    
  4. Include the ATM interface virtual circuit at-4/1/1.0 as part of the routing instance vpls1 configuration.

    content_copy zoom_out_map
    user@host# set routing-instances vpls1 instance-type vpls 
    user@host# set routing-instances vpls1 interface at-4/1/1.0
    user@host# set routing-instances vpls1 route-distinguisher 10.255.245.51:1
    user@host# set routing-instances vpls1 vrf-target target:1234:1
    user@host# set routing-instances vpls1 protocols vpls site-range 10
    user@host# set routing-instances vpls1 protocols vpls no-tunnel-services
    user@host# set routing-instances vpls1 protocols vpls site vpls-1-site-1 site-identifier 1
    

Results

From configuration mode, confirm your configuration by entering the show interfaces, show class-of-service, and show routing-instances commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

content_copy zoom_out_map
user@host# show interfaces at-4/1/1
content_copy zoom_out_map
mtu 9192;
atm-options {
    vpi 10;
}
unit 0 {
     classifiers {
       dscp dscp_vpls;
}    
     encapsulation ether-vpls-over-atm-llc;
     vci 10.128;
     family vpls;
}
content_copy zoom_out_map
user@host# show class-of-service
content_copy zoom_out_map
classifiers {
    dscp dscp_vpls {
        forwarding-class expedited-forwarding {
            loss-priority low code-points 000010;
        }
    }
}
content_copy zoom_out_map
user@host# show routing-instances
content_copy zoom_out_map
vpls1 {
    instance-type vpls;
    interface at-4/1/1.0;
    route-distinguisher 10.255.245.51:1;
    vrf-target target:1234:1;
    protocols {
        vpls {
            site-range 10;
            no-tunnel-services;
            site vpls-1-site-1 {
                site-identifier 1;
            }
        }
    }
}
footer-navigation